notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
rubygem-progressbar09 Ruby/ProgressBar is a text progress bar library for Ruby
0.9.2 devel Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 0.9.2Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Only used by deprecated sysutils/rubygem-bosh_cli
Expired This port expired on: 2018-02-28
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-02-19 17:37:45
Last Update: 2018-02-28 12:52:04
SVN Revision: 463203
Also Listed In: rubygems
License: BSD2CLAUSE RUBY
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (4 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-progressbar09-0.9.2/catalog.mk
  2. /usr/local/share/licenses/rubygem-progressbar09-0.9.2/LICENSE
  3. /usr/local/share/licenses/rubygem-progressbar09-0.9.2/BSD2CLAUSE
  4. /usr/local/share/licenses/rubygem-progressbar09-0.9.2/RUBY
Collapse this list.
Dependency lines:
  • rubygem-progressbar09>0:devel/rubygem-progressbar09
No installation instructions:
This port has been deleted.
PKGNAME: rubygem-progressbar09
Flavors: there is no flavor information for this port.
distinfo:
No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby24 : lang/ruby24
  2. gem24 : devel/ruby-gems
Runtime dependencies:
  1. ruby24 : lang/ruby24
  2. gem24 : devel/ruby-gems
Patch dependencies:
  1. ruby24 : lang/ruby24
  2. gem24 : devel/ruby-gems
Extract dependencies:
  1. ruby24 : lang/ruby24
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. sysutils/rubygem-bosh_cli*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.global.ssl.fastly.net/gems/
Collapse this list.
Port Moves
  • port deleted on 2018-02-28
    REASON: Has expired: Only used by deprecated sysutils/rubygem-bosh_cli

Number of commits found: 4

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
28 Feb 2018 12:52:04
Original commit files touched by this commit Revision:463203  0.9.2
sunpoet search for other commits by this committer
Remove expired devel/rubygem-progressbar09
18 Feb 2018 13:38:20
Original commit files touched by this commit Revision:462239  0.9.2
sunpoet search for other commits by this committer
Mark DEPRECATED and set EXPIRATION_DATE to 2018-02-28
20 Feb 2017 15:10:18
Original commit files touched by this commit Revision:434463  0.9.2
sunpoet search for other commits by this committer
Add PORTSCOUT
19 Feb 2017 17:37:37
Original commit files touched by this commit Revision:434410  0.9.2
dumbbell search for other commits by this committer
sysutils/rubygem-bosh_cli: Depend on devel/rubygem-progressbar09

sysutils/rubygem-bosh_cli is incompatible with devel/rubygem-progressbar
(1.8.2 at the time of this commit). This causes BOSH commands, such as
`bosh upload release` to fail with an obscure Ruby exception.

devel/rubygem-progressbar09 is svn-copied from devel/rubygem-progressbar
and downgraded to 0.9.2. sysutils/robygem-bosh_cli `PORTREVISION` is
bumped to reflect the change of dependency.

Approved by:	antoine (mentor), sunpoet
Differential Revision:	https://reviews.freebsd.org/D9651

Number of commits found: 4