notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
rubygem-validate_email Validating email addresses in Rails 3 models
0.1.6_3 devel on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 0.1.6_2Version of this port present on the latest quarterly branch.
Maintainer: mfechner@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-05-18 09:43:11
Last Update: 2021-09-30 12:47:21
Commit Hash: 70b621d
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-validate_email-0.1.6_3/catalog.mk
  2. /usr/local/share/licenses/rubygem-validate_email-0.1.6_3/LICENSE
  3. /usr/local/share/licenses/rubygem-validate_email-0.1.6_3/MIT
Collapse this list.
Dependency lines:
  • rubygem-validate_email>0:devel/rubygem-validate_email
To install the port:
cd /usr/ports/devel/rubygem-validate_email/ && make install clean
To add the package, run one of these commands:
  • pkg install devel/rubygem-validate_email
  • pkg install rubygem-validate_email
PKGNAME: rubygem-validate_email
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
rubygem-validate_email
ABIlatestquarterly
FreeBSD:11:aarch64-0.1.6_1
FreeBSD:11:amd640.1.6_20.1.6_2
FreeBSD:11:armv6-0.1.6_1
FreeBSD:11:i3860.1.6_20.1.6_2
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64-0.1.6_3
FreeBSD:12:amd640.1.6_30.1.6_3
FreeBSD:12:armv6-0.1.6_2
FreeBSD:12:armv7-0.1.6_2
FreeBSD:12:i3860.1.6_30.1.6_3
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64-0.1.6_2
FreeBSD:13:aarch640.1.6_20.1.6_3
FreeBSD:13:amd640.1.6_30.1.6_3
FreeBSD:13:armv60.1.6_20.1.6_2
FreeBSD:13:armv70.1.6_20.1.6_3
FreeBSD:13:i3860.1.6_30.1.6_3
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc640.1.6_20.1.6_2
FreeBSD:14:aarch640.1.6_3-
FreeBSD:14:amd640.1.6_3-
FreeBSD:14:armv60.1.6_2-
FreeBSD:14:armv70.1.6_2-
FreeBSD:14:i3860.1.6_3-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc640.1.6_2-
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-activemodel61>=3.0 : databases/rubygem-activemodel61
  2. rubygem-mail>=2.2.5 : mail/rubygem-mail
  3. ruby27 : lang/ruby27
  4. gem27 : devel/ruby-gems
Patch dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Extract dependencies:
  1. ruby27 : lang/ruby27
This port is required by:
for Run
  1. net/rubygem-openid_connect

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.org/downloads/
Collapse this list.

Number of commits found: 5

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
30 Sep 2021 12:47:21
 files touched by this commit commit hash:70b621db3cfe442260789464e506dc847eadb1ea  0.1.6_3
Matthias Fechner (mfechner) search for other commits by this committer
*/*: Switch deps from rails 6.0 to 6.1
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  0.1.6_2
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
03 Jul 2020 21:22:03
Original commit files touched by this commit Revision:541140  0.1.6_2
mfechner search for other commits by this committer
Use rails60.
07 Dec 2019 10:31:38
Original commit files touched by this commit Revision:519195  0.1.6_1
mfechner search for other commits by this committer
Change rubygem ports required by www/gitlab-ce to rails52.

Currently a lot of ports www/gitlab-ce is using pulls rails 5.0 and 5.2 ports as
dependencies in.
To reduce the number of ports required, the attached patch switches all required
ports to rails 5.2.

I carefully tested it, if I oversaw a port, please let me know.

Differential Revision:	https://reviews.freebsd.org/D22220
18 May 2019 09:42:49
Original commit files touched by this commit Revision:501925  0.1.6
mfechner search for other commits by this committer
Added new ports required by upcoming gitlab-ce version 11.11.

Number of commits found: 5