notbugIf you buy from Amazon USA, please support us by using this link.
Port details
pyfa Fitting tool for EVE Online
1.19.1_3 games on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port
Maintainer: andrey@bsdnir.info search for ports maintained by this maintainer
Port Added: 2015-05-15 20:27:51
Last Update: 2019-04-17 19:50:43
SVN Revision: 499201
Also Listed In: python
License: GPLv3+
Pyfa is a cross-platform desktop fitting application for EVE online
that can be used natively on any platform where python and wxwidgets
are available.

It provides many advanced features such as graphs and full calculations
of any possible combination of modules, fits, etc.

WWW: https://github.com/pyfa-org/Pyfa
SVNWeb : Homepage
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (4 items)
  1. bin/pyfa
  2. /usr/local/share/licenses/pyfa-1.19.1_3/catalog.mk
  3. /usr/local/share/licenses/pyfa-1.19.1_3/LICENSE
  4. /usr/local/share/licenses/pyfa-1.19.1_3/GPLv3+
  5. Collapse this list.
Dependency lines:
  • pyfa>0:games/pyfa

To install the port: cd /usr/ports/games/pyfa/ && make install clean
To add the package: pkg install pyfa

PKGNAME: pyfa

There is no flavor information for this port.

distinfo:

TIMESTAMP = 1483465523
SHA256 (pyfa-org-Pyfa-v1.19.1_GH0.tar.gz) = f597019117b335971287fd47c1faa5be049f8a6879d4144b6c8a0039f35cea98
SIZE (pyfa-org-Pyfa-v1.19.1_GH0.tar.gz) = 6688136


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. python2.7 : lang/python27
Runtime dependencies:
  1. py27-dateutil>0 : devel/py-dateutil@py27
  2. py27-sqlalchemy10>=0.6 : databases/py-sqlalchemy10@py27
  3. py27-requests>=2.3.0 : www/py-requests@py27
  4. python2.7 : lang/python27
  5. libwx_baseu-3.0.so.0 : x11-toolkits/wxgtk30
  6. __init__.py : x11-toolkits/py-wxPython30
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for pyfa-1.19.1_3:
     DPSGRAPHING=off: DPS graphing (requires NumPy and matplotlib)
===> Use 'make config' to modify these settings

USES:
python:2.7 dos2unix

Master Sites:
  1. https://codeload.github.com/pyfa-org/Pyfa/tar.gz/v1.19.1?dummy=/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2017-11-30
    Affects: */py*
    Author: mat@FreeBSD.org
    Reason: 
      Ports using Python via USES=python are now flavored.  All the py3-* ports
      have been removed and folded into their py-* master ports.
    
      People using Poudriere 3.2+ and binary packages do not have to do anything.
    
      For other people, to build the Python 3.6 version of, for example,
      databases/py-gdbm, you need to run:
    
        # make FLAVOR=py36 install
    
    

Number of commits found: 15

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
17 Apr 2019 18:50:43
Original commit files touched by this commit  1.19.1_3
Revision:499201
sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-more-itertools to py-more-itertools5

- Bump PORTREVISION for dependency change
19 Feb 2018 11:10:43
Original commit files touched by this commit  1.19.1_2
Revision:462307
antoine search for other commits by this committer
Reduce dependency on the python2 metaport

PR:		225752
Submitted by:	Yasuhiro KIMURA
30 Nov 2017 15:50:34
Original commit files touched by this commit  1.19.1_1
Revision:455210  Sanity Test Failure
mat search for other commits by this committer
Convert Python ports to FLAVORS.

  Ports using USE_PYTHON=distutils are now flavored.  They will
  automatically get flavors (py27, py34, py35, py36) depending on what
  versions they support.

  There is also a USE_PYTHON=flavors for ports that do not use distutils
  but need FLAVORS to be set.  A USE_PYTHON=noflavors can be set if
  using distutils but flavors are not wanted.

  A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been
  added to cope with Python ports that did not have the Python
  PKGNAMEPREFIX but are flavored.

  USES=python now also exports a PY_FLAVOR variable that contains the
(Only the first 15 lines of the commit message are shown above View all of this commit message)
03 Jan 2017 18:12:13
Original commit files touched by this commit  1.19.1_1
Revision:430490
mat search for other commits by this committer
Never set WRKSRC when using USE_GITHUB.

If you want to set WRKSRC, set GH_PROJECT instead.
- The GitHub URLs are case insensitive, but the distribution files you
  get out of them are not.
- If the repository was renamed, the old URL will still work, but the
  distribution name will be ith the new name.

Sponsored by:	Absolight
27 Dec 2016 11:56:53
Original commit files touched by this commit  1.19.1_1
Revision:429605
rene search for other commits by this committer
games/pyfa: update sqlalchemy dependency to 1.0, bump PORTREVISION

PR:		215229
Submitted by:	rene
Approved by:	maintainer timeout (andrey@bsdnir.info, 16 days)
09 Jun 2016 02:50:02
Original commit files touched by this commit  1.19.1
Revision:416578
mat search for other commits by this committer
It's been a long time since I checked ${PORTSDIR} in _DEPENDS line.  It
seems quite a few crept in.

Pointy hat to:	fluffy, mm, romain
Sponsored by:	Absolight
28 May 2016 14:40:32
Original commit files touched by this commit  1.19.1
Revision:415998
fluffy search for other commits by this committer
- games/pyfa: Update to 1.19.1

PR:		207180
Submitted by:	Andrey Fesenko (maintainer)
Approved by:	miwi (mentor, implicit)
22 May 2016 10:52:45
Original commit files touched by this commit  1.18.0
Revision:415627
matthew search for other commits by this committer
Reorganise and modernise the py-sqlalchemy ports.

 - Introduce new ports for the sqlalchemy 0.9 and 1.0 release branches.
 - Deprecate the ports for the 0.6 and 0.7 release branches, as these
   have been declared EoL and are no longer supported by upstream.
 - Update to the latest available version in each branch.

In detail:

   Port                 Version Maintainer
   ----------------------------------------------
   py-sqlalchemy06      0.6.9   nivit@FreeBSD.org (Deprecate 2016-08-20) [1]
   py-sqlalchemy07      0.7.10  nivit@FreeBSD.org (renamed py-sqlalchemy,
Deprecate 2016-08-20) [1]
   py-sqlalchemy08      0.8.7   nivit@FreeBSD.org (renamed py-sqlalchemy-devel)
[1]
   py-sqlalchemy09      0.9.10  m.tsatsenko@gmail.com (new, repocopy from
py-sqlalchemy-devel) [2]
(Only the first 15 lines of the commit message are shown above View all of this commit message)
01 Apr 2016 14:00:57
Original commit files touched by this commit  1.18.0
Revision:412346
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
18 Jan 2016 05:54:53
Original commit files touched by this commit  1.18.0
Revision:406545
miwi search for other commits by this committer
- Update to 1.18.0

PR:		206322
Submitted by:	maintainer
12 Jan 2016 16:20:32
Original commit files touched by this commit  1.17.1
Revision:405891
amdmi3 search for other commits by this committer
Convert LICENSE= "GPLxx # or later" to "GPLxx+"

Approved by:	portmgr blanket
22 Dec 2015 15:17:46
Original commit files touched by this commit  1.17.1
Revision:404240
miwi search for other commits by this committer
- Update to 1.17.1

PR:		205295
Submitted by:	Andrey Fesenko
Approved by:	mat (mentor)
Differential Revision:	D4571
16 Sep 2015 19:51:28
Original commit files touched by this commit  1.13.1_1
Revision:397077
bapt search for other commits by this committer
Remove ansi version fo wxGTK 2.8 and only keep the unicode version

All applications in the ports tree works correctly with unicode version of wxGTK

Newer version of wxGTK are unicode only (3.0+)

Note that now WX_UNICODE macro is noop
09 Jul 2015 13:44:20
Original commit files touched by this commit  1.13.1
Revision:391632
wen search for other commits by this committer
- Update 1.13.1

PR:		201436
Submitted by:	andrey@bsdnir.info(maintainer)
15 May 2015 20:27:43
Original commit files touched by this commit  1.11.0
Revision:386479
amdmi3 search for other commits by this committer
Pyfa is a cross-platform desktop fitting application for EVE online
that can be used natively on any platform where python and wxwidgets
are available.

It provides many advanced features such as graphs and full calculations
of any possible combination of modules, fits, etc.

WWW: https://github.com/DarkFenX/Pyfa

PR:		199838
Submitted by:	andrey@bsdnir.info

Number of commits found: 15

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
rustMay 15
linux-flashplayerMay 14
samba46May 14
samba47May 14
samba48May 14
php71-exifMay 11
php72-exifMay 11
php73-exifMay 11
postgresql10-serverMay 09
postgresql11-serverMay 09
postgresql11-serverMay 09
postgresql95-serverMay 09
postgresql96-serverMay 09
giteaMay 06
hylafaxMay 05

8 vulnerabilities affecting 48 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-05-18 02:24:37


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 36468
Broken 80
Deprecated 116
Ignore 299
Forbidden 3
Restricted 163
No CDROM 74
Vulnerable 32
Expired 34
Set to expire 90
Interactive 0
new 24 hours 17
new 48 hours28
new 7 days56
new fortnight93
new month197

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.