notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Hardware failure

The website is running on the old server. The new server stopped working at about 0200 UTC on 2020-08-22. The database was restored from 2020-08-21 00:59:15+00 UTC. We think we have covered all commits. Nothing should be missing. Any changes you made to your accounts after the restore date will be lost. Sorry about that.
Port details
python23 An interpreted object-oriented programming language
2.3.7_1 lang Deleted on this many watch lists=14 search for ports that depend on this port This port version is marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. 2.3.7_1Version of this port present on the latest quarterly branch.
Maintainer: python@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2004-12-01 15:06:15
Last Update: 2009-12-18 10:08:32
SVN Revision: unknown

People watching this port, also watch: gettext, libiconv, gmake, python, expat

Also Listed In: python ipv6
License: not specified in port
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • python23>0:lang/python23
No installation instructions: this port has been deleted.
The package name of this deleted port was: python23
PKGNAME: python23
Flavors: there is no flavor information for this port.
distinfo:
There is no distinfo for this port.
Packages: (move your mouse over the cells for more information)
No package information in database for this port.

There are no ports dependent upon this port

Configuration Options
Master Sites:
Expand this list (16 items)
    Collapse this list.
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/python/
  2. ftp://ftp.mirrorservice.org/sites/ftp.python.org/pub/www.python.org/ftp/python/2.3.7/
  3. http://SunSITE.Informatik.RWTH-Aachen.DE/python/ftp/python/2.3.7/
  4. http://ftp.easynet.be/python/ftp/python/2.3.7/
  5. http://gnu.kookel.org/ftp/www.python.org/ftp/python/2.3.7/
  6. http://mirrors.ccs.neu.edu/Python/pub/www.python.org/ftp/python/2.3.7/
  7. http://mirrors.sunsite.dk/pythonwww/ftp/python/2.3.7/
  8. http://python.cdpa.nsysu.edu.tw/ftp/python/2.3.7/
  9. http://python.emdia.fi/ftp/python/2.3.7/
  10. http://python.holywar.net/ftp/python/2.3.7/
  11. http://python.ilisys.com.au/ftp/python/2.3.7/
  12. http://python.mirrors.pair.com/ftp/python/2.3.7/
  13. http://www.auth.gr/mirrors/python/ftp/python/2.3.7/
  14. http://www.cwi.nl/www.python.org/ftp/python/2.3.7/
  15. http://www.linux.org.hk/mirror/python/ftp/python/2.3.7/
  16. http://www.python.org/ftp/python/2.3.7/
  17. Collapse this list.
Port Moves
  • port deleted on 2009-12-18
    REASON: No longer under development

Number of commits found: 26

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
18 Dec 2009 10:08:32
Original commit files touched by this commit  2.3.7_1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Get rid python-2.3 and python-3.0 (no longer under developement)

Reviewed by:    alexbl, clsung, pav
14 Jul 2009 09:29:03
Original commit files touched by this commit  2.3.7_1
 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Ask the first Python installed to install the bin/python link,
  and be the default Python version

PR:             ports/109550
Submitted by:   David Yeske <dyeske AT yahoo.com>
Obtained from:  tmclaugh
12 Jul 2009 16:50:39
Original commit files touched by this commit  2.3.7
 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Honor EXAMPLESDIR, DATADIR, NOPORTEXAMPLES, NOPORTDATA
- portlint(1)
08 Jun 2009 22:30:55
Original commit files touched by this commit  2.3.7
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update lang/python26 and make Python 2.6.2 to the default Python version

Tested by:      3 pointyhat runs
Thanks to:      pav, gahr, lwhsu, mva, amdmi3
21 Aug 2008 06:18:49
Original commit files touched by this commit  2.3.7
 This port version is marked as vulnerable.
rafan search for other commits by this committer
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the
configure target. In short, one should use --build=CONFIGURE_TARGET
instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning
and the old semantic may be removed in later autoconf releases.

To workaround this issue, many ports hack the CONFIGURE_TARGET variable
so that it contains the ``--build='' prefix.

To solve this issue, under the fact that some ports still have
configure script generated by the old autoconf, we use runtime detection
in the do-configure target so that the proper argument can be used.

Changes to Mk/*:
 - Add runtime detection magic in bsd.port.mk
(Only the first 15 lines of the commit message are shown above View all of this commit message)
30 May 2008 05:50:04
Original commit files touched by this commit  2.3.7
 This port version is marked as vulnerable.
perky search for other commits by this committer
Update python23 to 2.3.7.
28 Apr 2008 07:39:59
Original commit files touched by this commit  2.3.6_1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Fix zlib crash from zlib.decompressobj().flush(val)
  when val was not positive. It tried to allocate negative
  or zero memory.  That fails.
- Bump PORTREVISION

PR:             123153
Submitted by:   Nick Barkas <snb@threerings.net>
Security:      
http://www.vuxml.org/freebsd/ec41c3e2-129c-11dd-bab7-0016179b2dd5.html
19 Apr 2008 17:56:05
Original commit files touched by this commit  2.3.6
  Sanity Test Failure This port version is marked as vulnerable.
miwi search for other commits by this committer
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
        Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
        ehaupt, nox, itetcu, flz, pav

PR:             116263
Tested on:      pointyhat
Approved by:    portmgr (pav)
16 Mar 2008 10:25:08
Original commit files touched by this commit  2.3.6
 This port version is marked as vulnerable.
perky search for other commits by this committer
Update python23 to Python 2.3.6 and python24 to Python 2.4.5.
29 Oct 2007 00:14:50
Original commit files touched by this commit  2.3.5_3
 This port version is marked as vulnerable.
perky search for other commits by this committer
Add support for FreeBSD 8.

Obtained from:  Python SVN (r58697, r58698)
03 Oct 2007 23:22:04
Original commit files touched by this commit  2.3.5_2
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Remove support for OSVERSION < 5
30 Jul 2007 09:42:28
Original commit files touched by this commit  2.3.5_2
 This port version is marked as vulnerable.
alexbl search for other commits by this committer
 - Make Python 2.5.1 the default Python version
 - Add significantly better support in bsd.python.mk for working with
   Python Eggs and the easy_install system

Tested by:      pointyhat runs
Approved by:    pav (portmgr)
Most work by:   perky
Thanks to:      pav
21 Jan 2007 13:13:23
Original commit files touched by this commit  2.3.5_1
 This port version is marked as vulnerable.
rafan search for other commits by this committer
- history_length conflicts with include/readline/history.h.
  Similar fix is in 2.4 and above. This causes an incomplete pkg-plist
  with gcc 4.x + newer ncurses.

PR:             ports/108031
Approved by:    alexbl
09 Oct 2006 14:29:18
Original commit files touched by this commit  2.3.5_1
 This port version is marked as vulnerable.
perky search for other commits by this committer
- Update the main python version to 2.5.
  - Now, lang/python is just a meta-port which depends on lang/python25.
  - And all versions of Python ports have short version identifier in its
    package name; python25-2.5, python24-2.4.3 and etc.
  - Also you must upgrade all python modules after lang/python updated,
     cd /usr/ports/lang/python && make upgrade-site-packages

- Give maintainership of Python ports to the new python@ group which
  includes me, alexbl@ and others.
09 May 2006 20:52:24
Original commit files touched by this commit  2.3.5_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Remove USE_REINPLACE from the categories starting with L
22 Jan 2006 12:42:24
Original commit files touched by this commit  2.3.5_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
SHA256ify

Approved by: krion@
28 Jul 2005 07:05:20
Original commit files touched by this commit  2.3.5_1
 This port version is marked as vulnerable.
perky search for other commits by this committer
- Add support for FreeBSD 7
- Drop support for FreeBSD 3
- Fix fcntl.ioctl argument parsing to accept termios.TIOCGWINSZ. [1]

Submitted by:   jkim [1]
Obtained from:  Python CVS
12 Apr 2005 03:26:57
Original commit files touched by this commit  2.3.5
 This port version is marked as vulnerable.
obrien search for other commits by this committer
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
11 Apr 2005 08:04:41
Original commit files touched by this commit  2.3.5
 This port version is marked as vulnerable.
obrien search for other commits by this committer
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
02 Apr 2005 20:20:11
Original commit files touched by this commit  2.3.5
 This port version is marked as vulnerable.
perky search for other commits by this committer
Fix package building on 64bit architectures.
28 Mar 2005 23:11:44
Original commit files touched by this commit  2.3.5
 This port version is marked as vulnerable.
perky search for other commits by this committer
Fix package building on non-i386 platforms by unrestrict `audioop`
module for them in plist.

Approved by:    portmgr (kris)
23 Mar 2005 04:43:58
Original commit files touched by this commit  2.3.5
 This port version is marked as vulnerable.
perky search for other commits by this committer
Unbreak package building on ia64, alpha, amd64 and sparc64 by
adding ossaudiodev module to their plists, either.

Approved by: portmgr (kris)
20 Mar 2005 16:18:42
Original commit files touched by this commit  2.3.5
 This port version is marked as vulnerable.
perky search for other commits by this committer
Update lang/python23 to Python 2.3.5.
04 Feb 2005 04:15:53
Original commit files touched by this commit  2.3.4_4
 This port version is marked as vulnerable.
perky search for other commits by this committer
Add a patch from PSF-2005-001 which fixes SimpleXMLRPCServer
vulnerability.

PR:             77080
Submitted by:   Marcus Grando <marcus@corp.grupos.com.br>
Security:       CAN-2005-0089
Security:      
http://www.vuxml.org/freebsd/6afa87d3-764b-11d9-b0e7-0000e249a0a2.html
Security:       SimpleXMLRPCServer.py allows unrestricted traversal
30 Jan 2005 01:20:54
Original commit files touched by this commit  2.3.4_3
 This port version is marked as vulnerable.
perky search for other commits by this committer
Resolve LATEST_LINK conflict of stackless_python versus python23.

Pointed out by: kris
01 Dec 2004 15:04:05
Original commit files touched by this commit  2.3.4_3
 This port version is marked as vulnerable.
perky search for other commits by this committer
- Update lang/python to 2.4 final release.
- Finish repocopy lang/python -> lang/python23 for Python 2.3.4

Number of commits found: 26

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
freetype2Oct 22
chromiumOct 21
mysql56-serverOct 21
mysql57-serverOct 21
mysql80-serverOct 21
mariadb103-clientOct 18
mariadb103-serverOct 18
mariadb104-clientOct 18
mariadb104-serverOct 18
mariadb105-clientOct 18
mariadb105-serverOct 18
drupal7Oct 17
py-matrix-synapseOct 17
powerdns-recursorOct 14
linux-flashplayerOct 13

9 vulnerabilities affecting 118 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2020-10-22 09:39:08


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 41203
Broken 57
Deprecated 274
Ignore 294
Forbidden 4
Restricted 146
No CDROM 73
Vulnerable 23
Expired 10
Set to expire 245
Interactive 0
new 24 hours 3
new 48 hours14
new 7 days81
new fortnight110
new month210

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2020 Dan Langille. All rights reserved.