Belle-sip is a SIP (RFC3261) implementation written in C, with an object
oriented API.
* RFC3261 compliant implementation of SIP parser, writer, transactions and
dialog layers
* HTTP client API
* support of client TLS certificate
* fully asynchronous transport layer (UDP, TCP, TLS)
* fully asynchronous DNS resolution with SRV
* full dual-stack IPv6 support
* SIP transaction state machines with latest corrections (RFC6026)
* automatic management of request refreshes with network disconnection
resiliency thanks to the "refresher" object
* supported platforms: Linux, Mac OSX, Windows XP+, iOS, Android,
Blackberry 10
Mk/**java.mk: Convert bsd.java.mk to USES
The following features have been added or changed:
- Instead of USE_JAVA use USES=java. This defaults to
USES=java:build,run if NO_BUILD is undefined. Else it defaults to
USES=java:run
- Instead of USE_ANT=yes use USES=java:ant which also implies
USES=java:build
- Instead of JAVA_BUILD=yes use USES=java:build. Does not imply run or
extract
- Instead of JAVA_EXTRACT=yes use USES=java:extract does not imply
build or run
- Instead of JAVA_RUN=yes use USES=java:run does not imply extract or
build
- Instead of USE_JAVA=<version> use USES=java and JAVA_VERSION=<version>
Approved by: mat (portmgr), glewis
Differential Revision: https://reviews.freebsd.org/D48201
bsd.sites.mk: Update all ports using USE_GITLAB
Replace GL_COMMIT by GL_TAGNAME in all ports. The new GL_TAGNAME is
backwards-compatible (accepting any commit hash as before), but also
understands an actual tag name. Moving to tag names where appropriate is
left to individual ports' maintainers.
Approved by: portmgr (tcberner, mentor)
Differential Revision: https://reviews.freebsd.org/D37077
Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
Fix spelling mistakes, typos, poor wording, hyphenation, jargonisms,
contractions, "<portname> is ..." cases, missing Oxford commas, and
other miscellaneous style bugs in the COMMENT line.
Clean up after java/openjdk6 and java/openjdk6-jre removal
java/openjdk6 support was removed from Mk/bsd.java.mk (r512662) and
java/openjdk6 and java/openjdk6-jre were removed from the ports tree
(r512663). Now this patch completely removes remaining stuff from the
ports tree.
PR: 241953 (exp-run)
Reviewed by: glewis
Approved by: portmgr (antoine)
Differential Revision: https://reviews.freebsd.org/D22342
Update the Linphone stack and drop maintainership.
Linphone uses Qt5 now instead of GTK2.
audio/bcg729:
- switch to cmake, required by net/mediastreamer
- download distfile instead of using gitlab
- fix license: source code allows later GPL version
audio/msbcg729: deleted, net/mediastreamer contains a G.729 codec now
audio/msilbc: deleted, superseded by multimedia/mswebrtc
deskutils/belcard: version 1.0.2
multimedia/bcmatroska2: version 0.23
multimedia/msopenh264: version 1.2.1
multimedia/mswebrtc: version 1.1.1
multimedia/msx264: deleted, superseded by msopenh264
net/bctoolbox: version 0.6.0
net/belle-sip: version 1.6.3
net/liblinphone: version 3.12.0
net/linphone: version 4.1.1 + upstream Qt 5.11 patches
net/mediastreamer: version 2.16.1 + upstream libsrtp2 patch
net/ortp: version 1.0.2 + bump dependent port devel/libosmo-abis
security/bzrtp: version 1.0.6
textproc/belr: version 0.1.3
Bump PORTREVISION for ports depending on the canonical version of GCC
in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which
has now moved from GCC 6 to GCC 7 by default.
This includes ports
- featuring USE_GCC=yes or USE_GCC=any,
- featuring USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and those
- with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.
PR: 222542
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
c++14-lang, c++0x, c11, or gcc-c++11-lib.
PR: 219275
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using using Mk/bsd.octave.mk which in turn has USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
c++11-lang, c++0x, c11, or gcc-c++11-lib.
PR: 216707
Bump PORTREVISIONS for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.8.5 to GCC 4.9.4 (at least under some
circumstances such as versions of FreeBSD or platforms).
In particular that is ports with USE_GCC=yes, USE_GCC=any, or one of
gcc-c++11-lib, openmp, nestedfct, c++11-lib as well as c++14-lang,
c++11-lang, c++0x, c11 requested via USES=compiler.
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like
"CC foo.c"). CMake and ninja enable this by default, some autotools
using ports do as well. This is unacceptable because we need complete
build logs at any time, so we now switch to verbose build logs
unconditionally. Note that this change deliberately affects ALL
builds and not only package builds on cluster, because we need to
be sure that user experiencing failure can always provide informative
build log regardless of settings and without rerunning the build.
Change summary:
- Always do verbose builds for cmake, ninja and GNU configure (the
latter includes check if --disable-silent-rules is actually supported
by the configure script; there are isolated cases when it's not true)
(Only the first 15 lines of the commit message are shown above )
- Update security/polarssl13 to 1.3.11
- Patch a Makefile so regular make install works
- Replace a patch with MAKE_ENV
- Bump dependent ports
PR: 200816
Cleanup DIST* variables.
When appropriate:
- Try to use DISTVERSION{SUF,PRE}FIX
- Replace PORTNAME-PORTVERSION by DISTNAME
- Convert MASTER_SITES to use macros
- Other light cleanup
With hat: portmgr
Sponsored by: Absolight
- Updates to the Linphone stack: Belle-sip 1.4.0, oRTP 0.24.1,
Mediastreamer 2.11.1, Linphone 3.8.1
- Switch to PolarSSL 1.3.x to enable instant messaging encryption
- SRTP/ZRTP support has been moved from oRTP to Mediastreamer
Notable enhancements in this release:
- Fullscreen mode
- Hang up button in the video window
- Wizard for audio/video settings
- Arabic translation
- Support RTP/AVPF (RFC4585) with VP8 codec: this feature allows
transmission error recovery for video, which greatly enhances the
video quality over unreliable links
Switch from clang33 to clang34 for ports using compiler:*11*, objc or
gnustep on freebsd 8.4 and 9.1
PR: ports/193555
Differential Revision: https://reviews.freebsd.org/D935
Reviewed by: bapt
Exp-run: self
- Add patch to initialise a struct before calling res_ninit [1]
- Remove --enable-debug because it doesn't do anything
PR: 192648
Submitted by: Dom F <freebsd@talk2dom.com> [1]
Approved by: Muhammad Moinur Rahman <5u623l20@gmail.com> (maintainer)
New port: net/belle-sip
Belle-sip is a SIP (RFC3261) implementation written in C, with an object
oriented API.
* RFC3261 compliant implementation of SIP parser, writer, transactions and
dialog layers
* http client api
* support of client TLS certificate
* fully asynchronous transport layer (UDP, TCP, TLS)
* fully asynchronous DNS resolution with SRV
* full dual-stack IPv6 support
* SIP transaction state machines with lastest corrections (RFC6026)
* automatic management of request refreshes with network disconnection
resiliency thanks to the "refresher" object
* supported platforms: Linux, Mac OSX, windows XP+, iOS, Android,
Blackberry 10
PR: 191528
Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>