Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
net: remove 'Created by' lines
A big Thank You to the original contributors of these ports:
* <ports@c0decafe.net>
* Aaron Dalton <aaron@FreeBSD.org>
* Aaron Straup Cope <ascope@cpan.org>
* Aaron Zauner <az_mail@gmx.at>
* Adam Jette <jettea46@yahoo.com>
* Adam Weinberger <adamw@FreeBSD.org>
* Alan Eldridge <alane@geeksrus.net>
* Alex Bakhtin <Alex.Bakhtin@gmail.com>
* Alex Deiter <Alex.Deiter@Gmail.COM>
* Alex Dupre <ale@FreeBSD.org>
* Alex Dupre <sysadmin@alexdupre.com>
(Only the first 15 lines of the commit message are shown above )
Custom OSPF "wrong LSA collision detection patch" is in conflict with the fix
included in bird 1.6.7 and generate crashes, so remove it.
PR: 238496
Submitted by: pbd@pbd.name
Reported by: Ondrej Zajicek <santiago@crfreenet.org>
Update to 1.6.4 and remove the FreeBSD's specific feature FIREWALL option
to ease port maintenance.
PR: 226860
Reported by: Leo Vandewoestijne <freebsd@dns.company>
Update net/bird,net/bird6 to 1.6.0
Add sk_setup / io loop fixes from git.
Remove agg patch - new version with different syntax is comingTimeout, server
noc-myt.yandex.net not responding.
PR: 211413
Submitted by: zeising (original version)
Approved by: az (implicit)
Bump version to 1.5.0 (changelog below).
Remove experimental and already included patches.
Add OSPF: Fixes validation of LSA checksums from git.
Remove clang gnu89 constaint.
Version 1.5.0 (2015-04-20)
Major OSPF protocol redesign.
OSPFv2 multi-instance extension (RFC 6549).
BGP AS-wide unique router ID (RFC 6286).
BGP enhanced route refresh (RFC 7313).
Link state support in BGP.
Latency tracking and internal watchdog.
Uses high port range for BFD on BSD.
Increase max symbol length to 64.
Allows to define unnamed protocols from templates.
(Only the first 15 lines of the commit message are shown above )
Update to 1.4.5.
o New 'show route noexport' command option.
o Port option for BGP sessions.
o Better constant handling in set literals.
o Better rate filtering of log messages.
o Several minor bugfixes.
Approved by: az(implicit)
Update net/bird & net/bird6 to 1.3.11
New features:
* OSPF stub router option (RFC 3137).
* TTL security for OSPF and RIP.
* Protocol packet priority and traffic class handling.
* Multiple routing tables support for FreeBSD and OpenBSD.
* Extends constants to all filter data types.
* Implements eval command.
* 'bgppath ~ int set' filter operation.
* Several bugfixes.
MFIBS option was removed (gone to upstream, enabled by default)
Approved by: az
Convert USE_BISON to USES= bison
It brings bison as a build dependency in case it is set the following way:
USES= bison or USES= bison:build
it brings bison as a run dependency in case it is set the following way:
USES= bison:run
it brings bison both as a run and build dependency in case it the set the
following way:
USES= bison:both
While here trim some headers
Convert some USE_GNOME= gnomehack to USES= pathfix
* Move net/bird, net/bird6 and net/bird-devel socket to /var/run
* Bump portrevision for net/bird and net/bird6
* Update net/bird-devel to current version (20130301)
* Add router id fix patch to net/bird
* Add multiple fibs patch to net/bird-devel
Approved by: az (implicit)
In the rc.d scripts, change assignments to rcvar to use the
literal name_enable wherever possible, and ${name}_enable
when it's not, to prepare for the demise of set_rcvar().
In cases where I had to hand-edit unusual instances also
modify formatting slightly to be more uniform (and in
some cases, correct). This includes adding some $FreeBSD$
tags, and most importantly moving rcvar= to right after
name= so it's clear that one is derived from the other.
- Update to 1.3.2
- Update fibs patch (stop bird dumping core on shutdown)
- Update include patch (config errors are displayed correctly after SIGHUP or
configure)
- Remove bgp patch (included in tree now)
PR: ports/159330
Submitted by: Alexander V. Chernikov <melifaro@ipfw.ru> (maintainer)
* Import BGP incorrect attribute patch from git
* Improve multiple fibs support with working patch and warning
* Add CONFIG_INCLUDES option/patch permitting including other files in config
* Remove LEARN_FIX option due to problems with bird restarts
* Bump PORTREVISION
PR: 157645
Submitted by: "Alexander V. Chernikov" <melifaro@ipfw.ru>
- Update to 1.3.1
- Add optional patches (to ipv4 port) to enable multiple fibs support, and to
enable a simultaneous operation with other routing software
- Sign over a maintainership to an enthusiastic user
PR: ports/157001
Submitted by: Alexander V. Chernikov <melifaro@ipfw.ru>
The BIRD project aims to develop a fully functional dynamic IP routing daemon
primarily targetted on (but not limited to) UNIX-like systems and distributed
under the GNU General Public License.
* Both IPv4 and IPv6 (use --enable-ipv6 when configuring)
* Multiple routing tables
* BGP
* RIP
* OSPF (IPv4 only)
* Static routes
* Inter-table protocol