notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
rubygem-oauth212 Ruby wrapper for the OAuth 2.0 protocol
1.2.0_2 net Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 1.2.0Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Only created for www/gitlab; please use net/rubygem-oauth2 instead
Expired This port expired on: 2017-07-31
Maintainer: sunpoet@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-04-28 20:26:58
Last Update: 2017-07-31 18:42:34
SVN Revision: 446988
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • rubygem-oauth212>0:net/rubygem-oauth212
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: rubygem-oauth212
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby23 : lang/ruby23
  2. gem23 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-faraday>=0.8 : www/rubygem-faraday
  2. rubygem-jwt>=1.0 : www/rubygem-jwt
  3. rubygem-multi_json>=1.3 : devel/rubygem-multi_json
  4. rubygem-multi_xml>=0.5 : textproc/rubygem-multi_xml
  5. rubygem-rack>=1.2 : www/rubygem-rack
  6. ruby23 : lang/ruby23
  7. gem23 : devel/ruby-gems
Patch dependencies:
  1. ruby23 : lang/ruby23
  2. gem23 : devel/ruby-gems
Extract dependencies:
  1. ruby23 : lang/ruby23
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. https://rubygems.global.ssl.fastly.net/gems/
Port Moves
  • port moved to net/rubygem-oauth2 on 2017-07-31
    REASON: Has expired: Only created for www/gitlab; please use net/rubygem-oauth2 instead

Number of commits found: 3

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
31 Jul 2017 17:42:34
Original commit files touched by this commit  1.2.0_2
Revision:446988
rene search for other commits by this committer
Remove expired ports:
2017-07-31 net/rubygem-oauth212: Only created for www/gitlab; please use
net/rubygem-oauth2 instead
2017-07-31 textproc/rubygem-liquid3: Use textproc/rubygem-liquid instead
2017-07-31 mail/dovecot2-antispam-plugin: Use pigeonhole instead. See
https://wiki2.dovecot.org/HowTo/AntispamWithSieve
2017-07-31 mail/dovecot-antispam: Dovecot-1.x is deprecated. Use dovecot2 and
dovecot2-antispam-plugin instead
2017-07-31 mail/dovecot-sieve: Dovecot-1.x is deprecated. Use dovecot2 and
dovecot-pigeonhole instead
2017-07-31 mail/dovecot-managesieve: Dovecot-1.x is deprecated. Use dovecot2 and
dovecot-pigeonhole instead
2017-07-31 www/rubygem-jquery-ui-rails5-rails4: Only created for www/gitlab;
please use www/rubygem-jquery-ui-rails-rails4 instead
2017-07-31 security/rubygem-omniauth13: Only created for www/gitlab; please use
security/rubygem-omniauth instead
2017-07-31 devel/rubygem-health_check22: Only created for www/gitlab; please use
devel/rubygem-health_check instead
2017-07-31 devel/rubygem-semantic_puppet0: Use devel/rubygem-semantic_puppet
instead
2017-07-31 devel/rubygem-newrelic_rpm3: Only created for www/gitlab; please use
devel/rubygem-newrelic_rpm instead
2017-07-31 lang/p5-Parse-Perl: does not build with Perl >= 5.22
2017-07-31 sysutils/rubygem-puppet_forge1: Use sysutils/rubygem-puppet_forge
instead
2017-07-31 sysutils/rubygem-SyslogLogger: Project is EOL'd because it was merged
into Ruby 2.0
06 Jul 2017 14:14:22
Original commit files touched by this commit  1.2.0_2
Revision:445154
tz search for other commits by this committer
net/rubygem-oauth212: set DEPRICATED and EXPIRATION_DATE

This port was needed for www/gitlab 9.0. After the update to 9.1
it is no longer needed and therefore depricated.
28 Apr 2017 20:24:54
Original commit files touched by this commit  1.2.0_2
Revision:439632
sunpoet search for other commits by this committer
Add rubygem-oauth212 1.2.0 (copied from rubygem-oauth2)

- Add PORTSCOUT

Number of commits found: 3

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
python37Oct 19
py-pillowOct 15
mod_perl2Oct 09
xpdfOct 06
xpdf3Oct 06
xpdf4Oct 06
unboundOct 03
cactiOct 02
gitlab-ceOct 02
gitlab-ceOct 02
ruby24Oct 02
ruby25Oct 02
mongodb34Sep 30
mongodb34Sep 30
mongodb36Sep 30

4 vulnerabilities affecting 12 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-10-19 10:52:46


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 37705
Broken 75
Deprecated 102
Ignore 340
Forbidden 3
Restricted 156
No CDROM 73
Vulnerable 26
Expired 15
Set to expire 73
Interactive 0
new 24 hours 3
new 48 hours6
new 7 days12
new fortnight40
new month141

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.