notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
krb5-113 MIT implementation of RFC 4120 network authentication service
1.13.7_8 security Deleted on this many watch lists=0 search for ports that depend on this port This port version is marked as vulnerable. Find issues related to this port Report an issue related to this port 1.13.7Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: EOL twelve months after release of krb5-1.15
Expired This port expired on: 2017-12-02
Maintainer: cy@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2015-11-21 08:47:23
Last Update: 2017-12-03 19:23:25
SVN Revision: 455423
License: MIT
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (172 items)
  1. /usr/local/share/licenses/krb5-113-1.13.7_8/catalog.mk
  2. /usr/local/share/licenses/krb5-113-1.13.7_8/LICENSE
  3. /usr/local/share/licenses/krb5-113-1.13.7_8/MIT
  4. bin/compile_et
  5. bin/gss-client
  6. bin/k5srvutil
  7. bin/kadmin
  8. bin/kdestroy
  9. bin/kinit
  10. bin/klist
  11. bin/kpasswd
  12. bin/krb5-config
  13. @mode 04755
  14. @owner root
  15. @group wheel
  16. bin/ksu
  17. @mode
  18. @owner root
  19. @group wheel
  20. bin/kswitch
  21. bin/ktutil
  22. bin/kvno
  23. bin/sclient
  24. bin/sim_client
  25. bin/uuclient
  26. include/com_err.h
  27. include/gssapi.h
  28. include/gssapi/gssapi.h
  29. include/gssapi/gssapi_ext.h
  30. include/gssapi/gssapi_generic.h
  31. include/gssapi/gssapi_krb5.h
  32. include/gssapi/mechglue.h
  33. include/gssrpc/auth.h
  34. include/gssrpc/auth_gss.h
  35. include/gssrpc/auth_gssapi.h
  36. include/gssrpc/auth_unix.h
  37. include/gssrpc/clnt.h
  38. include/gssrpc/netdb.h
  39. include/gssrpc/pmap_clnt.h
  40. include/gssrpc/pmap_prot.h
  41. include/gssrpc/pmap_rmt.h
  42. include/gssrpc/rename.h
  43. include/gssrpc/rpc.h
  44. include/gssrpc/rpc_msg.h
  45. include/gssrpc/svc.h
  46. include/gssrpc/svc_auth.h
  47. include/gssrpc/types.h
  48. include/gssrpc/xdr.h
  49. include/krad.h
  50. include/krb5.h
  51. include/krb5/ccselect_plugin.h
  52. include/krb5/clpreauth_plugin.h
  53. include/krb5/hostrealm_plugin.h
  54. include/krb5/kadm5_hook_plugin.h
  55. include/krb5/kdcpreauth_plugin.h
  56. include/krb5/localauth_plugin.h
  57. include/krb5/krb5.h
  58. include/krb5/locate_plugin.h
  59. include/krb5/plugin.h
  60. include/krb5/pwqual_plugin.h
  61. include/kadm5/admin.h
  62. include/kadm5/chpass_util_strings.h
  63. include/kadm5/kadm_err.h
  64. include/kdb.h
  65. include/krb5/preauth_plugin.h
  66. include/profile.h
  67. include/verto-module.h
  68. include/verto.h
  69. lib/libcom_err.so
  70. lib/libcom_err.so.3
  71. lib/libcom_err.so.3.0
  72. lib/libgssapi_krb5.so
  73. lib/libgssapi_krb5.so.2
  74. lib/libgssapi_krb5.so.2.2
  75. lib/libgssrpc.so
  76. lib/libgssrpc.so.4
  77. lib/libgssrpc.so.4.2
  78. lib/libk5crypto.so
  79. lib/libk5crypto.so.3
  80. lib/libk5crypto.so.3.1
  81. lib/libkadm5clnt.so
  82. lib/libkadm5clnt_mit.so
  83. lib/libkadm5clnt_mit.so.9
  84. lib/libkadm5clnt_mit.so.9.0
  85. lib/libkadm5srv.so
  86. lib/libkadm5srv_mit.so
  87. lib/libkadm5srv_mit.so.9
  88. lib/libkadm5srv_mit.so.9.0
  89. lib/libkdb5.so
  90. lib/libkdb5.so.8
  91. lib/libkdb5.so.8.0
  92. lib/libkrb5.so
  93. lib/libkrb5.so.3
  94. lib/libkrb5.so.3.3
  95. lib/libkrb5support.so
  96. lib/libkrb5support.so.0
  97. lib/libkrb5support.so.0.1
  98. lib/krb5/plugins/kdb/db2.so
  99. lib/krb5/plugins/tls/k5tls.so
  100. @comment lib/krb5/plugins/kdb/kldap.so
  101. lib/krb5/plugins/preauth/otp.so
  102. lib/krb5/plugins/preauth/pkinit.so
  103. @comment lib/libkdb_ldap.so
  104. @comment lib/libkdb_ldap.so.1
  105. @comment lib/libkdb_ldap.so.1.0
  106. lib/libkrad.so
  107. lib/libkrad.so.0
  108. lib/libkrad.so.0.0
  109. lib/libverto.so
  110. lib/libverto.so.0
  111. lib/libverto.so.0.0
  112. libdata/pkgconfig/gssrpc.pc
  113. libdata/pkgconfig/kadm-client.pc
  114. libdata/pkgconfig/kadm-server.pc
  115. libdata/pkgconfig/kdb.pc
  116. libdata/pkgconfig/krb5-gssapi.pc
  117. libdata/pkgconfig/krb5.pc
  118. libdata/pkgconfig/mit-krb5-gssapi.pc
  119. libdata/pkgconfig/mit-krb5.pc
  120. man/man1/k5srvutil.1.gz
  121. man/man1/kadmin.1.gz
  122. man/man1/krb5-config.1.gz
  123. man/man1/kpasswd.1.gz
  124. man/man1/klist.1.gz
  125. man/man1/kinit.1.gz
  126. man/man1/kdestroy.1.gz
  127. man/man1/kswitch.1.gz
  128. man/man1/ksu.1.gz
  129. man/man1/ktutil.1.gz
  130. man/man1/sclient.1.gz
  131. man/man1/kvno.1.gz
  132. man/man1/compile_et.1.gz
  133. man/man5/kadm5.acl.5.gz
  134. man/man5/kdc.conf.5.gz
  135. man/man5/krb5.conf.5.gz
  136. man/man5/.k5identity.5.gz
  137. man/man5/.k5login.5.gz
  138. man/man5/k5identity.5.gz
  139. man/man5/k5login.5.gz
  140. man/man8/krb5kdc.8.gz
  141. man/man8/kadmin.local.8.gz
  142. man/man8/kdb5_ldap_util.8.gz
  143. man/man8/kdb5_util.8.gz
  144. man/man8/kadmind.8.gz
  145. man/man8/kprop.8.gz
  146. man/man8/kpropd.8.gz
  147. man/man8/kproplog.8.gz
  148. man/man8/sserver.8.gz
  149. sbin/gss-server
  150. sbin/kadmin.local
  151. sbin/kadmind
  152. @comment sbin/kdb5_ldap_util
  153. sbin/kdb5_util
  154. sbin/kprop
  155. sbin/kpropd
  156. sbin/kproplog
  157. sbin/krb5-send-pr
  158. sbin/krb5kdc
  159. sbin/sim_server
  160. sbin/sserver
  161. sbin/uuserver
  162. share/et/et_c.awk
  163. share/et/et_h.awk
  164. share/locale/en_US/LC_MESSAGES/mit-krb5.mo
  165. @comment share/krb5/kerberos.schema
  166. @comment share/krb5/kerberos.ldif
  167. @dir lib/krb5/plugins/authdata
  168. @dir lib/krb5/plugins/libkrb5
  169. @dir var/run/krb5kdc
  170. @dir var/krb5kdc
  171. @postexec /sbin/ldconfig -m /usr/local/lib
  172. @postunexec /sbin/ldconfig -R
Collapse this list.
Dependency lines:
  • krb5-113>0:security/krb5-113
  • libgssrpc.so:security/krb5-113
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: krb5-113
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. gmake : devel/gmake
  2. libtool : devel/libtool
  3. msgfmt : devel/gettext-tools
  4. perl5>=5.24<5.25 : lang/perl5.24
Runtime dependencies:
  1. pkgconf>=1.3.0_1 : devel/pkgconf
Library dependencies:
  1. libintl.so : devel/gettext-runtime
  2. libreadline.so.7 : devel/readline
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. http://web.mit.edu/kerberos/dist/krb5/1.13/
Port Moves
  • port moved to security/krb5-114 on 2017-12-03
    REASON: Has expired: EOL twelve months after release of krb5-1.15

Number of commits found: 33

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
03 Dec 2017 19:23:25
Original commit files touched by this commit  1.13.7_8
Revision:455423 This port version is marked as vulnerable.
rene search for other commits by this committer
Remove expired port:
2017-12-02 security/krb5-113: EOL twelve months after release of krb5-1.15
02 Nov 2017 21:41:47
Original commit files touched by this commit  1.13.7_8
Revision:453381 This port version is marked as vulnerable.
olgeni search for other commits by this committer
Fix whitespace issues (mixed tab/spaces, alignment) in a few ports.

This round is @FreeBSD.org residents except teams.
30 Oct 2017 16:55:27
Original commit files touched by this commit  1.13.7_8
Revision:453195 This port version is marked as vulnerable.
mandree search for other commits by this committer
Reconcile e2fsprogs ./. krb5-* conflicts.

* Move conflicting e2fsprogs headers & libs into .../e2fsprogs/... subdirs.
* Move conflicting awk scripts into ${DATADIR}.
* Rename and patch compile_et to e2fsprogs-compile_et.
* Remove conflict markers (from e2fsprogs and krb5-*).
* Add CPPFLAGS/LDFLAGS to sysutils/fusefs-ext2, including
  --rpath setting.

While here, also:
* sort pkg-plist and files/unwanted
* use FUSEFS_CONFIGURE_ENABLE=fuse2fs to prevent e2fsprogs from picking up
  fusefs (implies --disable-fuse2fs if the option remains disabled)
* add --without-included-gettext to CONFIGURE_ARGS just to be on the safe
  side.

And of course, bump PORTREVISION to 3 in e2fsprogs. Since other ports
do not change files or runtime behaviour, their PORTREVISION remains
untouched.
30 Oct 2017 00:16:28
Original commit files touched by this commit  1.13.7_8
Revision:453148 This port version is marked as vulnerable.
mandree search for other commits by this committer
Add CONFLICTS between krb5-* and e2fsprogs.

Reported by: jbeich@
05 Oct 2017 01:55:26
Original commit files touched by this commit  1.13.7_8
Revision:451259 This port version is marked as vulnerable.
cy search for other commits by this committer
Register conflicts among the krb5 ports.

Reported by:	rodrigo
27 Jun 2017 13:46:53
Original commit files touched by this commit  1.13.7_8
Revision:444463 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update devel/readline to 7.0 patch 3

- Bump PORTREVISION for shlib change

Changes:	https://cnswww.cns.cwru.edu/php/chet/readline/CHANGES
		https://lists.gnu.org/archive/html/bug-bash/2016-09/msg00107.html
		https://lists.gnu.org/archive/html/bug-readline/2017-01/msg00002.html
Differential Revision:	https://reviews.freebsd.org/D11172
PR:		219947
Exp-run by:	antoine
21 Jun 2017 02:46:53
Original commit files touched by this commit  1.13.7_7
Revision:444011 This port version is marked as vulnerable.
cy search for other commits by this committer
Switch to USES=localbase.
14 Mar 2017 04:57:38
Original commit files touched by this commit  1.13.7_7
Revision:436130 This port version is marked as vulnerable.
cy search for other commits by this committer
Fix up plist.
14 Mar 2017 03:24:42
Original commit files touched by this commit  1.13.7_7
Revision:436129 This port version is marked as vulnerable.
cy search for other commits by this committer
Pet portlint.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 03:22:20
Original commit files touched by this commit  1.13.7_7
Revision:436128 This port version is marked as vulnerable.
cy search for other commits by this committer
Simplfy WRKSRC by using WRKSRC_SUBDIR.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 03:17:52
Original commit files touched by this commit  1.13.7_7
Revision:436127 This port version is marked as vulnerable.
cy search for other commits by this committer
Describe CMD_LINE_EDITING RADIO group.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 03:15:55
Original commit files touched by this commit  1.13.7_7
Revision:436126 This port version is marked as vulnerable.
cy search for other commits by this committer
Respect global NLS option.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 03:14:08
Original commit files touched by this commit  1.13.7_7
Revision:436125 This port version is marked as vulnerable.
cy search for other commits by this committer
Convert to global EXAMPLES (default).

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 03:09:16
Original commit files touched by this commit  1.13.7_7
Revision:436122 This port version is marked as vulnerable.
cy search for other commits by this committer
New READLINE_PORT option to select to use readline in base or
readline in ports.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 03:06:23
Original commit files touched by this commit  1.13.7_7
Revision:436121 This port version is marked as vulnerable.
cy search for other commits by this committer
Remove redundant file that should have been removed in r253265.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 02:59:39
Original commit files touched by this commit  1.13.7_5
Revision:436119 This port version is marked as vulnerable.
cy search for other commits by this committer
Use options helpers.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 02:55:24
Original commit files touched by this commit  1.13.7_5
Revision:436118 This port version is marked as vulnerable.
cy search for other commits by this committer
Install LDIF and schema files if LDAP is enabled

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 02:51:37
Original commit files touched by this commit  1.13.7_3
Revision:436117 This port version is marked as vulnerable.
cy search for other commits by this committer
Replace explicit PLIST_SUB with OPTIONS_SUB, simplifying Makefiles.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
14 Mar 2017 02:48:20
Original commit files touched by this commit  1.13.7_3
Revision:436116 This port version is marked as vulnerable.
cy search for other commits by this committer
Make READLINE default.

PR:		217552
Submitted by:	John W. O'brien <john@saltant.com>
Differential Revision:	D9889
05 Mar 2017 03:27:05
Original commit files touched by this commit  1.13.7_2
Revision:435447  Sanity Test Failure This port version is marked as vulnerable.
cy search for other commits by this committer
Remove redundant message about Kerberos klogind and telnetd. These
programs ere moved to krb5-appl (by MIT) when krb5-appl was created
in r253265. This message should have been removed from this Makefile
at that time.

Pointy hat to:	cy (that's me)
04 Feb 2017 01:37:17
Original commit files touched by this commit  1.13.7_1
Revision:433276 This port version is marked as vulnerable.
cy search for other commits by this committer
pkgconfig is only needed at install/runtime.

Reported by:	des
16 Dec 2016 20:16:48
Original commit files touched by this commit  1.13.7
Revision:428694 This port version is marked as vulnerable.
cy search for other commits by this committer
Replace description with somthing more relevant to today.

Suggested by:	wollman
03 Dec 2016 00:54:23
Original commit files touched by this commit  1.13.7
Revision:427588 This port version is marked as vulnerable.
cy search for other commits by this committer
Welcome the new security/krb5-115 port. This port follows MIT's
KRB5 1.15 releases.

To support this new ports:

- The security/krb5 port includes an option to use this port instead
  of krb5-114 as its base. krb5-114 will remain the default until the
  next release of KRB5 1.15 (if it's stable of course).

- MIT by default deprecates KRB5 two versions back from the current
  release. krb5-113 has been deprecated and will expire one year from
  now.
17 Sep 2016 15:24:36
Original commit files touched by this commit  1.13.7
Revision:422329 This port version is marked as vulnerable.
cy search for other commits by this committer
Update 1.13.6 --> 1.13.7
27 Jul 2016 02:03:38
Original commit files touched by this commit  1.13.6
Revision:419157 This port version is marked as vulnerable.
cy search for other commits by this committer
Update to 1.13.6.

This is a bug fix release.

* Improve some error messages

* Improve documentation

* Allow a principal with nonexistent policy to bypass the minimum
  password lifetime check, consistent with other aspects of
  nonexistent policies

* Fix a rare KDC denial of service vulnerability when anonymous client
  principals are restricted to obtaining TGTs only [CVE-2016-3120]

MFH:		2016Q3
Security:	62d45229-4fa0-11e6-9d13-206a8a720317
Security:	CVE-2016-3120
27 Jul 2016 01:56:23
Original commit files touched by this commit  1.13.5
Revision:419156 This port version is marked as vulnerable.
cy search for other commits by this committer
Modernize krb5-112 and krb5-113 replacing USE_OPENSSL with USES=ssl.
19 May 2016 10:53:06
Original commit files touched by this commit  1.13.5
Revision:415500 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix trailing whitespace in pkg-descrs, categories [p-x]*

Approved by:	portmgr blanket
20 Apr 2016 12:28:55
Original commit files touched by this commit  1.13.5
Revision:413684 This port version is marked as vulnerable.
cy search for other commits by this committer
Update 1.13.4 --> 1.13.5
30 Mar 2016 07:28:23
Original commit files touched by this commit  1.13.4
Revision:412159 This port version is marked as vulnerable.
bapt search for other commits by this committer
Remove uneeded dependency on GNU m4
08 Mar 2016 06:57:00
Original commit files touched by this commit  1.13.4
Revision:410605 This port version is marked as vulnerable.
cy search for other commits by this committer
Update 1.13.3 --> 1.13.4
15 Dec 2015 05:02:21
Original commit files touched by this commit  1.13.3
Revision:403760 This port version is marked as vulnerable.
cy search for other commits by this committer
This is the second part of two commits, the first being r403749.

Adopt the same port structure as used by the cfengine family of ports:

security/krb5 is renamed to security/krb5-114.

A brand new security/krb5 now becomes a master port for the family of
security/krb5-* ports. The default installs krb5-1.14. There is no
functional change to the port build nor does the name of the latest krb5
port and package change. Users can continue to install security/krb5
to track the latest major version of security/krb5.

Users wishing to install a specific version branch of krb5 can continue
to install any of the security/krb5-* ports or by setting KRB5_VERSION
in make.conf make.conf or including the branch on the make command line
during build:

	make KRB5_VERSIN=NNN

make -V VERSIONS lists available versions.

security/krb5-appl has been updated to support this change (also fixing
a typo in the krb5-appl/Makefile).

Inspired by:            sysutils/cfengine
05 Dec 2015 03:59:25
Original commit files touched by this commit  1.13.3
Revision:403021 This port version is marked as vulnerable.
cy search for other commits by this committer
Update 1.13.2 --> 1.13.3
21 Nov 2015 08:47:13
Original commit files touched by this commit  1.13.2
Revision:402143 This port version is marked as vulnerable.
cy search for other commits by this committer
Introduce the new krb5 1.14:

- move (copy) krb5 (krb5 1.13.2) to krb5-113 (new, added)
- update krb5 1.13.2 --> 1.14
- update CONFLICTS in krb5, krb5-112 and krb5-113.
- update krb5-appl to allow optional dependency on krb5-113.
- update security/Makefile with copied krb5-113.
- deprecate and expire krb5-112 (krb5-1.12) on November 20, 2016, as it
  will EOL twelve months after the release of krb5-1.14.

Number of commits found: 33

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
asterisk13Nov 22
asterisk13Nov 22
asterisk13Nov 22
asterisk16Nov 22
asterisk16Nov 22
giteaNov 22
drm-current-kmodNov 20
drm-devel-kmodNov 20
drm-fbsd12.0-kmodNov 20
squidNov 19
libidn2Nov 18
gcpioNov 15
libmadNov 13
chromiumNov 12
wordpressNov 12

11 vulnerabilities affecting 112 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-11-22 11:17:49


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38090
Broken 775
Deprecated 103
Ignore 1045
Forbidden 3
Restricted 157
No CDROM 72
Vulnerable 33
Expired 8
Set to expire 72
Interactive 0
new 24 hours 7
new 48 hours9
new 7 days28
new fortnight67
new month136

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.