notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
openvpn23 Secure IP/Ethernet tunnel daemon
2.3.14 security Deleted on this many watch lists=0 search for ports that depend on this port This port version is marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.3.14Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Replaced by new upstream relesae 2.4.x
Expired This port expired on: 2017-03-31
Maintainer: mandree@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2016-12-27 23:17:07
Last Update: 2017-04-10 17:11:46
SVN Revision: 438191
Also Listed In: net
License: GPLv2
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • openvpn23>0:security/openvpn23
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: openvpn23
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
No package information in database for this port.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. pkgconf>=0.9.10 : devel/pkgconf
Runtime dependencies:
  1. easy-rsa>=0 : security/easy-rsa
Library dependencies:
  1. liblzo2.so : archivers/lzo2
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

Master Sites:
Expand this list (2 items)
Collapse this list.
  1. http://build.openvpn.net/downloads/releases/
  2. http://swupdate.openvpn.net/community/releases/
Collapse this list.
Port Moves
  • port moved to security/openvpn on 2017-04-10
    REASON: Has expired: Replaced by new upstream release 2.4.x

Number of commits found: 3

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
10 Apr 2017 17:11:46
Original commit files touched by this commit Revision:438191  2.3.14 This port version is marked as vulnerable.
rene search for other commits by this committer
Remove expired ports:
2017-02-05 sysutils/puppet38: Upstream support ended, see
http://tinyurl.com/puppet3eol
2017-03-31 editors/libreoffice4: Deprecated by upstream
2017-03-31 databases/rubygem-redis-actionpack4: Use
databases/rubygem-redis-actionpack instead
2017-03-31 devel/rubygem-nio4r1: Use devel/rubygem-nio4r instead
2017-03-31 devel/liborcus07: Deprecated by upstream, use devel/liborcus
2017-03-31 devel/mdds0: Deprecated by upstream, use devel/mdds
2017-03-31 security/openvpn23-polarssl: Replaced by new upstream relesae 2.4.x
2017-03-31 security/openvpn23: Replaced by new upstream relesae 2.4.x
2017-03-31 textproc/p5-XML-XSH: Deprecated by upstream
2017-03-31 www/rubygem-jquery-atwho-rails-rails4: Use
www/rubygem-jquery-atwho-rails instead
2017-03-31 www/p5-Catalyst-Plugin-Singleton: Deprecated by upstream
2017-04-01 x11/lumina-i18n: Obsolete, i18n files included in x11/lumina
2017-04-01 sysutils/jail2: Starting with 10.0 functionality has been merged into
base.
2017-04-01 sysutils/iocage-devel: Outdated version. Please use
sysutils/py-iocage instead
2017-04-01 sysutils/iocage: Outdated version. Please use sysutils/py-iocage
instead
2017-04-05 databases/puppetdb: Depends on expired sysutils/puppet38, use
puppetdb[34] instead
2017-04-05 databases/puppetdb-terminus: Depends on expired sysutils/puppet38,
use puppetdb-terminus[34]
2017-04-08 databases/pglesslog: Does not build with recent PostgreSQL versions
2017-04-08 textproc/go-text: Go libraries should not be packaged
2017-04-08 devel/go-pretty: Go libraries should not be packaged
2017-04-08 databases/godis: Go libraries should not be packaged
2017-04-10 www/moodle29: Upstream support EoL, please migrate to moodle32
28 Dec 2016 07:09:39
Original commit files touched by this commit Revision:429716  2.3.14 This port version is marked as vulnerable.
antoine search for other commits by this committer
Prevent PKGBASE collision with security/openvpn
27 Dec 2016 23:16:57
Original commit files touched by this commit Revision:429678  2.3.14 This port version is marked as vulnerable.
mandree search for other commits by this committer
OpenVPN update to v2.4.0, old version in openvpn23*.

OpenVPN has been updated to v2.4.0.
Changes: <https://github.com/OpenVPN/openvpn/blob/v2.4.0/Changes.rst>

openvpn-polarssl has been renamed to openvpn-mbedtls to match the TLS
library's change of name.

The prior versions of the openvpn ports have been preserved in openvpn23
and openvpn23-polarssl, respectively, and are set to expire 2017-03-31.

Number of commits found: 3