notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
putty-gtk2 Secure shell and telnet client
0.75 security on this many watch lists=0 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 0.75Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Deprecated DEPRECATED: putty-gtk2 is being phased out
Expiration Date EXPIRATION DATE: 2021-12-15
Maintainer: mandree@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2018-04-02 21:29:29
Last Update: 2021-05-08 15:00:56
Commit Hash: 6b288be
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (20 items)
Collapse this list.
  1. bin/plink
  2. bin/pscp
  3. bin/psftp
  4. bin/puttygen
  5. man/man1/plink.1.gz
  6. man/man1/pscp.1.gz
  7. man/man1/psftp.1.gz
  8. man/man1/puttygen.1.gz
  9. bin/pageant
  10. bin/pterm
  11. bin/putty
  12. bin/puttytel
  13. man/man1/pageant.1.gz
  14. man/man1/pterm.1.gz
  15. man/man1/putty.1.gz
  16. man/man1/puttytel.1.gz
  17. share/pixmaps/putty.ico
  18. /usr/local/share/licenses/putty-gtk2-0.75/catalog.mk
  19. /usr/local/share/licenses/putty-gtk2-0.75/LICENSE
  20. /usr/local/share/licenses/putty-gtk2-0.75/MIT
Collapse this list.
Dependency lines:
  • putty-gtk2>0:security/putty-gtk2
Conflicts:
CONFLICTS_INSTALL:
  • pssh-[0-9]*
  • putty-[0-9]*
  • putty-nogtk-[0-9]*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
To install the port: cd /usr/ports/security/putty-gtk2/ && make install clean
To add the package, run one of these commands:
  • pkg install security/putty-gtk2
  • pkg install putty-gtk2
PKGNAME: putty-gtk2
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
putty-gtk2
ABIlatestquarterly
FreeBSD:11:aarch640.700.74_1
FreeBSD:11:amd640.760.75
FreeBSD:11:armv6-0.74_1
FreeBSD:11:i3860.760.75
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch640.700.75
FreeBSD:12:amd640.760.75
FreeBSD:12:armv60.700.74_1
FreeBSD:12:armv70.700.74_1
FreeBSD:12:i3860.760.75
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64-0.74_1
FreeBSD:13:aarch640.74_10.75
FreeBSD:13:amd640.760.75
FreeBSD:13:armv60.74_1-
FreeBSD:13:armv70.74_10.74_1
FreeBSD:13:i3860.760.75
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64-0.75
FreeBSD:14:aarch640.76-
FreeBSD:14:amd640.76-
FreeBSD:14:armv6--
FreeBSD:14:armv70.74_1-
FreeBSD:14:i3860.76-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc640.74_1-
 

Master port: security/putty

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. gmake>=4.3 : devel/gmake
  2. pkgconf>=1.3.0_1 : devel/pkgconf
  3. x11.pc : x11/libX11
Runtime dependencies:
  1. x11.pc : x11/libX11
Library dependencies:
  1. libatk-1.0.so : accessibility/atk
  2. libcairo.so : graphics/cairo
  3. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  4. libglib-2.0.so : devel/glib20
  5. libintl.so : devel/gettext-runtime
  6. libgtk-x11-2.0.so : x11-toolkits/gtk20
  7. libpango-1.0.so : x11-toolkits/pango
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

Master Sites:
Expand this list (2 items)
Collapse this list.
  1. ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
  2. http://the.earth.li/~sgtatham/putty/0.75/
Collapse this list.

Number of commits found: 3

Commit History - (may be incomplete: see SVNWeb link above for full details)
This is a slave port. You may also want to view the commits to the master port: security/putty
DateByDescription
08 May 2021 15:00:56
 files touched by this commit commit hash:6b288be1e66ea83b1210a9bd2feac2359b76846a  0.75
mandree search for other commits by this committer
security/putty: update to 0.75

https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html

Deprecate -gtk2 version for Mid-December 2021.

Clean up a bit.
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  0.74_1
mat search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
02 Apr 2018 21:29:17
Original commit files touched by this commit Revision:466267  0.70 This port version is marked as vulnerable.
mandree search for other commits by this committer
Reinstate support for GTK2 (rather than GTK3) as an OPTION.

While here, add a putty-gtk2 slave port and update _CONFLICTS.

Since the default package does not change, and pkg would handle conflicts
around attempted installation of the new -gtk2 package, omit the
PORTREVISION bump from Miroslav's original patch.

PR:		227200
Submitted by:	Miroslav Lachman

Number of commits found: 3