notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Hardware failure

The website is running on the old server. The new server stopped working at about 0200 UTC on 2020-08-22. The database was restored from 2020-08-21 00:59:15+00 UTC. We think we have covered all commits. Nothing should be missing. Any changes you made to your accounts after the restore date will be lost. Sorry about that.
Port details
py-gtts-token Calculates a token to run the Google Translate text to speech
1.1.3 security on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. 1.1.3Version of this port present on the latest quarterly branch.
Maintainer: kai@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2020-07-30 19:18:21
Last Update: 2020-07-30 20:18:12
SVN Revision: 543817
Also Listed In: python
License: MIT
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • ${PYTHON_PKGNAMEPREFIX}gtts-token>0:security/py-gtts-token
To install the port: cd /usr/ports/security/py-gtts-token/ && make install clean
To add the package: pkg install py37-gtts-token
PKGNAME: py37-gtts-token
Package flavors (<flavor>: <package>)
  • py37: py37-gtts-token
  • py27: py27-gtts-token
distinfo:
Packages: (move your mouse over the cells for more information)
py27-gtts-token
ABIlatestquarterly
FreeBSD:11:aarch64-1.1.3
FreeBSD:11:amd641.1.31.1.3
FreeBSD:11:armv6-1.1.3
FreeBSD:11:i3861.1.31.1.3
FreeBSD:11:mips-1.1.3
FreeBSD:11:mips64-1.1.3
FreeBSD:12:aarch64-1.1.3
FreeBSD:12:amd641.1.31.1.3
FreeBSD:12:armv6-1.1.3
FreeBSD:12:armv7-1.1.3
FreeBSD:12:i3861.1.31.1.3
FreeBSD:12:mips-1.1.3
FreeBSD:12:mips64-1.1.3
FreeBSD:12:powerpc64-1.1.3
FreeBSD:13:aarch64--
FreeBSD:13:amd641.1.3-
FreeBSD:13:armv61.1.3-
FreeBSD:13:armv71.1.3-
FreeBSD:13:i3861.1.3-
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc641.1.3-
 
py37-gtts-token
ABIlatestquarterly
FreeBSD:11:aarch64-1.1.3
FreeBSD:11:amd641.1.31.1.3
FreeBSD:11:armv6-1.1.3
FreeBSD:11:i3861.1.31.1.3
FreeBSD:11:mips-1.1.3
FreeBSD:11:mips64-1.1.3
FreeBSD:12:aarch64-1.1.3
FreeBSD:12:amd641.1.31.1.3
FreeBSD:12:armv6-1.1.3
FreeBSD:12:armv7-1.1.3
FreeBSD:12:i3861.1.31.1.3
FreeBSD:12:mips-1.1.3
FreeBSD:12:mips64-1.1.3
FreeBSD:12:powerpc64-1.1.3
FreeBSD:13:aarch64--
FreeBSD:13:amd641.1.3-
FreeBSD:13:armv61.1.3-
FreeBSD:13:armv71.1.3-
FreeBSD:13:i3861.1.3-
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc641.1.3-
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py37-setuptools>0 : devel/py-setuptools@py37
  2. python3.7 : lang/python37
Runtime dependencies:
  1. py37-requests>0 : www/py-requests@py37
  2. py37-setuptools>0 : devel/py-setuptools@py37
  3. python3.7 : lang/python37
This port is required by:
for Run
  1. audio/py-gtts

Configuration Options

USES:

Master Sites:
Expand this list (1 items)
    Collapse this list.
  1. https://codeload.github.com/Boudewijn26/gTTS-token/tar.gz/v1.1.3?dummy=/
  2. Collapse this list.
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2017-11-30
    Affects: */py*
    Author: mat@FreeBSD.org
    Reason: 
      Ports using Python via USES=python are now flavored.  All the py3-* ports
      have been removed and folded into their py-* master ports.
    
      People using Poudriere 3.2+ and binary packages do not have to do anything.
    
      For other people, to build the Python 3.6 version of, for example,
      databases/py-gdbm, you need to run:
    
        # make FLAVOR=py36 install
    
    

Number of commits found: 1

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
30 Jul 2020 19:18:12
Original commit files touched by this commit  1.1.3
Revision:543817
lbartoletti search for other commits by this committer
games/py-mnemosyne: Take Maintainer'ship, fix runtime error and add missing
dependencies

Latest version of games/py-mnemosyne requires new dependencies. This commit adds
the missing dependencies:

 - audio/py-gtts
 - security/py-gtts-token (required by audio/py-gtts)
 - textproc/py-googletrans

The games/py-mnemosyne port needs to be limited to Python 3.7+ to keep the
dependency chains intact. This is because textproc/py-googletrans depends on
www/py-httpx which is only for Python 3.7+.

PR:		247595
Submitted by:	kai
Reported by:	gspurki@gmail.com
Approved by:	tcberner (mentor)
MFH:		2020Q3
Differential Revision:	https://reviews.freebsd.org/D25895

Number of commits found: 1

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
giteaNov 21
nodeNov 21
node12Nov 21
node14Nov 21
muttNov 20
mantisNov 14
goNov 12
py-saltNov 12
openoffice-4Nov 10
openoffice-develNov 10
raptor2Nov 09
py-notebookNov 08
mariadb103-server*Nov 07
mariadb104-server*Nov 07
mariadb105-server*Nov 07

9 vulnerabilities affecting 54 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2020-11-22 15:51:41


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 41448
Broken 62
Deprecated 279
Ignore 302
Forbidden 4
Restricted 142
No CDROM 73
Vulnerable 19
Expired 4
Set to expire 249
Interactive 0
new 24 hours 3
new 48 hours4
new 7 days30
new fortnight94
new month176

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2020 Dan Langille. All rights reserved.