notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
rubygem-openssl221 Wrap the OpenSSL library
2.2.1 security on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2022-11-22 09:39:04
Last Update: 2023-01-14 23:08:33
Commit Hash: 18c6e18
Also Listed In: rubygems
License: BSD2CLAUSE RUBY
Description:
Homepage    cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb - no subversion history for this port
pkg-plist: as obtained via: make generate-plist
Expand this list (4 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-openssl221-2.2.1/catalog.mk
  2. /usr/local/share/licenses/rubygem-openssl221-2.2.1/LICENSE
  3. /usr/local/share/licenses/rubygem-openssl221-2.2.1/BSD2CLAUSE
  4. /usr/local/share/licenses/rubygem-openssl221-2.2.1/RUBY
Collapse this list.
Dependency lines:
  • rubygem-openssl221>0:security/rubygem-openssl221
To install the port:
cd /usr/ports/security/rubygem-openssl221/ && make install clean
To add the package, run one of these commands:
  • pkg install security/rubygem-openssl221
  • pkg install rubygem-openssl221
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: rubygem-openssl221
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
rubygem-openssl221
ABIlatestquarterly
FreeBSD:11:aarch64pkg-falloutpkg-fallout
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv6pkg-falloutpkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch64pkg-fallout2.2.1
FreeBSD:12:amd642.2.12.2.1
FreeBSD:12:armv6pkg-falloutpkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i3862.2.12.2.1
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch642.2.12.2.1
FreeBSD:13:amd642.2.12.2.1
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv72.2.12.2.1
FreeBSD:13:i3862.2.12.2.1
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-fallout2.2.1
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch642.2.1pkg-fallout
FreeBSD:14:amd642.2.1pkg-fallout
FreeBSD:14:armv62.2.1pkg-fallout
FreeBSD:14:armv72.2.1pkg-fallout
FreeBSD:14:i3862.2.1pkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc642.2.1pkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby30 : lang/ruby30
  2. gem : devel/ruby-gems
Runtime dependencies:
  1. rubygem-ipaddr122>=0 : net/rubygem-ipaddr122
  2. ruby30 : lang/ruby30
  3. gem : devel/ruby-gems
Patch dependencies:
  1. ruby30 : lang/ruby30
  2. gem : devel/ruby-gems
Extract dependencies:
  1. ruby30 : lang/ruby30
There are no ports dependent upon this port

Configuration Options:
Options name:
USES:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.org/downloads/
Collapse this list.

Number of commits found: 2

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
2.2.1
14 Jan 2023 23:08:33
commit hash:18c6e18276691edf5274406bf82a3b06792ff9aecommit hash:18c6e18276691edf5274406bf82a3b06792ff9aecommit hash:18c6e18276691edf5274406bf82a3b06792ff9aecommit hash:18c6e18276691edf5274406bf82a3b06792ff9ae files touched by this commit
Muhammad Moinur Rahman (bofh) search for other commits by this committer
Mk/**ruby.mk: Switch from USE_RUBY=yes to USES=ruby

Switch from Mk/bsd.ruby.mk to Mk/Uses/ruby.mk

Notable changes are.

- Mk/bsd.ruby.mk is moved to Mk/Uses/ruby.mk.
- USE_RUBY=yes is replaced with USES=ruby.
- USE_RUBY_EXTCONF is replaced with USES=ruby:extconf.
- USE_RUBY_RDOC is replaced with USES=ruby:rdoc.
- USE_RUBY_SETUP is replaces with USES=ruby:setup.
- RUBY_NO_BUILD_DEPENDS and RUBY_NO_RUN_DEPENDS are replaced with
  USES=ruby:{build,none,run}.
- RUBY_REQUIRE isn't used anywhere, so removed.
- USES=gem now implies USES=ruby.

This is mainly the work of yasu@ at https://reviews.freebsd.org/D27863

I have just made some cosmetic changes and ran exp-run to test that the
tree is not in a BROKEN state.

Approved by:	portmgr
Differential Revision:	https://reviews.freebsd.org/D37925
2.2.1
22 Nov 2022 09:38:21
commit hash:a892bde8307d021f944c5568a14d01c1c727993dcommit hash:a892bde8307d021f944c5568a14d01c1c727993dcommit hash:a892bde8307d021f944c5568a14d01c1c727993dcommit hash:a892bde8307d021f944c5568a14d01c1c727993d files touched by this commit
Matthias Fechner (mfechner) search for other commits by this committer
www/gitlab-ce: new ports required for version 15.5

Number of commits found: 2