notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: the WWW: line in pkg-descr was relocated to a WWW= line in Makefile. Each port in FreshPorts has a homepage link. Look for it right after the Description: on each port's home page.

Do I know someone who can pick up a server from 7401 E. Ben White Blvd. Austin TX?

The emphasis is on know, or recommended by someone I know. This is the original FreshPorts server, way past useful: RAID, 8GB RAM, etc. The drives need to be wiped and everything recycled.
Port details
puppet27 Configuration management framework written in Ruby
2.7.26_1 sysutils Deleted on this many watch lists=0 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Broken BROKEN: Does not work with Ruby 2.0 or Ruby 2.1
Deprecated DEPRECATED: Does not work with Ruby 2.x
Expired This port expired on: 2015-03-28
Ignore IGNORE: is marked as broken: Does not work with Ruby 2.0 or Ruby 2.1
Maintainer: swills@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2012-10-22 13:39:57
Last Update: 2015-04-07 17:59:02
SVN Revision: 383527
License: APACHE20
Description:
HomepagecgitGitHubGitLabSVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • puppet27>0:sysutils/puppet27
No installation instructions:
This port has been deleted.
PKGNAME: puppet27
Flavors: there is no flavor information for this port.
distinfo:
There is no distinfo for this port.

No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby21 : lang/ruby21
Runtime dependencies:
  1. rubygem-facter>=0 : sysutils/rubygem-facter
  2. rubygem-ruby-augeas>=0 : textproc/rubygem-augeas
  3. rubygem-bzip2-ruby>=0 : archivers/rubygem-bzip2-ruby
  4. ruby21 : lang/ruby21
Patch dependencies:
  1. ruby21 : lang/ruby21
Extract dependencies:
  1. ruby21 : lang/ruby21
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. sysutils/rubygem-hiera-puppet*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (2 items)
Collapse this list.
  1. http://distcache.FreeBSD.org/ports-distfiles/
  2. http://downloads.puppetlabs.com/puppet/
Collapse this list.
Port Moves
  • port deleted on 2015-04-07
    REASON: Has expired: Does not work with Ruby 2.x
  • port moved here from sysutils/puppet26 on 2013-10-01
    REASON: Has expired: End of Life from April 2013. Upgrade to 2.7 or 3.x

Number of commits found: 21

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
2.7.26_1
07 Apr 2015 17:59:02
Revision:383527Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:
2015-03-31 lang/gnatdroid-armv5: Nobody cares enough to fix sigtramp-android.c
for ARMv5
2015-03-28 sysutils/puppet27: Does not work with Ruby 2.x
2015-03-31 www/rubygem-form_data: Use www/rubygem-http-form_data instead
(renamed by upstream)
2015-03-31 www/typo345: Upgrade to www/typo3 or www/typo3-lts
2.7.26_1
01 Mar 2015 13:09:57
Revision:380180Original commit files touched by this commit
antoine search for other commits by this committer
Deprecate ports that do not work with Ruby 2.x
2.7.26_1
05 Feb 2015 16:22:34
Revision:378469Original commit files touched by this commit
bapt search for other commits by this committer
Get rid of @cwd
2.7.26_1
12 Nov 2014 03:36:03
Revision:372481Original commit files touched by this commit
swills search for other commits by this committer
sysutils/puppet27: Mark broken with Ruby 2.0 and 2.1

Technically any Ruby version 1.9 or newer isn't supported:

https://docs.puppetlabs.com/guides/platforms.html#ruby-versions

but I didn't hear any complaints about Puppet 2.7 not working until 2.0 became
default, so leave it for now, instead of deleting it.
2.7.26_1
18 Sep 2014 12:31:25
Revision:368446Original commit files touched by this commit
mat search for other commits by this committer
Retire MANCOMPRESSED.

Also the compat NO_INSTALL_MANPAGES shim.

Differential Revision:	https://reviews.freebsd.org/D730
Reviewed by:	antoine
With hat:	portmgr
Sponsored by:	Absolight
2.7.26_1
29 Aug 2014 21:30:38
Revision:366567Original commit files touched by this commit
sunpoet search for other commits by this committer
- Respect rubygems naming: rename archivers/rubygem-bzip2 to
archivers/rubygem-bzip2-ruby
- Cleanup Makefile
- Bump PORTREVISION for dependency change
2.7.26
18 Aug 2014 16:43:25
Revision:365325Original commit files touched by this commit
bdrewery search for other commits by this committer
- Move RESETPREFIX to default PLIST_SUB

With hat:	portmgr
2.7.26
17 Jul 2014 08:33:56
Revision:362123Original commit files touched by this commit
robak search for other commits by this committer
sysutils/puppet27: update 2.7.25 -> 2.7.26

Approved by:	swills (mentor)
2.7.25
13 Apr 2014 02:15:38
Revision:351173Original commit files touched by this commit
swills search for other commits by this committer
- Update to 2.7.25
- Add LICENSE
- Pet portlint
- Stage

PR:		ports/188435
Submitted by:	Bartek Rutkowski <ports@robakdesign.com>
2.7.23_1
21 Feb 2014 13:39:38
Revision:345435Original commit files touched by this commit
ehaupt search for other commits by this committer
Remove trailing whitespaces from category sysutils
2.7.23_1
10 Feb 2014 13:54:28
Revision:343634Original commit files touched by this commit
ehaupt search for other commits by this committer
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we
have many ports violating this policy.

This patch adds the default options specified in the Porter's Handbook to
OPTIONS_DEFINE where they are being used. Ports maintained by
gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded.

Approved by:    portmgr (bapt)
2.7.23_1
29 Oct 2013 02:43:14
Revision:331926Original commit files touched by this commit
swills search for other commits by this committer
- Add PKGNAMESUFFIX to make package name unique
2.7.23
18 Oct 2013 03:05:47
Revision:330718Original commit files touched by this commit
tabthorpe search for other commits by this committer
- Mark devel/rubygem-rascut broken
- Remove dependancy on www/rubygem-mongerl from other ports

With hat:	portmgr
2.7.23
20 Sep 2013 23:06:00
Revision:327772Original commit files touched by this commit
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
sysutils)
2.7.23
16 Aug 2013 18:52:44
Revision:324813Original commit files touched by this commit
brd (doc committer) search for other commits by this committer
- Update puppet27 to 2.7.23 which fixes CVE-2013-4761 and CVE-2013-4956

Approved by:	swills@
Security:	2b2f6092-0694-11e3-9e8e-000c29f6ae42
2.7.22
22 Jun 2013 12:49:29
Revision:321570Original commit files touched by this commit
swills search for other commits by this committer
- Update puppet to 3.2.2 which fixes CVE-2013-3567 [1]
- Update puppet27 to 2.7.22 which fixes CVE-2013-3567
- Document security issue

PR:		ports/179816 [1]
Submitted by:	mat [1]
Security:	b162b218-c547-4ba2-ae31-6fdcb61bc763
2.7.21_1
17 Mar 2013 20:14:31
Revision:314483Original commit files touched by this commit
zi search for other commits by this committer
- Rename sysutils/facter to sysutils/rubygem-facter
- Update sysutils/rubygem-facter to 1.6.18
- Convert sysutils/rubygem-facter to utilize rubygem framework
- Update to new 'created by' header
- Add RG as additional MASTER_SITES for sysutils/rubygem-facter
- Update sysutils/puppet* RUN_DEPENDS due to rename of facter
- Bump PORTREVISION on sysutils/puppet* due to rename of facter

Approved by:	Rouslan Iskhakov <rouslan@rshell.net> (maintainer)
2.7.21
13 Mar 2013 03:35:54
Revision:314019Original commit files touched by this commit
swills search for other commits by this committer
- Update puppet to 3.1.1 resolving multiple security issues
- Update puppet27 to 2.7.21 resolving multiple security issues
- Document multiple puppet security issues

Security:	cda566a0-2df0-4eb0-b70e-ed7a6fb0ab3c
2.7.20
23 Nov 2012 22:32:31
Revision:307689Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update to 2.7.20
- Remove reversed and unnecessary patch for issue already fixed upstream

Feature safe:	yes
2.7.19_1
04 Nov 2012 17:00:06
Revision:306976Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Limit portscout to 2.7

Feature safe:	yes
2.7.19_1
22 Oct 2012 13:39:41
Revision:306274Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update puppet to 3.0.1
- Add sysutils/puppet27 for those who will still need the older version

Feature safe:	yes

Number of commits found: 21