notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Port details
py-googletrans Free Google Translate API that translates totally free of charge
3.0.0_1 textproc on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 3.0.0_1Version of this port present on the latest quarterly branch.
Maintainer: lbartoletti@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2020-07-30 19:18:21
Last Update: 2021-05-07 13:26:34
Commit Hash: 58fa1c7
Also Listed In: python
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • ${PYTHON_PKGNAMEPREFIX}googletrans>0:textproc/py-googletrans@${PY_FLAVOR}
To install the port:
cd /usr/ports/textproc/py-googletrans/ && make install clean
To add the package, run one of these commands:
  • pkg install textproc/py-googletrans
  • pkg install py38-googletrans
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.NOTE: This is a Python port. Instead of py38-googletrans listed in the above command, you can pick from the names under the Packages section.
PKGNAME: py38-googletrans
Package flavors (<flavor>: <package>)
  • py38: py38-googletrans
distinfo:
Packages (timestamps in pop-ups are UTC):
py37-googletrans
ABIlatestquarterly
FreeBSD:11:aarch64-3.0.0
FreeBSD:11:amd64--
FreeBSD:11:armv6-3.0.0
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64-3.0.0
FreeBSD:12:aarch64--
FreeBSD:12:amd64--
FreeBSD:12:armv6-3.0.0_1
FreeBSD:12:armv7-3.0.0_1
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64-3.0.0
FreeBSD:12:powerpc64-3.0.0_1
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv63.0.0_1-
FreeBSD:13:armv73.0.0_1-
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc643.0.0_1-
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc643.0.0_1-
 
py38-googletrans
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd643.0.0_13.0.0_1
FreeBSD:11:armv6--
FreeBSD:11:i3863.0.0_13.0.0_1
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64-3.0.0_1
FreeBSD:12:amd643.0.0_13.0.0_1
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i3863.0.0_13.0.0_1
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch643.0.0_13.0.0_1
FreeBSD:13:amd643.0.0_13.0.0_1
FreeBSD:13:armv6-3.0.0_1
FreeBSD:13:armv7-3.0.0_1
FreeBSD:13:i3863.0.0_13.0.0_1
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64-3.0.0_1
FreeBSD:14:aarch643.0.0_1-
FreeBSD:14:amd643.0.0_1-
FreeBSD:14:armv63.0.0_1-
FreeBSD:14:armv73.0.0_1-
FreeBSD:14:i3863.0.0_1-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py38-setuptools>0 : devel/py-setuptools@py38
  2. python3.8 : lang/python38
Runtime dependencies:
  1. py38-httpx013>=0.13.3<0.13.4 : www/py-httpx013@py38
  2. py38-setuptools>0 : devel/py-setuptools@py38
  3. python3.8 : lang/python38
This port is required by:
for Run
  1. games/py-mnemosyne

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (2 items)
Collapse this list.
  1. https://files.pythonhosted.org/packages/source/g/googletrans/
  2. https://pypi.org/packages/source/g/googletrans/
Collapse this list.

Number of commits found: 6

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
07 May 2021 13:26:34
 files touched by this commit commit hash:58fa1c7810afa2be6922aa870da2a45f22473b32  3.0.0_1
Kai Knoblich (kai) search for other commits by this committer
audio/py-gtts, textproc/py-googletrans: Pass maintainership

Approved by:	lbartoletti (new maintainer)
MFH:		2021Q2
07 Apr 2021 08:09:01
 files touched by this commit commit hash:cf118ccf875508b9a1c570044c93cfcc82bd455c  3.0.0_1
Mathieu Arnold (mat) search for other commits by this committer
One more small cleanup, forgotten yesterday.
Reported by:	lwhsu
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  3.0.0_1
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
23 Sep 2020 19:18:05
Original commit files touched by this commit Revision:549829  3.0.0_1  Sanity Test Failure
sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-httpx to py-httpx013

- Bump PORTREVISION for dependency change

Kai checked the test suite and 1 test fails with httpx 0.14.0.
Therefore, I change this port to use repocopied httpx 0.13.3 for now.

Approved by:	kai (maintainer, implicit, via private mail)
07 Sep 2020 02:52:37
Original commit files touched by this commit Revision:547873  3.0.0
linimon search for other commits by this committer
Catch up with dependency update from r547729 by sunpoet.

Approved by:	portmgr ("just fix it")
30 Jul 2020 19:18:12
Original commit files touched by this commit Revision:543817  3.0.0
lbartoletti search for other commits by this committer
games/py-mnemosyne: Take Maintainer'ship, fix runtime error and add missing
dependencies

Latest version of games/py-mnemosyne requires new dependencies. This commit adds
the missing dependencies:

 - audio/py-gtts
 - security/py-gtts-token (required by audio/py-gtts)
 - textproc/py-googletrans

The games/py-mnemosyne port needs to be limited to Python 3.7+ to keep the
dependency chains intact. This is because textproc/py-googletrans depends on
www/py-httpx which is only for Python 3.7+.

PR:		247595
Submitted by:	kai
Reported by:	gspurki@gmail.com
Approved by:	tcberner (mentor)
MFH:		2020Q3
Differential Revision:	https://reviews.freebsd.org/D25895

Number of commits found: 6