notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
uim-qt QT modules of uim input method
1.8.5 textproc Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 1.8.5Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Maintainer: nobutaka@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2006-04-16 16:53:41
Last Update: 2013-07-26 19:19:21
SVN Revision: 323748
License: not specified in port
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • uim-qt>0:textproc/uim-qt
No installation instructions: this port has been deleted.
The package name of this deleted port was: uim-qt
PKGNAME: uim-qt
Flavors: there is no flavor information for this port.
distinfo:
There is no distinfo for this port.
No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Master port: textproc/uim

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. moc : x11-toolkits/qt33
  2. gmake : devel/gmake
  3. perl5.14.2 : lang/perl5.14
  4. libtool>=2.4 : devel/libtool
  5. intltool-extract : textproc/intltool
Runtime dependencies:
  1. moc : x11-toolkits/qt33
  2. libgiofam.so : devel/gio-fam-backend
Library dependencies:
  1. uim : textproc/uim
  2. Xft.2 : x11-fonts/libXft
  3. intl : devel/gettext
  4. iconv.3 : converters/libiconv
  5. glib-2.0 : devel/glib20
  6. pcre : devel/pcre
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. textproc/uim-kde*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (2 items)
Collapse this list.
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/
  2. http://uim.googlecode.com/files/
Collapse this list.
Port Moves
  • port deleted on 2013-07-26
    REASON: Has expired: Depends on Qt 3.x

Number of commits found: 23

Commit History - (may be incomplete: see SVNWeb link above for full details)
This is a slave port. You may also want to view the commits to the master port: textproc/uim
DateByDescription
26 Jul 2013 19:19:21
Original commit files touched by this commit Revision:323748  1.8.5
rene search for other commits by this committer
KDE3 and QT3 expired on 2013-07-01, remove these ports.
Unfortunately, this also affects some ports using QT3 as a GUI toolkit.

Changes to infrastructure files:
- bsd.kde.mk : obsolete, remove
- bsd.qt.mk : note that a CONFLICTS_BUILD line can probably go after a while
- CHANGES : document the removals from bsd.port.mk
- KNOBS : remove KDE and QT (KDE4 and QT4 should be used instead)
- MOVED : add the removed ports

PR:		ports/180745
Submitted by:	rene
Approved by:	portmgr (bapt)
Exp-run by:	bapt
14 May 2013 16:51:17
Original commit files touched by this commit Revision:318178  1.8.5
nobutaka search for other commits by this committer
- Update to 1.8.5.
- Trim Makefile header.
- Remove shared lib version from LIB_DEPENDS.
01 Apr 2012 15:41:28
Original commit files touched by this commit   1.8.0
nobutaka search for other commits by this committer
Update to 1.8.0.

Feature safe:   yes
23 Sep 2011 22:26:39
Original commit files touched by this commit   1.7.1
amdmi3 search for other commits by this committer
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead

PR:             157936
Submitted by:   myself
Exp-runs by:    pav
Approved by:    pav
28 May 2011 19:42:58
Original commit files touched by this commit   1.7.0
nobutaka search for other commits by this committer
Update to 1.7.0.
04 Dec 2010 07:34:27
Original commit files touched by this commit   1.6.0
ade search for other commits by this committer
Sync to new bsd.autotools.mk
26 Nov 2010 17:38:22
Original commit files touched by this commit   1.6.0
nobutaka search for other commits by this committer
- Update to 1.6.0.
- Add textproc/uim-kde4, KDE4 panel applet of uim input method. It is a
  slave port of textproc/uim.
- Remove japanese/uim-canna and japanese/uim-prime. Now the canna and prime
  modules are implemented as scheme scripts and they can be installed from
  textproc/uim.
- Enable helper tools installation of textproc/uim-qt4.
- Enable sj3 support of textproc/uim.
26 Sep 2009 09:42:47
Original commit files touched by this commit   1.5.6
nobutaka search for other commits by this committer
Add dependency on intltool to fix configure error.

Reported by:   pointyhat via pav and QAT
Feature safe:  yes
24 Sep 2009 21:37:24
Original commit files touched by this commit   1.5.6
miwi search for other commits by this committer
- Mark BROKEN (fails to configure)

Reported by:    pointyhat
Feature safe: yes
02 Aug 2009 19:36:34
Original commit files touched by this commit   1.5.5_2
mezz search for other commits by this committer
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:      marcus and kwm
Pointyhat-exp:  a few times by pav
Tested by:      pgollucci, "Romain Tartière" <romain@blogreen.org>, and
                a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:    marcus
Approved by:    portmgr
18 May 2008 15:40:06
Original commit files touched by this commit   1.5.1
nobutaka search for other commits by this committer
Update to 1.5.1.
11 May 2008 13:09:45
Original commit files touched by this commit   1.5.0
nobutaka search for other commits by this committer
Update to 1.5.0.
14 Oct 2007 15:12:51
Original commit files touched by this commit   1.4.1
nobutaka search for other commits by this committer
- Update to 1.4.1.
- Update WWW entry in pkg-descr.
29 Sep 2007 15:30:19
Original commit files touched by this commit   1.3.1_1
linimon search for other commits by this committer
Mark as broken: leaves usr/local/etc/settings behind on deinstall.
28 Mar 2007 11:39:53
Original commit files touched by this commit   1.3.1
nobutaka search for other commits by this committer
Fix pkg-plist.
10 Mar 2007 20:11:13
Original commit files touched by this commit   1.3.1
nobutaka search for other commits by this committer
Update to 1.3.1.

PR:             ports/109399
Submitted by:   Yamashiro Jun<yamajun@ofug.net>
03 Sep 2006 14:09:23
Original commit files touched by this commit   1.2.1
nobutaka search for other commits by this committer
Update to 1.2.1.
23 Jul 2006 12:16:55
Original commit files touched by this commit   1.1.1
nobutaka search for other commits by this committer
Fix build error of uim-qt on 6-stable.

Reported by:    Dan Reinholz <xaenn@yahoo.com>
10 Jul 2006 02:06:29
Original commit files touched by this commit   1.1.1
nobutaka search for other commits by this committer
Add WITHOUT_X11 knob.
26 Jun 2006 16:46:51
Original commit files touched by this commit   1.1.0
nobutaka search for other commits by this committer
Change the dependency on textproc/uim to LIB_DEPENDS to fix package building
errors.

Reported by:    linimon
12 Jun 2006 17:45:54
Original commit files touched by this commit   1.1.0
nobutaka search for other commits by this committer
- Update to 1.1.0.
- Mark textproc/uim-m17nlib IGNORE since it requires m17n-lib-1.3.1 or later.
20 Apr 2006 21:55:37
Original commit files touched by this commit   1.0.1_2
lofi search for other commits by this committer
Ports using Qt without setting USE_QT_VER need environment fixups.
16 Apr 2006 16:47:40
Original commit files touched by this commit   1.0.1_2
nobutaka search for other commits by this committer
Add uim-qt. QT modules of uim input method.

PR:             ports/95785
Submitted by:   NIIMI Satoshi <sa2c@sa2c.net>

Number of commits found: 23