Domoticz is a Home Automation System that lets you monitor and configure
various devices like: Lights, Switches, various sensors/meters like
Temperature, Rain, Wind, UV, Electra, Gas, Water and much more.
Notifications/Alerts can be sent to any mobile device
===> The following configuration options are available for domoticz-2026.4:
PRECOMP=on: Enable usage of precompiled header to speed build time
PYTHON=on: Enable Python for Plugins and Event-Scripts
===> Use 'make config' to modify these settings
Notice:
This port runs per default using uid:gid domoticz:domoticz to
avoid security problems.
Some code of Domoticz may needs root access. If you are ok with
that change the following rc.conf to:
domoticz_user="root"
domoticz_group="wheel"
And restart domoticz.
If you have issues with domoticz listen option, you can add
net.inet6.ip6.v6only=0 to /etc/sysctl.conf
www/domoticz*: Mark BROKEN
Fails to build with boost 1.91.0
error: no matching function for call to object of type 'const
asio_require_fn::impl'
Reported by: pkg-fallout
*: Revise USES=python:... version range constraints
and strip all lower bounds of 3.9 or 3.10 because they are implied now.
python:3.9-X -> python:-X
python:3.9+ -> python
python:3.10-X -> python:-X
python:3.10+ -> python
(options such as ,build preserved)
www/domoticz: Update to 2025.2
This update domoticz to 2025.2.
Changelog:
Version 2025.2 (October 13th 2025)
- Implemented: EnergyDashboard, add option for (Outside) Temperature Sensor
- Implemented: Enever, Added Pure Energy, removed obsolete providers
- Implemented: Enphase, display a error is a IQ inverter has not been received
for more then a day
- Implemented: Kodi, support for 'tvshow' type
- Implemented: MQTT-AD, added support for Climate action_template/state
- Implemented: MQTT-AD, added support for IR Blaster (Tuya iH-F8260)
- Implemented: MQTT-AD, support for disabling cover stop button
- Implemented: New Blinds type "Blinds + Stop"
- Implemented: MQTT-AD, handling battery low boolean sensors
(Only the first 15 lines of the commit message are shown above )
www/domoticz: prepare for Boost-1.89, do not link with stub Boost::system (+)
Get rid of overlinking on empty stub library Boost::system, it is header-only
since boost-1.70
With hat: office/boost
www/domoticz*: Fix build for boost >= 1.87
With boost >= 1.87, domoticz cannot be built. This has been
handled by PR 6252 on domoticz github.
I'm adding the patches to files/ because they do not apply
cleanly unfortunately when managed via PATCH_SITES.
The problem is that the upstream patch modifies the
msbuild-related parts of the build system. Those parts are
not relevant on FreeBSD and has been already removed in
previous updates. So adding modified version of the patches
from the GitHub PR to files/ seems to be the right approach.
PR: 286076
Reported by: <erwin.freebsd-bugzilla@bk3.nl>
Approved by: 0mp (mentor)
Differential Revision: https://reviews.freebsd.org/D50373
www/domoticz: mark as BROKEN with Boost>=1.87 (+)
Since 1.87 release some long-time-ago deprecated Boost.asio facilities was
dropped off
Sponsored by: Future Crew, LLC
www/domoticz: Update to 2024.7
This will update www/domoticz to 2024.7. Updated Makefile as www/domoticz-devel.
Changelog between 2024.4 to 2024.7:
Version 2024.7 (July 13th 2024)
- Implemented: P1 Meter, Report, Header now also supports simple mode (No
T1/T2/R1/R2 but just total)
- Fixed: Google Cloud Messaging (GCM/FCM) possible crash when notification
needed to be send
Version 2024.6 (July 8th 2024)
- Fixed: EventSystem, LOG_FORCE now always logged
- Changed: Google Cloud Messaging (GCM) now uses the new v1 API of Google's
Firebase Cloud Messaging (FCM)
Version 2024.5 (July 7th 2024)
(Only the first 15 lines of the commit message are shown above )
www/domoticz: update to 2023.1
Upstream changes:
- Implemented: Accept JWT tokens as authentication and Authorization Bearer
tokens (either from internal or external IAM service)
- Implemented: Blinds, added option to schedule 0%
- Implemented: dzVents, OpenURL PATCH method
- Implemented: Enphase, redesign and added battery readings (Supports firmware
V7)
- Implemented: Internal OAuth2/OIDC IAM service supporting 4 different flows
(OAuth2 (RFC6749), PKCE extension (RFC7636) and JWT Tokens (RFC7519))
- Implemented: MQTT, added support for Lock status
- Implemented: MQTT, added support for wildcards in discovery topics
- Implemented: MQTT, climate preset mode
- Implemented: New 'auth' debug flag to see IAM related messages
- Implemented: Now 'Applications' can be registered to get secure access to
Domoticz, see 'setup' menu (standard DomoticzUI app is registered by default)
- Implemented: P1 Meter, added number of (long) power failures, voltage
sags/swells
(Only the first 15 lines of the commit message are shown above )
databases/and_others: Fix rc.d script comment
I found this typo while researching something else. It seems to have
propgated around the tree.
Approved by: blanket
Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
archivers/minizip*: Add minizip-ng and zlib-ng and create USES=minizip
Import minizip-ng and zlib-ng
Minizip was originally developed in 1998. It was first included in the zlib
distribution as an additional code contribution starting in zlib 1.1.2. Since
that time, it has been continually improved upon and contributed to by many
people.
+ Creating and extracting zip archives.
+ Adding and removing entries from zip archives.
+ Read and write raw zip entry data.
+ Reading and writing zip archives from memory.
+ Zlib, BZIP2, LZMA, and ZSTD compression methods.
+ Password protection through Traditional PKWARE and WinZIP AES encryption.
(Only the first 15 lines of the commit message are shown above )
www/domoticz: Update to 2020.2
- Make LUA as hard dependency as internal LUA is not supported anymore
- Make OPENZWAVE optional dependency
- Enable usage of precompiled headers by default to follow the upstream
- Use GH_TUPLE to load external dependencies from the github (upstream uses git
submodules), disable GIT_SUBMODULE. As for now only MQQT is supported
- Fix CMAKE_INSTALL_PREFIX (should be specified as Makefile option, not as CMAKE
one) and remove patches obsoleted by that fix
- USE CMAKE_ON/CMAKE_OFF for the better readability
- Remove `post-patch` target, as version is normally set by the cmake itself
- Include patches for the embedded `mosquitto`, disable mosquitto shared
libraries
installation
- Update `pkg-plist` to support files added by the embedded dependencies
- Remove `CONFLICTS` as there are no such matched packages in the ports tree
- Fix build without PYTHON, patch accepted by the upstream
- Remove most of the STATIC* options
ChangeLog: https://github.com/domoticz/domoticz/blob/development/History.txt
PR: 245007
Approved by: krion (mentor)
Differential Revision: https://reviews.freebsd.org/D24984
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.
PR: 238330
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.
This includes ports
- with USE_GCC=yes or USE_GCC=any,
- with USES=fortran,
- using Mk/bsd.octave.mk which in turn features USES=fortran, and
- with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.
PR: 231590
Update to 3.5877
* Add OPTIONS to toggle between ports ad bundled versions of various libs
* Drop GH_TAGNAME since we're using a release version
* Various changes to mollify portlint:
- Regenerated files/patch-* using 'make makepatch'
* Add USES=ssl
PR: 215439
Submitted by: kiwi@oav.net (maintainer)
Domoticz is a Home Automation System that lets you monitor and configure
various devices like: Lights, Switches, various sensors/meters like
Temperature, Rain, Wind, UV, Electra, Gas, Water and much more.
Notifications/Alerts can be sent to any mobile device
WWW: http://www.domoticz.com/
PR: 205583
Submitted by: kiwi@oav.net