Remove expired ports:
2017-02-05 sysutils/puppet38: Upstream support ended, see
http://tinyurl.com/puppet3eol
2017-03-31 editors/libreoffice4: Deprecated by upstream
2017-03-31 databases/rubygem-redis-actionpack4: Use
databases/rubygem-redis-actionpack instead
2017-03-31 devel/rubygem-nio4r1: Use devel/rubygem-nio4r instead
2017-03-31 devel/liborcus07: Deprecated by upstream, use devel/liborcus
2017-03-31 devel/mdds0: Deprecated by upstream, use devel/mdds
2017-03-31 security/openvpn23-polarssl: Replaced by new upstream relesae 2.4.x
2017-03-31 security/openvpn23: Replaced by new upstream relesae 2.4.x
2017-03-31 textproc/p5-XML-XSH: Deprecated by upstream
2017-03-31 www/rubygem-jquery-atwho-rails-rails4: Use
www/rubygem-jquery-atwho-rails instead
2017-03-31 www/p5-Catalyst-Plugin-Singleton: Deprecated by upstream
2017-04-01 x11/lumina-i18n: Obsolete, i18n files included in x11/lumina
2017-04-01 sysutils/jail2: Starting with 10.0 functionality has been merged into
base.
2017-04-01 sysutils/iocage-devel: Outdated version. Please use
sysutils/py-iocage instead
2017-04-01 sysutils/iocage: Outdated version. Please use sysutils/py-iocage
instead
2017-04-05 databases/puppetdb: Depends on expired sysutils/puppet38, use
puppetdb[34] instead
2017-04-05 databases/puppetdb-terminus: Depends on expired sysutils/puppet38,
use puppetdb-terminus[34]
2017-04-08 databases/pglesslog: Does not build with recent PostgreSQL versions
2017-04-08 textproc/go-text: Go libraries should not be packaged
2017-04-08 devel/go-pretty: Go libraries should not be packaged
2017-04-08 databases/godis: Go libraries should not be packaged
2017-04-10 www/moodle29: Upstream support EoL, please migrate to moodle32
Cleanup dependencies on lang/p5-Scalar-List-Utils.
The different cases are:
- Only bring it if the one bundled with Perl is outdated.
- The version bundled with all our Perl is sufficient.
- Scalar-List-Util is not really needed by the port.
(looking for /(Sub|Scalar|List)::Util/ returns nothing.)
While there, do some minor cleanup that caught my eye.
PR: 208378
With hat: perl@
Sponsored by: Absolight
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had:
site_perl : lib/perl5/site_perl/5.18
site_perl/perl_arch : lib/perl5/site_perl/5.18/mach
perl_man3 : lib/perl5/5.18/man/man3
Now we have:
site_perl : lib/perl5/site_perl
site_arch : lib/perl5/site_perl/mach/5.18
perl_man3 : lib/perl5/site_perl/man/man3
Modules without any .so will be installed at the same place regardless of the
(Only the first 15 lines of the commit message are shown above )
- Replace ../../authors in MASTER_SITE_SUBDIR with CPAN:CPANID macro.
See http://wiki.freebsd.org/Perl for details.
- Change maintainership from ports@ to perl@ for ports in this changeset.
With perl@ hat
- Take advantage of CPAN macro from bsd.sites.mk, change
${MASTER_SITE_PERL_CPAN} to CPAN.
PR: ports/122674
Submitted by: Philip M. Gollucci <pgollucci@p6m7g8.com>
Reworked by: araujo (myself)
Approved by: portmgr (pav)
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl.
Work done by: gabor
Sponsored by: Google Summer of Code 2007
Hat: portmgr