notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Two new features

Two two features were added on 2020-05-30:
  1. Repology links - each port now has a link to repology.org. See issue 148 for details.
  2. Ports I maintain report - port maintainers can now subscribe to a daily report of commits to the ports they maintain. See Watch ports I maintain at Report Subscriptions. Details at issue 138
Port details
py-django16 High-level Python Web Framework (1.6.x)
1.6.11 www Deleted on this many watch lists=0 search for ports that depend on this port This port version is marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. 1.6.11Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: End of extended support: April 1, 2015
Expired This port expired on: 2015-10-01
Maintainer: python@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2014-09-07 09:59:07
Last Update: 2017-04-19 20:56:12
SVN Revision: 438908
Also Listed In: python
License: BSD3CLAUSE
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • py27-django16>0:www/py-django16
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: py27-django16
Flavors: there is no flavor information for this port.
distinfo:
Packages:
py27-django16
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd64--
FreeBSD:11:armv61.6.11-
FreeBSD:11:i386--
FreeBSD:11:mips1.6.11-
FreeBSD:11:mips641.6.11-
FreeBSD:12:aarch64--
FreeBSD:12:amd64--
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py27-setuptools>0 : devel/py27-setuptools
  2. python2.7 : lang/python27
Runtime dependencies:
  1. py27-sqlite3>0 : databases/py-sqlite3
  2. py27-setuptools>0 : devel/py27-setuptools
  3. python2.7 : lang/python27
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Build

    Deleted ports which required this port:

    Expand this list of 1 deleted port
    1. www/reviewboard*
    2. Collapse this list of deleted ports.
for Run

    Deleted ports which required this port:

    Expand this list of 8 deleted ports
    1. devel/py-django16-tastypie-mongoengine*
    2. security/py-crits*
    3. www/py-cactus*
    4. www/py-django-pipeline13*
    5. www/py-django-pipeline14*
    6. www/py-django16-tastypie*
    7. www/py-djblets*
    8. www/reviewboard*
    9. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options

USES:

Master Sites:
  1. https://files.pythonhosted.org/packages/source/D/Django/
  2. https://pypi.python.org/packages/source/D/Django/
  3. https://www.djangoproject.com/m/releases/1.6.11/
Port Moves
  • port moved to www/py-django18 on 2017-04-19
    REASON: Has expired: End of extended support: April 1, 2015

Number of commits found: 12

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
19 Apr 2017 19:56:12
Original commit files touched by this commit  1.6.11
Revision:438908 This port version is marked as vulnerable.
rene search for other commits by this committer
Remove expired ports:
2015-10-01 www/py-django16: End of extended support: April 1, 2015
www/py-django16-tastypie: Uses expired Django version
2017-04-01 www/py-django-pipeline13: Depends on expired www/py-django16, and
expired upstream
2017-04-19 www/py-djblets: Does not build with py-django18 see pr: 216758
2017-04-19 security/py-crits: Does not build with py-django18 see pr: 216758
www/py-cactus: Depends on expired Django version
devel/py-django16-tastypie-mongoengine: Uses expired Django version
07 Apr 2017 07:55:09
Original commit files touched by this commit  1.6.11
Revision:437915 This port version is marked as vulnerable.
wen search for other commits by this committer
- Adjust CONFLICTS_INSTALL after add py-django111
07 Sep 2016 08:54:26
Original commit files touched by this commit  1.6.11
Revision:421483 This port version is marked as vulnerable.
wen search for other commits by this committer
- Update CONFLICTS_INSTALL
01 Apr 2016 14:33:58
Original commit files touched by this commit  1.6.11
Revision:412351 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.

With hat:	portmgr
Sponsored by:	Absolight
01 Sep 2015 05:47:41
Original commit files touched by this commit  1.6.11
Revision:395745 This port version is marked as vulnerable.
koobs search for other commits by this committer
www/django1{4,6,7,8}: Reduce diffs between ports

Reduce diffs between Django ports, standardizing on:

 * Prefer CHEESESHOP (Geo CDN) over DjangoProject.com for DISTFILES
 * Include version and optionally "LTS" in COMMENT suffixes
 * De-scope CONFLICTS to CONFLICTS_INSTALL and update match strings
 * Whitespace alignment and improve readability
 * Use empty(VARIABLE) instead of ! ${VARIABLE}
 * Sort Makefile entries (CPE_VENDOR and CONFLICTS_INSTALL)

Approved by:	python (with hat)
01 Sep 2015 04:27:21
Original commit files touched by this commit  1.6.11
Revision:395739 This port version is marked as vulnerable.
koobs search for other commits by this committer
www/django16: Update DEPRECATED text and EXPIRATION date

Update DEPRECATED text displayed to users to match the verbage used at
upstream [1].

Set the EXPIRATION_DATE to "End of extended support" date + 6 months

While I'm here:

- Improve whitespace alignment
- Add whitespace for readability

[1] https://www.djangoproject.com/download/#supported-versions

Approved by:	python (with hat)
MFH:		2015Q3
09 Jul 2015 17:47:47
Original commit files touched by this commit  1.6.11
Revision:391670 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Mark DEPRECATED
- Pass maintainership to python@
27 Mar 2015 05:37:08
Original commit files touched by this commit  1.6.11
Revision:382362 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update for CVE-2015-2316 and CVE-2015-2317

PR:		198911
Submitted by:	Sevan Janiyan <venture37@geeklan.co.uk>
Security:	62287f51-d43d-11e4-879c-00e0814cab4e
23 Jan 2015 17:49:28
Original commit files touched by this commit  1.6.10
Revision:377752 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 1.6.10

Security:	9c7b6c20-a324-11e4-879c-00e0814cab4e
15 Oct 2014 14:08:19
Original commit files touched by this commit  1.6.7
Revision:370923 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 1.4.15, 1.5.10, 1.6.7 [1]
- Make 1.5.x and 1.6.x work with Python3 [2]

Notified by:	delphij [1] demon [2]
Reviewed by:	koobs [2]
07 Sep 2014 12:59:35
Original commit files touched by this commit  1.6.6
Revision:367541 This port version is marked as vulnerable.
antoine search for other commits by this committer
Fix duplicate pkgnames

Pointy hat:	lwhsu
07 Sep 2014 09:59:01
Original commit files touched by this commit  1.6.6
Revision:367503 This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Copy py-django -> py-django16 for Django 1.7 update

Number of commits found: 12

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
libnghttp2Jun 03
nghttp2Jun 03
rubygem-websocket-extensionsJun 03
giteaMay 31
powerdns-recursor*May 29
gitlab-ceMay 28
rubygem-kaminari-coreMay 28
sane-backendsMay 28
sympaMay 26
chromiumMay 24
piwigoMay 23
drupal7May 22
sympaMay 22
tomcat-develMay 22
tomcat7May 22

15 vulnerabilities affecting 78 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2020-06-03 17:48:31


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 39481
Broken 95
Deprecated 629
Ignore 338
Forbidden 5
Restricted 147
No CDROM 77
Vulnerable 22
Expired 14
Set to expire 579
Interactive 0
new 24 hours 8
new 48 hours14
new 7 days37
new fortnight71
new month182

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2020 Dan Langille. All rights reserved.