notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
FreshPorts needs to find a new hosting provide willing to take a 2U chassis and host it free of charge. This is part of the FreshPorts project. Preferably in the Austin area. This is not a primary server, but it used for development.
Port details
rubygem-http2 Simple Ruby DSL for making HTTP requests
2.2.2 www Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Use www/rubygem-http instead
Expired This port expired on: 2018-01-31
Maintainer: sunpoet@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-12-12 13:33:00
Last Update: 2018-01-31 16:42:34
SVN Revision: 460509
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-http2-2.2.2/catalog.mk
  2. /usr/local/share/licenses/rubygem-http2-2.2.2/LICENSE
  3. /usr/local/share/licenses/rubygem-http2-2.2.2/MIT
Collapse this list.
Dependency lines:
  • rubygem-http2>0:www/rubygem-http2
No installation instructions:
This port has been deleted.
PKGNAME: rubygem-http2
Flavors: there is no flavor information for this port.
distinfo:
No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby24 : lang/ruby24
  2. gem24 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-addressable>=2.3 : www/rubygem-addressable
  2. rubygem-http-cookie>=1.0 : www/rubygem-http-cookie
  3. rubygem-http-form_data1>=1.0.1 : www/rubygem-http-form_data1
  4. rubygem-http_parser.rb>=0.6.0 : net/rubygem-http_parser.rb
  5. ruby24 : lang/ruby24
  6. gem24 : devel/ruby-gems
Patch dependencies:
  1. ruby24 : lang/ruby24
  2. gem24 : devel/ruby-gems
Extract dependencies:
  1. ruby24 : lang/ruby24
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.global.ssl.fastly.net/gems/
Collapse this list.
Port Moves
  • port moved to www/rubygem-http on 2018-01-31
    REASON: Has expired: Use www/rubygem-http instead

Number of commits found: 3

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
31 Jan 2018 16:42:34
Original commit files touched by this commit Revision:460509  2.2.2
sunpoet search for other commits by this committer
Remove www/rubygem-http2
23 Jan 2018 15:17:02
Original commit files touched by this commit Revision:459768  2.2.2
sunpoet search for other commits by this committer
Mark DEPRECATED and set EXPIRATION_DATE to 2018-01-31
12 Dec 2017 13:32:48
Original commit files touched by this commit Revision:456132  2.2.2
sunpoet search for other commits by this committer
Add rubygem-http2 2.2.2 (copied from rubygem-http)

- Update RUN_DEPENDS
- Add PORTSCOUT

Number of commits found: 3