notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
varnish-libvmod-maxminddb Varnish Module (vmod) for accessing maxminddb geoip data
1.0.0_1 www on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port 1.0.0Version of this port present on the latest quarterly branch.
There is no maintainer for this port.
Any concerns regarding this port should be directed to the FreeBSD Ports mailing list via ports@FreeBSD.org
search for ports maintained by this maintainer
Port Added: 2016-05-16 00:30:47
Last Update: 2019-07-26 21:46:57
SVN Revision: 507372
License: BSD2CLAUSE
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (7 items)
  1. /usr/local/share/licenses/varnish-libvmod-maxminddb-1.0.0_1/catalog.mk
  2. /usr/local/share/licenses/varnish-libvmod-maxminddb-1.0.0_1/LICENSE
  3. /usr/local/share/licenses/varnish-libvmod-maxminddb-1.0.0_1/BSD2CLAUSE
  4. lib/varnish/vmods/libvmod_maxminddb.so
  5. man/man3/vmod_maxminddb.3.gz
  6. share/doc/libvmod-maxminddb/LICENSE
  7. share/doc/libvmod-maxminddb/README.rst
Collapse this list.
Dependency lines:
  • varnish-libvmod-maxminddb>0:www/varnish-libvmod-maxminddb
To install the port: cd /usr/ports/www/varnish-libvmod-maxminddb/ && make install clean
To add the package: pkg install varnish-libvmod-maxminddb
PKGNAME: varnish-libvmod-maxminddb
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. rst2man : textproc/py-docutils
  2. autoconf>=2.69 : devel/autoconf
  3. automake>=1.16.1 : devel/automake
  4. libtoolize : devel/libtool
  5. gmake : devel/gmake
  6. pkgconf>=1.3.0_1 : devel/pkgconf
  7. python2.7 : lang/python27
  8. varnish4>=4 : www/varnish4
Runtime dependencies:
  1. varnish4>=4 : www/varnish4
Library dependencies:
  1. libmaxminddb.so : net/libmaxminddb
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. https://codeload.github.com/simonvik/libvmod_maxminddb/tar.gz/4ae6a7f?dummy=/

Number of commits found: 7

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
26 Jul 2019 20:46:57
Original commit files touched by this commit  1.0.0_1
Revision:507372
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.

PR:		238330
09 May 2019 12:51:27
Original commit files touched by this commit  1.0.0
Revision:501092
pkubaj search for other commits by this committer
www/varnish-libvmod-maxminddb: fix build with GCC-based architectures

Add USES=compiler:c11 to fix build:
/usr/local/include/maxminddb.h:92: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'mmdb_uint128_t'

Approved by:	mentors (implicit approval)
10 Sep 2018 13:14:52
Original commit files touched by this commit  1.0.0
Revision:479406
mat search for other commits by this committer
Add DOCS options to ports that should have one.

Also various fixes related to said option.

PR:		230864
Submitted by:	mat
exp-runs by:	antoine
19 Feb 2018 11:10:43
Original commit files touched by this commit  1.0.0
Revision:462307
antoine search for other commits by this committer
Reduce dependency on the python2 metaport

PR:		225752
Submitted by:	Yasuhiro KIMURA
26 Oct 2016 14:15:39
Original commit files touched by this commit  1.0.0
Revision:424707
feld search for other commits by this committer
Introduce USES=varnish

You can now set the default version of Varnish with DEFAULT_VERSIONS to
build Varnish and its modules against your desired Varnish release
train.

The default version of Varnish throughout the ports tree will remain as
www/varnish4 until at least 2017Q1 when it will be changed in HEAD to be
www/varnish5. This should allow plenty of time for migration and for
stabilization of the changes in Varnish 5.x.

Submitted by:	vanilla
27 Jul 2016 03:55:01
Original commit files touched by this commit  1.0.0
Revision:419161
marino search for other commits by this committer
www/varnish-libvmod-maxminddb is not jobs safe

I've see two failures already.  The last one had vcc_if.h being included
before it was generated.
16 May 2016 00:29:36
Original commit files touched by this commit  1.0.0
Revision:415292
allanjude search for other commits by this committer
add www/varnish-libvmod-maxminddb

Varnish Module (vmod) for accessing maxminddb geoip data

Approved by:	feld
Sponsored by:	ScaleEngine Inc.
Differential Revision:	https://reviews.freebsd.org/D6380

Number of commits found: 7

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
broSep 17
expat2Sep 16
curlSep 14
opensslSep 11
openssl111Sep 11
linux-flashplayerSep 10
onigurumaSep 07
xymon-serverSep 07
asterisk13Sep 06
asterisk15Sep 06
asterisk16Sep 06
asterisk16Sep 06
eximSep 06
wordpressSep 06
wordpressSep 06

14 vulnerabilities affecting 201 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-09-17 23:50:39


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 37704
Broken 409
Deprecated 537
Ignore 668
Forbidden 3
Restricted 162
No CDROM 74
Vulnerable 29
Expired 9
Set to expire 508
Interactive 0
new 24 hours 6
new 48 hours9
new 7 days25
new fortnight73
new month418

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.