notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Remember
I remember
Port details
geany-plugin-devhelp Geany plugin:
1.34 devel Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 1.34Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Depends on forbidden webkit port
Expired This port expired on: 2019-03-24
Maintainer: madpilot@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2012-10-06 18:21:21
Last Update: 2019-03-24 18:43:27
SVN Revision: 496768
License: not specified in port
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (11 items)
  1. lib/geany/devhelp.so
  2. share/doc/geany-plugins/devhelp/AUTHORS
  3. share/doc/geany-plugins/devhelp/COPYING
  4. share/doc/geany-plugins/devhelp/ChangeLog
  5. share/doc/geany-plugins/devhelp/NEWS
  6. share/doc/geany-plugins/devhelp/README
  7. share/geany-plugins/devhelp/devhelp-plugin-48.png
  8. share/geany-plugins/devhelp/devhelp-plugin.svg
  9. share/geany-plugins/devhelp/devhelp.conf
  10. share/geany-plugins/devhelp/geany-devhelp-plugin.png
  11. share/geany-plugins/devhelp/home.html
Collapse this list.
Dependency lines:
  • geany-plugin-devhelp-gtk2>0:devel/geany-plugin-devhelp
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: geany-plugin-devhelp-gtk2
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. msgfmt : devel/gettext-tools
  2. gmake : devel/gmake
  3. intltool-extract : textproc/intltool
  4. pkgconf>=1.3.0_1 : devel/pkgconf
Library dependencies:
  1. libwnck-1.so : x11-toolkits/libwnck
  2. libwebkitgtk-1.0.so : www/webkit-gtk2
  3. libsoup-2.4.so : devel/libsoup
  4. libgeany.so : devel/geany@gtk2
  5. libfontconfig.so : x11-fonts/fontconfig
  6. libfreetype.so : print/freetype2
  7. libatk-1.0.so : accessibility/atk
  8. libcairo.so : graphics/cairo
  9. libgconf-2.so : devel/gconf2
  10. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  11. libglib-2.0.so : devel/glib20
  12. libintl.so : devel/gettext-runtime
  13. libgtk-x11-2.0.so : x11-toolkits/gtk20
  14. libIDL-2.so : devel/libIDL
  15. libxml2.so : textproc/libxml2
  16. libORBit-2.so : devel/ORBit2
  17. libpango-1.0.so : x11-toolkits/pango
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. http://plugins.geany.org/geany-plugins/
Port Moves
  • port deleted on 2019-03-24
    REASON: Has expired: webkit-gtk* last release in 2016 and security issues

Number of commits found: 18

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
24 Mar 2019 18:43:27
Original commit files touched by this commit  1.34
Revision:496768
kwm search for other commits by this committer
Remove expired webkit-gtk2 and webkit-gtk3 ports.

Bump graphics/variety deprecation date, there is a patch for a update which
uses webkit2-gtk3 in ports/236180 but I had issues that I could't fix.
25 Feb 2019 21:27:10
Original commit files touched by this commit  1.34
Revision:493898
madpilot search for other commits by this committer
- Deprecate geany pplugins devhelp and webhelper. They depend on
  deprecated and forbidden webkit. Set same expiration date
- Markdown geany plugin now available only in gtk3 flavor, the gtk2
  flavor depends on deprecated and forbidden webkit-gtk2
- Update geany-plugins port to not depend on deprecated modules

NOTE: these plugins can be added back in the future, once upstream
converts them to work with a supported webkit version.

Approved by:	portmgr (FLAVORS already approved)
09 Dec 2018 17:29:13
Original commit files touched by this commit  1.33_1
Revision:487062
madpilot search for other commits by this committer
- Add gtk2 and gtk3 flavors to geany ports
- Make gtk3 the default

NOTE: some plugins are gtk2 only, please check UPDATING.

PR:			226523
Submitted by:		Greg V <greg@unrelenting.technology>
Reviewed by:		mat
Approved by:		portmgr (mat)
Differential Revision:	https://reviews.freebsd.org/D18018
21 Nov 2017 17:59:25
Original commit files touched by this commit  1.32
Revision:454620
madpilot search for other commits by this committer
- Update devel/geany and it's plugins to 1.32
- Added new "workbench" plugin
- Added utilslib special plugin to install an extra library and
  some code to handle the dependency in the common Makefile
- Update project home pages to use https (thanks to amdmi3)
- Projectorganizer plugin dropped custom icons, using stock ones now
18 Jul 2017 07:18:28
Original commit files touched by this commit  1.31
Revision:446127
madpilot search for other commits by this committer
- Update devel/geany to 1.31
- Update geany plugins to 1.31
- Add missing dependencies reported by poudriere
03 Jan 2017 18:43:02
Original commit files touched by this commit  1.29
Revision:430508
jbeich search for other commits by this committer
Assume "pkg-config zlib" works after 9.x reached EOL
09 Jun 2016 15:24:55
Original commit files touched by this commit  1.27
Revision:416609
madpilot search for other commits by this committer
Take.

Approved by:	makc@ (former maintainer, via email)
01 Apr 2016 14:00:57
Original commit files touched by this commit  1.25
Revision:412346
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
31 Aug 2015 08:57:39
Original commit files touched by this commit  1.25
Revision:395656
makc search for other commits by this committer
devel/geany:
- Update to 1.25
- Use install-strip target to strip binaries

devel/geany-plugin*:
- Update to 1.25. geany-plugin-gproject was renamed to
  geany-plugin-projectorganizer
  New plugins added:
   geany-plugin-automark
   geany-plugin-ctags
   geany-plugin-git-changebar
   geany-plugin-markdown
   geany-plugin-overview
- Drop obsolete patches
- Use install-strip target to strip binaries
- Enable verbose build on package cluster
08 Mar 2015 18:43:09
Original commit files touched by this commit  1.24
Revision:380787
makc search for other commits by this committer
devel/geany:
- Update to 1.24.1
- Fix build without NLS option [1]
- Convert to options helpers

devel/geany-plugin*:
- Update to 1.24, add new plugins:
   geany-plugin-autoclose
   geany-plugin-defineformat
   geany-plugin-geanypy
   geany-plugin-pairtaghighlighter
   geany-plugin-pohelper
- Fix build without NLS option

Reported by:	Kamil Szczesny <mailto.kamils@gmail.com> [1]
27 Oct 2014 10:10:59
Original commit files touched by this commit  1.23_3
Revision:371544
bapt search for other commits by this committer
Cleanup plist
10 Sep 2014 20:50:37
Original commit files touched by this commit  1.23_3
Revision:367888
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
05 Jul 2014 12:19:33
Original commit files touched by this commit  1.23_2
Revision:360738
tijl search for other commits by this committer
Bump more ports that depend on libsqlite3.so:
- ports that set USE_SQLITE with the *_USE option helper
- ports that depend on libsqlite3 indirectly as reported by pkg rquery

Approved by:	portmgr (implicit)
12 May 2014 08:03:36
Original commit files touched by this commit  1.23_1
Revision:353783
tijl search for other commits by this committer
Convert devel/geany* to USES=libtool tar:bzip2.

Approved by:	makc
23 Oct 2013 13:08:42
Original commit files touched by this commit  1.23
Revision:331383
makc search for other commits by this committer
- Support staging
- Use new LIB_DEPENDS syntax
- Use options helpers
- Convert to USES
- Minor changes/fixes
20 Sep 2013 17:04:44
Original commit files touched by this commit  1.23
Revision:327723
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
devel part 2)
21 Mar 2013 14:43:24
Original commit files touched by this commit  1.23
Revision:314846
makc search for other commits by this committer
- Update Geany and plugins to 1.23
- Add ports for new plugins (commander, scope) and localization forgotten
  after splitting (geany-plugins-l10n). geanyGDB plugin has been removed
  upstream. markdown plugin excluded from ports as it requires currently
  missing port for libmarkdown.
- Patch configure script and remove build dependence on shells/bash
06 Oct 2012 18:21:00
Original commit files touched by this commit  1.22
Revision:305393
makc search for other commits by this committer
- Update to 0.21 [1]
- Update to 1.22 and split into geany-plugin-* ports
- Convert to new options framework
- Take maintainership

PR:		ports/165494 [1],
		ports/171856
Submitted by:	Marco Trentini <marco at datasked.com> [1]
Approved by:	maintainer timeouts (2 weeks for ports/171856)

Number of commits found: 18

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
nexus2-ossNov 07
php71Nov 06
php72Nov 06
php73Nov 06
php74Nov 06
fileNov 02
mariadb101-serverNov 02
mariadb102-serverNov 02
mariadb103-serverNov 02
mariadb104-serverNov 02
mariadb55-serverNov 02
mysql56-serverNov 02
mysql57-serverNov 02
mysql80-serverNov 02
percona55-serverNov 02

10 vulnerabilities affecting 139 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-11-07 12:09:53


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38031
Broken 794
Deprecated 81
Ignore 1074
Forbidden 3
Restricted 156
No CDROM 72
Vulnerable 33
Expired 7
Set to expire 51
Interactive 0
new 24 hours 6
new 48 hours9
new 7 days23
new fortnight55
new month119

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.