FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

We also have a status page: https://freshports.wordpress.com/

Port details
libsoup SOAP (Simple Object Access Protocol) implementation in C
2.54.1 devel on this many watch lists=96 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 07 May 2003 05:58:17
Also Listed In: gnome
License: not specified in port
Soup is a SOAP (Simple Object Access Protocol) implementation in C.

It provides a queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) for C
compilers which generates client stubs and server skeletons for easily
calling and implementing SOAP methods.  It uses GLib and is designed to work
well with GTK applications.

Features:
  * Completely Asynchronous
  * Connection cache
  * HTTP chunked transfer and persistent connections
  * Authenticated HTTP, SOCKS4, and SOCKS5 proxy support
  * SSL Support using OpenSSL
  * Apache module server support
  * Client digest authentication
SVNWeb : PortsMon
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (187 items)
  1. include/libsoup-2.4/libsoup/soup-address.h
  2. include/libsoup-2.4/libsoup/soup-auth-domain-basic.h
  3. include/libsoup-2.4/libsoup/soup-auth-domain-digest.h
  4. include/libsoup-2.4/libsoup/soup-auth-domain.h
  5. include/libsoup-2.4/libsoup/soup-auth-manager.h
  6. include/libsoup-2.4/libsoup/soup-auth.h
  7. include/libsoup-2.4/libsoup/soup-autocleanups.h
  8. include/libsoup-2.4/libsoup/soup-cache.h
  9. include/libsoup-2.4/libsoup/soup-connection.h
  10. include/libsoup-2.4/libsoup/soup-content-decoder.h
  11. include/libsoup-2.4/libsoup/soup-content-sniffer.h
  12. include/libsoup-2.4/libsoup/soup-cookie-jar-db.h
  13. include/libsoup-2.4/libsoup/soup-cookie-jar-text.h
  14. include/libsoup-2.4/libsoup/soup-cookie-jar.h
  15. include/libsoup-2.4/libsoup/soup-cookie.h
  16. include/libsoup-2.4/libsoup/soup-date.h
  17. include/libsoup-2.4/libsoup/soup-enum-types.h
  18. include/libsoup-2.4/libsoup/soup-form.h
  19. include/libsoup-2.4/libsoup/soup-headers.h
  20. include/libsoup-2.4/libsoup/soup-logger.h
  21. include/libsoup-2.4/libsoup/soup-message-body.h
  22. include/libsoup-2.4/libsoup/soup-message-headers.h
  23. include/libsoup-2.4/libsoup/soup-message.h
  24. include/libsoup-2.4/libsoup/soup-method.h
  25. include/libsoup-2.4/libsoup/soup-misc.h
  26. include/libsoup-2.4/libsoup/soup-multipart-input-stream.h
  27. include/libsoup-2.4/libsoup/soup-multipart.h
  28. include/libsoup-2.4/libsoup/soup-password-manager.h
  29. include/libsoup-2.4/libsoup/soup-portability.h
  30. include/libsoup-2.4/libsoup/soup-proxy-resolver-default.h
  31. include/libsoup-2.4/libsoup/soup-proxy-resolver.h
  32. include/libsoup-2.4/libsoup/soup-proxy-uri-resolver.h
  33. include/libsoup-2.4/libsoup/soup-request-data.h
  34. include/libsoup-2.4/libsoup/soup-request-file.h
  35. include/libsoup-2.4/libsoup/soup-request-http.h
  36. include/libsoup-2.4/libsoup/soup-request.h
  37. include/libsoup-2.4/libsoup/soup-requester.h
  38. include/libsoup-2.4/libsoup/soup-server.h
  39. include/libsoup-2.4/libsoup/soup-session-async.h
  40. include/libsoup-2.4/libsoup/soup-session-feature.h
  41. include/libsoup-2.4/libsoup/soup-session-sync.h
  42. include/libsoup-2.4/libsoup/soup-session.h
  43. include/libsoup-2.4/libsoup/soup-socket.h
  44. include/libsoup-2.4/libsoup/soup-status.h
  45. include/libsoup-2.4/libsoup/soup-tld.h
  46. include/libsoup-2.4/libsoup/soup-types.h
  47. include/libsoup-2.4/libsoup/soup-uri.h
  48. include/libsoup-2.4/libsoup/soup-value-utils.h
  49. include/libsoup-2.4/libsoup/soup-version.h
  50. include/libsoup-2.4/libsoup/soup-websocket-connection.h
  51. include/libsoup-2.4/libsoup/soup-websocket.h
  52. include/libsoup-2.4/libsoup/soup-xmlrpc-old.h
  53. include/libsoup-2.4/libsoup/soup-xmlrpc.h
  54. include/libsoup-2.4/libsoup/soup.h
  55. lib/girepository-1.0/Soup-2.4.typelib
  56. lib/libsoup-2.4.a
  57. lib/libsoup-2.4.so
  58. lib/libsoup-2.4.so.1
  59. lib/libsoup-2.4.so.1.8.0
  60. libdata/pkgconfig/libsoup-2.4.pc
  61. share/gir-1.0/Soup-2.4.gir
  62. share/gtk-doc/html/libsoup-2.4/SoupAddress.html
  63. share/gtk-doc/html/libsoup-2.4/SoupAuth.html
  64. share/gtk-doc/html/libsoup-2.4/SoupAuthDomain.html
  65. share/gtk-doc/html/libsoup-2.4/SoupAuthDomainBasic.html
  66. share/gtk-doc/html/libsoup-2.4/SoupAuthDomainDigest.html
  67. share/gtk-doc/html/libsoup-2.4/SoupAuthManager.html
  68. share/gtk-doc/html/libsoup-2.4/SoupCache.html
  69. share/gtk-doc/html/libsoup-2.4/SoupContentDecoder.html
  70. share/gtk-doc/html/libsoup-2.4/SoupContentSniffer.html
  71. share/gtk-doc/html/libsoup-2.4/SoupCookie.html
  72. share/gtk-doc/html/libsoup-2.4/SoupCookieJar.html
  73. share/gtk-doc/html/libsoup-2.4/SoupCookieJarDB.html
  74. share/gtk-doc/html/libsoup-2.4/SoupCookieJarText.html
  75. share/gtk-doc/html/libsoup-2.4/SoupLogger.html
  76. share/gtk-doc/html/libsoup-2.4/SoupMessage.html
  77. share/gtk-doc/html/libsoup-2.4/SoupMessageBody.html
  78. share/gtk-doc/html/libsoup-2.4/SoupMessageHeaders.html
  79. share/gtk-doc/html/libsoup-2.4/SoupMultipart.html
  80. share/gtk-doc/html/libsoup-2.4/SoupMultipartInputStream.html
  81. share/gtk-doc/html/libsoup-2.4/SoupProxyResolverDefault.html
  82. share/gtk-doc/html/libsoup-2.4/SoupRequest.html
  83. share/gtk-doc/html/libsoup-2.4/SoupRequestData.html
  84. share/gtk-doc/html/libsoup-2.4/SoupRequestFile.html
  85. share/gtk-doc/html/libsoup-2.4/SoupRequestHTTP.html
  86. share/gtk-doc/html/libsoup-2.4/SoupServer.html
  87. share/gtk-doc/html/libsoup-2.4/SoupSession.html
  88. share/gtk-doc/html/libsoup-2.4/SoupSessionAsync.html
  89. share/gtk-doc/html/libsoup-2.4/SoupSessionFeature.html
  90. share/gtk-doc/html/libsoup-2.4/SoupSessionSync.html
  91. share/gtk-doc/html/libsoup-2.4/SoupSocket.html
  92. share/gtk-doc/html/libsoup-2.4/SoupURI.html
  93. share/gtk-doc/html/libsoup-2.4/annotation-glossary.html
  94. share/gtk-doc/html/libsoup-2.4/ch01.html
  95. share/gtk-doc/html/libsoup-2.4/ch02.html
  96. share/gtk-doc/html/libsoup-2.4/ch03.html
  97. share/gtk-doc/html/libsoup-2.4/ch04.html
  98. share/gtk-doc/html/libsoup-2.4/ch05.html
  99. share/gtk-doc/html/libsoup-2.4/home.png
  100. share/gtk-doc/html/libsoup-2.4/index.html
  101. share/gtk-doc/html/libsoup-2.4/index.sgml
  102. share/gtk-doc/html/libsoup-2.4/ix01.html
  103. share/gtk-doc/html/libsoup-2.4/left-insensitive.png
  104. share/gtk-doc/html/libsoup-2.4/left.png
  105. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-HTML-Form-Support.html
  106. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-Soup-Miscellaneous-Utilities.html
  107. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-SoupServer-deprecated-API.html
  108. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-Top-Level-Domain-utils.html
  109. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-Version-Information.html
  110. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-WebSockets.html
  111. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-XMLRPC-Support.html
  112. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-soup-method.html
  113. share/gtk-doc/html/libsoup-2.4/libsoup-2.4-soup-status.html
  114. share/gtk-doc/html/libsoup-2.4/libsoup-2.4.devhelp2
  115. share/gtk-doc/html/libsoup-2.4/libsoup-build-howto.html
  116. share/gtk-doc/html/libsoup-2.4/libsoup-client-howto.html
  117. share/gtk-doc/html/libsoup-2.4/libsoup-request-howto.html
  118. share/gtk-doc/html/libsoup-2.4/libsoup-server-howto.html
  119. share/gtk-doc/html/libsoup-2.4/libsoup-session-porting.html
  120. share/gtk-doc/html/libsoup-2.4/right-insensitive.png
  121. share/gtk-doc/html/libsoup-2.4/right.png
  122. share/gtk-doc/html/libsoup-2.4/style.css
  123. share/gtk-doc/html/libsoup-2.4/up-insensitive.png
  124. share/gtk-doc/html/libsoup-2.4/up.png
  125. share/locale/an/LC_MESSAGES/libsoup.mo
  126. share/locale/as/LC_MESSAGES/libsoup.mo
  127. share/locale/be/LC_MESSAGES/libsoup.mo
  128. share/locale/bg/LC_MESSAGES/libsoup.mo
  129. share/locale/bn_IN/LC_MESSAGES/libsoup.mo
  130. share/locale/bs/LC_MESSAGES/libsoup.mo
  131. share/locale/ca/LC_MESSAGES/libsoup.mo
  132. share/locale/ca@valencia/LC_MESSAGES/libsoup.mo
  133. share/locale/cs/LC_MESSAGES/libsoup.mo
  134. share/locale/da/LC_MESSAGES/libsoup.mo
  135. share/locale/de/LC_MESSAGES/libsoup.mo
  136. share/locale/el/LC_MESSAGES/libsoup.mo
  137. share/locale/en_GB/LC_MESSAGES/libsoup.mo
  138. share/locale/eo/LC_MESSAGES/libsoup.mo
  139. share/locale/es/LC_MESSAGES/libsoup.mo
  140. share/locale/et/LC_MESSAGES/libsoup.mo
  141. share/locale/eu/LC_MESSAGES/libsoup.mo
  142. share/locale/fa/LC_MESSAGES/libsoup.mo
  143. share/locale/fr/LC_MESSAGES/libsoup.mo
  144. share/locale/fur/LC_MESSAGES/libsoup.mo
  145. share/locale/gl/LC_MESSAGES/libsoup.mo
  146. share/locale/gu/LC_MESSAGES/libsoup.mo
  147. share/locale/he/LC_MESSAGES/libsoup.mo
  148. share/locale/hi/LC_MESSAGES/libsoup.mo
  149. share/locale/hu/LC_MESSAGES/libsoup.mo
  150. share/locale/id/LC_MESSAGES/libsoup.mo
  151. share/locale/it/LC_MESSAGES/libsoup.mo
  152. share/locale/ja/LC_MESSAGES/libsoup.mo
  153. share/locale/kn/LC_MESSAGES/libsoup.mo
  154. share/locale/ko/LC_MESSAGES/libsoup.mo
  155. share/locale/lt/LC_MESSAGES/libsoup.mo
  156. share/locale/lv/LC_MESSAGES/libsoup.mo
  157. share/locale/ml/LC_MESSAGES/libsoup.mo
  158. share/locale/mr/LC_MESSAGES/libsoup.mo
  159. share/locale/nb/LC_MESSAGES/libsoup.mo
  160. share/locale/nl/LC_MESSAGES/libsoup.mo
  161. share/locale/oc/LC_MESSAGES/libsoup.mo
  162. share/locale/or/LC_MESSAGES/libsoup.mo
  163. share/locale/pa/LC_MESSAGES/libsoup.mo
  164. share/locale/pl/LC_MESSAGES/libsoup.mo
  165. share/locale/pt/LC_MESSAGES/libsoup.mo
  166. share/locale/pt_BR/LC_MESSAGES/libsoup.mo
  167. share/locale/ro/LC_MESSAGES/libsoup.mo
  168. share/locale/ru/LC_MESSAGES/libsoup.mo
  169. share/locale/sk/LC_MESSAGES/libsoup.mo
  170. share/locale/sl/LC_MESSAGES/libsoup.mo
  171. share/locale/sr/LC_MESSAGES/libsoup.mo
  172. share/locale/sr@latin/LC_MESSAGES/libsoup.mo
  173. share/locale/sv/LC_MESSAGES/libsoup.mo
  174. share/locale/ta/LC_MESSAGES/libsoup.mo
  175. share/locale/te/LC_MESSAGES/libsoup.mo
  176. share/locale/tg/LC_MESSAGES/libsoup.mo
  177. share/locale/th/LC_MESSAGES/libsoup.mo
  178. share/locale/tr/LC_MESSAGES/libsoup.mo
  179. share/locale/ug/LC_MESSAGES/libsoup.mo
  180. share/locale/uk/LC_MESSAGES/libsoup.mo
  181. share/locale/uz@cyrillic/LC_MESSAGES/libsoup.mo
  182. share/locale/vi/LC_MESSAGES/libsoup.mo
  183. share/locale/zh_CN/LC_MESSAGES/libsoup.mo
  184. share/locale/zh_HK/LC_MESSAGES/libsoup.mo
  185. share/locale/zh_TW/LC_MESSAGES/libsoup.mo
  186. @postexec /sbin/ldconfig -m /usr/local/lib
  187. @postunexec /sbin/ldconfig -R
  188. Collapse this list.

To install the port: cd /usr/ports/devel/libsoup/ && make install clean
To add the package: pkg install libsoup

PKGNAME: libsoup

distinfo:

TIMESTAMP = 1508503209
SHA256 (gnome2/libsoup-2.54.1.tar.xz) = 47b42c232034734d66e5f093025843a5d8cc4b2357c011085a2fd04ef02dd633
SIZE (gnome2/libsoup-2.54.1.tar.xz) = 1793108


Slave ports
  1. devel/libsoup-gnome

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. glib-networking>=2.29.18 : net/glib-networking
  2. msgfmt : devel/gettext-tools
  3. gmake : devel/gmake
  4. intltool-extract : textproc/intltool
  5. g-ir-scanner : devel/gobject-introspection
  6. pkgconf>=1.3.0_1 : devel/pkgconf
  7. python2.7 : lang/python27
Runtime dependencies:
  1. glib-networking>=2.29.18 : net/glib-networking
Library dependencies:
  1. libgcrypt.so : security/libgcrypt
  2. libintl.so : devel/gettext-runtime
  3. libglib-2.0.so : devel/glib20
  4. libintl.so : devel/gettext-runtime
  5. libxml2.so : textproc/libxml2
  6. libsqlite3.so : databases/sqlite3

This port is required by:

for Build for Libraries
  1. astro/foxtrotgps
  2. astro/tangogps*
  3. audio/ario
  4. audio/gmpc
  5. audio/gmpc-wikipedia
  6. audio/pragha
  7. databases/evolution-data-server
  8. Expand this list (104 items)
  9. databases/libgda5
  10. databases/libgda5-bdb
  11. databases/libgda5-jdbc
  12. databases/libgda5-ldap
  13. databases/libgda5-mdb
  14. databases/libgda5-mysql
  15. databases/libgda5-postgresql
  16. databases/libgda5-ui
  17. deskutils/california*
  18. deskutils/drivel
  19. deskutils/gnome-contacts
  20. deskutils/gnome-maps
  21. deskutils/gnome-photos
  22. deskutils/google-gadgets*
  23. deskutils/osmo
  24. devel/appdata-tools*
  25. devel/appstream-glib
  26. devel/bug-buddy*
  27. devel/devhelp
  28. devel/geany-plugin-devhelp
  29. devel/geany-plugin-geniuspaste
  30. devel/geany-plugin-markdown
  31. devel/geany-plugin-updatechecker
  32. devel/geany-plugin-webhelper
  33. devel/gitg
  34. devel/gstreamer-plugins-soup
  35. devel/gstreamer1-plugins-soup
  36. devel/libgdata
  37. devel/libsoup-gnome
  38. devel/py-itools*
  39. editors/abiword
  40. editors/gedit
  41. editors/mate-text-editor*
  42. finance/gnucash
  43. finance/homebank
  44. graphics/atril
  45. graphics/atril-lite
  46. graphics/darktable
  47. graphics/eog-plugins
  48. graphics/frogr
  49. graphics/gimp-app
  50. graphics/gthumb
  51. graphics/libchamplain
  52. graphics/shotwell
  53. graphics/solang*
  54. graphics/swfdec
  55. mail/evolution
  56. mail/evolution-ews
  57. mail/gnome-gmail-notifier*
  58. math/gnome-calculator
  59. misc/bigboard*
  60. misc/xfce4-weather-plugin
  61. multimedia/banshee*
  62. multimedia/quodlibet
  63. multimedia/totem-pl-parser
  64. net/geoclue
  65. net/geocode-glib
  66. net/gnome-online-accounts
  67. net/grilo
  68. net/grilo-plugins
  69. net/grilo2
  70. net/gssdp
  71. net/gupnp
  72. net/gupnp-ui
  73. net/libdmapsharing
  74. net/libgweather
  75. net/libmateweather
  76. net/liferea
  77. net/twitux
  78. net/uhttpmock
  79. net/vino
  80. net-im/corebird
  81. net-im/empathy
  82. net-im/pino*
  83. net-im/ring-gnome
  84. net-im/telepathy-gabble
  85. net-im/telepathy-salut
  86. security/seahorse
  87. textproc/libgepub
  88. textproc/libtranslate
  89. www/epiphany
  90. www/gtkhtml3
  91. www/gtkhtml4
  92. www/libepc
  93. www/luakit
  94. www/surf
  95. www/uzbl
  96. www/vimb-gtk2
  97. www/webkit-gtk2
  98. www/webkit-gtk3
  99. www/webkit2-gtk3
  100. www/xombrero
  101. www/xxxterm*
  102. x11/gnome-shell
  103. x11/xfce4-screenshooter-plugin
  104. x11/yelp
  105. x11-toolkits/osm-gps-map
  106. Collapse this list.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
     No options to configure

USES:
tar:xz gettext gmake gnome libtool pathfix pkgconfig  python:build sqlite:3 tar:xz gnome

Master Sites:
  1. ftp://ftp.belnet.be/mirror/ftp.gnome.org/sources/libsoup/2.54/
  2. ftp://ftp.cse.buffalo.edu/pub/Gnome/sources/libsoup/2.54/
  3. ftp://ftp.kddlabs.co.jp/pub/GNOME/sources/libsoup/2.54/
  4. ftp://ftp.mirrorservice.org/sites/ftp.gnome.org/pub/GNOME/sources/libsoup/2.54/
  5. ftp://ftp.nara.wide.ad.jp/pub/X11/GNOME/sources/libsoup/2.54/
  6. http://download.gnome.org/sources/libsoup/2.54/
  7. http://fr2.rpmfind.net/linux/gnome.org/sources/libsoup/2.54/
  8. http://ftp.acc.umu.se/pub/GNOME/sources/libsoup/2.54/
  9. http://ftp.belnet.be/mirror/ftp.gnome.org/sources/libsoup/2.54/
  10. http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.54/
  11. http://www.gtlib.gatech.edu/pub/gnome/sources/libsoup/2.54/
  12. https://download.gnome.org/sources/libsoup/2.54/
Port Moves

Number of commits found: 108 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
30 Nov 2017 17:54:32
Original commit files touched by this commit  2.54.1
Revision:455216
mat search for other commits by this committer
Fix USES=python usage.

It has been using Python 2 for a very long time, let's assume it is ok.

Sponsored by:	Absolight
20 Nov 2017 17:10:27
Original commit files touched by this commit  2.54.1
Revision:454573
madpilot search for other commits by this committer
Fix build and paackaging.

- Imported upstream patch [1]
- While here regenerated patches.

Approved by:	portmgr fixit blanket
Obtained
from:	https://github.com/GNOME/libsoup/commit/589c2761265f6bf3b8b59b788d48c9b9c461f7de#diff-c63b04cf5692b7697906c1ec308622ae
20 Nov 2017 14:38:11
Original commit files touched by this commit  2.54.1
Revision:454568
dvl search for other commits by this committer
Upgrade to 2.54.1

PR:		223134
Approved by:	maintainer timeout (gnome, one month)
20 Aug 2017 07:53:28
Original commit files touched by this commit  2.52.2_1
Revision:448358
kwm search for other commits by this committer
Fix CVE-2017-2885

Obtained from:	libsoup upstream
MFH:		2017Q3
Security:	8e7bbddd-8338-11e7-867f-b499baebfeaf
19 May 2016 10:21:25
Original commit files touched by this commit  2.52.2
Revision:415498 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix trailing whitespace in pkg-descrs, categories [a-f]*

Approved by:	portmgr blanket
25 Apr 2016 16:13:39
Original commit files touched by this commit  2.52.2
Revision:414014 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove USE_SQLITE from bsd.databases.mk, replaced by USES=sqlite.

While there replace USE_SQLITE=x by USES=sqlite:x.

PR:		208971
Submitted by:	mat
Exp-run by:	antoine
With hat:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D5951
01 Apr 2016 14:00:57
Original commit files touched by this commit  2.52.2
Revision:412346 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
14 Feb 2016 18:57:54
Original commit files touched by this commit  2.52.2
Revision:408881 This port version is marked as vulnerable.
kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.18 for FreeBSD.

The offical GNOME 3.18 release notes can be found at
https://help.gnome.org/misc/release-notes/3.18/

This update doesn't contain the glib/gtk c++ bindings which will
be done in a another update due to the requirement on c++11 and the
amount of fallout this probably will give.

GDM is still at version 3.16 due to some issues.

Bump mate-themes to use the gtk 3.18 version of the themes.

Thanks to Antoine Brodin for running the exp-runs.

This release was made possible by the following people:
  Gustau Perez
  Ting-Wei_Lan

PR:	207006
05 Aug 2015 19:13:26
Original commit files touched by this commit  2.50.0
Revision:393607  Sanity Test Failure This port version is marked as vulnerable.
kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.

The offical GNOME 3.16 release notes can be found at
https://help.gnome.org/misc/release-notes/3.16/

Upgrade instructions for port users:

Delete the old tracker package with:
# pkg delete -f tracker
And user port upgrade tool of choice to upgrade.

Thanks to Antoine Brodin for running the exp-runs.

This release was made possible by the following people:
  Gustau Perez
  Ting-Wei_Lan

PR:		201980
02 Jan 2015 18:46:34
Original commit files touched by this commit  2.48.1_1
Revision:376062 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.6.1 -> 1.6.2, bump depends

Changes:
- src/sexp.c (do_vsexp_sscan): Return error for invalid args.
- cipher/md.c (_gcry_md_info): Fix a segv in case of calling
  with wrong parameters.
- cipher/primegen.c (_gcry_generate_elg_prime): Change to return an
  error code, possible NULL deref in call to prime generator.
- cipher/dsa.c (generate): Take care of new return code.
- cipher/elgamal.c (generate): Change to return an error code.  Take
	care of _gcry_generate_elg_prime return code.
- ecc: Support the non-standard 0x40 compression flag for EdDSA.
- mpi: Extend the internal mpi_get_buffer.
- mpi: Fix regression for powerpc-apple-darwin detection.
- Fix bug inhibiting the use of the sentinel attribute in src/gcrypt.h.in
(Only the first 15 lines of the commit message are shown above View all of this commit message)
30 Dec 2014 20:13:47
Original commit files touched by this commit  2.48.1
Revision:375852  Sanity Test Failure This port version is marked as vulnerable.
kwm search for other commits by this committer
Update cinnamon to 2.4, this should fix [1] and [2].
Update totem to 3.14 now that we have gstreamer 1.4 and minor gnome updates.
Update evolution suite to 3.12.9.
Make sure gtk30 pulls in adwait-icon-theme, since it now the default theme [3].

PR:		195290 [1], 195289 [2], 195455 [3]
Obtained from:	gnome devel repo
19 Nov 2014 11:49:06
Original commit files touched by this commit  2.48.0
Revision:372768  Sanity Test Failure This port version is marked as vulnerable.
kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up.

This commit removes the old GNOME 2 desktop, bindings and some ports that
can't be compiled. A few ports where updated to more recent versions to
allow them to compile with this update.

Apart from updating ports to newer versions

GDM is more integrated with gnome-shell now, and handles several things for
the GNOME desktop such as screen locking. If you want to use GNOME 3 via
startx, you will have to add your own lock screen/screensaver. For example
xscreensaver
can be used for sessions started without GDM.

Shell Extensions can be installed via https://extensions.gnome.org/ , we have
(Only the first 15 lines of the commit message are shown above View all of this commit message)
27 Oct 2014 10:40:08
Original commit files touched by this commit  2.40.3_6
Revision:371546 This port version is marked as vulnerable.
bapt search for other commits by this committer
Cleanup plist
20 Oct 2014 16:04:14
Original commit files touched by this commit  2.40.3_6
Revision:371280 This port version is marked as vulnerable.
mva search for other commits by this committer
- Convert ports of devel/ to USES=python

Approved by:	portmgr (implicit)
30 Jul 2014 03:57:24
Original commit files touched by this commit  2.40.3_6
Revision:363436 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.5.3_3 -> 1.6.1

- Update to 1.6.1
- Remove some unneeded patches
- Fix pkg-plist
- report configure bug upstream
  https://bugs.g10code.com/gnupg/issue1668
- report API breakage downstream and find that MacPorts had the same issue
  https://rt.cpan.org/Ticket/Display.html?id=97201
- bump PORTREVISION for dependent ports (approx. 100 ports)
- Thanks to exp-run by antoine@ to find ports that break
- patch ports that would otherwise break
  security/shishi with PR 192164 is already committed
  [1] devel/ccrtp
  [2] editors/abiword
  [3] security/p5-Crypt-GCrypt

PR:		191256, 192162 [1], 192163 [2], 192166 [3]
Submitted by:	Carlos Jacobo Puga Medina <cjpugmed@gmail.com>
Approved by:	maintainer timeout, antoine (exp-run), portmgr (implicit)
29 Jul 2014 21:20:05
Original commit files touched by this commit  2.40.3_5
Revision:363393 This port version is marked as vulnerable.
antoine search for other commits by this committer
Unbreak some reference ports

Pointy hat:	adamw
29 Jul 2014 21:07:40
Original commit files touched by this commit  2.40.3_5
Revision:363392 This port version is marked as vulnerable.
adamw search for other commits by this committer
Convert a bunch of USE_XZ to USES=tar:xz.

Approved by:	portmgr (not really, but touches unstaged ports)
04 Jul 2014 09:41:00
Original commit files touched by this commit  2.40.3_5
Revision:360588 This port version is marked as vulnerable.
tijl search for other commits by this committer
Bump PORTREVISION on all ports with USE_SQLITE=yes or USE_SQLITE=3 that
have not been bumped yet after the latest libsqlite3.so library version
change.

Approved by:	portmgr (implicit)
25 Jun 2014 05:35:32
Original commit files touched by this commit  2.40.3_4
Revision:359185 This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert GMAKE to MAKE_CMD
Please note that lots of invocation of MAKE_CMD here are wrong as they do not
properly respect MAKE_ENV and friends

With hat:	portmgr
23 Apr 2014 13:25:17
Original commit files touched by this commit  2.40.3_4
Revision:351936 This port version is marked as vulnerable.
tijl search for other commits by this committer
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs
field) to the linker command line and store them in the dependency_libs
field of libA.la.  So everything that subsequently links with libA will also
link to these extra libraries.  This causes too much overlinking.

This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs
field in .la libraries during staging.  However, because .la libraries have
very limited use when dependency_libs is empty it makes sense to completely
remove them during staging.

So with this commit USES=libtool is modified to remove .la libraries and a
new form (USES=libtool:keepla) is introduced in case they need to be kept
(dependency_libs is still emptied).
(Only the first 15 lines of the commit message are shown above View all of this commit message)
16 Apr 2014 18:28:50
Original commit files touched by this commit  2.40.3_3
Revision:351411 This port version is marked as vulnerable.
zeising search for other commits by this committer
The FreeBSD x11@ and graphics team proudly presents
a zeising, kwm production, with help from dumbbell, bdrewery:

NEW XORG ON FREEBSD 9-STABLE AND 10-STABLE

This update switches over to use the new xorg stack by default on FreeBSD 9
and 10 stable, on osversions where vt(9) is available.
It is still possible to use the old stack by specifying WITHOUT_NEW_XORG in
/etc/make.conf .
FreeBSD 8-STABLE and released versions of FreeBSD still use
the old version.
A package repository with binary packages for new xorg will
be available soon.

This patch also contains updates of libxcb and related ports, pixman, as well
(Only the first 15 lines of the commit message are shown above View all of this commit message)
08 Mar 2014 13:49:34
Original commit files touched by this commit  2.40.3_2
Revision:347496 This port version is marked as vulnerable.
kwm search for other commits by this committer
Stagify
Use new lib_depend syntax.
Add USES=libtool
Use USE_GNOME introspection component

Obtained from:	GNOME dev repo
13 Jan 2014 21:00:04
Original commit files touched by this commit  2.40.3_2
Revision:339634 This port version is marked as vulnerable.
rene search for other commits by this committer
Python cleanup:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2
- USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes
Reviewed by:	python (mva, rm)
Approved by:	portmgr-lurkers (mat)
20 Sep 2013 17:13:47
Original commit files touched by this commit  2.40.3_2
Revision:327724 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
devel part 3)
02 Sep 2013 16:55:04
Original commit files touched by this commit  2.40.3_2
Revision:326032 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add an explicit dependency on pkgconf
17 Aug 2013 22:44:28
Original commit files touched by this commit  2.40.3_2
Revision:324877 This port version is marked as vulnerable.
mva search for other commits by this committer
- Fix build support by adding lang/python2 as dependency
14 Aug 2013 22:35:54
Original commit files touched by this commit  2.40.3_2
Revision:324744  Sanity Test Failure This port version is marked as vulnerable.
ak search for other commits by this committer
- Remove MAKE_JOBS_SAFE variable

Approved by:	portmgr (bdrewery)
20 May 2013 20:46:21
Original commit files touched by this commit  2.40.3_2
Revision:318626 This port version is marked as vulnerable.
kwm search for other commits by this committer
libsoup isn't python 3 safe restrict python version, patch script to call
python2 since bin/python can be both major versions. [1]
While here: Add build depend on python for above said script, document sqlite3
depend and mark jobs safe.

Submitted by:	eadler@ [1]
Obtained from:	GNOME devel repo
03 May 2013 16:36:41
Original commit files touched by this commit  2.40.3_1
Revision:317220 This port version is marked as vulnerable.
ehaupt search for other commits by this committer
Chase security/libgcrypt update
24 Apr 2013 18:10:32
Original commit files touched by this commit  2.40.3
Revision:316464 This port version is marked as vulnerable.
ak search for other commits by this committer
- Convert USE_GETTEXT to USES (part 3)

Approved by:	portmgr (bapt)
08 Mar 2013 10:51:36
Original commit files touched by this commit  2.40.3
Revision:313633 This port version is marked as vulnerable.
kwm search for other commits by this committer
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
  are the latest stable releases.
* Update vala to the newest stable release 0.18.1, also update a few ports
  in the gtk/gnome stack.
* The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles.
* Remove pkg-config run depends from glib20 and freetype2. This doesn't
  eliminate pkg-config run dependency completely, a second phase is needed
  and is planned.
* Support for .:run. and .:build. for USE_GNOME components was added.
  Currently only libxml2 and libxslt support this mechanism.
* Updates of the telepathy stack and empathy.
* Trim makefile headers, convert ports to new options, trim off library
  versions for some ports.
* Fix other ports so they build with the new glib version.

Thanks to miwi and crees for helping out with some exp-runs.
Approved by:	portmgr (miwi & bapt)
Obtained from:	gnome team repo
23 Sep 2011 22:26:39
Original commit files touched by this commit  2.34.3
 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead

PR:             157936
Submitted by:   myself
Exp-runs by:    pav
Approved by:    pav
23 Aug 2011 18:31:40
Original commit files touched by this commit  2.34.3
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.34.3.
28 Jul 2011 19:20:07
Original commit files touched by this commit  2.32.2_3
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Fix a security hole that caused some SoupServer users to unintentionally
allow accessing the entire local filesystem when they thought they were only
providing access to a single directory.

Security:       30cb4522-b94d-11e0-8182-485d60cb5385
04 Jul 2011 19:19:49
Original commit files touched by this commit  2.32.2_2
 This port version is marked as vulnerable.
swills search for other commits by this committer
- Chase the libgcrypt shared lib version
- Add explicit dependency so it doesn't get missed in the future
05 Jun 2011 18:43:16
Original commit files touched by this commit  2.32.2_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Chase security/gnutls update and add an UPDATING entry.
04 Dec 2010 07:34:27
Original commit files touched by this commit  2.32.2
 This port version is marked as vulnerable.
ade search for other commits by this committer
Sync to new bsd.autotools.mk
30 Nov 2010 00:23:43
Original commit files touched by this commit  2.32.2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.32.2.
20 Nov 2010 15:37:08
Original commit files touched by this commit  2.32.1
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/

This will be the last release of the GNOME 2.x series, mainly a bugfix and
bridge release to the first release of the GNOME 3.x series.

This release features commits by avl, marcus, mezz and myself.

The FreeBSD GNOME Team would like to thank the following contributors and
testers for there help with this release:

Zane C.B. <vvelox@vvelox.net>
romain@
Olaf Seibert <O.Seibert@cs.ru.nl>
DomiX
(Only the first 15 lines of the commit message are shown above View all of this commit message)
27 Jul 2010 19:56:09
Original commit files touched by this commit  2.30.2_1
 This port version is marked as vulnerable.
olgeni search for other commits by this committer
Bump PORTREVISION in a few more ports affected by the libgcrypt
upgrade (they have references to libgcrypt.so.16).
25 Jul 2010 19:35:08
Original commit files touched by this commit  2.30.2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Presenting GNOME 2.30.2. for FreeBSD.
31 May 2010 22:52:40
Original commit files touched by this commit  2.30.1_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION and add USE_GETTEXT where missing.

PR:             147257
10 May 2010 21:19:08
Original commit files touched by this commit  2.30.1
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ .

This release brings initial PackageKit support, Upower (replaces power
management part of hal), cuse4bsd integration with HAL and cheese, and a
faster Evolution.

Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This
will also be the last of the 2.x releases. The next release will be the
highly-anticipated GNOME 3.0 which will bring with it a new UI experience.

Currently, there are a few bugs with GNOME 2.30 that may be of note for our
users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at
http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading
instructions, and the up-to-date list of known issues.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
28 Mar 2010 06:47:48
Original commit files touched by this commit  2.28.2_2
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to 1.4.1
Reviewed by:    exp8 run on pointyhat
Supported by:   miwi
05 Feb 2010 11:46:55
Original commit files touched by this commit  2.28.2_1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg-8
16 Dec 2009 18:33:15
Original commit files touched by this commit  2.28.2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.28.2.
28 Nov 2009 20:06:37
Original commit files touched by this commit  2.28.1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Presenting GNOME 2.28.1 for FreeBSD.  The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ .
Officially, this is mostly a polishing release in preparation for GNOME 3.0
due in about a year.

On the FreeBSD front, though, a lot went into this release.  Major thanks
goes to kwm and avl who did a lot of the porting work for this release.
In particular, kwm brought in Evolution MAPI support for better Microsoft
Exchange integration.  Avl made sure that the new gobject introspection
repository ports were nicely compartmentalized so that large dependencies
aren't brought in wholesale.

But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself)
contributed to this release.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
16 Aug 2009 18:04:40
Original commit files touched by this commit  2.26.3_2
 This port version is marked as vulnerable.
novel search for other commits by this committer
Bump PORTREVISIONs of the gnutls dependant ports to chase gnutls update.
02 Aug 2009 19:36:34
Original commit files touched by this commit  2.26.3_1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:      marcus and kwm
Pointyhat-exp:  a few times by pav
Tested by:      pgollucci, "Romain Tartière" <romain@blogreen.org>, and
                a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:    marcus
Approved by:    portmgr
31 Jul 2009 13:57:52
Original commit files touched by this commit  2.26.3_1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- bump all port that indirectly depends on libjpeg and have not yet been bumped
or updated
Requested by:   edwin
03 Jul 2009 10:18:41
Original commit files touched by this commit  2.26.3
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.26.3.
15 Jun 2009 05:14:09
Original commit files touched by this commit  2.26.2
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Remove a "==" bashism in configure.
18 May 2009 17:17:52
Original commit files touched by this commit  2.26.2
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.26.2.
24 Apr 2009 06:38:26
Original commit files touched by this commit  2.26.1
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Presenting GNOME 2.26.1 for FreeBSD.

Approved by:    portmgr (marcus)
10 Apr 2009 05:56:28
Original commit files touched by this commit  2.26.0_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Presenting GNOME 2.26 for FreeBSD.  See
http://library.gnome.org/misc/release-notes/2.26/ for a list of what's new.
On the FreeBSD front, we introduced a port of libxul 1.9 as an alternative
for Firefox 2.0 as a Gecko provider.  Almost all of the Gecko consumers
can make use of this provider by setting:

WITH_GECKO=libxul

The GNOME 2.26 port was done by ahze, kwm, marcus, and mezz with
contributions by Joseph S. Atkinson, Peter Wemm, Eric L. Chen,
Martin Matuska, Craig Butler, and Pawel Worach.
13 Jan 2009 06:30:16
Original commit files touched by this commit  2.24.3
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.24.3.
10 Jan 2009 05:22:13
Original commit files touched by this commit  2.24.2.1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Presenting GNOME 2.24 for FreeBSD.

See http://library.gnome.org/misc/release-notes/2.24/ for the general
release notes.  On the FreeBSD front, this release introduces Fuse support
in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some
long-standing seahorse and gnome-keyring bugs.  The documentation updates
to the website are forthcoming.

This release features commits by adamw, ahze, kwm, mezz, and myself.  It would
not have been possible without are contributors and testers:

Alexander Loginov
Craig Butler [1]
Dmitry Marakasov [6]
Eric L. Chen
(Only the first 15 lines of the commit message are shown above View all of this commit message)
06 Jun 2008 13:21:59
Original commit files touched by this commit  2.4.1_1
 This port version is marked as vulnerable.
edwin search for other commits by this committer
Bump portrevision due to upgrade of devel/gettext.

The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).

PR:             ports/124340
Submitted by:   edwin@
Approved by:    portmgr (pav)
07 Apr 2008 18:58:25
Original commit files touched by this commit  2.4.1
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Update to 2.4.1.
24 Mar 2008 03:50:55
Original commit files touched by this commit  2.4.0
 This port version is marked as vulnerable.
marcus search for other commits by this committer
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD.  The official GNOME 2.22 release notes can be found at
http://library.gnome.org/misc/release-notes/2.22/ .  On the FreeBSD front,
this release features an updated hal port with support for video4linux
devices, DRM (Direct Rendering), and better support of removable media.  Work
is also underway to tie webkit more closely into GNOME.  As part of the
GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well.
Be sure to consult UPDATING on the proper steps to upgrade all of your
GNOME ports.

This release would not have been possible without the contributions and
testing efforts of the following people:

Pawel Worach
kan
edwin
Peter Ulrich Kruppa
J. W. Ballantine
Yasuda Keisuke
Andriy Gapon
03 Mar 2008 11:57:08
Original commit files touched by this commit  2.2.105_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
- Chase security/gnutls shlib version bump
- Add an entry to UPDATING
11 Feb 2008 21:47:30
Original commit files touched by this commit  2.2.105
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.105.
12 Dec 2007 04:35:56
Original commit files touched by this commit  2.2.104
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.104.
15 Oct 2007 18:01:15
Original commit files touched by this commit  2.2.102
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Update to 2.2.102.
06 Oct 2007 22:06:22
Original commit files touched by this commit  2.2.101
 This port version is marked as vulnerable.
mezz search for other commits by this committer
Update to 2.2.101.
01 Jul 2007 08:56:17
Original commit files touched by this commit  2.2.100_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Chase gnutls shared library version chase: adjust DEPENDS lines and
bump PORTREVISIONs.
13 Feb 2007 01:23:14
Original commit files touched by this commit  2.2.100
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.100.
09 Jan 2007 04:11:20
Original commit files touched by this commit  2.2.99
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 2.2.99
02 Jan 2007 08:54:13
Original commit files touched by this commit  2.2.98_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
- Chase security/gnutls update
- Add an entry to UPDATING
- Pet portlint(1) for some ports while I'm here
21 Nov 2006 07:03:40
Original commit files touched by this commit  2.2.98
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.98.
07 Nov 2006 15:13:23
Original commit files touched by this commit  2.2.97
 This port version is marked as vulnerable.
ahze search for other commits by this committer
Update to 2.2.97
05 Nov 2006 03:13:38
Original commit files touched by this commit  2.2.96
 This port version is marked as vulnerable.
mezz search for other commits by this committer
INSTALLS_SHLIB -> USE_LDCONFIG.

Found by:       portlint (cports.sh)
24 Jul 2006 23:39:57
Original commit files touched by this commit  2.2.96
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 2.2.96
10 Jul 2006 19:01:06
Original commit files touched by this commit  2.2.95.1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.95.1.
06 Jul 2006 17:41:23
Original commit files touched by this commit  2.2.94_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Chase gnutls shlib version change.
13 Jun 2006 00:34:25
Original commit files touched by this commit  2.2.94
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 2.2.94
31 May 2006 22:18:51
Original commit files touched by this commit  2.2.93
 This port version is marked as vulnerable.
mezz search for other commits by this committer
- Add header in these *-reference ports.
- Fix a few of pkg-descr by chase the rename.
- Move all PORTREVISION and PORTEPOCH to top with ?=.
- Put USE_X_PREFIX back in, but under REFERENCE_PORT, and remove PREFIX? and
  USE_XLIB. This fix ports to use the correct mtree when you change the prefix,
  for example:

        Incorrect: (Without USE_X_PREFIX)
        ================================
        # cd /usr/ports/x11-toolkits/gtk20
        # make -V MTREE_FILE
        /etc/mtree/BSD.x11-4.dist
        # make PREFIX=/tmp/foo -V MTREE_FILE
        /etc/mtree/BSD.local.dist <-- Here...
        ================================
(Only the first 15 lines of the commit message are shown above View all of this commit message)
31 May 2006 20:33:08
Original commit files touched by this commit  2.2.93
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.93.
10 May 2006 17:13:21
Original commit files touched by this commit  2.2.92_1
 This port version is marked as vulnerable.
jylefort search for other commits by this committer
Move the libsoup programming reference to the libsoup-reference port.
30 Apr 2006 00:47:21
Original commit files touched by this commit  2.2.92
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Presenting GNOME 2.14.1 for FreeBSD!  Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list
of all the gooides in this new release.  In particular, GNOME 2.14 focused
on performance, and they did not miss the mark.  There's some new eye candy,
but most of the big things are waiting until GNOME 2.16.  On the FreeBSD
side, we tried to clean up all the crashers we could.  In particular, we
really improved GNOME's 64-bit support.

The good news is that this release does not bring any big shared library
version bumps, so you can almost do a simple portupgrade to get to 2.14.
There are a few minor gotchas that will be documented in UPDATING shortly.

The FreeBSD GNOME Team would like th thank the following users for their
patches, feedback, and sometimes incessant complaing about crashes (you
know who you are).
(Only the first 15 lines of the commit message are shown above View all of this commit message)
23 Feb 2006 10:40:45
Original commit files touched by this commit  2.2.7_2
 This port version is marked as vulnerable.
ade search for other commits by this committer
Conversion to a single libtool environment.

Approved by:    portmgr (kris)
09 Jan 2006 16:34:19
Original commit files touched by this commit  2.2.7_1
 This port version is marked as vulnerable.
novel search for other commits by this committer
Chase gnutls update.
24 Dec 2005 22:21:57
Original commit files touched by this commit  2.2.7
 This port version is marked as vulnerable.
adamw search for other commits by this committer
Poot zee LDFLAGS beck intu zee CONFIGURE_ENV. Bork Bork Bork!
24 Dec 2005 21:00:45
Original commit files touched by this commit  2.2.7
 This port version is marked as vulnerable.
adamw search for other commits by this committer
Back out the last commit, now that the libtool-1.5.22 issue is
resolved. And marcus says that the LDFLAGS should stay separate
for OpenSSL purposes.
24 Dec 2005 16:55:31
Original commit files touched by this commit  2.2.7
 This port version is marked as vulnerable.
adamw search for other commits by this committer
Add PTHREAD_CFLAGS/LIBS to CONFIGURE_ENV, and make LDFLAGS actually
be a part of CONFIGURE_ENV.
20 Nov 2005 21:37:57
Original commit files touched by this commit  2.2.7
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Remove patch and remove BROKEN on 4.x

Reported by:    mjl on irc.freenode.org/#FreeBSD-GNOME
19 Nov 2005 19:54:29
Original commit files touched by this commit  2.2.7
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Mark BROKEN on 4.X.

Reported by:    pointyhat via kris
17 Nov 2005 22:47:16
Original commit files touched by this commit  2.2.7
 This port version is marked as vulnerable.
ahze search for other commits by this committer
- Update to 2.2.7
05 Nov 2005 04:53:48
Original commit files touched by this commit  2.2.6.1_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Presenting GNOME 2.12 for FreeBSD.  The release is chock full of bug fixes
and new features.  Don't believe me?  Then see for yourself at
http://www.gnome.org/start/2.12/notes/en/.

DO NOT USE portupgrade by itself to upgrade to GNOME 2.12.  Instead, use
the gnome_upgrade.sh script from
http://www.marcuscom.com/downloads/gnome_upgrade212.sh.  This script will
circumvent some potential pitfalls users can see if they use portupgrade
by itself.

In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special
splash screen.  The winner of this release's contest is
Dominique Goncalves <dominique.goncalves@gmail.com>.  His splash screen
was inspired by http://art.gnome.org/contests/2.12-splash/83.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
28 Aug 2005 08:29:34
Original commit files touched by this commit  2.2.6.1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Update to 2.2.6.1.
14 Mar 2005 17:48:44
Original commit files touched by this commit  2.2.3
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.2.3.
12 Mar 2005 10:54:27
Original commit files touched by this commit  2.2.2_2
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION to chase the glib20 shared lib version change.
11 Feb 2005 23:05:45
Original commit files touched by this commit  2.2.2_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION since the gnutls ABI changed.

Suggested by:   kwm
24 Jan 2005 20:46:33
Original commit files touched by this commit  2.2.2
 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.2.2.
Changelog:
o) The SSL validation fix from 2.2.1 is now completely
   fixed. (Part of the fix didn't actually make it into 2.2.1)
o) HTTPS certificate validation now works when using an HTTP proxy.
o) HTTP proxy code deals better with proxies that try to make
   the user do HTML-form-based authentication.
o) 64-bit fixes for NTLM auth code.
07 Nov 2004 22:24:32
Original commit files touched by this commit  2.2.1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Presenting GNOME 2.8 for FreeBSD (2.8.1 to be exact).

This release notes detailing all of the new goodies in GNOME 2.8 can
be found at http://www.gnome.org/start/2.8/notes/, and the list of what
was fixed in GNOME 2.8.1 can be found at
http://lists.gnome.org/archives/gnome-announce-list/2004-October/msg00056.html.

This release, as well as all of our others, would not have been possible
without the great efforts of our FreeBSD GNOME Team.  The list of
current members can be found at http://www.freebsd.org/gnome/contact.html
(including our newest member, Michael Johnson <ahze@FreeBSD.org>).

Special thanks also goes out to all of the loyal FreeBSD GNOME users that
put up with crashes and hangs to test and debug GNOME on FreeBSD.  We would
especially like to thank those users that provided patches for GNOME 2.7 and
(Only the first 15 lines of the commit message are shown above View all of this commit message)
09 Jul 2004 17:43:11
Original commit files touched by this commit  1.99.28_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port.  Ports that
set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of
the included version.  To restore previous behavior, use the new macro,
USE_INC_LIBTOOL_VER.  Both macros accept the same argument: a libtool version.

For example, to use the ports version of libtool-1.5, add the following to
your Makefile:

USE_LIBTOOL_VER=        15

To use the included version of libtool with extra hacks provided by
libtool-1.5, add the following to your Makefile:

USE_INC_LIBTOOL_VER=    15

With this change, ports that had to add additional libtool hacks to prevent
.la files from being installed or to fix certain threading issues can now
delete those hacks (after appropriate testing, of course).

PR:             63944
Based on work by:eik and marcus
Approved by:    ade (autotools maintainer)
Tested by:      kris on pointyhat
Bound to be hidden problems:    You bet
07 Apr 2004 00:08:36
Original commit files touched by this commit  1.99.28_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Avoid GnuTLS support at all costs.
05 Apr 2004 03:31:02
Original commit files touched by this commit  1.99.28_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Chase the glib20 update, and bump all affected ports' PORTREVISIONs.
15 Mar 2004 18:10:32
Original commit files touched by this commit  1.99.28
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Ensure we do not build against GnuTLS.
14 Mar 2004 06:17:56
Original commit files touched by this commit  1.99.28
 This port version is marked as vulnerable.
ade search for other commits by this committer
Whoa there, boy, that's a mighty big commit y'all have there...

Begin autotools sanitization sequence by requiring ports to explicitly
specify which version of {libtool,autoconf,automake} they need, erasing
the concept of a "system default".

For ports-in-waiting:

        USE_LIBTOOL=YES         ->      USE_LIBTOOL_VER=13
        USE_AUTOCONF=YES        ->      USE_AUTOCONF_VER=213
        USE_AUTOMAKE=YES        ->      USE_AUTOMAKE_VER=14

Ports attempting to use the old style system after June 1st 2004 will be
sorely disappointed.

Number of commits found: 108 (showing only 100 on this page)

1 | 2  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
jenkinsDec 15
jenkins-ltsDec 15
gitlabDec 14
nodeDec 14
node4Dec 14
node6Dec 14
node8Dec 14
torDec 14
asterisk13Dec 13
asterisk13*Dec 13
asterisk13*Dec 13
asterisk13*Dec 13
libxml2Dec 13
curl*Dec 11
linux-c7-curl*Dec 11

17 vulnerabilities affecting 108 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2017-12-15 16:33:45


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 32130
Broken 122
Deprecated 47
Ignore 358
Forbidden 0
Restricted 173
No CDROM 77
Vulnerable 44
Expired 10
Set to expire 39
Interactive 0
new 24 hours 1
new 48 hours7
new 7 days77
new fortnight119
new month48543

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2017 Dan Langille. All rights reserved.