FreshPorts -- The Place For Ports notbugIf you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

Port details
webkit2-gtk3 Opensource browser engine using the GTK+ 3 toolkit
2.16.6_3 www on this many watch lists=2 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 25 Dec 2014 21:14:57
License: GPLv2 BSD2CLAUSE
WebKitGTK+ is a full-featured port of the WebKit rendering engine, suitable
for projects requiring any kind of web integration, from hybrid HTML/CSS
applications to full-fledged web browsers. It offers WebKit's full
functionality and is useful in a wide range of systems from desktop
computers to embedded systems like phones, tablets, and televisions.

WebKitGTK+ is made by a lively community of developers and designers,
who hope to bring the web platform to everyone. It's the official web
engine of the GNOME platform and is used in browsers such as Epiphany
and Midori.

WWW: http://webkitgtk.org/
SVNWeb : Homepage : PortsMon
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (265 items)
  1. /usr/local/share/licenses/webkit2-gtk3-2.16.6_3/catalog.mk
  2. /usr/local/share/licenses/webkit2-gtk3-2.16.6_3/LICENSE
  3. /usr/local/share/licenses/webkit2-gtk3-2.16.6_3/GPLv2
  4. /usr/local/share/licenses/webkit2-gtk3-2.16.6_3/BSD2CLAUSE
  5. bin/MiniBrowser-4
  6. bin/jsc-4
  7. include/webkitgtk-4.0/JavaScriptCore/JSBase.h
  8. include/webkitgtk-4.0/JavaScriptCore/JSContextRef.h
  9. include/webkitgtk-4.0/JavaScriptCore/JSObjectRef.h
  10. include/webkitgtk-4.0/JavaScriptCore/JSStringRef.h
  11. include/webkitgtk-4.0/JavaScriptCore/JSTypedArray.h
  12. include/webkitgtk-4.0/JavaScriptCore/JSValueRef.h
  13. include/webkitgtk-4.0/JavaScriptCore/JavaScript.h
  14. include/webkitgtk-4.0/JavaScriptCore/WebKitAvailability.h
  15. include/webkitgtk-4.0/webkit2/WebKitAuthenticationRequest.h
  16. include/webkitgtk-4.0/webkit2/WebKitAutocleanups.h
  17. include/webkitgtk-4.0/webkit2/WebKitBackForwardList.h
  18. include/webkitgtk-4.0/webkit2/WebKitBackForwardListItem.h
  19. include/webkitgtk-4.0/webkit2/WebKitColorChooserRequest.h
  20. include/webkitgtk-4.0/webkit2/WebKitConsoleMessage.h
  21. include/webkitgtk-4.0/webkit2/WebKitContextMenu.h
  22. include/webkitgtk-4.0/webkit2/WebKitContextMenuActions.h
  23. include/webkitgtk-4.0/webkit2/WebKitContextMenuItem.h
  24. include/webkitgtk-4.0/webkit2/WebKitCookieManager.h
  25. include/webkitgtk-4.0/webkit2/WebKitCredential.h
  26. include/webkitgtk-4.0/webkit2/WebKitDefines.h
  27. include/webkitgtk-4.0/webkit2/WebKitDownload.h
  28. include/webkitgtk-4.0/webkit2/WebKitEditingCommands.h
  29. include/webkitgtk-4.0/webkit2/WebKitEditorState.h
  30. include/webkitgtk-4.0/webkit2/WebKitEnumTypes.h
  31. include/webkitgtk-4.0/webkit2/WebKitError.h
  32. include/webkitgtk-4.0/webkit2/WebKitFaviconDatabase.h
  33. include/webkitgtk-4.0/webkit2/WebKitFileChooserRequest.h
  34. include/webkitgtk-4.0/webkit2/WebKitFindController.h
  35. include/webkitgtk-4.0/webkit2/WebKitFormSubmissionRequest.h
  36. include/webkitgtk-4.0/webkit2/WebKitForwardDeclarations.h
  37. include/webkitgtk-4.0/webkit2/WebKitFrame.h
  38. include/webkitgtk-4.0/webkit2/WebKitGeolocationPermissionRequest.h
  39. include/webkitgtk-4.0/webkit2/WebKitHitTestResult.h
  40. include/webkitgtk-4.0/webkit2/WebKitInstallMissingMediaPluginsPermissionRequest.h
  41. include/webkitgtk-4.0/webkit2/WebKitJavascriptResult.h
  42. include/webkitgtk-4.0/webkit2/WebKitMimeInfo.h
  43. include/webkitgtk-4.0/webkit2/WebKitNavigationAction.h
  44. include/webkitgtk-4.0/webkit2/WebKitNavigationPolicyDecision.h
  45. include/webkitgtk-4.0/webkit2/WebKitNetworkProxySettings.h
  46. include/webkitgtk-4.0/webkit2/WebKitNotification.h
  47. include/webkitgtk-4.0/webkit2/WebKitNotificationPermissionRequest.h
  48. include/webkitgtk-4.0/webkit2/WebKitPermissionRequest.h
  49. include/webkitgtk-4.0/webkit2/WebKitPlugin.h
  50. include/webkitgtk-4.0/webkit2/WebKitPolicyDecision.h
  51. include/webkitgtk-4.0/webkit2/WebKitPrintCustomWidget.h
  52. include/webkitgtk-4.0/webkit2/WebKitPrintOperation.h
  53. include/webkitgtk-4.0/webkit2/WebKitResponsePolicyDecision.h
  54. include/webkitgtk-4.0/webkit2/WebKitScriptDialog.h
  55. include/webkitgtk-4.0/webkit2/WebKitScriptWorld.h
  56. include/webkitgtk-4.0/webkit2/WebKitSecurityManager.h
  57. include/webkitgtk-4.0/webkit2/WebKitSecurityOrigin.h
  58. include/webkitgtk-4.0/webkit2/WebKitSettings.h
  59. include/webkitgtk-4.0/webkit2/WebKitURIRequest.h
  60. include/webkitgtk-4.0/webkit2/WebKitURIResponse.h
  61. include/webkitgtk-4.0/webkit2/WebKitURISchemeRequest.h
  62. include/webkitgtk-4.0/webkit2/WebKitUserContent.h
  63. include/webkitgtk-4.0/webkit2/WebKitUserContentManager.h
  64. include/webkitgtk-4.0/webkit2/WebKitUserMediaPermissionRequest.h
  65. include/webkitgtk-4.0/webkit2/WebKitVersion.h
  66. include/webkitgtk-4.0/webkit2/WebKitWebContext.h
  67. include/webkitgtk-4.0/webkit2/WebKitWebEditor.h
  68. include/webkitgtk-4.0/webkit2/WebKitWebExtension.h
  69. include/webkitgtk-4.0/webkit2/WebKitWebExtensionAutocleanups.h
  70. include/webkitgtk-4.0/webkit2/WebKitWebHitTestResult.h
  71. include/webkitgtk-4.0/webkit2/WebKitWebInspector.h
  72. include/webkitgtk-4.0/webkit2/WebKitWebPage.h
  73. include/webkitgtk-4.0/webkit2/WebKitWebResource.h
  74. include/webkitgtk-4.0/webkit2/WebKitWebView.h
  75. include/webkitgtk-4.0/webkit2/WebKitWebViewBase.h
  76. include/webkitgtk-4.0/webkit2/WebKitWebViewSessionState.h
  77. include/webkitgtk-4.0/webkit2/WebKitWebsiteData.h
  78. include/webkitgtk-4.0/webkit2/WebKitWebsiteDataManager.h
  79. include/webkitgtk-4.0/webkit2/WebKitWindowProperties.h
  80. include/webkitgtk-4.0/webkit2/webkit-web-extension.h
  81. include/webkitgtk-4.0/webkit2/webkit2.h
  82. include/webkitgtk-4.0/webkitdom/WebKitDOMAttr.h
  83. include/webkitgtk-4.0/webkitdom/WebKitDOMBlob.h
  84. include/webkitgtk-4.0/webkitdom/WebKitDOMCDATASection.h
  85. include/webkitgtk-4.0/webkitdom/WebKitDOMCSSRule.h
  86. include/webkitgtk-4.0/webkitdom/WebKitDOMCSSRuleList.h
  87. include/webkitgtk-4.0/webkitdom/WebKitDOMCSSStyleDeclaration.h
  88. include/webkitgtk-4.0/webkitdom/WebKitDOMCSSStyleSheet.h
  89. include/webkitgtk-4.0/webkitdom/WebKitDOMCSSValue.h
  90. include/webkitgtk-4.0/webkitdom/WebKitDOMCharacterData.h
  91. include/webkitgtk-4.0/webkitdom/WebKitDOMComment.h
  92. include/webkitgtk-4.0/webkitdom/WebKitDOMCustom.h
  93. include/webkitgtk-4.0/webkitdom/WebKitDOMCustomUnstable.h
  94. include/webkitgtk-4.0/webkitdom/WebKitDOMDOMImplementation.h
  95. include/webkitgtk-4.0/webkitdom/WebKitDOMDOMSelection.h
  96. include/webkitgtk-4.0/webkitdom/WebKitDOMDOMTokenList.h
  97. include/webkitgtk-4.0/webkitdom/WebKitDOMDOMWindow.h
  98. include/webkitgtk-4.0/webkitdom/WebKitDOMDOMWindowUnstable.h
  99. include/webkitgtk-4.0/webkitdom/WebKitDOMDeprecated.h
  100. include/webkitgtk-4.0/webkitdom/WebKitDOMDocument.h
  101. include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentFragment.h
  102. include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentFragmentUnstable.h
  103. include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentType.h
  104. include/webkitgtk-4.0/webkitdom/WebKitDOMDocumentUnstable.h
  105. include/webkitgtk-4.0/webkitdom/WebKitDOMElement.h
  106. include/webkitgtk-4.0/webkitdom/WebKitDOMElementUnstable.h
  107. include/webkitgtk-4.0/webkitdom/WebKitDOMEvent.h
  108. include/webkitgtk-4.0/webkitdom/WebKitDOMEventTarget.h
  109. include/webkitgtk-4.0/webkitdom/WebKitDOMFile.h
  110. include/webkitgtk-4.0/webkitdom/WebKitDOMFileList.h
  111. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAnchorElement.h
  112. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAppletElement.h
  113. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLAreaElement.h
  114. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBRElement.h
  115. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBaseElement.h
  116. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLBodyElement.h
  117. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLButtonElement.h
  118. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLCanvasElement.h
  119. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLCollection.h
  120. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDListElement.h
  121. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDirectoryElement.h
  122. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDivElement.h
  123. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLDocument.h
  124. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLElement.h
  125. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLElementUnstable.h
  126. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLEmbedElement.h
  127. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFieldSetElement.h
  128. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFontElement.h
  129. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFormElement.h
  130. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFrameElement.h
  131. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLFrameSetElement.h
  132. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHRElement.h
  133. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHeadElement.h
  134. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHeadingElement.h
  135. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLHtmlElement.h
  136. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLIFrameElement.h
  137. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLImageElement.h
  138. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLInputElement.h
  139. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLIElement.h
  140. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLabelElement.h
  141. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLegendElement.h
  142. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLLinkElement.h
  143. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMapElement.h
  144. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMarqueeElement.h
  145. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMenuElement.h
  146. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLMetaElement.h
  147. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLModElement.h
  148. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOListElement.h
  149. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLObjectElement.h
  150. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOptGroupElement.h
  151. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOptionElement.h
  152. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLOptionsCollection.h
  153. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLParagraphElement.h
  154. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLParamElement.h
  155. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLPreElement.h
  156. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLQuoteElement.h
  157. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLScriptElement.h
  158. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLSelectElement.h
  159. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLStyleElement.h
  160. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableCaptionElement.h
  161. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableCellElement.h
  162. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableColElement.h
  163. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableElement.h
  164. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableRowElement.h
  165. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTableSectionElement.h
  166. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTextAreaElement.h
  167. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLTitleElement.h
  168. include/webkitgtk-4.0/webkitdom/WebKitDOMHTMLUListElement.h
  169. include/webkitgtk-4.0/webkitdom/WebKitDOMKeyboardEvent.h
  170. include/webkitgtk-4.0/webkitdom/WebKitDOMMediaList.h
  171. include/webkitgtk-4.0/webkitdom/WebKitDOMMouseEvent.h
  172. include/webkitgtk-4.0/webkitdom/WebKitDOMNamedNodeMap.h
  173. include/webkitgtk-4.0/webkitdom/WebKitDOMNode.h
  174. include/webkitgtk-4.0/webkitdom/WebKitDOMNodeFilter.h
  175. include/webkitgtk-4.0/webkitdom/WebKitDOMNodeIterator.h
  176. include/webkitgtk-4.0/webkitdom/WebKitDOMNodeList.h
  177. include/webkitgtk-4.0/webkitdom/WebKitDOMObject.h
  178. include/webkitgtk-4.0/webkitdom/WebKitDOMProcessingInstruction.h
  179. include/webkitgtk-4.0/webkitdom/WebKitDOMRange.h
  180. include/webkitgtk-4.0/webkitdom/WebKitDOMRangeUnstable.h
  181. include/webkitgtk-4.0/webkitdom/WebKitDOMStyleSheet.h
  182. include/webkitgtk-4.0/webkitdom/WebKitDOMStyleSheetList.h
  183. include/webkitgtk-4.0/webkitdom/WebKitDOMText.h
  184. include/webkitgtk-4.0/webkitdom/WebKitDOMTreeWalker.h
  185. include/webkitgtk-4.0/webkitdom/WebKitDOMUIEvent.h
  186. include/webkitgtk-4.0/webkitdom/WebKitDOMWheelEvent.h
  187. include/webkitgtk-4.0/webkitdom/WebKitDOMXPathExpression.h
  188. include/webkitgtk-4.0/webkitdom/WebKitDOMXPathNSResolver.h
  189. include/webkitgtk-4.0/webkitdom/WebKitDOMXPathResult.h
  190. include/webkitgtk-4.0/webkitdom/webkitdom.h
  191. include/webkitgtk-4.0/webkitdom/webkitdomautocleanups.h
  192. include/webkitgtk-4.0/webkitdom/webkitdomdefines.h
  193. lib/girepository-1.0/JavaScriptCore-4.0.typelib
  194. lib/girepository-1.0/WebKit2-4.0.typelib
  195. lib/girepository-1.0/WebKit2WebExtension-4.0.typelib
  196. lib/libjavascriptcoregtk-4.0.so
  197. lib/libjavascriptcoregtk-4.0.so.18
  198. lib/libjavascriptcoregtk-4.0.so.18.5.13
  199. lib/libwebkit2gtk-4.0.so
  200. lib/libwebkit2gtk-4.0.so.37
  201. lib/libwebkit2gtk-4.0.so.37.19.9
  202. lib/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
  203. libdata/pkgconfig/javascriptcoregtk-4.0.pc
  204. libdata/pkgconfig/webkit2gtk-4.0.pc
  205. libdata/pkgconfig/webkit2gtk-web-extension-4.0.pc
  206. libexec/webkit2gtk-4.0/MiniBrowser
  207. libexec/webkit2gtk-4.0/WebKitDatabaseProcess
  208. libexec/webkit2gtk-4.0/WebKitNetworkProcess
  209. libexec/webkit2gtk-4.0/WebKitPluginProcess
  210. libexec/webkit2gtk-4.0/WebKitPluginProcess2
  211. libexec/webkit2gtk-4.0/WebKitWebProcess
  212. libexec/webkit2gtk-4.0/jsc
  213. share/gir-1.0/JavaScriptCore-4.0.gir
  214. share/gir-1.0/WebKit2-4.0.gir
  215. share/gir-1.0/WebKit2WebExtension-4.0.gir
  216. share/locale/ar/LC_MESSAGES/WebKit2GTK-4.0.mo
  217. share/locale/as/LC_MESSAGES/WebKit2GTK-4.0.mo
  218. share/locale/bg/LC_MESSAGES/WebKit2GTK-4.0.mo
  219. share/locale/ca/LC_MESSAGES/WebKit2GTK-4.0.mo
  220. share/locale/cs/LC_MESSAGES/WebKit2GTK-4.0.mo
  221. share/locale/de/LC_MESSAGES/WebKit2GTK-4.0.mo
  222. share/locale/el/LC_MESSAGES/WebKit2GTK-4.0.mo
  223. share/locale/en_CA/LC_MESSAGES/WebKit2GTK-4.0.mo
  224. share/locale/en_GB/LC_MESSAGES/WebKit2GTK-4.0.mo
  225. share/locale/eo/LC_MESSAGES/WebKit2GTK-4.0.mo
  226. share/locale/es/LC_MESSAGES/WebKit2GTK-4.0.mo
  227. share/locale/et/LC_MESSAGES/WebKit2GTK-4.0.mo
  228. share/locale/eu/LC_MESSAGES/WebKit2GTK-4.0.mo
  229. share/locale/fi/LC_MESSAGES/WebKit2GTK-4.0.mo
  230. share/locale/fr/LC_MESSAGES/WebKit2GTK-4.0.mo
  231. share/locale/gl/LC_MESSAGES/WebKit2GTK-4.0.mo
  232. share/locale/gu/LC_MESSAGES/WebKit2GTK-4.0.mo
  233. share/locale/he/LC_MESSAGES/WebKit2GTK-4.0.mo
  234. share/locale/hi/LC_MESSAGES/WebKit2GTK-4.0.mo
  235. share/locale/hu/LC_MESSAGES/WebKit2GTK-4.0.mo
  236. share/locale/id/LC_MESSAGES/WebKit2GTK-4.0.mo
  237. share/locale/it/LC_MESSAGES/WebKit2GTK-4.0.mo
  238. share/locale/ja/LC_MESSAGES/WebKit2GTK-4.0.mo
  239. share/locale/kn/LC_MESSAGES/WebKit2GTK-4.0.mo
  240. share/locale/ko/LC_MESSAGES/WebKit2GTK-4.0.mo
  241. share/locale/lt/LC_MESSAGES/WebKit2GTK-4.0.mo
  242. share/locale/lv/LC_MESSAGES/WebKit2GTK-4.0.mo
  243. share/locale/ml/LC_MESSAGES/WebKit2GTK-4.0.mo
  244. share/locale/mr/LC_MESSAGES/WebKit2GTK-4.0.mo
  245. share/locale/nb/LC_MESSAGES/WebKit2GTK-4.0.mo
  246. share/locale/nl/LC_MESSAGES/WebKit2GTK-4.0.mo
  247. share/locale/or/LC_MESSAGES/WebKit2GTK-4.0.mo
  248. share/locale/pa/LC_MESSAGES/WebKit2GTK-4.0.mo
  249. share/locale/pl/LC_MESSAGES/WebKit2GTK-4.0.mo
  250. share/locale/pt/LC_MESSAGES/WebKit2GTK-4.0.mo
  251. share/locale/pt_BR/LC_MESSAGES/WebKit2GTK-4.0.mo
  252. share/locale/ro/LC_MESSAGES/WebKit2GTK-4.0.mo
  253. share/locale/ru/LC_MESSAGES/WebKit2GTK-4.0.mo
  254. share/locale/sl/LC_MESSAGES/WebKit2GTK-4.0.mo
  255. share/locale/sr/LC_MESSAGES/WebKit2GTK-4.0.mo
  256. share/locale/sr@latin/LC_MESSAGES/WebKit2GTK-4.0.mo
  257. share/locale/sv/LC_MESSAGES/WebKit2GTK-4.0.mo
  258. share/locale/ta/LC_MESSAGES/WebKit2GTK-4.0.mo
  259. share/locale/te/LC_MESSAGES/WebKit2GTK-4.0.mo
  260. share/locale/tr/LC_MESSAGES/WebKit2GTK-4.0.mo
  261. share/locale/uk/LC_MESSAGES/WebKit2GTK-4.0.mo
  262. share/locale/vi/LC_MESSAGES/WebKit2GTK-4.0.mo
  263. share/locale/zh_CN/LC_MESSAGES/WebKit2GTK-4.0.mo
  264. @postexec /sbin/ldconfig -m /usr/local/lib
  265. @postunexec /sbin/ldconfig -R
  266. Collapse this list.

To install the port: cd /usr/ports/www/webkit2-gtk3/ && make install clean
To add the package: pkg install webkit2-gtk3

PKGNAME: webkit2-gtk3

distinfo:

TIMESTAMP = 1500907942
SHA256 (webkitgtk-2.16.6.tar.xz) = fc23650df953123c59b9c0edf3855e7bd55bd107820997fc72375811e1ea4b21
SIZE (webkitgtk-2.16.6.tar.xz) = 14658120


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. geoclue>=2.4.3 : net/geoclue
  2. ruby23 : lang/ruby23
  3. bison : devel/bison
  4. cmake : devel/cmake
  5. ninja : devel/ninja
  6. msgfmt : devel/gettext-tools
  7. g-ir-scanner : devel/gobject-introspection
  8. gperf : devel/gperf
  9. pkgconf>=1.3.0_1 : devel/pkgconf
  10. python2.7 : lang/python27
  11. libGL.so : graphics/mesa-libs
  12. libEGL.so : graphics/mesa-libs
  13. glproto.pc : x11/glproto
  14. dri2proto.pc : x11/dri2proto
  15. dri3proto.pc : x11/dri3proto
  16. x11.pc : x11/libX11
  17. xcomposite.pc : x11/libXcomposite
  18. xdamage.pc : x11/libXdamage
  19. xext.pc : x11/libXext
  20. xrender.pc : x11/libXrender
  21. xt.pc : x11-toolkits/libXt
  22. ice.pc : x11/libICE
  23. gstreamer1-plugins-bad>=1.4 : multimedia/gstreamer1-plugins-bad
  24. gstreamer1-plugins-gl>=1.4 : graphics/gstreamer1-plugins-gl
  25. gstreamer1-plugins>=1.4 : multimedia/gstreamer1-plugins
  26. perl5>=5.24<5.25 : lang/perl5.24
Runtime dependencies:
  1. geoclue>=2.4.3 : net/geoclue
  2. libGL.so : graphics/mesa-libs
  3. libEGL.so : graphics/mesa-libs
  4. x11.pc : x11/libX11
  5. xcomposite.pc : x11/libXcomposite
  6. xdamage.pc : x11/libXdamage
  7. xext.pc : x11/libXext
  8. xrender.pc : x11/libXrender
  9. xt.pc : x11-toolkits/libXt
  10. ice.pc : x11/libICE
  11. gstreamer1-plugins-bad>=1.4 : multimedia/gstreamer1-plugins-bad
  12. gstreamer1-plugins-gl>=1.4 : graphics/gstreamer1-plugins-gl
  13. gstreamer1-plugins>=1.4 : multimedia/gstreamer1-plugins
Library dependencies:
  1. libenchant.so : textproc/enchant
  2. libfontconfig.so : x11-fonts/fontconfig
  3. libfreetype.so : print/freetype2
  4. libwebp.so : graphics/webp
  5. libpng.so : graphics/png
  6. libsecret-1.so : security/libsecret
  7. libnotify.so : devel/libnotify
  8. libhyphen.so : textproc/hyphen
  9. libicutu.so : devel/icu
  10. libharfbuzz.so : print/harfbuzz
  11. libharfbuzz-icu.so : print/harfbuzz-icu
  12. libsoup-2.4.so : devel/libsoup
  13. libgcrypt.so : security/libgcrypt
  14. libgnutls.so : security/gnutls
  15. libintl.so : devel/gettext-runtime
  16. libatk-1.0.so : accessibility/atk
  17. libcairo.so : graphics/cairo
  18. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  19. libglib-2.0.so : devel/glib20
  20. libintl.so : devel/gettext-runtime
  21. libgtk-x11-2.0.so : x11-toolkits/gtk20
  22. libgtk-3.so : x11-toolkits/gtk30
  23. libxml2.so : textproc/libxml2
  24. libxslt.so : textproc/libxslt
  25. libpango-1.0.so : x11-toolkits/pango
  26. libjpeg.so : graphics/jpeg-turbo
  27. libsqlite3.so : databases/sqlite3
  28. libgstreamer-1.0.so : multimedia/gstreamer1
Patch dependencies:
  1. ruby23 : lang/ruby23
Extract dependencies:
  1. ruby23 : lang/ruby23

This port is required by:

for Libraries * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
===> The following configuration options are available for webkit2-gtk3-2.16.6_3:
     DEBUG=off: Build with debugging support
     GEOIP=on: GeoIP IP location support
     NPAPI=on: Support gtk2 (NPAPI) based plugins (like flash)
===> Use 'make config' to modify these settings

USES:
bison cmake compiler:c++14-lang gettext gnome gperf  jpeg perl5 pkgconfig python:2.7,build sqlite tar:xz gnome

Master Sites:
  1. http://webkitgtk.org/releases/

Number of commits found: 46

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
09 Nov 2017 02:31:48
Original commit files touched by this commit  2.16.6_3
Revision:453790
jbeich search for other commits by this committer
devel/icu: update to 60.1

Changes:	http://site.icu-project.org/download/60
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		223373
Exp-run by:	antoine
25 Sep 2017 00:02:36
Original commit files touched by this commit  2.16.6_2
Revision:450556  Sanity Test Failure
jbeich search for other commits by this committer
devel/icu: update to 59.1

- Temporarily keep C++98 working in consumers for Clang's default -std=

Changes:	http://site.icu-project.org/download/59
PR:		218788
Submitted by:	takefu@airport.fm, dcarmich@dcarmichael.net (early version)
Exp-run by:	antoine
10 Sep 2017 20:55:39
Original commit files touched by this commit  2.16.6_1
Revision:449591
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
   c++14-lang, c++0x, c11, or gcc-c++11-lib.

PR:		219275
25 Jul 2017 18:17:55
Original commit files touched by this commit  2.16.6
Revision:446618
kwm search for other commits by this committer
Update webkit2-gtk3 to 2.16.6.

Security:	0f66b901-715c-11e7-ad1f-bcaec565249c
MFH:		2017Q3
02 Jul 2017 07:01:19
Original commit files touched by this commit  2.16.5
Revision:444872 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2-gtk3 to 2.16.5.
25 Jun 2017 21:07:58
Original commit files touched by this commit  2.16.3
Revision:444324 This port version is marked as vulnerable.
tcberner search for other commits by this committer
Make ninja opt-out in cmake.mk

Using ninja instead of make (1) can lead to significant speed ups while
building.
Therefore switch from having the ninja generator opt-in to having it opt-out.

Previously cmake-ports that wanted to use ninja could set
    CMAKE_NINJA=yes
now, ports that do not work with ninja can set
    cmake:<existing args>,noninja
Note, that needing this should be an exception and most often points to a broken
cmake of the port.

The ports using cmake were modified
* removed USES=gmake, if ninja is used
* removed MAKE_ARGS, if ninja is used
* added the cmake-argument noninja if necessary

PR:		219629
PR:		213331
Exp-run by:	antoine
Reviewed by:	rakuco
Differential Revision:	https://reviews.freebsd.org/D10748
27 May 2017 07:14:31
Original commit files touched by this commit  2.16.3
Revision:441828 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2-gtk3 to 2.16.3.

* Fix the build when using port compile and binutils is installed. It
  seems Cmake picks up ar and ranlib from localbase when using a compiler
  from ports, but the compiler uses ld from base for linking. Base ld
  doesn't understand some features newer ar and ranlib from localbase
  are using. So tell the build to always use ar and ranlib from base. [1]
* Fix build failure on armv6 [2]

PR:		219161 [1], 219495 [2]
Submitted by:	mikael.urankar@gmail.com [2]
23 May 2017 05:03:16
Original commit files touched by this commit  2.16.2_1
Revision:441503 This port version is marked as vulnerable.
rezny search for other commits by this committer
Revision bump of all ports with USE_GL after consolidation of mesa-libs

Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D10845
13 May 2017 08:57:40
Original commit files touched by this commit  2.16.2
Revision:440762 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2-gtk3 to 2.16.2.

* Switch to ninja for building webkit.
10 May 2017 09:04:54
Original commit files touched by this commit  2.14.7
Revision:440549 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2-gtk3 to 2.14.7.

 * Add option for NPAPI support (flash etc). Only enable it on i386
   and amd64 by default.
09 May 2017 01:41:18
Original commit files touched by this commit  2.14.6
Revision:440464 This port version is marked as vulnerable.
jbeich search for other commits by this committer
www/webkit2-gtk3: properly apply r440362

Reported by:	ashish
Pointy hat to:	jbeich
07 May 2017 20:15:22
Original commit files touched by this commit  2.14.6
Revision:440362 This port version is marked as vulnerable.
jbeich search for other commits by this committer
www/webkit2-gtk3: unbreak on armv6 + -mcpu=cortex-a15

<inline asm>:149:16: error: invalid operand for instruction
vmov.u32 r2, r3, s8, s9

PR:		216149
Submitted by:	mikael.urankar@gmail.com
06 May 2017 19:45:45
Original commit files touched by this commit  2.14.6
Revision:440284 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2gtk3 to 2.14.6.

* Add License
* Make Geolocation optional
* Fix the DEBUG option so it works again
* Fix build on powerpc* [1]

Submitted by:	jhibbits@ [1]
Obtained from:	gnome devel repo
Differential Revision:	https://reviews.freebsd.org/D10627 [1]
30 Apr 2017 12:50:54
Original commit files touched by this commit  2.8.5_10
Revision:439814 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update to 0.6.0

- Bump PORTREVISION for dependent ports

Changes:	https://chromium.googlesource.com/webm/libwebp/+/master/NEWS
27 Apr 2017 21:31:10
Original commit files touched by this commit  2.8.5_9
Revision:439575 This port version is marked as vulnerable.
kwm search for other commits by this committer
Split off the harfbuzz icu support into it's own port.

PR:		207779
Submitted by:	Vladimir Kondratyev <vladimir@kondratyev.su>
Exp-run by:	antoine@
01 Apr 2017 15:23:32
Original commit files touched by this commit  2.8.5_8
Revision:437439 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using using Mk/bsd.octave.mk which in turn has USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
   c++11-lang, c++0x, c11, or gcc-c++11-lib.

PR:		216707
20 Jan 2017 14:15:50
Original commit files touched by this commit  2.8.5_7
Revision:431958 This port version is marked as vulnerable.
jbeich search for other commits by this committer
www/webkit2-gtk3: attempt to unbreak on aarch64

./Source/JavaScriptCore/assembler/ARM64Assembler.h:2760:2: error: "The
cacheFlush support is missing on this platform."
 #error "The cacheFlush support is missing on this platform."
  ^

./Source/JavaScriptCore/assembler/MacroAssemblerARM64.h:133:17: error: class
member cannot be redeclared
    static bool shouldBlindForSpecificArch(uintptr_t value) { return value >=
0x00ffffff; }
                ^
./Source/JavaScriptCore/assembler/MacroAssemblerARM64.h:132:17: note: previous
declaration is here
    static bool shouldBlindForSpecificArch(uint64_t value) { return value >=
0x00ffffff; }
                ^

Reported by:	pkg-fallout
11 Jan 2017 10:08:38
Original commit files touched by this commit  2.8.5_7
Revision:431169 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL

Approved by:	portmgr blanket
22 Nov 2016 21:56:37
Original commit files touched by this commit  2.8.5_7
Revision:426869 This port version is marked as vulnerable.
antoine search for other commits by this committer
Add explicit build dependency on the python symlink, right now they rely on
it being provided by x11-toolkits/gtk20
19 Nov 2016 18:21:20
Original commit files touched by this commit  2.8.5_7
Revision:426525 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 58.1

Changes:	http://site.icu-project.org/download/58
PR:		214384
Exp-run by:	antoine
Approved by:	office (bapt)
25 Sep 2016 12:19:16
Original commit files touched by this commit  2.8.5_6
Revision:422748 This port version is marked as vulnerable.
brd search for other commits by this committer
Try #2 for fixing build of www/webkit2-gtk3 on armv6 by matching the correct
define and disabling the JIT compiler.

PR:		207275
Submitted by:	mikael.urankar@gmail.com
Reported by:	sbruno
Reviewed by:	bdrewery (implicit)
Approved by:	maintainer timeout
24 Sep 2016 11:06:57
Original commit files touched by this commit  2.8.5_6
Revision:422711 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update devel/icu to 57.1.
- Clean up the Makefile.
- Follow some upstream recommendations (--with-data-packaging=archive,
  --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE).
- Patch makefiles to install static libraries with INSTALL_DATA so they
  aren't stripped.
- Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc.
- Fix endianness detection in ICU.  The code wanted to use BYTE_ORDER
  defined in machine/endian.h, but this isn't visible because ICU is
  compiled with _XOPEN_SOURCE.  Patch the code to use _BYTE_ORDER instead.
- Compile ICU with C++11 compiler to enable move constructors.
- Patch ICU to fix a problem with atomics in the case of a C++11 compiler
  without C++11 header <atomic> (like Clang on FreeBSD 9).
- Bump all ports that depend on it due to library version change.
- Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU
  pkgconfig files.
- Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs
  a C++11 runtime library now.  Add this to all ports that depend on it
  so their executables load the right libstdc++.so on FreeBSD 9.

PR:		205120
Exp-run by:	antoine
Approved by:	portmgr (antoine)
14 Sep 2016 05:43:13
Original commit files touched by this commit  2.8.5_5
Revision:422112 This port version is marked as vulnerable.
antoine search for other commits by this committer
Revert r422019, patch fails to apply

PR:		207275
Reported by:	pkg-fallout
13 Sep 2016 15:34:28
Original commit files touched by this commit  2.8.5_5
Revision:422019 This port version is marked as vulnerable.
brd search for other commits by this committer
Fix build of www/webkit2-gtk3 on armv6 by matching the correct define and
disabling the JIT compiler.

PR:		207275
Submitted by:	mikael.urankar@gmail.com
Reported by:	sbruno
Reviewed by:	bdrewery (implicit)
Approved by:	maintainer timeout
25 Jul 2016 21:46:23
Original commit files touched by this commit  2.8.5_5
Revision:419069 This port version is marked as vulnerable.
jbeich search for other commits by this committer
Apply r402343 to other gnome@ ports restoring r297047 behavior

- Invoke pkg-config(1) instead of checking manually
- Convert to ECHO_MSG which can be silenced

PR:		166279
Approved by:	portmgr blanket
MFH:		2016Q3
06 Jul 2016 22:10:14
Original commit files touched by this commit  2.8.5_5
Revision:418153 This port version is marked as vulnerable.
mat search for other commits by this committer
Bump PORTREVISION for the icu revert.

This time not bumping lang/php70, but devel/php70-intl which is the one
really depending on icu.

PR:		205120
With hat:	portmgr
Sponsored by:	Absolight
06 Jul 2016 07:34:13
Original commit files touched by this commit  2.8.5_4
Revision:418119 This port version is marked as vulnerable.
gahr search for other commits by this committer
devel/icu: bump PORTREVISION on dependent ports
05 Jun 2016 19:11:57
Original commit files touched by this commit  2.8.5_3
Revision:416418 This port version is marked as vulnerable.
sbruno search for other commits by this committer
Add explicit cast to float to repair build with libc++ 3.8.0

PR:		209686
Submitted by:	dim
01 Apr 2016 14:33:58
Original commit files touched by this commit  2.8.5_2
Revision:412351 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.

With hat:	portmgr
Sponsored by:	Absolight
01 Apr 2016 11:17:54
Original commit files touched by this commit  2.8.5_2
Revision:412334 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 0.5.0
- Bump PORTREVISION for graphics/webp shlib change

Changes:	https://chromium.googlesource.com/webm/libwebp/+/master/NEWS
27 Mar 2016 14:58:00
Original commit files touched by this commit  2.8.5_1
Revision:411990 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol
  supported by libgnutls-dane and gnutls-cli.  Also clarify the option
  description.
- Add an IDN option.
- libgnutls-openssl has been removed in 3.4.  Some ports used this library
  in their LIB_DEPENDS but no port actually required it.
- Some old API functions have been removed.  Ports that used these have been
  updated or patched to use the new API.
- Add a patch to print/cups to prevent overlinking of libgnutls.so.
- Bump PORTREVISION on dependent ports.

net-im/jabber: This port used the old API to give users fine grained
control over which crypto algorithms were used via a configuration file.
It's not immediately obvious how to port this to the new API so the port
always uses the defaults now.

www/hydra: Mark BROKEN.  This uses more removed calls than the other ports,
is said to be alpha quality and not fully functional and has been abandoned
10 years ago.

PR:		207768
Exp-run by:	antoine
Approved by:	portmgr (antoine)
10 Jan 2016 16:19:37
Original commit files touched by this commit  2.8.5
Revision:405717 This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert www ports to USES=sqlite and USES=firebird
26 Nov 2015 12:13:50
Original commit files touched by this commit  2.8.5
Revision:402440 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Add upstream commit to fix the build with CMake 3.4.0.

In preparation for PR 204629, import an upstream SVN commit that explicitly
includes the CheckIncludeFiles module. No need to bump PORTREVISION.

Approved by:	gnome@ (kwm)
08 Oct 2015 15:12:22
Original commit files touched by this commit  2.8.5
Revision:398833 This port version is marked as vulnerable.
olgeni search for other commits by this committer
Remove trailing whitespace from Makefiles, M-X.
19 Aug 2015 08:14:20
Original commit files touched by this commit  2.8.5
Revision:394759 This port version is marked as vulnerable.
kwm search for other commits by this committer
Add patch so we can start using USES=cmake instead of custom code.
Thanks go to rakuco@ for helping to dig into webkit cmake stuff and
Ting-Wei_Lan for digging deeper and figuring out the patch [1].

Obtained from:	webkit upstream [1]
18 Aug 2015 10:51:02
Original commit files touched by this commit  2.8.5
Revision:394572 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Uses/cmake.mk: Replace CMAKE_ENV with CONFIGURE_ENV.

Instead of defining a variable that is almost always based on CONFIGURE_ENV,
just use CONFIGURE_ENV directly.

This also matches the behavior of other ports that do not use autotools (so
most ports can just worry about CONFIGURE_ENV). Additionally, the fact that
we do not use ?= means we do not have problems if another file in Uses/
needs to set CONFIGURE_ENV (with CMAKE_ENV, the order of the arguments to
USES would matter).

Ports which set CMAKE_ENV have been adjusted accordingly. In most cases,
CMAKE_ENV was just replaced with CONFIGURE_ENV, the exceptions being:
* databases/sqliteman: CMAKE_ENV line removed; setting QMAKESPEC there has
                       no effect on the build system.
* devel/freeocl: CMAKE_ENV line removed; FREEOCL_CXX_COMPILER is already
                 retrieved from the CMAKE_CXX_COMPILER variable in the build
                 system.
* graphics/openimageio: CMAKE_ENV line removed; setting Qt variables there
                        has no effect on the build system.

Reviewed by:		makc
Differential Revision:	https://reviews.freebsd.org/D3403
09 Aug 2015 16:46:24
Original commit files touched by this commit  2.8.5
Revision:393808 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 2.8.5 [1].

* libxslt is also needed at run time [2], this was fixed in webkit-gtk[23] but
  didn't make to webkit2-gtk3 or accedently reversed.
* Fix portscout macro.

PR:		202171 [1]
Submitted by:	olivierd@ [1], marino@ [2]
06 Aug 2015 07:57:30
Original commit files touched by this commit  2.8.4
Revision:393637 This port version is marked as vulnerable.
kwm search for other commits by this committer
Add a check to see if cairo was build with OPENGL and EGL support.
Webkit2-gtk needs both.
05 Aug 2015 19:13:26
Original commit files touched by this commit  2.8.4
Revision:393607  Sanity Test Failure This port version is marked as vulnerable.
kwm search for other commits by this committer
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.

The offical GNOME 3.16 release notes can be found at
https://help.gnome.org/misc/release-notes/3.16/

Upgrade instructions for port users:

Delete the old tracker package with:
# pkg delete -f tracker
And user port upgrade tool of choice to upgrade.

Thanks to Antoine Brodin for running the exp-runs.

This release was made possible by the following people:
  Gustau Perez
  Ting-Wei_Lan

PR:		201980
22 Jun 2015 18:33:22
Original commit files touched by this commit  2.6.6
Revision:390310 This port version is marked as vulnerable.
antoine search for other commits by this committer
Convert to USES=jpeg
04 Jun 2015 22:39:16
Original commit files touched by this commit  2.6.6
Revision:388557 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2-gtk3 to 2.6.6.

* Update PORTSCOUT to try to look for new versions in the current series.
  New major versions will be imported with GNOME updates.
* This version builds with cmake 3.2
* Changelog: http://webkitgtk.org/2015/04/07/webkitgtk2.6.6-released.html
* Update pkg-descr and WWW [1]

Noticed by:	swills@ [1]
18 Feb 2015 11:49:24
Original commit files touched by this commit  2.6.5_1
Revision:379206 This port version is marked as vulnerable.
kwm search for other commits by this committer
Backport upstream patches to fix the function collision with glib 2.37.4
which added the GMutexLocker function.

Obtained from:	upstream (based on)
20 Jan 2015 22:55:14
Original commit files touched by this commit  2.6.5
Revision:377553 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update webkit2gtk to 2.6.5.
15 Jan 2015 17:17:33
Original commit files touched by this commit  2.6.4
Revision:377130 This port version is marked as vulnerable.
kwm search for other commits by this committer
Sprinkle some PORTSCOUT macros around to either mark ports:
 * ignore because there will not be any new releases.
 * check specific versions or ignore devel versions.
26 Dec 2014 21:59:12
Original commit files touched by this commit  2.6.4
Revision:375660 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Depend on libpng.so, not libpng15.so.

Approved by:	gnome (kwm)
25 Dec 2014 21:10:28
Original commit files touched by this commit  2.6.4
Revision:375603 This port version is marked as vulnerable.
kwm search for other commits by this committer
Add webkit2-gtk3 2.6.4.

This port only supplies the WebKit2 library for gtk3, and has some API changes.
The webkitgtk project switch to cmake. Due to issues I don't understand
  yet we can't use USES=cmake yet.
Use USES=compiler:c++11-lib to replace custom dancing around with clang
  and OSVERSION.
Make 8.x as IGNORE, because of c++ and other issues.

Number of commits found: 46

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
chromiumJan 23
chromium*Jan 23
chromiumJan 23
mariadb100-serverJan 19
mariadb101-serverJan 19
mariadb102-serverJan 19
mariadb55-serverJan 19
mysql55-serverJan 19
mysql56-serverJan 19
mysql57-serverJan 19
percona55-serverJan 19
percona56-serverJan 19
percona57-serverJan 19
phpbb3Jan 19
unboundJan 19

11 vulnerabilities affecting 80 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2018-01-23 01:54:21


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 32668
Broken 129
Deprecated 97
Ignore 369
Forbidden 0
Restricted 172
No CDROM 77
Vulnerable 46
Expired 8
Set to expire 88
Interactive 0
new 24 hours 2
new 48 hours13
new 7 days375
new fortnight1337
new month2038

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2018 Dan Langille. All rights reserved.