notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
rubygem-warning Adds custom processing for warnings
1.2.1 devel on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 1.2.0Version of this port present on the latest quarterly branch.
Maintainer: mfechner@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2021-08-31 09:57:08
Last Update: 2021-10-11 08:20:41
Commit Hash: 85b96fd
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-warning-1.2.1/catalog.mk
  2. /usr/local/share/licenses/rubygem-warning-1.2.1/LICENSE
  3. /usr/local/share/licenses/rubygem-warning-1.2.1/MIT
Collapse this list.
Dependency lines:
  • rubygem-warning>0:devel/rubygem-warning
To install the port:
cd /usr/ports/devel/rubygem-warning/ && make install clean
To add the package, run one of these commands:
  • pkg install devel/rubygem-warning
  • pkg install rubygem-warning
PKGNAME: rubygem-warning
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
rubygem-warning
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd641.2.0-
FreeBSD:11:armv6--
FreeBSD:11:i3861.2.0-
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64-1.2.0
FreeBSD:12:amd641.2.11.2.0
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i3861.2.11.2.0
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64-1.2.0
FreeBSD:13:amd641.2.11.2.0
FreeBSD:13:armv6--
FreeBSD:13:armv7-1.2.0
FreeBSD:13:i3861.2.11.2.0
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch641.2.1-
FreeBSD:14:amd641.2.1-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i3861.2.1-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Runtime dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Patch dependencies:
  1. ruby27 : lang/ruby27
  2. gem27 : devel/ruby-gems
Extract dependencies:
  1. ruby27 : lang/ruby27
This port is required by:
for Build
  1. www/gitlab-ce
for Run
  1. www/gitlab-ce

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.org/downloads/
Collapse this list.

Number of commits found: 2

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
11 Oct 2021 08:20:41
 files touched by this commit commit hash:85b96fdd8d46e10b2b9ae54970761d39468ae588  1.2.1
Matthias Fechner (mfechner) search for other commits by this committer
devel/rubygem-warning: update to 1.2.1

Changelog:
https://github.com/jeremyevans/ruby-warning/blob/master/CHANGELOG
31 Aug 2021 09:54:27
 files touched by this commit commit hash:fa756e8ac4eaf4d50b20c8b28b0191585e024d91  1.2.0
Matthias Fechner (mfechner) search for other commits by this committer
devel/rubygem-warning: New port required for gitlab-ce 14.2

Number of commits found: 2