notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
gitlab-ce Web GUI for managing git repositories
14.4.0 www on this many watch lists=9 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 14.3.0_1Version of this port present on the latest quarterly branch.
Maintainer: mfechner@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2018-07-04 17:38:49
Last Update: 2021-10-27 06:20:37
Commit Hash: 5ca638b
People watching this port, also watch:: gitlab-workhorse, nginx, tt-rss, gitlab-runner, gitlab-pages
Also Listed In: devel
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/gitlab-ce-14.4.0/catalog.mk
  2. /usr/local/share/licenses/gitlab-ce-14.4.0/LICENSE
  3. /usr/local/share/licenses/gitlab-ce-14.4.0/MIT
Collapse this list.
Dependency lines:
  • gitlab-ce>0:www/gitlab-ce
Conflicts:
CONFLICTS_INSTALL:
  • gitolite-*
  • gitolite2-*
  • gogs-*
  • gitea-*
  • -gitosis-*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
To install the port:
cd /usr/ports/www/gitlab-ce/ && make install clean
To add the package, run one of these commands:
  • pkg install www/gitlab-ce
  • pkg install gitlab-ce
PKGNAME: gitlab-ce
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
gitlab-ce
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd6414.3.0_114.0.5
FreeBSD:11:armv6--
FreeBSD:11:i38614.3.0_114.0.5
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64--
FreeBSD:12:amd6414.3.2_314.3.2_3
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i38614.3.2_314.3.2_3
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64-14.3.2_3
FreeBSD:13:amd6414.3.2_314.4.0
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i38614.3.2_314.3.2_3
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch6414.3.2_3-
FreeBSD:14:amd6414.3.2_3-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i38614.3.2_3-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. gem : devel/ruby-gems
  2. git>=2.32.0 : devel/git
  3. gitaly>=14.4.0 : devel/gitaly
  4. gitlab-elasticsearch-indexer>=2.16.0 : textproc/gitlab-elasticsearch-indexer
  5. gitlab-agent>=14.4.0 : net/gitlab-agent
  6. gitlab-pages>=1.46.0 : www/gitlab-pages
  7. gitlab-shell>=13.21.1 : devel/gitlab-shell
  8. gitlab-workhorse>=14.4.0 : www/gitlab-workhorse
  9. redis>=6.0.14 : databases/redis
  10. yarn>=1.10.0 : www/yarn
  11. gtar>0 : archivers/gtar
  12. bash>0 : shells/bash
  13. rubygem-rails61>=6.1.4.1<6.1.4.2 : www/rubygem-rails61
  14. rubygem-bootsnap14>=1.4.6<2.0 : devel/rubygem-bootsnap14
  15. rubygem-responders-rails61>=3.0<4.0 : www/rubygem-responders-rails61
  16. rubygem-sprockets3>=3.7<3.8 : devel/rubygem-sprockets3
  17. rubygem-default_value_for>=3.4.0<3.5.0 : devel/rubygem-default_value_for
  18. rubygem-pg>=1.2.3<2 : databases/rubygem-pg
  19. rubygem-rugged>=1.1<2 : devel/rubygem-rugged
  20. rubygem-grape-path-helpers>=1.7.0<1.8 : devel/rubygem-grape-path-helpers
  21. rubygem-faraday>=1.0<2 : www/rubygem-faraday
  22. rubygem-marginalia>=1.10.0<1.11 : databases/rubygem-marginalia
  23. rubygem-declarative_policy>=1.0.0<1.1 : security/rubygem-declarative_policy
  24. rubygem-devise47-rails61>=4.7.2<4.8 : devel/rubygem-devise47-rails61
  25. rubygem-bcrypt>=3.1.14<3.2 : security/rubygem-bcrypt
  26. rubygem-doorkeeper>=5.5.0.rc2<5.6 : security/rubygem-doorkeeper
  27. rubygem-doorkeeper-openid_connect>=1.7.5<1.8 : security/rubygem-doorkeeper-openid_connect
  28. rubygem-rexml>=3.2.5<3.3 : textproc/rubygem-rexml
  29. rubygem-ruby-saml>=1.13.0<1.14 : security/rubygem-ruby-saml
  30. rubygem-omniauth1>=1.9.1<2.0 : security/rubygem-omniauth1
  31. rubygem-omniauth-auth0>=2.0.0<2.1.0 : net/rubygem-omniauth-auth0
  32. rubygem-omniauth-azure-activedirectory-v2>=1.0<2 : net/rubygem-omniauth-azure-activedirectory-v2
  33. rubygem-omniauth-azure-oauth2>=0.0.9<0.1.0 : net/rubygem-omniauth-azure-oauth2
  34. rubygem-omniauth-cas3>=1.1.4<1.2.0 : security/rubygem-omniauth-cas3
  35. rubygem-omniauth-facebook4>=4.0.0<4.1.0 : net/rubygem-omniauth-facebook4
  36. rubygem-omniauth-github>=1.4.0<2.0 : net/rubygem-omniauth-github
  37. rubygem-omniauth-gitlab>=1.0.2<1.1.0 : security/rubygem-omniauth-gitlab
  38. rubygem-omniauth-google-oauth2>=0.6.0<0.7.0 : net/rubygem-omniauth-google-oauth2
  39. rubygem-omniauth-kerberos>=0.3.0<0.4.0 : net/rubygem-omniauth-kerberos
  40. rubygem-omniauth-oauth2-generic>=0.2.2<0.3.0 : security/rubygem-omniauth-oauth2-generic
  41. rubygem-omniauth-saml>=1.10<2.0 : security/rubygem-omniauth-saml
  42. rubygem-omniauth-shibboleth>=1.3.0<1.4.0 : security/rubygem-omniauth-shibboleth
  43. rubygem-omniauth-twitter>=1.4<2.0 : net/rubygem-omniauth-twitter
  44. rubygem-omniauth_crowd>=2.4.0<2.5 : devel/rubygem-omniauth_crowd
  45. rubygem-omniauth-authentiq>=0.3.3<0.4.0 : net/rubygem-omniauth-authentiq
  46. rubygem-gitlab-omniauth-openid-connect>=0.8.0<0.9.0 : net/rubygem-gitlab-omniauth-openid-connect
  47. rubygem-omniauth-ultraauth>=0.0.2<0.1.0 : net/rubygem-omniauth-ultraauth
  48. rubygem-omniauth-salesforce>=1.0.5<1.1.0 : net/rubygem-omniauth-salesforce
  49. rubygem-omniauth-atlassian-oauth2>=0.2.0<0.3 : security/rubygem-omniauth-atlassian-oauth2
  50. rubygem-rack-oauth2>=1.16.0<1.17.0 : security/rubygem-rack-oauth2
  51. rubygem-jwt21>=2.1.0<2.2.0 : www/rubygem-jwt21
  52. rubygem-gssapi>0 : security/rubygem-gssapi
  53. rubygem-recaptcha>=4.11<5.0 : devel/rubygem-recaptcha
  54. rubygem-akismet>=3.0<4.0 : devel/rubygem-akismet
  55. rubygem-invisible_captcha>=1.1.0<1.2.0 : graphics/rubygem-invisible_captcha
  56. rubygem-devise-two-factor-rails61>=4.0.0<4.1 : security/rubygem-devise-two-factor-rails61
  57. rubygem-rqrcode-rails3>=0.1.7<0.2.0 : www/rubygem-rqrcode-rails3
  58. rubygem-attr_encrypted>=3.1.0<3.2.0 : security/rubygem-attr_encrypted
  59. rubygem-u2f0>=0.2.1<0.3.0 : net/rubygem-u2f0
  60. rubygem-validates_hostname>=1.0.11<1.1.0 : dns/rubygem-validates_hostname
  61. rubygem-rubyzip20>=2.0.0<2.1.0 : archivers/rubygem-rubyzip20
  62. rubygem-acme-client>=2.0.6<3 : security/rubygem-acme-client
  63. rubygem-browser>=4.2<5.0 : www/rubygem-browser
  64. rubygem-ohai>=16.10<17 : sysutils/rubygem-ohai
  65. rubygem-gpgme>=2.0.20<2.1.0 : security/rubygem-gpgme
  66. rubygem-gitlab_omniauth-ldap>=2.1.1<2.2.0 : net/rubygem-gitlab_omniauth-ldap
  67. rubygem-net-ldap>0.16.3 : net/rubygem-net-ldap
  68. rubygem-grape>=1.5.2<1.6 : devel/rubygem-grape
  69. rubygem-grape-entity>=0.10.0<0.11.0,1 : devel/rubygem-grape-entity
  70. rubygem-rack-cors>=1.0.6<1.1.0 : www/rubygem-rack-cors
  71. rubygem-graphql>=1.11.8<1.12 : devel/rubygem-graphql
  72. rubygem-graphiql-rails>=1.4.10<1.5.0 : devel/rubygem-graphiql-rails
  73. rubygem-apollo_upload_server>=2.1.0<2.2 : net/rubygem-apollo_upload_server
  74. rubygem-graphql-docs>=1.6.0<1.7.0 : devel/rubygem-graphql-docs
  75. rubygem-graphlient>=0.4.0<0.5 : devel/rubygem-graphlient
  76. rubygem-hashie>=4.1.0 : devel/rubygem-hashie
  77. rubygem-hashie-forbidden_attributes>0 : devel/rubygem-hashie-forbidden_attributes
  78. rubygem-kaminari-rails61>=1.2.1<2.0 : www/rubygem-kaminari-rails61
  79. rubygem-hamlit>=2.15.0<2.16 : www/rubygem-hamlit
  80. rubygem-carrierwave>=1.3.2<2.0 : www/rubygem-carrierwave
  81. rubygem-mini_magick>=4.10.1<4.11 : graphics/rubygem-mini_magick
  82. rubygem-fog-aws>=3.12<4 : net/rubygem-fog-aws
  83. rubygem-fog-core210=2.1.0 : devel/rubygem-fog-core210
  84. rubygem-fog-google>=1.15<2 : net/rubygem-fog-google
  85. rubygem-fog-local>=0.6<1.0 : net/rubygem-fog-local
  86. rubygem-fog-openstack>=1.0<2.0 : net/rubygem-fog-openstack
  87. rubygem-fog-rackspace>=0.1.1<1.2.0 : net/rubygem-fog-rackspace
  88. rubygem-fog-aliyun>=0.3<1.0 : net/rubygem-fog-aliyun
  89. rubygem-gitlab-fog-azure-rm>=1.2.0<1.3 : net/rubygem-gitlab-fog-azure-rm
  90. rubygem-google-api-client>=0.33<1 : devel/rubygem-google-api-client
  91. rubygem-unf>=0.1.4<0.2.0 : textproc/rubygem-unf
  92. rubygem-seed-fu>=2.3.7<2.4.0 : databases/rubygem-seed-fu
  93. rubygem-elasticsearch-model6>=6.1.1<7 : textproc/rubygem-elasticsearch-model6
  94. rubygem-elasticsearch-rails6>=6.1.1<7 : textproc/rubygem-elasticsearch-rails6
  95. rubygem-elasticsearch-api6>=6.8.2<6.9 : textproc/rubygem-elasticsearch-api6
  96. rubygem-aws-sdk-core>=3<4 : devel/rubygem-aws-sdk-core
  97. rubygem-aws-sdk-cloudformation>=1<2 : devel/rubygem-aws-sdk-cloudformation
  98. rubygem-aws-sdk-s3>=1<2 : devel/rubygem-aws-sdk-s3
  99. rubygem-faraday_middleware-aws-sigv403>=0.3.0<0.4 : devel/rubygem-faraday_middleware-aws-sigv403
  100. rubygem-html-pipeline>=2.13.2<2.14 : textproc/rubygem-html-pipeline
  101. rubygem-deckar01-task_list=2.3.1 : www/rubygem-deckar01-task_list
  102. rubygem-gitlab-markup>=1.7.1<1.8.0 : textproc/rubygem-gitlab-markup
  103. rubygem-github-markup17>=1.7.0<1.8.0 : textproc/rubygem-github-markup17
  104. rubygem-commonmarker>=0.23.2<0.24 : textproc/rubygem-commonmarker
  105. rubygem-kramdown>=2.3.1<2.4 : textproc/rubygem-kramdown
  106. rubygem-redcloth>=4.3.2<4.4.0 : www/rubygem-redcloth
  107. rubygem-rdoc>=6.3.2<7 : devel/rubygem-rdoc
  108. rubygem-org-ruby>=0.9.12<0.10.0 : textproc/rubygem-org-ruby
  109. rubygem-creole>=0.5.0<0.6.0 : textproc/rubygem-creole
  110. rubygem-wikicloth081>=0.8.1<0.8.2 : textproc/rubygem-wikicloth081
  111. rubygem-asciidoctor>=2.0.15<2.1.0 : textproc/rubygem-asciidoctor
  112. rubygem-asciidoctor-include-ext>=0.3.1<0.4.0 : textproc/rubygem-asciidoctor-include-ext
  113. rubygem-asciidoctor-plantuml>=0.0.12<0.1 : textproc/rubygem-asciidoctor-plantuml
  114. rubygem-asciidoctor-kroki>=0.5.0<0.6 : textproc/rubygem-asciidoctor-kroki
  115. rubygem-rouge>=3.26.1<3.27 : textproc/rubygem-rouge
  116. rubygem-truncato>=0.7.11<0.8.0 : textproc/rubygem-truncato
  117. rubygem-bootstrap_form>=4.2.0<4.3.0 : devel/rubygem-bootstrap_form
  118. rubygem-nokogiri>=1.11.5<1.12 : textproc/rubygem-nokogiri
  119. rubygem-escape_utils>=1.1<2.0 : textproc/rubygem-escape_utils
  120. rubygem-icalendar>=0 : devel/rubygem-icalendar
  121. rubygem-diffy>=3.3<4 : textproc/rubygem-diffy
  122. rubygem-diff_match_patch>=0.1.0<0.2.0 : textproc/rubygem-diff_match_patch
  123. rubygem-rack>=2.2.3<2.3,3 : www/rubygem-rack
  124. rubygem-rack-timeout>=0.5.1<0.6 : www/rubygem-rack-timeout
  125. rubygem-puma>=5.3.1<5.4 : www/rubygem-puma
  126. rubygem-puma_worker_killer>=0.3.1 : www/rubygem-puma_worker_killer
  127. rubygem-state_machines-activerecord>=0.8.0<0.9.0 : databases/rubygem-state_machines-activerecord
  128. rubygem-acts-as-taggable-on>=7.0<8.0 : www/rubygem-acts-as-taggable-on
  129. rubygem-sidekiq>=6.2.2<6.3 : devel/rubygem-sidekiq
  130. rubygem-sidekiq-cron>=1.0<2.0 : devel/rubygem-sidekiq-cron
  131. rubygem-redis-namespace>=1.8.1<1.9.0 : databases/rubygem-redis-namespace
  132. rubygem-gitlab-sidekiq-fetcher>=0.8.0<0.9 : devel/rubygem-gitlab-sidekiq-fetcher
  133. rubygem-fugit12>=1.2.1<1.3.0 : devel/rubygem-fugit12
  134. rubygem-httparty>=0.16.4<0.17.0 : www/rubygem-httparty
  135. rubygem-rainbow>=3.0<4.0 : devel/rubygem-rainbow
  136. rubygem-ruby-progressbar>=1.11<2 : devel/rubygem-ruby-progressbar
  137. rubygem-settingslogic>=2.0.9<2.1.0 : devel/rubygem-settingslogic
  138. rubygem-re2>=1.2.0<1.3.0 : devel/rubygem-re2
  139. rubygem-version_sorter>=2.2.4<2.3.0 : textproc/rubygem-version_sorter
  140. rubygem-js_regex>=3.7<4.0 : textproc/rubygem-js_regex
  141. rubygem-device_detector>=0 : devel/rubygem-device_detector
  142. rubygem-redis44>=4.4.0<4.5 : databases/rubygem-redis44
  143. rubygem-connection_pool>=2.0<3.0 : net/rubygem-connection_pool
  144. rubygem-redis-actionpack-rails61>=5.2.0<5.3 : databases/rubygem-redis-actionpack-rails61
  145. rubygem-discordrb-webhooks>=3.4<4.0 : net-im/rubygem-discordrb-webhooks
  146. rubygem-jira-ruby>=2.1.4<2.2 : devel/rubygem-jira-ruby
  147. rubygem-atlassian-jwt>=0.2.0<0.3.0 : www/rubygem-atlassian-jwt
  148. rubygem-flowdock>=0.7<1.0 : www/rubygem-flowdock
  149. rubygem-slack-messenger>=2.3.4<2.4.0 : devel/rubygem-slack-messenger
  150. rubygem-hangouts-chat>=0.0.5<0.1.0 : net/rubygem-hangouts-chat
  151. rubygem-asana>=0.10.3<0.11 : www/rubygem-asana
  152. rubygem-ruby-fogbugz021>=0.2.1<0.3.0 : devel/rubygem-ruby-fogbugz021
  153. rubygem-kubeclient>=4.9.2<4.10.0 : www/rubygem-kubeclient
  154. rubygem-sanitize>=5.2.1<6 : textproc/rubygem-sanitize
  155. rubygem-babosa>=1.0.4<1.1.0 : textproc/rubygem-babosa
  156. rubygem-loofah>=2.9.0<3.0 : textproc/rubygem-loofah
  157. rubygem-licensee>=9.14.1<9.15 : devel/rubygem-licensee
  158. rubygem-charlock_holmes>=0.7.7<0.8.0 : textproc/rubygem-charlock_holmes
  159. rubygem-ruby-magic>=0.4<1 : devel/rubygem-ruby-magic
  160. rubygem-fast_blank>=0 : devel/rubygem-fast_blank
  161. rubygem-gitlab-chronic>=0.10.5<0.11.0 : devel/rubygem-gitlab-chronic
  162. rubygem-gitlab_chronic_duration>=0.10.6.2<0.10.7 : devel/rubygem-gitlab_chronic_duration
  163. rubygem-rack-proxy06>=0.6.0<0.7.0 : www/rubygem-rack-proxy06
  164. rubygem-sassc-rails-rails61>=2.1.0<2.2.0 : textproc/rubygem-sassc-rails-rails61
  165. rubygem-autoprefixer-rails>=10.2.5.1<10.2.6 : textproc/rubygem-autoprefixer-rails
  166. rubygem-terser>=1.0.2 : textproc/rubygem-terser
  167. rubygem-addressable>=2.8<3 : www/rubygem-addressable
  168. rubygem-gemojione>=3.3<4.0 : graphics/rubygem-gemojione
  169. rubygem-gon-rails61>=6.4.0<6.5 : www/rubygem-gon-rails61
  170. rubygem-request_store>=1.5<2.0 : devel/rubygem-request_store
  171. rubygem-base32>=0.3.0<0.4.0 : converters/rubygem-base32
  172. rubygem-gitlab-license>=2.0<3 : devel/rubygem-gitlab-license
  173. rubygem-rack-attack>=6.3.0<6.4.0 : www/rubygem-rack-attack
  174. rubygem-sentry-raven>=3.1<4.0 : devel/rubygem-sentry-raven
  175. rubygem-pg_query>=2.1<3 : databases/rubygem-pg_query
  176. rubygem-premailer-rails-rails61>=1.10.3<1.11.0 : mail/rubygem-premailer-rails-rails61
  177. rubygem-gitlab-labkit>=0.21.1<0.22 : devel/rubygem-gitlab-labkit
  178. rubygem-thrift>=0.14.0 : devel/rubygem-thrift
  179. rubygem-ruby_parser>=3.15<4.0 : devel/rubygem-ruby_parser
  180. rubygem-rails-i18n-rails61>=6.0<7.0 : devel/rubygem-rails-i18n-rails61
  181. rubygem-gettext_i18n_rails>=1.8.0<1.9.0 : devel/rubygem-gettext_i18n_rails
  182. rubygem-gettext_i18n_rails_js-rails61>=1.3<2.0 : devel/rubygem-gettext_i18n_rails_js-rails61
  183. rubygem-gettext>=3.3<4 : devel/rubygem-gettext
  184. rubygem-batch-loader>=2.0.1<2.1 : devel/rubygem-batch-loader
  185. rubygem-peek-rails61>=1.1.0<2.0 : devel/rubygem-peek-rails61
  186. rubygem-snowplow-tracker>=0.6.1<0.7.0 : devel/rubygem-snowplow-tracker
  187. rubygem-method_source>=1.0<2 : devel/rubygem-method_source
  188. rubygem-webrick>=1.6.1 : www/rubygem-webrick
  189. rubygem-prometheus-client-mmap>=0.15.0<0.16.0 : devel/rubygem-prometheus-client-mmap
  190. rubygem-warning>=1.2.0<1.3 : devel/rubygem-warning
  191. rubygem-octokit>=4.20<5.0 : net/rubygem-octokit
  192. rubygem-gitlab-mail_room>=0.0.9<0.1.0 : mail/rubygem-gitlab-mail_room
  193. rubygem-email_reply_trimmer>=0.1<1.0 : mail/rubygem-email_reply_trimmer
  194. rubygem-html2text>=0 : textproc/rubygem-html2text
  195. rubygem-ruby-prof>=1.3.0<1.4.0 : devel/rubygem-ruby-prof
  196. rubygem-stackprof>=0.2.15<0.3 : devel/rubygem-stackprof
  197. rubygem-rbtrace>=0.4.14<1.0 : devel/rubygem-rbtrace
  198. rubygem-memory_profiler>=0.9<1.0 : devel/rubygem-memory_profiler
  199. rubygem-benchmark-memory>=0.1<1.0 : benchmarks/rubygem-benchmark-memory
  200. rubygem-activerecord-explain-analyze>=0.1<1.0 : databases/rubygem-activerecord-explain-analyze
  201. rubygem-oauth2>=1.4.7<2.0 : net/rubygem-oauth2
  202. rubygem-health_check>=3.0<4 : devel/rubygem-health_check
  203. rubygem-vmstat>=2.3.0<2.4.0 : sysutils/rubygem-vmstat
  204. rubygem-sys-filesystem>=1.1.9<1.2.0 : sysutils/rubygem-sys-filesystem
  205. rubygem-net-ntp>0 : net/rubygem-net-ntp
  206. rubygem-net-ssh>=6.0<7,2 : security/rubygem-net-ssh
  207. rubygem-sshkey>=2.0<3.0 : security/rubygem-sshkey
  208. rubygem-ed25519>=1.2<2.0 : security/rubygem-ed25519
  209. rubygem-bcrypt_pbkdf>=1.0<2.0 : security/rubygem-bcrypt_pbkdf
  210. rubygem-spamcheck>=0.1.0<0.2 : net/rubygem-spamcheck
  211. rubygem-gitaly>=14.3.0.pre.rc2<14.4.0 : net/rubygem-gitaly
  212. rubygem-kas-grpc>=0.0.2,1<0.0.3,1 : net/rubygem-kas-grpc
  213. rubygem-grpc>=1.30.2<2 : net/rubygem-grpc
  214. rubygem-google-protobuf317>=3.17.1<3.18 : devel/rubygem-google-protobuf317
  215. rubygem-toml-rb>=2.0.1<3 : www/rubygem-toml-rb
  216. rubygem-flipper021>=0.21.0<0.22 : devel/rubygem-flipper021
  217. rubygem-flipper-active_record-rails61>=0.21.0<0.22 : databases/rubygem-flipper-active_record-rails61
  218. rubygem-flipper-active_support_cache_store-rails61>=0.21.0<0.22 : devel/rubygem-flipper-active_support_cache_store-rails61
  219. rubygem-unleash>=3.2.2<3.3 : devel/rubygem-unleash
  220. rubygem-gitlab-experiment>=0.6.4<0.7 : devel/rubygem-gitlab-experiment
  221. rubygem-lograge-rails61>=0.11.2<1.0 : www/rubygem-lograge-rails61
  222. rubygem-grape_logging>=1.7<2.0 : devel/rubygem-grape_logging
  223. rubygem-gitlab-net-dns>=0.9.1<0.10 : dns/rubygem-gitlab-net-dns
  224. rubygem-countries>=3.0.0<4.0.0 : devel/rubygem-countries
  225. rubygem-retriable>=3.1.2<3.2.0 : devel/rubygem-retriable
  226. rubygem-lru_redux>0 : devel/rubygem-lru_redux
  227. rubygem-erubi19>=1.9.0<1.10 : www/rubygem-erubi19
  228. rubygem-mail>=2.7.1<2.7.2,2 : mail/rubygem-mail
  229. rubygem-lockbox>=0.6.2<0.7 : security/rubygem-lockbox
  230. rubygem-valid_email>=0.1<1 : mail/rubygem-valid_email
  231. rubygem-json>=2.5.1<2.6 : devel/rubygem-json
  232. rubygem-json_schemer>=0.2.18<0.3 : devel/rubygem-json_schemer
  233. rubygem-oj310>=3.10.6<3.11 : devel/rubygem-oj310
  234. rubygem-multi_json114>=1.14.1<1.15 : devel/rubygem-multi_json114
  235. rubygem-yajl-ruby>=1.4.1<1.5 : devel/rubygem-yajl-ruby
  236. rubygem-webauthn>=2.3<3 : security/rubygem-webauthn
  237. rubygem-ipaddress>=0.8.3<0.9 : net/rubygem-ipaddress
  238. rubygem-parslet1>=1.8<2 : textproc/rubygem-parslet1
  239. ruby27 : lang/ruby27
  240. go : lang/go
Runtime dependencies:
  1. git>=2.32.0 : devel/git
  2. gitaly>=14.4.0 : devel/gitaly
  3. gitlab-elasticsearch-indexer>=2.16.0 : textproc/gitlab-elasticsearch-indexer
  4. gitlab-agent>=14.4.0 : net/gitlab-agent
  5. gitlab-pages>=1.46.0 : www/gitlab-pages
  6. gitlab-shell>=13.21.1 : devel/gitlab-shell
  7. gitlab-workhorse>=14.4.0 : www/gitlab-workhorse
  8. redis>=6.0.14 : databases/redis
  9. yarn>=1.10.0 : www/yarn
  10. gtar>0 : archivers/gtar
  11. bash>0 : shells/bash
  12. rubygem-rails61>=6.1.4.1<6.1.4.2 : www/rubygem-rails61
  13. rubygem-bootsnap14>=1.4.6<2.0 : devel/rubygem-bootsnap14
  14. rubygem-responders-rails61>=3.0<4.0 : www/rubygem-responders-rails61
  15. rubygem-sprockets3>=3.7<3.8 : devel/rubygem-sprockets3
  16. rubygem-default_value_for>=3.4.0<3.5.0 : devel/rubygem-default_value_for
  17. rubygem-pg>=1.2.3<2 : databases/rubygem-pg
  18. rubygem-rugged>=1.1<2 : devel/rubygem-rugged
  19. rubygem-grape-path-helpers>=1.7.0<1.8 : devel/rubygem-grape-path-helpers
  20. rubygem-faraday>=1.0<2 : www/rubygem-faraday
  21. rubygem-marginalia>=1.10.0<1.11 : databases/rubygem-marginalia
  22. rubygem-declarative_policy>=1.0.0<1.1 : security/rubygem-declarative_policy
  23. rubygem-devise47-rails61>=4.7.2<4.8 : devel/rubygem-devise47-rails61
  24. rubygem-bcrypt>=3.1.14<3.2 : security/rubygem-bcrypt
  25. rubygem-doorkeeper>=5.5.0.rc2<5.6 : security/rubygem-doorkeeper
  26. rubygem-doorkeeper-openid_connect>=1.7.5<1.8 : security/rubygem-doorkeeper-openid_connect
  27. rubygem-rexml>=3.2.5<3.3 : textproc/rubygem-rexml
  28. rubygem-ruby-saml>=1.13.0<1.14 : security/rubygem-ruby-saml
  29. rubygem-omniauth1>=1.9.1<2.0 : security/rubygem-omniauth1
  30. rubygem-omniauth-auth0>=2.0.0<2.1.0 : net/rubygem-omniauth-auth0
  31. rubygem-omniauth-azure-activedirectory-v2>=1.0<2 : net/rubygem-omniauth-azure-activedirectory-v2
  32. rubygem-omniauth-azure-oauth2>=0.0.9<0.1.0 : net/rubygem-omniauth-azure-oauth2
  33. rubygem-omniauth-cas3>=1.1.4<1.2.0 : security/rubygem-omniauth-cas3
  34. rubygem-omniauth-facebook4>=4.0.0<4.1.0 : net/rubygem-omniauth-facebook4
  35. rubygem-omniauth-github>=1.4.0<2.0 : net/rubygem-omniauth-github
  36. rubygem-omniauth-gitlab>=1.0.2<1.1.0 : security/rubygem-omniauth-gitlab
  37. rubygem-omniauth-google-oauth2>=0.6.0<0.7.0 : net/rubygem-omniauth-google-oauth2
  38. rubygem-omniauth-kerberos>=0.3.0<0.4.0 : net/rubygem-omniauth-kerberos
  39. rubygem-omniauth-oauth2-generic>=0.2.2<0.3.0 : security/rubygem-omniauth-oauth2-generic
  40. rubygem-omniauth-saml>=1.10<2.0 : security/rubygem-omniauth-saml
  41. rubygem-omniauth-shibboleth>=1.3.0<1.4.0 : security/rubygem-omniauth-shibboleth
  42. rubygem-omniauth-twitter>=1.4<2.0 : net/rubygem-omniauth-twitter
  43. rubygem-omniauth_crowd>=2.4.0<2.5 : devel/rubygem-omniauth_crowd
  44. rubygem-omniauth-authentiq>=0.3.3<0.4.0 : net/rubygem-omniauth-authentiq
  45. rubygem-gitlab-omniauth-openid-connect>=0.8.0<0.9.0 : net/rubygem-gitlab-omniauth-openid-connect
  46. rubygem-omniauth-ultraauth>=0.0.2<0.1.0 : net/rubygem-omniauth-ultraauth
  47. rubygem-omniauth-salesforce>=1.0.5<1.1.0 : net/rubygem-omniauth-salesforce
  48. rubygem-omniauth-atlassian-oauth2>=0.2.0<0.3 : security/rubygem-omniauth-atlassian-oauth2
  49. rubygem-rack-oauth2>=1.16.0<1.17.0 : security/rubygem-rack-oauth2
  50. rubygem-jwt21>=2.1.0<2.2.0 : www/rubygem-jwt21
  51. rubygem-gssapi>0 : security/rubygem-gssapi
  52. rubygem-recaptcha>=4.11<5.0 : devel/rubygem-recaptcha
  53. rubygem-akismet>=3.0<4.0 : devel/rubygem-akismet
  54. rubygem-invisible_captcha>=1.1.0<1.2.0 : graphics/rubygem-invisible_captcha
  55. rubygem-devise-two-factor-rails61>=4.0.0<4.1 : security/rubygem-devise-two-factor-rails61
  56. rubygem-rqrcode-rails3>=0.1.7<0.2.0 : www/rubygem-rqrcode-rails3
  57. rubygem-attr_encrypted>=3.1.0<3.2.0 : security/rubygem-attr_encrypted
  58. rubygem-u2f0>=0.2.1<0.3.0 : net/rubygem-u2f0
  59. rubygem-validates_hostname>=1.0.11<1.1.0 : dns/rubygem-validates_hostname
  60. rubygem-rubyzip20>=2.0.0<2.1.0 : archivers/rubygem-rubyzip20
  61. rubygem-acme-client>=2.0.6<3 : security/rubygem-acme-client
  62. rubygem-browser>=4.2<5.0 : www/rubygem-browser
  63. rubygem-ohai>=16.10<17 : sysutils/rubygem-ohai
  64. rubygem-gpgme>=2.0.20<2.1.0 : security/rubygem-gpgme
  65. rubygem-gitlab_omniauth-ldap>=2.1.1<2.2.0 : net/rubygem-gitlab_omniauth-ldap
  66. rubygem-net-ldap>0.16.3 : net/rubygem-net-ldap
  67. rubygem-grape>=1.5.2<1.6 : devel/rubygem-grape
  68. rubygem-grape-entity>=0.10.0<0.11.0,1 : devel/rubygem-grape-entity
  69. rubygem-rack-cors>=1.0.6<1.1.0 : www/rubygem-rack-cors
  70. rubygem-graphql>=1.11.8<1.12 : devel/rubygem-graphql
  71. rubygem-graphiql-rails>=1.4.10<1.5.0 : devel/rubygem-graphiql-rails
  72. rubygem-apollo_upload_server>=2.1.0<2.2 : net/rubygem-apollo_upload_server
  73. rubygem-graphql-docs>=1.6.0<1.7.0 : devel/rubygem-graphql-docs
  74. rubygem-graphlient>=0.4.0<0.5 : devel/rubygem-graphlient
  75. rubygem-hashie>=4.1.0 : devel/rubygem-hashie
  76. rubygem-hashie-forbidden_attributes>0 : devel/rubygem-hashie-forbidden_attributes
  77. rubygem-kaminari-rails61>=1.2.1<2.0 : www/rubygem-kaminari-rails61
  78. rubygem-hamlit>=2.15.0<2.16 : www/rubygem-hamlit
  79. rubygem-carrierwave>=1.3.2<2.0 : www/rubygem-carrierwave
  80. rubygem-mini_magick>=4.10.1<4.11 : graphics/rubygem-mini_magick
  81. rubygem-fog-aws>=3.12<4 : net/rubygem-fog-aws
  82. rubygem-fog-core210=2.1.0 : devel/rubygem-fog-core210
  83. rubygem-fog-google>=1.15<2 : net/rubygem-fog-google
  84. rubygem-fog-local>=0.6<1.0 : net/rubygem-fog-local
  85. rubygem-fog-openstack>=1.0<2.0 : net/rubygem-fog-openstack
  86. rubygem-fog-rackspace>=0.1.1<1.2.0 : net/rubygem-fog-rackspace
  87. rubygem-fog-aliyun>=0.3<1.0 : net/rubygem-fog-aliyun
  88. rubygem-gitlab-fog-azure-rm>=1.2.0<1.3 : net/rubygem-gitlab-fog-azure-rm
  89. rubygem-google-api-client>=0.33<1 : devel/rubygem-google-api-client
  90. rubygem-unf>=0.1.4<0.2.0 : textproc/rubygem-unf
  91. rubygem-seed-fu>=2.3.7<2.4.0 : databases/rubygem-seed-fu
  92. rubygem-elasticsearch-model6>=6.1.1<7 : textproc/rubygem-elasticsearch-model6
  93. rubygem-elasticsearch-rails6>=6.1.1<7 : textproc/rubygem-elasticsearch-rails6
  94. rubygem-elasticsearch-api6>=6.8.2<6.9 : textproc/rubygem-elasticsearch-api6
  95. rubygem-aws-sdk-core>=3<4 : devel/rubygem-aws-sdk-core
  96. rubygem-aws-sdk-cloudformation>=1<2 : devel/rubygem-aws-sdk-cloudformation
  97. rubygem-aws-sdk-s3>=1<2 : devel/rubygem-aws-sdk-s3
  98. rubygem-faraday_middleware-aws-sigv403>=0.3.0<0.4 : devel/rubygem-faraday_middleware-aws-sigv403
  99. rubygem-html-pipeline>=2.13.2<2.14 : textproc/rubygem-html-pipeline
  100. rubygem-deckar01-task_list=2.3.1 : www/rubygem-deckar01-task_list
  101. rubygem-gitlab-markup>=1.7.1<1.8.0 : textproc/rubygem-gitlab-markup
  102. rubygem-github-markup17>=1.7.0<1.8.0 : textproc/rubygem-github-markup17
  103. rubygem-commonmarker>=0.23.2<0.24 : textproc/rubygem-commonmarker
  104. rubygem-kramdown>=2.3.1<2.4 : textproc/rubygem-kramdown
  105. rubygem-redcloth>=4.3.2<4.4.0 : www/rubygem-redcloth
  106. rubygem-rdoc>=6.3.2<7 : devel/rubygem-rdoc
  107. rubygem-org-ruby>=0.9.12<0.10.0 : textproc/rubygem-org-ruby
  108. rubygem-creole>=0.5.0<0.6.0 : textproc/rubygem-creole
  109. rubygem-wikicloth081>=0.8.1<0.8.2 : textproc/rubygem-wikicloth081
  110. rubygem-asciidoctor>=2.0.15<2.1.0 : textproc/rubygem-asciidoctor
  111. rubygem-asciidoctor-include-ext>=0.3.1<0.4.0 : textproc/rubygem-asciidoctor-include-ext
  112. rubygem-asciidoctor-plantuml>=0.0.12<0.1 : textproc/rubygem-asciidoctor-plantuml
  113. rubygem-asciidoctor-kroki>=0.5.0<0.6 : textproc/rubygem-asciidoctor-kroki
  114. rubygem-rouge>=3.26.1<3.27 : textproc/rubygem-rouge
  115. rubygem-truncato>=0.7.11<0.8.0 : textproc/rubygem-truncato
  116. rubygem-bootstrap_form>=4.2.0<4.3.0 : devel/rubygem-bootstrap_form
  117. rubygem-nokogiri>=1.11.5<1.12 : textproc/rubygem-nokogiri
  118. rubygem-escape_utils>=1.1<2.0 : textproc/rubygem-escape_utils
  119. rubygem-icalendar>=0 : devel/rubygem-icalendar
  120. rubygem-diffy>=3.3<4 : textproc/rubygem-diffy
  121. rubygem-diff_match_patch>=0.1.0<0.2.0 : textproc/rubygem-diff_match_patch
  122. rubygem-rack>=2.2.3<2.3,3 : www/rubygem-rack
  123. rubygem-rack-timeout>=0.5.1<0.6 : www/rubygem-rack-timeout
  124. rubygem-puma>=5.3.1<5.4 : www/rubygem-puma
  125. rubygem-puma_worker_killer>=0.3.1 : www/rubygem-puma_worker_killer
  126. rubygem-state_machines-activerecord>=0.8.0<0.9.0 : databases/rubygem-state_machines-activerecord
  127. rubygem-acts-as-taggable-on>=7.0<8.0 : www/rubygem-acts-as-taggable-on
  128. rubygem-sidekiq>=6.2.2<6.3 : devel/rubygem-sidekiq
  129. rubygem-sidekiq-cron>=1.0<2.0 : devel/rubygem-sidekiq-cron
  130. rubygem-redis-namespace>=1.8.1<1.9.0 : databases/rubygem-redis-namespace
  131. rubygem-gitlab-sidekiq-fetcher>=0.8.0<0.9 : devel/rubygem-gitlab-sidekiq-fetcher
  132. rubygem-fugit12>=1.2.1<1.3.0 : devel/rubygem-fugit12
  133. rubygem-httparty>=0.16.4<0.17.0 : www/rubygem-httparty
  134. rubygem-rainbow>=3.0<4.0 : devel/rubygem-rainbow
  135. rubygem-ruby-progressbar>=1.11<2 : devel/rubygem-ruby-progressbar
  136. rubygem-settingslogic>=2.0.9<2.1.0 : devel/rubygem-settingslogic
  137. rubygem-re2>=1.2.0<1.3.0 : devel/rubygem-re2
  138. rubygem-version_sorter>=2.2.4<2.3.0 : textproc/rubygem-version_sorter
  139. rubygem-js_regex>=3.7<4.0 : textproc/rubygem-js_regex
  140. rubygem-device_detector>=0 : devel/rubygem-device_detector
  141. rubygem-redis44>=4.4.0<4.5 : databases/rubygem-redis44
  142. rubygem-connection_pool>=2.0<3.0 : net/rubygem-connection_pool
  143. rubygem-redis-actionpack-rails61>=5.2.0<5.3 : databases/rubygem-redis-actionpack-rails61
  144. rubygem-discordrb-webhooks>=3.4<4.0 : net-im/rubygem-discordrb-webhooks
  145. rubygem-jira-ruby>=2.1.4<2.2 : devel/rubygem-jira-ruby
  146. rubygem-atlassian-jwt>=0.2.0<0.3.0 : www/rubygem-atlassian-jwt
  147. rubygem-flowdock>=0.7<1.0 : www/rubygem-flowdock
  148. rubygem-slack-messenger>=2.3.4<2.4.0 : devel/rubygem-slack-messenger
  149. rubygem-hangouts-chat>=0.0.5<0.1.0 : net/rubygem-hangouts-chat
  150. rubygem-asana>=0.10.3<0.11 : www/rubygem-asana
  151. rubygem-ruby-fogbugz021>=0.2.1<0.3.0 : devel/rubygem-ruby-fogbugz021
  152. rubygem-kubeclient>=4.9.2<4.10.0 : www/rubygem-kubeclient
  153. rubygem-sanitize>=5.2.1<6 : textproc/rubygem-sanitize
  154. rubygem-babosa>=1.0.4<1.1.0 : textproc/rubygem-babosa
  155. rubygem-loofah>=2.9.0<3.0 : textproc/rubygem-loofah
  156. rubygem-licensee>=9.14.1<9.15 : devel/rubygem-licensee
  157. rubygem-charlock_holmes>=0.7.7<0.8.0 : textproc/rubygem-charlock_holmes
  158. rubygem-ruby-magic>=0.4<1 : devel/rubygem-ruby-magic
  159. rubygem-fast_blank>=0 : devel/rubygem-fast_blank
  160. rubygem-gitlab-chronic>=0.10.5<0.11.0 : devel/rubygem-gitlab-chronic
  161. rubygem-gitlab_chronic_duration>=0.10.6.2<0.10.7 : devel/rubygem-gitlab_chronic_duration
  162. rubygem-rack-proxy06>=0.6.0<0.7.0 : www/rubygem-rack-proxy06
  163. rubygem-sassc-rails-rails61>=2.1.0<2.2.0 : textproc/rubygem-sassc-rails-rails61
  164. rubygem-autoprefixer-rails>=10.2.5.1<10.2.6 : textproc/rubygem-autoprefixer-rails
  165. rubygem-terser>=1.0.2 : textproc/rubygem-terser
  166. rubygem-addressable>=2.8<3 : www/rubygem-addressable
  167. rubygem-gemojione>=3.3<4.0 : graphics/rubygem-gemojione
  168. rubygem-gon-rails61>=6.4.0<6.5 : www/rubygem-gon-rails61
  169. rubygem-request_store>=1.5<2.0 : devel/rubygem-request_store
  170. rubygem-base32>=0.3.0<0.4.0 : converters/rubygem-base32
  171. rubygem-gitlab-license>=2.0<3 : devel/rubygem-gitlab-license
  172. rubygem-rack-attack>=6.3.0<6.4.0 : www/rubygem-rack-attack
  173. rubygem-sentry-raven>=3.1<4.0 : devel/rubygem-sentry-raven
  174. rubygem-pg_query>=2.1<3 : databases/rubygem-pg_query
  175. rubygem-premailer-rails-rails61>=1.10.3<1.11.0 : mail/rubygem-premailer-rails-rails61
  176. rubygem-gitlab-labkit>=0.21.1<0.22 : devel/rubygem-gitlab-labkit
  177. rubygem-thrift>=0.14.0 : devel/rubygem-thrift
  178. rubygem-ruby_parser>=3.15<4.0 : devel/rubygem-ruby_parser
  179. rubygem-rails-i18n-rails61>=6.0<7.0 : devel/rubygem-rails-i18n-rails61
  180. rubygem-gettext_i18n_rails>=1.8.0<1.9.0 : devel/rubygem-gettext_i18n_rails
  181. rubygem-gettext_i18n_rails_js-rails61>=1.3<2.0 : devel/rubygem-gettext_i18n_rails_js-rails61
  182. rubygem-gettext>=3.3<4 : devel/rubygem-gettext
  183. rubygem-batch-loader>=2.0.1<2.1 : devel/rubygem-batch-loader
  184. rubygem-peek-rails61>=1.1.0<2.0 : devel/rubygem-peek-rails61
  185. rubygem-snowplow-tracker>=0.6.1<0.7.0 : devel/rubygem-snowplow-tracker
  186. rubygem-method_source>=1.0<2 : devel/rubygem-method_source
  187. rubygem-webrick>=1.6.1 : www/rubygem-webrick
  188. rubygem-prometheus-client-mmap>=0.15.0<0.16.0 : devel/rubygem-prometheus-client-mmap
  189. rubygem-warning>=1.2.0<1.3 : devel/rubygem-warning
  190. rubygem-octokit>=4.20<5.0 : net/rubygem-octokit
  191. rubygem-gitlab-mail_room>=0.0.9<0.1.0 : mail/rubygem-gitlab-mail_room
  192. rubygem-email_reply_trimmer>=0.1<1.0 : mail/rubygem-email_reply_trimmer
  193. rubygem-html2text>=0 : textproc/rubygem-html2text
  194. rubygem-ruby-prof>=1.3.0<1.4.0 : devel/rubygem-ruby-prof
  195. rubygem-stackprof>=0.2.15<0.3 : devel/rubygem-stackprof
  196. rubygem-rbtrace>=0.4.14<1.0 : devel/rubygem-rbtrace
  197. rubygem-memory_profiler>=0.9<1.0 : devel/rubygem-memory_profiler
  198. rubygem-benchmark-memory>=0.1<1.0 : benchmarks/rubygem-benchmark-memory
  199. rubygem-activerecord-explain-analyze>=0.1<1.0 : databases/rubygem-activerecord-explain-analyze
  200. rubygem-oauth2>=1.4.7<2.0 : net/rubygem-oauth2
  201. rubygem-health_check>=3.0<4 : devel/rubygem-health_check
  202. rubygem-vmstat>=2.3.0<2.4.0 : sysutils/rubygem-vmstat
  203. rubygem-sys-filesystem>=1.1.9<1.2.0 : sysutils/rubygem-sys-filesystem
  204. rubygem-net-ntp>0 : net/rubygem-net-ntp
  205. rubygem-net-ssh>=6.0<7,2 : security/rubygem-net-ssh
  206. rubygem-sshkey>=2.0<3.0 : security/rubygem-sshkey
  207. rubygem-ed25519>=1.2<2.0 : security/rubygem-ed25519
  208. rubygem-bcrypt_pbkdf>=1.0<2.0 : security/rubygem-bcrypt_pbkdf
  209. rubygem-spamcheck>=0.1.0<0.2 : net/rubygem-spamcheck
  210. rubygem-gitaly>=14.3.0.pre.rc2<14.4.0 : net/rubygem-gitaly
  211. rubygem-kas-grpc>=0.0.2,1<0.0.3,1 : net/rubygem-kas-grpc
  212. rubygem-grpc>=1.30.2<2 : net/rubygem-grpc
  213. rubygem-google-protobuf317>=3.17.1<3.18 : devel/rubygem-google-protobuf317
  214. rubygem-toml-rb>=2.0.1<3 : www/rubygem-toml-rb
  215. rubygem-flipper021>=0.21.0<0.22 : devel/rubygem-flipper021
  216. rubygem-flipper-active_record-rails61>=0.21.0<0.22 : databases/rubygem-flipper-active_record-rails61
  217. rubygem-flipper-active_support_cache_store-rails61>=0.21.0<0.22 : devel/rubygem-flipper-active_support_cache_store-rails61
  218. rubygem-unleash>=3.2.2<3.3 : devel/rubygem-unleash
  219. rubygem-gitlab-experiment>=0.6.4<0.7 : devel/rubygem-gitlab-experiment
  220. rubygem-lograge-rails61>=0.11.2<1.0 : www/rubygem-lograge-rails61
  221. rubygem-grape_logging>=1.7<2.0 : devel/rubygem-grape_logging
  222. rubygem-gitlab-net-dns>=0.9.1<0.10 : dns/rubygem-gitlab-net-dns
  223. rubygem-countries>=3.0.0<4.0.0 : devel/rubygem-countries
  224. rubygem-retriable>=3.1.2<3.2.0 : devel/rubygem-retriable
  225. rubygem-lru_redux>0 : devel/rubygem-lru_redux
  226. rubygem-erubi19>=1.9.0<1.10 : www/rubygem-erubi19
  227. rubygem-mail>=2.7.1<2.7.2,2 : mail/rubygem-mail
  228. rubygem-lockbox>=0.6.2<0.7 : security/rubygem-lockbox
  229. rubygem-valid_email>=0.1<1 : mail/rubygem-valid_email
  230. rubygem-json>=2.5.1<2.6 : devel/rubygem-json
  231. rubygem-json_schemer>=0.2.18<0.3 : devel/rubygem-json_schemer
  232. rubygem-oj310>=3.10.6<3.11 : devel/rubygem-oj310
  233. rubygem-multi_json114>=1.14.1<1.15 : devel/rubygem-multi_json114
  234. rubygem-yajl-ruby>=1.4.1<1.5 : devel/rubygem-yajl-ruby
  235. rubygem-webauthn>=2.3<3 : security/rubygem-webauthn
  236. rubygem-ipaddress>=0.8.3<0.9 : net/rubygem-ipaddress
  237. rubygem-parslet1>=1.8<2 : textproc/rubygem-parslet1
  238. ruby27 : lang/ruby27
Patch dependencies:
  1. ruby27 : lang/ruby27
Extract dependencies:
  1. ruby27 : lang/ruby27
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

pkg-message:
If installing:
If upgrading from < 11.9.7:
If upgrading
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://gitlab.com/gitlab-org/gitlab-foss/-/archive/51b27ab58055b65e14e68b19604e4823389adb73.tar.gz?dummy=/
Collapse this list.
<a id="updating">Notes from UPDATING</a>
These upgrade notes are taken from /usr/ports/UPDATING
  • 2021-06-21
    Affects: users of www/gitlab-ce
    Author: mfechner@FreeBSD.org
    Reason: 
      The upgrade of Gitlab 14.0.0 is in preparation.
      You must upgrade first to 13.12.
      For more information see here:
      https://about.gitlab.com/blog/2021/06/04/gitlab-moving-to-14-breaking-changes/
    
      To do the upgrade, make sure you follow the upgrade manuals:
      https://gitlab.fechner.net/mfechner/Gitlab-docu/-/tree/master/update
    
      I will merge the 14.0.0 upgrade later to quarterly branch to give you
      some time for the upgrade to 13.12.
    
    
Expand this list (3 items)
  • 2019-08-30
    Affects: users of www/gitlab-ce
    Author: mfechner@FreeBSD.org
    Reason: 
      Make sure you upgrade your PostgreSQL to version 11 as described in 20190829,
      before you upgrade your gitlab-ce version.
      Gitlab-ce 12.1 needs at least PostgreSQL version 9.6.
    
      After this you can follow the usual upgrade guide:
      https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/12.0-12.1-freebsd.md
    
    
  • 2019-07-07
    Affects: users of www/gitlab-ce
    Author: mfechner@FreeBSD.org
    Reason: 
      You must at first upgrade to version 11.11.5 before you can upgrade
      to version 12.
      Support for MySQL will be dropped with next version.
      Make sure you use at least PostgreSQL version 9.6.
      Follow the normal upgrade manual that can be found here:
      https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/update/11.11-12.0-freebsd.md
    
    
  • 2019-04-23
    Affects: users of www/gitlab-ce
    Author: mfechner@FreeBSD.org
    Reason: 
      The directory where all repositories and ssh permissions are stored
      was changed from /usr/home/git back to /usr/local/git, to match again the
      recommended standards on FreeBSD.
      This will cause now some other git management packages to collide with
      gitlab. Make sure you migrate all you git repositories to gitlab first,
      before you continue.
    
      Make sure /usr/local/git/repositories and /usr/local/git/.ssh are not
      existing!
      Otherwise the next commands can break your installation for managing
      git repositories within gitlab and with your other gitlab management
      software!
    
      You must move the old files to the new location with:
      # service gitlab stop
      # mv /usr/home/git /usr/local/
      # pkg upg
    
      Make sure you update your config files, diff shows you what you maybe
      must change:
      # cd /usr/local/www/gitlab-ce
      # git diff config/gitlab.yml.sample config/gitlab.yml
      # cd /usr/local/share/gitlab-shell/
      # git diff config.yml.sample config.yml
      # cd /usr/local/share/gitaly
      # git diff config.toml.sample config.toml
    
      # Change home directory of user git back to /usr/local/git
      # vipw
      The line should now looks like:
      git:*:211:211::0:0:gitosis user:/usr/local/git:/bin/sh
    
      If you do an upgrade of gitlab follow the upgrade guide.
      If not, just start gitlab again with:
      # service gitlab start
    
    
  • Collapse this list.
Port Moves
  • port moved here from www/gitlab on 2018-07-04
    REASON: Port renamed to match name on gitlab.org

Number of commits found: 259 (showing only 100 on this page)

1 | 2 | 3  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
27 Oct 2021 06:20:37
 files touched by this commit commit hash:46b95c05501c643fada4e953533f5eb9ff3caba6  14.4.0
mfechner search for other commits by this committer
www/gitlab-ce: Update to 14.4.0

Changelog:
https://about.gitlab.com/releases/2021/10/22/gitlab-14-4-released/

I included the following patch to fix a problem with
sidekiq-cron gem version 1.2.0:
https://gitlab.com/gitlab-org/gitlab/-/merge_requests/73093
27 Oct 2021 06:20:37
 files touched by this commit commit hash:5ca638b2b17e9da2636d5901235d3bf0d5be1738  14.4.0
mfechner search for other commits by this committer
databases/rubygem-redis44: make version 4.4.x available

Required for gitlab-ce.
27 Oct 2021 06:20:24
 files touched by this commit commit hash:4a7e890e91522896eb83f1c2f278ce0414175333  14.3.2_3
mfechner search for other commits by this committer
*/*: Revert "*/*: Make rails 6.1.3 available"

This reverts commit f4511dc4a7c439b30c898b75246d314a574f01cb.
Add MOVED entries.
These ports are not required anymore as gitlab 14.4.0 has upgrade
now to rails 6.1.4.1.
05 Oct 2021 10:24:07
 files touched by this commit commit hash:c5ec57f9363c81d07601b1d921ce8048c35e4abf  14.3.2_3
mfechner search for other commits by this committer
www/gitlab-ce: Readded a by mistake removed directory for PLIST
05 Oct 2021 10:14:41
 files touched by this commit commit hash:2c47b503373d7c6c29cf94a2756f4179828f60c0  14.3.2_2
mfechner search for other commits by this committer
www/gitlab-ce: fix default backup configuration

PR:		258922
05 Oct 2021 07:40:04
 files touched by this commit commit hash:f4511dc4a7c439b30c898b75246d314a574f01cb  14.3.2_1
mfechner search for other commits by this committer
*/*: Make rails 6.1.3 available

The upgrade of rails to 6.1.4 broke www/gitlab-ce.
PR:		258855
05 Oct 2021 07:40:03
 files touched by this commit commit hash:7dcb3ca59065e8f1c74bbed2f64f3bc8100bbc18  14.3.2
mfechner search for other commits by this committer
www/gitlab-ce: Revert unapproved modification that broke gitlab
02 Oct 2021 07:49:36
 files touched by this commit commit hash:c7a5935b859e0598f4b9ebcc08a5fcb0eebfc4c6  14.3.2
mfechner search for other commits by this committer
www/gitlab-ce: Bugfix update 14.3.2

Changelog:
https://about.gitlab.com/releases/2021/10/01/gitlab-14-3-2-released/
01 Oct 2021 14:53:39
 files touched by this commit commit hash:96e60ab5270da77331e623d6e25635301b101aeb  14.3.1
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 14.3.1

Changelog:
https://about.gitlab.com/releases/2021/09/30/security-release-gitlab-14-3-1-released/

Security:	1bdd4db6-2223-11ec-91be-001b217b3468
27 Sep 2021 15:56:30
 files touched by this commit commit hash:bb4b4cf9ca48617f4dc8f888ee65e0717637ccd0  14.3.0_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Fix Gemfile for rubygem-rails61 6.1.4.1 update

- Bump PORTREVISION for package change
23 Sep 2021 19:42:07
 files touched by this commit commit hash:fa814a6e9e3d770ffec356a07b3ed381a2e385b0  14.3.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Update to 14.3.0

Changelog:
https://about.gitlab.com/releases/2021/09/22/gitlab-14-3-released/
21 Sep 2021 03:47:28
 files touched by this commit commit hash:c7b293aff6fb18b5ad0e5afd0e258b1a5222771e  14.2.2_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Change RUN_DEPENDS from rubygem-google-protobuf to
rubygem-google-protobuf317

- Bump PORTREVISION for dependency change
31 Aug 2021 21:20:15
 files touched by this commit commit hash:4edd9ea5d5ced64dbefab85fab25db83f914968f  14.2.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 14.2.2

Changelog:
https://about.gitlab.com/releases/2021/08/31/security-release-gitlab-14-2-2-released/

Security:	6c22bb39-0a9a-11ec-a265-001b217b3468
31 Aug 2021 09:54:32
 files touched by this commit commit hash:2f757d6c4401f88ceef7ed05d9583de44159fb62  14.2.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Update to 14.2.1

Changelog:
https://about.gitlab.com/releases/2021/08/22/gitlab-14-2-released/
https://about.gitlab.com/releases/2021/08/23/gitlab-14-2-1-released/
16 Aug 2021 15:33:19
 files touched by this commit commit hash:c2977d6d6670065a2c3fb002f3241e326edf2c86  14.1.2 This port version is marked as vulnerable.
arrowd search for other commits by this committer
www/gitlab-ce: Remove ?= assignments.

There was a slave port planned in https://reviews.freebsd.org/D25763 , but
I gave up on it.
04 Aug 2021 08:29:40
 files touched by this commit commit hash:ad51d83d0c1f79bf52e0ab4319022fbf367ecba2  14.1.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 14.1.2

Changelog:
https://about.gitlab.com/releases/2021/08/03/security-release-gitlab-14-1-2-released/

Security:	1d651770-f4f5-11eb-ba49-001b217b3468
31 Jul 2021 14:19:17
 files touched by this commit commit hash:7dac4c3477587656ddf7ab292927ab36c0f26b7f  14.1.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Bugfix update to 14.1.1

Changelog:
https://about.gitlab.com/releases/2021/07/28/gitlab-14-1-1-released/
24 Jul 2021 07:08:06
 files touched by this commit commit hash:3729fba860ebf1802b3883e7ca7e32ac9d35a210  14.1.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Update to 14.1.0

Changelog:
https://about.gitlab.com/releases/2021/07/22/gitlab-14-1-released/
19 Jul 2021 11:22:22
 files touched by this commit commit hash:111056fb15b76cde45100df1a1495604be740447  14.0.5_2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Autogenerate PLIST

Most of the work was done by bofh, I had only to fix some small issues.
15 Jul 2021 20:47:44
 files touched by this commit commit hash:cf666b172715d62e16d5277baf14b9d40269dc4a  14.0.5_2 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Change RUN_DEPENDS from rubygem-flipper to rubygem-flipper021

- Bump PORTREVISION for dependency change
14 Jul 2021 16:11:01
 files touched by this commit commit hash:2f755c7a5eb0b8eceedb1105951415175a77bde8  14.0.5_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Change RUN_DEPENDS from rubygem-omniauth to rubygem-omniauth1

- Bump PORTREVISION for dependency change
10 Jul 2021 08:09:29
 files touched by this commit commit hash:5f4b94a21377a8e580cebf0e9f6a92e183dc4c55  14.0.5 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Bugfix update to 14.0.5

Changelog:
https://about.gitlab.com/releases/2021/07/08/gitlab-14-0-5-released/
MFH:		2021Q3
08 Jul 2021 06:49:58
 files touched by this commit commit hash:8d5ba0cec7367f31aeb9eb25dd8804536b0c1c8e  14.0.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 14.0.4

Changelog:
https://about.gitlab.com/releases/2021/07/07/critical-security-release-gitlab-14-0-4-released/

Security:	01974420-dfaf-11eb-ba49-001b217b3468
06 Jul 2021 09:52:35
 files touched by this commit commit hash:943cc2e9f0474989ac172ceeef8994265e3dddb6  14.0.2_2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
databases/rubygem-pg_query: Update to 2.1.0

This upgrade included patches upstream.
Changelog:
https://github.com/pganalyze/pg_query/blob/main/CHANGELOG.md
03 Jul 2021 07:50:19
 files touched by this commit commit hash:da75672c1fa6ed42eb2413b52aa7bcb0b1117ed3  14.0.2_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Fixed problem with asset compilation

The old autoprefixer gem used by gitlab cause at the upgrade the
following error message (cause by newer execjs gem):
Done in 0.68s.
rake aborted!
ExecJS::ProgramError: TypeError: Cannot read property 'version' of undefined
eval (eval at <anonymous> ((execjs):1:213), <anonymous>:1:10)
(execjs):1:213
(execjs):19:14
(execjs):1:40
Object.<anonymous> ((execjs):1:58)
Module._compile (node:internal/modules/cjs/loader:1109:14)
Object.Module._extensions..js (node:internal/modules/cjs/loader:1138:10)
Module.load (node:internal/modules/cjs/loader:989:32)
Function.Module._load (node:internal/modules/cjs/loader:829:14)
Function.executeUserEntryPoint [as runMain]
(node:internal/modules/run_main:76:12)
/usr/local/www/gitlab-ce/lib/gitlab/task_helpers.rb:18:in `invoke_and_time_task'
/usr/local/www/gitlab-ce/lib/tasks/gitlab/assets.rake:59:in `each'
/usr/local/www/gitlab-ce/lib/tasks/gitlab/assets.rake:59:in `block (3 levels) in
<top (required)>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
Tasks: TOP => assets:precompile
(See full trace by running task with --trace)
03 Jul 2021 06:03:25
 files touched by this commit commit hash:a0e1c4944ab9197944fe505c000d52bf7a644067  14.0.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 14.0.2

Changelog:
https://about.gitlab.com/releases/2021/07/01/security-release-gitlab-14-0-2-released/
Security:	8ba8278d-db06-11eb-ba49-001b217b3468
03 Jul 2021 06:03:23
 files touched by this commit commit hash:e98b6d8455a815d1bd6099e58a727b1cc24ee083  14.0.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Patch update to 14.0.1.

Changelog:
https://about.gitlab.com/releases/2021/06/24/gitlab-14-0-1-released/
03 Jul 2021 06:03:23
 files touched by this commit commit hash:ef4b2158071b50bec91852efdca886d5c35bd72c  14.0.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Major upgrade to 14.0.0.

Make sure you upgrade first to 13.12.2, otherwise you will lose your
advanced search index.
Upgrade instructions as usual:
https://gitlab.fechner.net/mfechner/Gitlab-docu/-/blob/master/update/13.12-14.0-freebsd.md

Changelog:
https://about.gitlab.com/releases/2021/06/22/gitlab-14-0-released/
10 Jun 2021 14:46:24
 files touched by this commit commit hash:1856abfe7ca79100f77a771511f155fcbd2b3ecd  13.12.2_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Change RUN_DEPENDS from rubygem-rack-proxy to
rubygem-rack-proxy06

- Bump PORTREVISION for dependency change
01 Jun 2021 22:37:26
 files touched by this commit commit hash:5b56d04e28e5561d6e694f6c3cc7ec269dbb7b1c  13.12.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security related update to 13.12.2.

Changelog:
https://about.gitlab.com/releases/2021/06/01/security-release-gitlab-13-12-2-released/
01 Jun 2021 07:18:52
 files touched by this commit commit hash:ffd3e0f40148e2e71f8a5d231908ab5b9f64a49a  13.12.1_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
net/gitlab-agent: Update to 13.12.2.

Old version has some build problem that were fixed upstream.
29 May 2021 16:23:59
 files touched by this commit commit hash:c23015d41328121309efe741d70bdf0e653d08d1  13.12.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Update to 13.12.1.

Changelog:
https://about.gitlab.com/releases/2021/05/25/gitlab-13-12-1-released/
29 May 2021 16:23:59
 files touched by this commit commit hash:6104340f64f758efc669a64f259acb598c1b1c54  13.12.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Update to 13.12.0.

Changelog:
https://about.gitlab.com/releases/2021/05/22/gitlab-13-12-released/
17 May 2021 08:23:45
 files touched by this commit commit hash:ceb9a127250ad428c1ac3a1a01eb2e676640c77b  13.11.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Bugfix update to 13.11.4.

Changelog:
https://about.gitlab.com/releases/2021/05/14/gitlab-13-11-4-released/
11 May 2021 21:47:33
 files touched by this commit commit hash:8c63378076e7814a3bc987e122dd9c10f038dfaf  13.11.3_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Change RUN_DEPENDS from rubygem-autoprefixer-rails to
rubygem-autoprefixer-rails1020

- Bump PORTREVISION for dependency change
07 May 2021 09:39:44
 files touched by this commit commit hash:03c16070511096932d3a6c283e675481ab7aed43  13.11.3 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Fix RUN_DEPENDS

It matches the Gemfile (~> 6.0.3.6).
06 May 2021 21:37:13
 files touched by this commit commit hash:04902cce7c5461e5071017126c3ef17994d85050  13.11.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Bugfixupdate to 13.11.3

Changelog:
https://about.gitlab.com/releases/2021/04/30/gitlab-13-11-3-released/
02 May 2021 19:47:26
 files touched by this commit commit hash:1abcf47e0ad93f57317c01d78351fba67a3a2c2a  13.11.2_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
www/gitlab-ce: Change RUN_DEPENDS from rubygem-devise-rails60 to
rubygem-devise47-rails60

- Bump PORTREVISION for dependency change
28 Apr 2021 21:57:39
 files touched by this commit commit hash:a90f2f815473dea018ab5a9e4a1235b5c34936cb  13.11.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 13.11.2.

Changelog:
https://about.gitlab.com/releases/2021/04/28/security-release-gitlab-13-11-2-released/

Security:	518a119c-a864-11eb-8ddb-001b217b3468
23 Apr 2021 19:06:09
 files touched by this commit commit hash:b838d9b5daf4897d9952cb41f277a801c858776d  13.11.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Major upgrade to 13.11.1.

Changelog:
https://about.gitlab.com/releases/2021/04/22/gitlab-13-11-released/
https://about.gitlab.com/releases/2021/04/23/gitlab-13-11-1-released/
18 Apr 2021 21:41:15
 files touched by this commit commit hash:77d6936ce6b750acc1503f712be7e507b90b5f47  13.10.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Security update to 13.10.3.

Changelog:
https://about.gitlab.com/releases/2021/04/14/security-release-gitlab-13-10-3-released/
10 Apr 2021 06:32:14
 files touched by this commit commit hash:bac76e3032045008b963d972884a3e1390ebc669  13.10.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: bugfix update to 13.10.2.

Changelog:
https://about.gitlab.com/releases/2021/04/01/gitlab-13-10-2-released/

MFH:		2021Q2
09 Apr 2021 18:44:23
 files touched by this commit commit hash:911f04257e3175fca4e46c7d57bf5ca79767e209  13.10.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Regenerate all distfiles using gitlab as source.

This regeneration is required as the new gitlab version changed
the address and the directory the source files can be downloaded.

This commit also applies some small fixes to make sure all ports using
gitlab are buildable.

Reviewed by:	mat
Approved by:	portmgr
Differential Revision:	https://reviews.freebsd.org/D29628
06 Apr 2021 14:31:13
 files touched by this commit commit hash:135fdeebb99c3569e42d8162b265e15d29bd937d  13.10.1 This port version is marked as vulnerable.
mat search for other commits by this committer
all: Remove all other $FreeBSD keywords.
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  13.10.1 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
06 Apr 2021 09:43:51
 files touched by this commit commit hash:1b802f473e9f400cbfcc0b897a1771cc02cd70f9  13.10.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Removed svn keywords again.
They went in by accident while merging older commits.
Reported by:	jbeich
06 Apr 2021 07:51:05
 files touched by this commit commit hash:9b79896e8f150befb82aa29e57c0713c17199345  13.10.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major upgrade to 13.10 which includes security related upgrade to 13.10.1.
Changelog:
https://about.gitlab.com/releases/2021/03/22/gitlab-13-10-released/
https://about.gitlab.com/releases/2021/03/31/security-release-gitlab-13-10-1-released/
18 Mar 2021 16:32:56
Original commit files touched by this commit Revision:568749  13.9.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.9.4.
Changelog:
https://about.gitlab.com/releases/2021/03/17/security-release-gitlab-13-9-4-released/

Security:	50e59056-87f2-11eb-b6a2-001b217b3468
13 Mar 2021 08:59:51
Original commit files touched by this commit Revision:568237  13.9.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to 13.9.3.
Changelog:
https://about.gitlab.com/releases/2021/03/08/gitlab-13-9-3-released/

This commit also includes the script to generate the pkg-plist so we have in one
place.
08 Mar 2021 11:07:10
Original commit files touched by this commit Revision:567833  13.9.2_2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Make sure gitlab uses a version of google-protobuf that works.
Version 3.15.x is causing segfaults.
Problem is also reported upstream:
https://gitlab.com/gitlab-org/gitlab/-/merge_requests/55972
07 Mar 2021 22:56:38
Original commit files touched by this commit Revision:567795  13.9.2_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-google-protobuf to rubygem-google-protobuf314

- While I'm here, use = instead of ?= because gitlab-ce does not have slave port
(r564168) [1]
- Bump PORTREVISION for dependency change

Approved by:	mfechner (r564168) [1]
06 Mar 2021 10:08:30
Original commit files touched by this commit Revision:567475  13.9.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to gitlab-ce 13.9.2.
Changelog:
https://about.gitlab.com/releases/2021/03/04/security-release-gitlab-13-9-2-released/

This commit also enforces an older version of devel/rubygem-google-protobuf of
version 3.14.0.
This also linked PR.
This ensures that users to not upgrade by accident to a version that is core
dumping.
So it is wanted that this port is currently not buildable to protect users from
an update.

If you want to this upgrade, wait till devel/rubygem-google-protobuf is fixed or
downgrade it to 3.14.0.

PR:		254014 254010
Security:	8bf856ea-7df7-11eb-9aad-001b217b3468
03 Mar 2021 09:50:29
Original commit files touched by this commit Revision:567055  13.9.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major upgrade to 13.9.1.
Changelog:
https://about.gitlab.com/releases/2021/02/22/gitlab-13-9-released/
https://about.gitlab.com/releases/2021/02/23/gitlab-13-9-1-released/
16 Feb 2021 22:22:28
Original commit files touched by this commit Revision:565466  13.8.4_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Changed the startup script to be able to work together with cbsd.
Parts of it where written by Oleg Ginzburg I only had to do some small
modifications, thanks for this support.

Submitted by:	Oleg Ginzburg
12 Feb 2021 14:34:24
Original commit files touched by this commit Revision:565021  13.8.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.8.4.
Changelog:
https://about.gitlab.com/releases/2021/02/11/security-release-gitlab-13-8-4-released/

Security:	1020d401-6d2d-11eb-ab0b-001b217b3468
06 Feb 2021 15:34:28
Original commit files touched by this commit Revision:564227  13.8.3_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Added a configuration variable gitlab_wait to configure how long to wait that
gitlab is started.
By default the value is 120 second.

PR:		253289
Submitted by:	vvd@unislabs.com
06 Feb 2021 08:39:20
Original commit files touched by this commit Revision:564206  13.8.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to 13.8.3.
Changelog:
https://about.gitlab.com/releases/2021/02/05/gitlab-13-8-3-released/
06 Feb 2021 08:08:25
Original commit files touched by this commit Revision:564200  13.8.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security upgrade to 13.8.2.
Changelog:
https://about.gitlab.com/releases/2021/02/01/security-release-gitlab-13-8-2-released/

Security:	66d1c277-652a-11eb-bb3f-001b217b3468
06 Feb 2021 01:22:51
Original commit files touched by this commit Revision:564168  13.8.1_2 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix grpc issue in gitlab-ce

- While I'm here, use = instead of ?= because gitlab-ce does not have slave port
- Bump PORTREVISION for dependency change

gitlab-ce has some runtime issue with grpc versions, especially upb stuff.
Move all gitlab-ce dependencies to specific grpc/rubygem-grpc versions in order
to keep gitlab-ce port more robust.

The changes are as follows:
- Add devel/grpc134 (copied from devel/grpc)
- Add net/rubygem-grpc130 (copied from net/rubygem-grpc)
- Move gitlab-ce and its dependencies to grpc134 and rubygem-grpc130

Differential Revision:	https://reviews.freebsd.org/D28491
Submitted by:	sunpoet (myself)
Approved by:	mfechner
Tested by:	mfechner
30 Jan 2021 12:36:06
Original commit files touched by this commit Revision:563395  13.8.1_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-oj to rubygem-oj310

- Bump PORTREVISION for dependency change
27 Jan 2021 13:41:52
Original commit files touched by this commit Revision:563074  13.8.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to gitlab-ce 13.8.1.
Changelog:
https://about.gitlab.com/releases/2021/01/26/gitlab-13-8-1-released/
27 Jan 2021 12:52:38
Original commit files touched by this commit Revision:563070  13.8.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major upgrade to gitlab-ce 13.8.
Changelog:
https://about.gitlab.com/releases/2021/01/22/gitlab-13-8-released/
14 Jan 2021 12:06:06
Original commit files touched by this commit Revision:561552  13.7.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.7.4.
Changelog:
https://about.gitlab.com/releases/2021/01/14/critical-security-release-gitlab-13-7-4-released/

Security:	0a8ebf4a-5660-11eb-b4e2-001b217b3468
13 Jan 2021 16:13:24
Original commit files touched by this commit Revision:561486  13.7.3_1 This port version is marked as vulnerable.
osa search for other commits by this committer
Update databases/redis to the recent stable version 6.0.10.
Update CONFLICTS for:
o) databases/redis4
o) databases/redis5
o) databases/redis
o) databases/redis-devel

Connect databases/redis5 to the build.

Bump PORTREVISIONs for dependant ports.
09 Jan 2021 20:32:38
Original commit files touched by this commit Revision:560890  13.7.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.7.2:
https://about.gitlab.com/releases/2021/01/07/security-release-gitlab-13-7-2-released/
Bugfix update to 13.7.3:
https://about.gitlab.com/releases/2021/01/08/gitlab-13-7-3-released/

Security:	a2a2b34d-52b4-11eb-87cb-001b217b3468
29 Dec 2020 23:25:59
Original commit files touched by this commit Revision:559630  13.7.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Removed a duplicated dep line for gtar.

PR:		252269
Reported by:	vvd@unislabs.com
27 Dec 2020 13:52:45
Original commit files touched by this commit Revision:559360  13.7.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to 13.7.1.
Changelog:
https://about.gitlab.com/releases/2020/12/23/gitlab-13-7-1-released/

This release also fixes a problem with an upgrade related to rubygem-rdoc.
22 Dec 2020 16:51:09
Original commit files touched by this commit Revision:558926  13.7.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major update to 13.7.
Changelog:
https://about.gitlab.com/releases/2020/12/22/gitlab-13-7-released/
13 Dec 2020 14:51:51
Original commit files touched by this commit Revision:557988  13.6.3_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-rouge to rubygem-rouge325

- Bump PORTREVISION for dependency change
12 Dec 2020 08:35:00
Original commit files touched by this commit Revision:557804  13.6.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to gitlab-ce 13.6.3.
Changelog:
https://about.gitlab.com/releases/2020/12/10/gitlab-13-6-3-released/
10 Dec 2020 17:39:47
Original commit files touched by this commit Revision:557448  13.6.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.6.2.
Changelog:
https://about.gitlab.com/releases/2020/12/07/security-release-gitlab-13-6-2-released/

Security:	5d5e5cda-38e6-11eb-bbbf-001b217b3468
28 Nov 2020 17:41:30
Original commit files touched by this commit Revision:556516  13.6.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to gitlab 13.6.1.

Changelog:
https://about.gitlab.com/releases/2020/11/23/gitlab-13-6-1-released/
28 Nov 2020 15:09:27
Original commit files touched by this commit Revision:556511  13.6.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major upgrade to 13.6.0.
Changelog:
https://about.gitlab.com/releases/2020/11/22/gitlab-13-6-released/

Please note, this version requires ruby 2.7 so do not change the default version
of ruby.
21 Nov 2020 09:45:06
Original commit files touched by this commit Revision:555944  13.5.4_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-erubi to rubygem-erubi19

- Bump PORTREVISION for dependency change
18 Nov 2020 20:26:12
Original commit files touched by this commit Revision:555664  13.5.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix release to 13.5.4.
Changelog:
https://about.gitlab.com/releases/2020/11/13/gitlab-13-5-4-released/
15 Nov 2020 18:13:28
Original commit files touched by this commit Revision:555410  13.5.3_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-rouge to rubygem-rouge324

- Bump PORTREVISION for dependency change
10 Nov 2020 11:56:51
Original commit files touched by this commit Revision:554831  13.5.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update for www/gitlab-ce to 13.5.3.
Changelog:
https://about.gitlab.com/releases/2020/11/03/gitlab-13-5-3-released/
09 Nov 2020 10:54:55
Original commit files touched by this commit Revision:554705  13.5.2_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Made rubygem-bootsnap 1.4 available again (was updated by 554614), as it is
required for gitlab-ce.
Also updated it to 1.4.9.

PR:		250976
Reported by:	lysfjord.daniel@smokepit.net
03 Nov 2020 07:54:46
Original commit files touched by this commit Revision:553953  13.5.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update of www/gitlab-ce to version 13.5.2.
Changelog:
https://about.gitlab.com/releases/2020/11/02/security-release-gitlab-13-5-2-released/

Security:	174e466b-1d48-11eb-bd0f-001b217b3468
23 Oct 2020 06:08:09
Original commit files touched by this commit Revision:553086  13.5.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: bugfix update to 13.5.1.
Changelog:
https://about.gitlab.com/releases/2020/10/22/gitlab-13-5-1-released/
23 Oct 2020 04:57:47
Original commit files touched by this commit Revision:553082  13.5.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major upgrade to 13.5.0.
Changelog:
https://about.gitlab.com/releases/2020/10/22/gitlab-13-5-released/
18 Oct 2020 15:37:25
Original commit files touched by this commit Revision:552669  13.4.4_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-faraday_middleware-aws-sigv4 to
rubygem-faraday_middleware-aws-sigv403

- Bump PORTREVISION for dependency change
16 Oct 2020 15:51:30
Original commit files touched by this commit Revision:552516  13.4.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update of www/gitlab-ce to 13.4.4.
Changelog:
https://about.gitlab.com/releases/2020/10/15/gitlab-13-4-4-released/
10 Oct 2020 07:47:29
Original commit files touched by this commit Revision:551905  13.4.3_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-grape to rubygem-grape140

- Bump PORTREVISION for dependency change
09 Oct 2020 07:52:30
Original commit files touched by this commit Revision:551751  13.4.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update of www/gitlab-ce to 13.4.3.
05 Oct 2020 07:52:28
Original commit files touched by this commit Revision:551480  13.4.2_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Fix dependecy problem with upgrade of rdoc to 6.2.1.

PR:		250086
02 Oct 2020 13:51:44
Original commit files touched by this commit Revision:551209  13.4.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.4.2.
Changelog:
https://about.gitlab.com/releases/2020/10/01/security-release-13-4-2-release/

MFH:		2020Q4
Security:	a3495e61-047f-11eb-86ea-001b217b3468
26 Sep 2020 10:00:40
Original commit files touched by this commit Revision:550152  13.4.1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
www/gitlab-ce: Bugfix upgrade to 13.4.1.
Changelog:
https://about.gitlab.com/releases/2020/09/24/gitlab-13-4-1-released/
26 Sep 2020 07:36:54
Original commit files touched by this commit Revision:550131  13.4.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Major upgrade to 13.4.
Changelog:
https://about.gitlab.com/releases/2020/09/22/gitlab-13-4-released/
16 Sep 2020 10:23:27
Original commit files touched by this commit Revision:548776  13.3.6 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to 13.3.6.
Changelog:
https://about.gitlab.com/releases/2020/09/14/gitlab-13-3-6-released/
04 Sep 2020 18:28:12
Original commit files touched by this commit Revision:547562  13.3.5 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to 13.3.5.
Changelog:
https://about.gitlab.com/releases/2020/09/04/gitlab-13-3-5-released/
03 Sep 2020 13:07:35
Original commit files touched by this commit Revision:547443  13.3.4 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.3.4.
This upgrade includes what was missing in 13.3.3 and fixes now all open
vulnerabilities.
Changelog:
https://about.gitlab.com/releases/2020/09/02/security-release-gitlab-13-3-3-released/

Security:	1fb13175-ed52-11ea-8b93-001b217b3468
02 Sep 2020 20:18:19
Original commit files touched by this commit Revision:547388  13.3.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Security update to 13.3.3.
This security update does not fix all problems, we have to wait here for 13.3.4.
Changelog:
https://about.gitlab.com/releases/2020/09/02/security-release-gitlab-13-3-3-released/

Security:	1fb13175-ed52-11ea-8b93-001b217b3468
28 Aug 2020 20:09:41
Original commit files touched by this commit Revision:546816  13.3.2 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Bugfix update to 13.3.2.
Changelog:
https://about.gitlab.com/releases/2020/08/25/gitlab-13-3-1-released/
https://about.gitlab.com/releases/2020/08/28/gitlab-13-3-2-released/
27 Aug 2020 19:07:40
Original commit files touched by this commit Revision:546667  13.3.0_1 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-grape-entity to rubygem-grape-entity07

- Bump PORTREVISION for dependency change
25 Aug 2020 13:09:14
Original commit files touched by this commit Revision:546177  13.3.0 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Update to 13.3.0.
This version already fixes security issues which version 13.2.3 should have
fixed.
Please see here also:
https://gitlab.com/gitlab-org/gitlab/-/issues/233881

The securty record will be updated accordingly with a next commit.

https://about.gitlab.com/releases/2020/08/22/gitlab-13-3-released/
23 Aug 2020 19:49:58
Original commit files touched by this commit Revision:546017  13.2.3_3 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-redis-namespace to rubygem-redis-namespace16

- Bump PORTREVISION for dependency change
21 Aug 2020 21:32:23
Original commit files touched by this commit Revision:545724  13.2.3_2 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-rouge to rubygem-rouge321

- Bump PORTREVISION for dependency change
11 Aug 2020 14:15:00
Original commit files touched by this commit Revision:544686  13.2.3_1 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Switch gitlab internal webserver to puma.
Gitlab switched with version 13.0 to puma as default.

PR:		247564
09 Aug 2020 07:26:50
Original commit files touched by this commit Revision:544546  13.2.3 This port version is marked as vulnerable.
mfechner search for other commits by this committer
Update to 13.2.3.
This release fixes some security issues, but not all:
https://about.gitlab.com/releases/2020/08/05/gitlab-13-2-3-released/

I opened an issue upstream for this problem:
https://gitlab.com/gitlab-org/gitlab/-/issues/233881

Maybe the vulnerability entry a003b74f-d7b3-11ea-9df1-001b217b3468
has to be updated accordingly.

Security:	a003b74f-d7b3-11ea-9df1-001b217b3468

Number of commits found: 259 (showing only 100 on this page)

1 | 2 | 3  »