notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

Current status

The server has been repaired, with a new power supply, for $23. I am waiting for lower COVID rates before visiting the datacenter to return it.
Port details
gimp The "meta-port" for The Gimp
2.10.22,2 graphics on this many watch lists=141 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.10.20_1,2Version of this port present on the latest quarterly branch.
Maintainer: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2004-03-27 18:08:30
Last Update: 2021-01-16 01:28:27
SVN Revision: 561698

People watching this port, also watch: firefox, mplayer, gmake, glib, gtk2

Also Listed In: gnome
License: not specified in port
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • gimp>0:graphics/gimp
To install the port: cd /usr/ports/graphics/gimp/ && make install clean
To add the package: pkg install gimp
PKGNAME: gimp
Flavors: there is no flavor information for this port.
distinfo:
There is no distinfo for this port.
Packages: (move your mouse over the cells for more information)
gimp
ABIlatestquarterly
FreeBSD:11:aarch64-2.10.20,2
FreeBSD:11:amd642.10.22,22.10.20_1,2
FreeBSD:11:armv6--
FreeBSD:11:i3862.10.22,22.10.20_1,2
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64-2.10.20_1,2
FreeBSD:12:amd642.10.22,22.10.20_1,2
FreeBSD:12:armv62.8.22,2-
FreeBSD:12:armv7--
FreeBSD:12:i3862.10.22,22.10.20_1,2
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64-2.10.20_1,2
FreeBSD:13:aarch64--
FreeBSD:13:amd642.10.22,22.10.20_1,2
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i3862.10.22,22.10.20_1,2
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch642.10.22,2-
FreeBSD:14:amd642.10.22,2-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i3862.10.22,2-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc642.10.22,2-
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Runtime dependencies:
  1. gimp-2.10 : graphics/gimp-app
  2. gutenprint : print/gimp-gutenprint
  3. gutenprint>0 : print/gutenprint
This port is required by:
for Run

    Deleted ports which required this port:

    Expand this list of 2 deleted ports
    1. graphics/gimp-gap*
    2. x11/gnome2-fifth-toe*
    3. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options

USES:

pkg-message:
If installing:
Master Sites:
  • There is no master site for this port.
  • Number of commits found: 114 (showing only 100 on this page)

    1 | 2  »  

    Commit History - (may be incomplete: see SVNWeb link above for full details)
    DateByDescription
    16 Jan 2021 01:28:27
    Original commit files touched by this commit  2.10.22,2
    Revision:561698
    fluffy search for other commits by this committer
    graphics/gimp[-app]: update to 2.10.22
    
    With hat:	desktop
    Submitted by:	Sergey Golyashov via im
    29 Sep 2020 19:14:04
    Original commit files touched by this commit  2.10.20_1,2
    Revision:550610
    rene search for other commits by this committer
    graphics/gimp: remove optional dependency on expired py-gimp, bump PORTREVISION
    
    PR:		245519
    Submitted by:	Andy Mender
    15 Jun 2020 16:06:44
    Original commit files touched by this commit  2.10.20,2
    Revision:538911
    bapt search for other commits by this committer
    Update to 2.10.20
    25 Feb 2020 21:23:31
    Original commit files touched by this commit  2.10.18,2
    Revision:527134
    kwm search for other commits by this committer
    Update gimp to 2.10.18.
    07 Jan 2020 09:01:17
    Original commit files touched by this commit  2.10.14_1,2
    Revision:522318
    antoine search for other commits by this committer
    Deprecate gimp-help ports
    
    With hat:	portmgr
    27 Dec 2019 14:39:45
    Original commit files touched by this commit  2.10.14,2
    Revision:520992
    bapt search for other commits by this committer
    Update to 2.10.14
    
    Note that -lm has been added to libs otherwise some plugins fails to build
    with the following error:
    ld: error: undefined symbol: floor
    13 Aug 2019 16:03:12
    Original commit files touched by this commit  2.10.12_1,2
    Revision:508837
    mat search for other commits by this committer
    Convert to UCL & cleanup pkg-message (categories e-g)
    13 Jul 2019 15:52:16
    Original commit files touched by this commit  2.10.12_1,2
    Revision:506546
    tcberner search for other commits by this committer
    graphics/exiv2: readd visibility patch for graphics/gimp
    
    PR:		236677
    Reported by:	 lumiwa@gmail.com, starikarp@dismail.de
    10 Jul 2019 16:54:31
    Original commit files touched by this commit  2.10.12,2
    Revision:506363
    kwm search for other commits by this committer
    Update gimp to 2.10.12.
    
    PR:		238833
    Reported by:	kunda <chitty_cloud@me.com>
    11 May 2019 18:53:19
    Original commit files touched by this commit  2.10.10,2
    Revision:501288
    kwm search for other commits by this committer
    Update gimp to 2.10.10.
    24 Nov 2018 14:02:15
    Original commit files touched by this commit  2.10.8,2
    Revision:485776
    kwm search for other commits by this committer
    Update gimp to 2.10.8.
    
    * enable SIMD by default.
    
    submitted by:
    07 Oct 2018 19:10:03
    Original commit files touched by this commit  2.10.6,2
    Revision:481477
    kwm search for other commits by this committer
    Update the gimp suite to 2.10.6.
    
    * add libheif support
    * use openjpeg for jpeg2000 support instead of jasper.
    12 Oct 2017 09:04:05
    Original commit files touched by this commit  2.8.22,2
    Revision:451833
    amdmi3 search for other commits by this committer
    - Update WWW
    
    Approved by:	portmgr blanket
    23 May 2017 19:36:56
    Original commit files touched by this commit  2.8.22,2
    Revision:441550
    kwm search for other commits by this committer
    Update gimp to 2.8.22. (1)
    
    * Move libsoup to the helpbrowser dependancy (2)
    * Gimp plugins need kern.ipc.shm_allow_removed=1, which is default for
      11.0-R and newer. Add pkg-message for 10.x (3)
    * Move desktop-file-utils so it only applies to the gimp-app port.
    
    PR:		219156 (based on)(1), 214751 (2), 204919 (3), 206097 (3)
    Submitted by:	mi@ (1), Christian Heckendorf <heckendorfc@gmail.com> (2)
    29 Jul 2016 08:38:09
    Original commit files touched by this commit  2.8.18,2
    Revision:419233 This port version is marked as vulnerable.
    cmt search for other commits by this committer
    Update The Gimp to 2.8.18
    
    PR:		211124
    Submitted by:	pkubaj@anongoth.pl
    Approved by:	rene (mentor)
    Approved by:	maintainer-timeout
    MFH:		2016Q3
    Security:	6fb8a90f-c9d5-4d14-b940-aed3d63c2edc
    19 May 2016 10:44:12
    Original commit files touched by this commit  2.8.16,2
    Revision:415499 This port version is marked as vulnerable.
    amdmi3 search for other commits by this committer
    - Fix trailing whitespace in pkg-descrs, categories [g-n]*
    
    Approved by:	portmgr blanket
    01 Apr 2016 14:00:57
    Original commit files touched by this commit  2.8.16,2
    Revision:412346 This port version is marked as vulnerable.
    mat search for other commits by this committer
    Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
    
    With hat:	portmgr
    Sponsored by:	Absolight
    23 Nov 2015 21:28:10
    Original commit files touched by this commit  2.8.16,2
    Revision:402331 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update gimp to 2.8.16, 20 years gimp anniversary edition.
    28 Mar 2015 16:32:34
    Original commit files touched by this commit  2.8.14,2
    Revision:382522 This port version is marked as vulnerable.
    robak search for other commits by this committer
    graphics/gimp: remove CPE information
    
    - After discussing with kwm I decided to remove CPE info from graphics/gimp
    because
      it is just a meta port and relevand CPE bits are supposed to be added to the
    ports it pulls instead
    
    PR:		198241
    Approved by:	kwm (blanket)
    28 Mar 2015 15:14:01
    Original commit files touched by this commit  2.8.14,2
    Revision:382502 This port version is marked as vulnerable.
    bapt search for other commits by this committer
    Convert to USES=metaport
    27 Mar 2015 10:38:09
    Original commit files touched by this commit  2.8.14,2
    Revision:382394 This port version is marked as vulnerable.
    robak search for other commits by this committer
    graphics/gimp: add CPE information
    
    PR:		198241
    Submitted by:	Shun <shun.fbsd.pr@dropcut.net>
    Approved by:	kwm (blanket)
    09 Dec 2014 15:04:23
    Original commit files touched by this commit  2.8.14,2
    Revision:374400 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update to 2.8.14.
    
    This fixes a bug in the brush tool [1]
    Use new GIMP master site macro.
    Drop :keepla from USES=libtool
    Remove intltool, libartlgpl2 and gnomehier from USE_GNOME.
      Intlhack already implies intltool, gnomehier is obsolete now that pkg
      handles directories and libartlgpl2 is unused.
    
    PR:		194532 [1]
    Submitted by:	Kalten <kalten@gmx.at> [1]
    09 Dec 2014 11:17:27
    Original commit files touched by this commit  2.8.10_3,2
    Revision:374368 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Only bring in the english help instead of depending on the gimp-help meta
    port which will include all the translated gimp help ports. Add pkg-message
    to point to the other available translations.
    
    Suggested by:	des@
    10 Sep 2014 20:50:37
    Original commit files touched by this commit  2.8.10_2,2
    Revision:367888 This port version is marked as vulnerable.
    gerald search for other commits by this committer
    Update the default version of GCC in the Ports Collection from GCC 4.7.4
    to GCC 4.8.3.
    
    Part II, Bump PORTREVISIONs.
    
    PR:		192025
    Tested by:	antoine (-exp runs)
    Approved by:	portmgr (implicit)
    15 Aug 2014 20:37:33
    Original commit files touched by this commit  2.8.10_1,2
    Revision:365038 This port version is marked as vulnerable.
    mandree search for other commits by this committer
    Upgrade OpenEXR and ilmbase to 2.2.0.
    
    GCC 4.2 in FreeBSD 8.X/9.X base is now too old to compile OpenEXR, so
    GCC-based systems will upgrade to the default ports compiler (GCC 4.7
    currently.)
    
    Add two patches to OpenEXR to permit building it in a live system with
    the older OpenEXR version installed. Bug report filed to upstream Github
    at https://github.com/openexr/openexr/issues/130
    
    Couple OpenEXR more tightly to ilmbase and require its exact .so
    version.
    
    Add UPDATING note, and bump PORTREVISION of all dependent ports.
    
    Proto-STAGE hugin-devel, and mark it IGNORE because hugin is newer.
    
    Approved by:	portmgr (implicit for bumping PORTREVISION on unstaged ports)
    02 Dec 2013 21:19:11
    Original commit files touched by this commit  2.8.10,2
    Revision:335541 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update to 2.8.10.
    
    Add upstream patch to fix build with freetype 2.5.1.
    Switch to libtool free ltverhack.
    04 Nov 2013 19:26:52
    Original commit files touched by this commit  2.8.8,2
    Revision:332760 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update to 2.8.8.
    
    Switch to lcms2, remove stray desktopfileutils from USE_GNOME,
    use libexecinfo from base if it is there else use the port.
    Strip unstripped libraries.
    Fix portname of graphics/py-gimp, so it doesn't say py-gimp-app.
    20 Sep 2013 18:35:46
    Original commit files touched by this commit  2.8.6,2
    Revision:327733 This port version is marked as vulnerable.
    bapt search for other commits by this committer
    Add NO_STAGE all over the place in preparation for the staging support (cat:
    graphics)
    24 Jun 2013 18:24:31
    Original commit files touched by this commit  2.8.6,2
    Revision:321699 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update to 2.8.6.
    
    Bug fix and translations update.
    Changelog: https://git.gnome.org/browse/gimp/plain/NEWS?h=gimp-2-8
    
    Utilize USES=desktop-file-utils
    18 Mar 2013 22:20:39
    Original commit files touched by this commit  2.8.4,2
    Revision:314608 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Change the meta port to include all the options my default.
    11 Mar 2013 12:23:26
    Original commit files touched by this commit  2.8.4,2
    Revision:313873 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Disable python support by default. Like it was before conversion.
    11 Mar 2013 12:19:09
    Original commit files touched by this commit  2.8.4,2
    Revision:313872 This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update to 2.8.4.
    
    Convert to OptionsNG, remove shlib versions, update Makefile header.
    Disable helpbrowser for now, need newer webkit.
    Use USE_PKGCONFIG and switch to pathfix instead of gnomehack
    
    Requested by many.
    
    Obtained from:	gnome team repo
    14 Feb 2012 22:08:59
    Original commit files touched by this commit  2.6.12,2
     This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Update to 2.6.12.
    20 Nov 2010 15:37:08
    Original commit files touched by this commit  2.6.11,2
     This port version is marked as vulnerable.
    kwm search for other commits by this committer
    Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
    release can be found at http://library.gnome.org/misc/release-notes/2.32/
    
    This will be the last release of the GNOME 2.x series, mainly a bugfix and
    bridge release to the first release of the GNOME 3.x series.
    
    This release features commits by avl, marcus, mezz and myself.
    
    The FreeBSD GNOME Team would like to thank the following contributors and
    testers for there help with this release:
    
    Zane C.B. <vvelox@vvelox.net>
    romain@
    Olaf Seibert <O.Seibert@cs.ru.nl>
    DomiX
    (Only the first 15 lines of the commit message are shown above View all of this commit message)
    24 Jul 2010 23:44:12
    Original commit files touched by this commit  2.6.10,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.6.10.
    25 Jun 2010 02:16:59
    Original commit files touched by this commit  2.6.9,2
     This port version is marked as vulnerable.
    mezz search for other commits by this committer
    The name of gimp-help package has been changed from 'gimp-help' to
    'gimp-help-html'. Update it to allow user able to install this port without
    get any failure.
    
    PR:             ports/148123
    Submitted by:   Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp>
    Feature safe:   yes
    24 Jun 2010 17:12:10
    Original commit files touched by this commit  2.6.9,2
     This port version is marked as vulnerable.
    mezz search for other commits by this committer
    Update to 2.6.9, it has a few of fixes with the up to date GTK+2. Only bugs
    fix with no new feature in this release, see here:
    
            http://developer.gimp.org/NEWS-2.6
    
    PR:             ports/147859
    Reported by:    Warren Block <wblock@wonkity.com>
    Feature safe:   yes
    28 Mar 2010 06:47:48
    Original commit files touched by this commit  2.6.8_2,2
     This port version is marked as vulnerable.
    dinoex search for other commits by this committer
    - update to 1.4.1
    Reviewed by:    exp8 run on pointyhat
    Supported by:   miwi
    05 Feb 2010 11:46:55
    Original commit files touched by this commit  2.6.8_1,2
     This port version is marked as vulnerable.
    dinoex search for other commits by this committer
    - update to jpeg-8
    19 Dec 2009 22:37:04
    Original commit files touched by this commit  2.6.8,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.6.8.
    28 Nov 2009 20:06:37
    Original commit files touched by this commit  2.6.7,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Presenting GNOME 2.28.1 for FreeBSD.  The official release notes for this
    release can be found at http://library.gnome.org/misc/release-notes/2.28/ .
    Officially, this is mostly a polishing release in preparation for GNOME 3.0
    due in about a year.
    
    On the FreeBSD front, though, a lot went into this release.  Major thanks
    goes to kwm and avl who did a lot of the porting work for this release.
    In particular, kwm brought in Evolution MAPI support for better Microsoft
    Exchange integration.  Avl made sure that the new gobject introspection
    repository ports were nicely compartmentalized so that large dependencies
    aren't brought in wholesale.
    
    But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself)
    contributed to this release.
    
    (Only the first 15 lines of the commit message are shown above View all of this commit message)
    21 Mar 2009 04:52:37
    Original commit files touched by this commit  2.6.6,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.6.6, and re-enable the rsvg OPTIONS (default on).
    24 Feb 2009 01:33:06
    Original commit files touched by this commit  2.6.5,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.6.5.
    04 Jan 2009 22:14:45
    Original commit files touched by this commit  2.6.4,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.6.4.
    05 Dec 2008 23:22:53
    Original commit files touched by this commit  2.6.3,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.6.3.
    13 Oct 2008 19:01:18
    Original commit files touched by this commit  2.6.1,2
     This port version is marked as vulnerable.
    adamw search for other commits by this committer
    Look for gimp-2.6, not gimp-2.4.
    
    One pointyhat to:       ahze
    13 Oct 2008 03:35:19
    Original commit files touched by this commit  2.6.1,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.6.1
    31 Aug 2008 15:26:11
    Original commit files touched by this commit  2.4.7,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.4.7
    17 Jun 2008 03:20:48
    Original commit files touched by this commit  2.4.6,2
     This port version is marked as vulnerable.
    mezz search for other commits by this committer
    Update to 2.4.6.
    06 Jun 2008 13:35:04
    Original commit files touched by this commit  2.4.5_1,2
     This port version is marked as vulnerable.
    edwin search for other commits by this committer
    Bump portrevision due to upgrade of devel/gettext.
    
    The affected ports are the ones with gettext as a run-dependency
    according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
    in Makefile (29 of them).
    
    PR:             ports/124340
    Submitted by:   edwin@
    Approved by:    portmgr (pav)
    02 Mar 2008 08:36:09
    Original commit files touched by this commit  2.4.5,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.4.5
    29 Feb 2008 18:42:49
    Original commit files touched by this commit  2.4.4_1,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    When WITH_PRINT is defined add print/gutenprint to depends so users have an
    option for cups drivers instead of just the standard gutenprint drivers.
    09 Feb 2008 18:08:06
    Original commit files touched by this commit  2.4.4,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.4.4.
    19 Dec 2007 20:06:56
    Original commit files touched by this commit  2.4.3,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.4.3
    12 Dec 2007 05:04:17
    Original commit files touched by this commit  2.4.2,2
     This port version is marked as vulnerable.
    mezz search for other commits by this committer
    Update to 2.4.2.
    
    Submitted by: ahze
    24 Oct 2007 23:37:25
    Original commit files touched by this commit  2.4.0,2
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Presenting GNOME 2.20.1 and all related works for FreeBSD.  The official
    GNOME 2.20 release notes can be found at
    http://www.gnome.org/start/2.20/notes/en/ .  Beyond that, this update
    includes the new GIMP 2.4 (courtesy of ahze).
    
    The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME
    hierarchy.  We are now using the more standard DATADIR of ${PREFIX}/share
    rather than ${PREFIX}/share/gnome. The result is that fewer patches and
    hacks are needed to port GNOME components to FreeBSD.  This will mean some
    user changes may be required, so be sure to read /usr/ports/UPDATING for
    more details.
    
    This release and the things we accomplished in it would not have been
    possible without mezz's crazy idea to collapse DATADIR, and his persistence
    to make it happen successfully.  Ahze and pav also deserve thanks for
    (Only the first 15 lines of the commit message are shown above View all of this commit message)
    23 Jul 2007 15:45:05
    Original commit files touched by this commit  2.2.17,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.2.17
    08 Jul 2007 23:12:26
    Original commit files touched by this commit  2.2.16,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.2.16
    01 Jun 2007 11:16:54
    Original commit files touched by this commit  2.2.15,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Use the same PORTVERSION as gimp-app[-devel]
    19 May 2007 20:32:57
    Original commit files touched by this commit  2.2_1,2
     This port version is marked as vulnerable.
    flz search for other commits by this committer
    - Welcome X.org 7.2 \o/.
    - Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
    - Bump PORTREVISION for ports intalling files in ${X11BASE}.
    05 Apr 2007 13:29:39
    Original commit files touched by this commit  2.2,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Better detect gimp-gnome
    
    Submitted by:   Lars Kristiansen <lars+lister.freebsd@adventuras.no>
    05 Apr 2007 12:25:13
    Original commit files touched by this commit  2.2,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Detect old versions gimp-gnome along with gimp
    
    PR:             111266
    Submitted by:   Lars Kristiansen<lars+lister.freebsd@adventuras.no>
    04 Apr 2007 15:18:50
    Original commit files touched by this commit  2.2,2
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Split gimp in to master/slave port
    
    You will need to upgrade via
    
    portmaster -o graphics/gimp-app gimp
    portmaster -u grapics/gimp
    
    or
    
    portupgrade -o graphics/gimp-app gimp
    portmaster -u grapics/gimp
    
    Repocopied by: marcus
    22 Oct 2006 17:36:11
    Original commit files touched by this commit  2.2.13_2,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Fix a startup crash for anyone running non-latin-1 locale
    
    Approved by:    portmgr (marcus)
    Obtained from:  GIMP authors
    14 Oct 2006 08:54:54
    Original commit files touched by this commit  2.2.13_1,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
    new freetype2 where needed.
    
    Submitted by:   mezz, ahze, pav, and many others
    Approved by:    portmgr (implicit, kris)
    25 Aug 2006 18:01:29
    Original commit files touched by this commit  2.2.13,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Update to 2.2.13
    
    PR:             ports/102503 (based on)
    Submitted by:   Henrik Brix Andersen <henrik@brixandersen.dk>
    26 Jun 2006 10:39:06
    Original commit files touched by this commit  2.2.11,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Make librsvg dependency optional
    15 May 2006 22:23:04
    Original commit files touched by this commit  2.2.11,1
     This port version is marked as vulnerable.
    mezz search for other commits by this committer
    Add USE_GETTEXT to appease portlint.
    07 May 2006 23:46:33
    Original commit files touched by this commit  2.2.11,1
     This port version is marked as vulnerable.
    edwin search for other commits by this committer
    Remove USE_REINPLACE for categories starting with a G
    14 Apr 2006 15:15:44
    Original commit files touched by this commit  2.2.11,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Update to 2.2.11
    23 Feb 2006 10:40:45
    Original commit files touched by this commit  2.2.10_1,1
     This port version is marked as vulnerable.
    ade search for other commits by this committer
    Conversion to a single libtool environment.
    
    Approved by:    portmgr (kris)
    22 Feb 2006 04:15:08
    Original commit files touched by this commit  2.2.10,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Add CONFLICTS for gimpshop.
    28 Dec 2005 19:35:45
    Original commit files touched by this commit  2.2.10,1
     This port version is marked as vulnerable.
    adamw search for other commits by this committer
    Update to 2.2.10. Works with GNOME 2.15 too!
    23 Nov 2005 22:41:05
    Original commit files touched by this commit  2.2.9_1,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Add SHA256 checksums
    15 Nov 2005 06:52:12
    Original commit files touched by this commit  2.2.9_1,1
     This port version is marked as vulnerable.
    ade search for other commits by this committer
    Mass-conversion to the USE_AUTOTOOLS New World Order.  The code present
    in bsd.autotools.mk essentially makes this a no-op given that all the
    old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in
    exactly the same way as USE_AUTOTOOLS itself.
    
    Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME
    team -- all GNOME 2.12.x ports use it.
    
    Preliminary documentation can be found at:
            http://people.FreeBSD.org/~ade/autotools.txt
    
    which is in the process of being SGMLized before introduction into the
    Porters Handbook.
    
    Light blue touch-paper.  Run.
    06 Nov 2005 19:29:19
    Original commit files touched by this commit  2.2.9_1,1
     This port version is marked as vulnerable.
    adamw search for other commits by this committer
    Add a patch that will allow gimp to build against librsvg2-2.13.1.
    05 Nov 2005 05:22:06
    Original commit files touched by this commit  2.2.9_1,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Bump PORTREVISION to chase the glib20 shared library update.
    02 Nov 2005 18:10:09
    Original commit files touched by this commit  2.2.9,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Update to 2.2.9.
    
    PR:             88392
    Submitted by:   Vasil Dimov <vd@datamax.bg>
    03 Jul 2005 04:55:55
    Original commit files touched by this commit  2.2.8,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Fix a portlint warning.
    30 Jun 2005 10:53:19
    Original commit files touched by this commit  2.2.8,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Update to 2.2.8
    27 Jun 2005 18:35:22
    Original commit files touched by this commit  2.2.6_1,1
     This port version is marked as vulnerable.
    jylefort search for other commits by this committer
    - Unconditionally enable image handlers
    - Convert other tunables to OPTIONS [1]
    
    [1]:
    PR:             ports/78931
    Submitted by:   Miguel Mendez <flynn@energyhq.es.eu.org>
    17 May 2005 18:55:06
    Original commit files touched by this commit  2.2.6,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Fix WITHOUT_MNG knob: libmng would indirectly add lcms dependency, which
      is needed for color management components in GIMP
    
    PR:             ports/81152
    Submitted by:   Bjorn Konig <bkoenig@cs.tu-berlin.de>
    10 Apr 2005 16:39:29
    Original commit files touched by this commit  2.2.6,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Update to 2.2.6
    04 Apr 2005 05:56:08
    Original commit files touched by this commit  2.2.4_5,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Chase libexif update
    - Bump PORTREVISION
    16 Mar 2005 21:47:50
    Original commit files touched by this commit  2.2.4_4,1
     This port version is marked as vulnerable.
    mezz search for other commits by this committer
    Fully-qualify the path to update-desktop-database and update-mime-database in
    the plist since /usr/local/bin isn't in pkg_add's PATH. Bump the PORTREVISION.
    12 Mar 2005 10:54:27
    Original commit files touched by this commit  2.2.4_3,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Bump PORTREVISION to chase the glib20 shared lib version change.
    06 Mar 2005 20:48:53
    Original commit files touched by this commit  2.2.4_2,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Add GIMP_THREAD_LIBS to GTK_LIBS so that all plug-ins get some thread lovin'.
    This fixes some missing pthread symbols, and allows the new GTK+ file
    chooser to work in certain plug-ins (e.g. print).
    05 Mar 2005 22:07:02
    Original commit files touched by this commit  2.2.4_1,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Be sure to link against PTHREAD_LIBS even in the non-GNOME case to fix
    a crash with the file chooser when gnomevfs2 is installed.
    28 Feb 2005 02:08:58
    Original commit files touched by this commit  2.2.4,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    The sphere.py file is no longer installed.  This fixes the WITH_PYTHON case.
    
    Submitted by:   sf
    23 Feb 2005 03:33:01
    Original commit files touched by this commit  2.2.4,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Remove gimp.setfont, not used since gimp 1.2.
    23 Feb 2005 03:24:21
    Original commit files touched by this commit  2.2.4,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Update to 2.2.4
    
    ChangeLog:      http://developer.gimp.org/NEWS-2.2
    29 Jan 2005 19:55:31
    Original commit files touched by this commit  2.2.3,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Fix JPEG pkg-plist
    28 Jan 2005 06:34:25
    Original commit files touched by this commit  2.2.3,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Update to 2.2.3
    - Add new WITHOUT_ knobs to make a "gimp-lite" [1]
    
    PR:             ports/76212 [1]
    Submitted by:   oliver [1]
    12 Jan 2005 09:54:32
    Original commit files touched by this commit  2.2.2,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    - Update to 2.2.2
    - Add 2 more mirrors
    30 Dec 2004 00:41:59
    Original commit files touched by this commit  2.2.1,1
     This port version is marked as vulnerable.
    ahze search for other commits by this committer
    Update to 2.2.1
    29 Dec 2004 02:18:31
    Original commit files touched by this commit  2.2.0_2,1
     This port version is marked as vulnerable.
    marcus search for other commits by this committer
    Chase the new location for update-desktop-database by allowing the command
    to be found in PATH.
    28 Dec 2004 20:01:22
    Original commit files touched by this commit  2.2.0_2,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Create empty share/gimp/fonts directory in package install
    28 Dec 2004 14:28:50
    Original commit files touched by this commit  2.2.0_2,1
     This port version is marked as vulnerable.
    bland search for other commits by this committer
    Fix plist.
    
    Submitted by:   sf
    26 Dec 2004 15:58:26
    Original commit files touched by this commit  2.2.0_1,1
     This port version is marked as vulnerable.
    bland search for other commits by this committer
    - In case we building GNOME version of GIMP link it against pthreads
      library to avoid crash in GtkFileChooser.
    - Fix plist.
    24 Dec 2004 18:41:07
    Original commit files touched by this commit  2.2.0,1
     This port version is marked as vulnerable.
    pav search for other commits by this committer
    - Fix python plugin: it expects a png logo, which is not included
      in the tarball.

    Number of commits found: 114 (showing only 100 on this page)

    1 | 2  »  

    Login
    User Login
    Create account

    Servers and bandwidth provided by
    New York Internet, iXsystems, and RootBSD

    This site
    What is FreshPorts?
    About the authors
    Issues
    FAQ
    How big is it?
    The latest upgrade!
    Privacy
    Blog
    Contact

    Search
    Enter Keywords:
     
    more...

    Latest Vulnerabilities
    redisFeb 23
    redis-develFeb 23
    redis5Feb 23
    zeekFeb 22
    jenkinsFeb 20
    raptor2Feb 20
    asterisk13Feb 18
    asterisk13Feb 18
    asterisk13Feb 18
    asterisk16Feb 18
    asterisk16Feb 18
    asterisk16Feb 18
    asterisk16Feb 18
    asterisk16Feb 18
    asterisk18Feb 18

    15 vulnerabilities affecting 114 ports have been reported in the past 14 days

    * - modified, not new

    All vulnerabilities

    Last updated:
    2021-02-25 03:33:54


    Ports
    Home
    Categories
    Deleted ports
    Sanity Test Failures
    Newsfeeds

    Statistics
    Graphs
    NEW Graphs (Javascript)
    Traffic

    Calculated hourly:
    Port count 42615
    Broken 77
    Deprecated 173
    Ignore 317
    Forbidden 4
    Restricted 139
    No CDROM 71
    Vulnerable 21
    Expired 37
    Set to expire 149
    Interactive 0
    new 24 hours 11
    new 48 hours12
    new 7 days42
    new fortnight77
    new month138

    Servers and bandwidth provided by
    New York Internet, iXsystems, and RootBSD
    Valid HTML, CSS, and RSS.
    Copyright © 2000-2021 Dan Langille. All rights reserved.