notbugIf you buy from Amazon USA, please support us by using this link.
Port details
sam2p Converts raster (bitmap) image formats into PS or PDF files
0.49.4_1,1 graphics on this many watch lists=1 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: des@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2003-02-06 18:36:36
Last Update: 2018-12-12 01:35:36
SVN Revision: 487272
License: GPLv2
sam2p is a UNIX command line utility written in ANSI C++ that converts many
raster (bitmap) image formats into Adobe PostScript or PDF files and several
other formats. The images are not vectorized. sam2p gives full control to the
user to specify standards-compliance, compression, and bit depths. In some
cases sam2p can compress an image 100 times smaller than the PostScript output
of many other common image converters. sam2p provides ZIP, RLE and LZW
(de)compression filters even on Level1 devices.

WWW: http://code.google.com/p/sam2p/
SVNWeb : Homepage : PortsMon
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (4 items)
  1. bin/sam2p
  2. /usr/local/share/licenses/sam2p-0.49.4_1,1/catalog.mk
  3. /usr/local/share/licenses/sam2p-0.49.4_1,1/LICENSE
  4. /usr/local/share/licenses/sam2p-0.49.4_1,1/GPLv2
  5. Collapse this list.

Dependency line: sam2p>0:graphics/sam2p


To install the port: cd /usr/ports/graphics/sam2p/ && make install clean
To add the package: pkg install sam2p

PKGNAME: sam2p

There is no flavor information for this port.

distinfo:

TIMESTAMP = 1538584194
SHA256 (sam2p-0.49.4.tar.gz) = 5bc5b5a526bc798315da23b02564d6a1bfea51b364b8b03f76695a833f6d2bed
SIZE (sam2p-0.49.4.tar.gz) = 497193


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. bash : shells/bash
  2. gmake : devel/gmake
  3. gcc8 : lang/gcc8
  4. as : devel/binutils
  5. perl5>=5.26<5.27 : lang/perl5.26
Runtime dependencies:
  1. zip : archivers/zip
  2. tif22pnm : graphics/tif22pnm
  3. ghostscript9-agpl-base>=9.16_2 : print/ghostscript9-agpl-base
  4. cjpeg : graphics/jpeg-turbo
  5. gcc8 : lang/gcc8
There are no ports dependent upon this port

Configuration Options
===> The following configuration options are available for sam2p-0.49.4_1,1:
     DOCS=on: Build and/or install documentation
     EXAMPLES=on: Build and/or install examples
===> Use 'make config' to modify these settings

USES:
ghostscript:run gmake jpeg:run perl5

Master Sites:
  1. https://github.com/pts/sam2p/releases/download/v0.49.4/

Number of commits found: 51

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
12 Dec 2018 01:35:36
Original commit files touched by this commit  0.49.4_1,1
Revision:487272
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.

PR:		231590
05 Oct 2018 14:28:02
Original commit files touched by this commit  0.49.4,1
Revision:481276
des search for other commits by this committer
Try to guess at what's tripping up pkg-fallout, as I am unable to reproduce
the issue in my own poudriere.
04 Oct 2018 14:10:39
Original commit files touched by this commit  0.49.4,1
Revision:481224
des search for other commits by this committer
Fix for good, hopefully: bash and gcc are required to build.
03 Oct 2018 16:41:35
Original commit files touched by this commit  0.49.4,1
Revision:481168
des search for other commits by this committer
Upgrade to 0.49.4 with re-rolled tarball.
03 Oct 2018 12:38:56
Original commit files touched by this commit  0.49.3,1
Revision:481158
des search for other commits by this committer
Regenerate all patches and add the necessary changes for Makedep to work
on FreeBSD 11.2 and 12.  Remove BROKEN.  No PORTREVISION bump necessary.
03 Oct 2018 12:28:03
Original commit files touched by this commit  0.49.3,1
Revision:481157
des search for other commits by this committer
Rename patches as per current convention.
25 Jun 2018 21:09:16
Original commit files touched by this commit  0.49.3,1
Revision:473347
linimon search for other commits by this committer
The failure is on -CURRENT everywhere, but not on -11.
18 Dec 2017 05:03:39
Original commit files touched by this commit  0.49.3,1
Revision:456591
linimon search for other commits by this committer
Mark as broken on various arm archs.

While here, pet portlint.

Approved by:	portmgr (tier-2 blanket)
11 Oct 2016 10:01:53
Original commit files touched by this commit  0.49.3,1
Revision:423755
des search for other commits by this committer
Take maintainership and upgrade to latest version.
14 Sep 2016 15:59:34
Original commit files touched by this commit  0.49.2_2,1
Revision:422140 This port version is marked as vulnerable.
mat search for other commits by this committer
GOOGLE_CODE has gone away.

- If a port has another upstream, remove GOOGLE_CODE
- If a port only has GOOGLE_CODE mark it BROKEN

Some ports have a local mirror configured but for security reasons, it
is not considered upstream.

Sponsored by:	Absolight
01 Apr 2016 14:00:57
Original commit files touched by this commit  0.49.2_2,1
Revision:412346 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
27 Mar 2016 01:23:34
Original commit files touched by this commit  0.49.2_2,1
Revision:411971 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Add LICENSE_FILE
- Switch to options helpers
24 Mar 2016 15:47:50
Original commit files touched by this commit  0.49.2_2,1
Revision:411798 This port version is marked as vulnerable.
tijl search for other commits by this committer
Make print/ghostscript9-agpl-base the default Ghostscript port.  Upstream
changed the license to the AGPL 3 in version 9.07 so print/ghostscript9-base
is stuck at 9.06 which is almost 4 years old now.

Fix the logic in Uses/ghostscript.mk so "agpl" is treated as a real version
on its own instead of as a variant of other versions.

Fix print/ghostscript9-agpl-base to install eps2write.

Update math/asymptote to 2.37 to support newer Ghostscript.

PR:		208159
Exp-run by:	antoine
Approved by:	portmgr (antoine)
22 Aug 2015 17:48:36
Original commit files touched by this commit  0.49.2_1,1
Revision:395047 This port version is marked as vulnerable.
hrs search for other commits by this committer
- Split ghostscript into X11-independent and -dependent parts:

 * print/ghostscript{7,8,9,9-agpl}-base

   Installs Ghostscript binary, libgs, and related files.
   These ports do not depend on X11 libraries (i.e. x11* devices
   are not available).  USES=ghostscript will set dependency on
   one of them depending on GHOSTSCRIPT_DEFAULT.

   The default device is set to "display" or "bbox".

 * print/ghostscript{7,8,9,9-agpl}-x11

   Installs a shared library which provides X11 support to
   the installed Ghostscript binaries.  x11* devices will be
(Only the first 15 lines of the commit message are shown above View all of this commit message)
16 Jul 2015 20:53:29
Original commit files touched by this commit  0.49.2,1
Revision:392322 This port version is marked as vulnerable.
kwm search for other commits by this committer
Convert code in bsd.port.mk for USE_GHOSTSCRIPT* to USES=ghostscript.

Add GHOSTSCRIPT_DEFAULT to bsd.default-versions.mk for easy version selection.
Arguments supported: <empty>, build, run, nox11 and agpl

PR:		201201 (exp-run)
Approved by:	portmgr (mat@)
Exp run by:	antione@ (previous patch)
Differential Revision:	https://reviews.freebsd.org/D2938
22 Jun 2015 18:33:22
Original commit files touched by this commit  0.49.2,1
Revision:390310 This port version is marked as vulnerable.
antoine search for other commits by this committer
Convert to USES=jpeg
20 May 2014 19:32:39
Original commit files touched by this commit  0.49.2,1
Revision:354670 This port version is marked as vulnerable.
tijl search for other commits by this committer
Quote ${CC} and similar variables in MAKE_ARGS.

Reported by:	Dominic Fandrey <kamikaze@bsdforen.de>
11 Oct 2013 19:59:27
Original commit files touched by this commit  0.49.2,1
Revision:330098 This port version is marked as vulnerable.
danilo search for other commits by this committer
- Update from 0.49.1 to 0.49.2
- Convert USE_GMAKE to USES
- Add stage support

PR:		ports/182805
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
Approved by:	wg/culot (mentors, implicit)
20 Sep 2013 18:35:46
Original commit files touched by this commit  0.49.1_1,1
Revision:327733 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
graphics)
03 Aug 2013 13:44:01
Original commit files touched by this commit  0.49.1_1
Revision:324191  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
- Convert to new perl framework
- Remove MAKE_JOBS_SAFE=yes, it's the default.
17 Mar 2013 20:49:20
Original commit files touched by this commit  0.49.1_1,1
Revision:314491 This port version is marked as vulnerable.
beech search for other commits by this committer
- Convert to OptionsNG
- Bump portrevision

PR:		ports/177044
Submitted by:	nemysis <nemysis@gmx.ch>
28 Nov 2012 17:12:26
Original commit files touched by this commit  0.49.1,1
Revision:307915 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Update to 0.49.1
- Trim header
- Fix keyword property on distinfo

Feature safe:   yes
01 Jun 2012 05:26:28
Original commit files touched by this commit  0.49_1,1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update png to 1.5.10
26 Aug 2011 04:41:24
Original commit files touched by this commit  0.49,1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to version 0.49

PR:             160121
Submitted by:   Ports Fury
02 Jul 2011 18:23:25
Original commit files touched by this commit  0.48,1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 0.48

PR:             158466
Submitted by:   Ports Fury
09 May 2010 11:21:59
Original commit files touched by this commit  0.47,1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 0.47

PR:             146305
Submitted by:   Ports Fury
28 Mar 2010 06:47:48
Original commit files touched by this commit  0.45_3,1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to 1.4.1
Reviewed by:    exp8 run on pointyhat
Supported by:   miwi
05 Feb 2010 11:46:55
Original commit files touched by this commit  0.45_2,1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg-8
22 Nov 2009 19:49:43
Original commit files touched by this commit  0.45_1,1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Mark MAKE_JOBS_UNSAFE

Reported by:    pointyhat
18 Jul 2009 11:11:29
Original commit files touched by this commit  0.45_1,1
 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update to jpeg7
Tested by:      pav on pointyhat
21 Aug 2008 06:18:49
Original commit files touched by this commit  0.45,1
 This port version is marked as vulnerable.
rafan search for other commits by this committer
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the
configure target. In short, one should use --build=CONFIGURE_TARGET
instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning
and the old semantic may be removed in later autoconf releases.

To workaround this issue, many ports hack the CONFIGURE_TARGET variable
so that it contains the ``--build='' prefix.

To solve this issue, under the fact that some ports still have
configure script generated by the old autoconf, we use runtime detection
in the do-configure target so that the proper argument can be used.

Changes to Mk/*:
 - Add runtime detection magic in bsd.port.mk
(Only the first 15 lines of the commit message are shown above View all of this commit message)
27 Apr 2008 08:28:05
Original commit files touched by this commit  0.45,1
 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 0.45

PR:             123134
Submitted by:   Ganael Laplanche <ganael.laplanche@martymac.com>
01 Mar 2008 13:22:51
Original commit files touched by this commit  0.44_1,1
 This port version is marked as vulnerable.
erwin search for other commits by this committer
Mark BROKEN: size mismatch
19 May 2007 20:32:57
Original commit files touched by this commit  0.44_1,1
 This port version is marked as vulnerable.
flz search for other commits by this committer
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}.
- Bump PORTREVISION for ports intalling files in ${X11BASE}.
19 Jan 2006 13:33:35
Original commit files touched by this commit  0.44,1
 This port version is marked as vulnerable.
anray search for other commits by this committer
Required shells/bash instead of shells/bash2.
19 Jan 2006 12:31:38
Original commit files touched by this commit  0.44,1
 This port version is marked as vulnerable.
anray search for other commits by this committer
Update 0.44.4 -> 0.44,1 and unbroken port.
26 Nov 2005 01:48:16
Original commit files touched by this commit  0.44.4
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Add SHA256
05 Oct 2005 06:16:52
Original commit files touched by this commit  0.44.4
 This port version is marked as vulnerable.
kris search for other commits by this committer
BROKEN: Size mismatch
12 Apr 2005 03:26:57
Original commit files touched by this commit  0.44.4
 This port version is marked as vulnerable.
obrien search for other commits by this committer
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
11 Apr 2005 08:04:41
Original commit files touched by this commit  0.44.4
 This port version is marked as vulnerable.
obrien search for other commits by this committer
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
08 Mar 2005 23:42:07
Original commit files touched by this commit  0.44.4
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Update to 0.44.4 and unbreak on 5.X

PR:             ports/78557
Submitted by:   Johan van Selst <johans@stack.nl>
26 Sep 2004 03:03:11
Original commit files touched by this commit  0.44_2
 This port version is marked as vulnerable.
kris search for other commits by this committer
BROKEN on 5.x: Does not compile

Approved by:    portmgr (self)
05 Feb 2004 20:38:07
Original commit files touched by this commit  0.44_2
 This port version is marked as vulnerable.
trevor search for other commits by this committer
Use PLIST_FILES.

Reviewed by:    marcus
04 Feb 2004 05:21:48
Original commit files touched by this commit  0.44_2
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.

(Part 2)
28 Jan 2004 18:04:33
Original commit files touched by this commit  0.44_1
 This port version is marked as vulnerable.
trevor search for other commits by this committer
Remove extraneous text.  List size.  Add ID.
20 Jan 2004 16:30:09
Original commit files touched by this commit  0.44_1
 This port version is marked as vulnerable.
marcus search for other commits by this committer
Use the new ghostscript options.

Submitted by:   linimon
11 Jan 2004 19:54:12
Original commit files touched by this commit  0.44_1
 This port version is marked as vulnerable.
pav search for other commits by this committer
- Update to new version without version bump

PR:             ports/61182
Submitted by:   bruno schwander <bruno@mail.tinkerbox.org>
26 Oct 2003 18:34:36
Original commit files touched by this commit  0.44
 This port version is marked as vulnerable.
krion search for other commits by this committer
- Update to version 0.44

PR:             58381
Submitted by:   Ports Fury
31 Aug 2003 00:42:39
Original commit files touched by this commit  0.42
 This port version is marked as vulnerable.
edwin search for other commits by this committer
[PATCH] graphics/sam2p: enable choose of ghostscript interpreter

        This patch allows the admin of the machine to choose either
        print/ghostscript-gnu or print/ghostscript-afp1

PR:             ports/54935
Submitted by:   Jens Rehsack <rehsack@liwing.de>
20 Feb 2003 18:08:19
Original commit files touched by this commit  0.42
 This port version is marked as vulnerable.
knu search for other commits by this committer
de-pkg-comment
06 Feb 2003 18:33:13
Original commit files touched by this commit  0.42
 This port version is marked as vulnerable.
ijliao search for other commits by this committer
add sam2p 0.42
Converts raster (bitmap) image formats into PS or PDF files

Number of commits found: 51

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
msmtpFeb 15
firefoxFeb 13
firefox-esrFeb 13
thunderbirdFeb 13
linux-flashplayerFeb 12
openjpeg*Feb 11
openjpeg*Feb 11
kf5-kauthFeb 10
unitFeb 08
curlFeb 07
gitlab-ceFeb 06
dovecotFeb 05
typo3-8Feb 02
typo3-9Feb 02
giteaFeb 01

12 vulnerabilities affecting 85 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-02-15 15:06:58


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 36391
Broken 114
Deprecated 423
Ignore 328
Forbidden 3
Restricted 162
No CDROM 74
Vulnerable 36
Expired 5
Set to expire 395
Interactive 0
new 24 hours 1
new 48 hours7
new 7 days47
new fortnight97
new month330

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.