notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
libproxy-webkit WebKit JavaScript plug-in for libproxy
0.4.15 net Deleted on this many watch lists=0 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 0.4.15Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Deprecated DEPRECATED: Uses webkit-gtk2 which has security issues
Expired This port expired on: 2019-03-24
Maintainer: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2009-02-27 05:31:33
Last Update: 2019-03-24 18:43:27
SVN Revision: 496768
Also Listed In: www
License: LGPL21+
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (4 items)
Collapse this list.
  1. /usr/local/share/licenses/libproxy-webkit-0.4.15/catalog.mk
  2. /usr/local/share/licenses/libproxy-webkit-0.4.15/LICENSE
  3. /usr/local/share/licenses/libproxy-webkit-0.4.15/LGPL21+
  4. lib/libproxy/0.4.15/modules/pacrunner_webkit.so
Collapse this list.
Dependency lines:
  • libproxy-webkit>0:net/libproxy-webkit
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: libproxy-webkit
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
libproxy-webkit
ABIlatestquarterly
FreeBSD:11:aarch640.4.15-
FreeBSD:11:amd64--
FreeBSD:11:armv6--
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch640.4.15-
FreeBSD:12:amd64--
FreeBSD:12:armv60.4.15-
FreeBSD:12:armv70.4.15-
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Master port: net/libproxy

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. cmake : devel/cmake
  2. ninja : devel/ninja
  3. pkgconf>=1.3.0_1 : devel/pkgconf
Library dependencies:
  1. libwebkitgtk-1.0.so : www/webkit-gtk2
  2. libproxy.so : net/libproxy
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://codeload.github.com/libproxy/libproxy/tar.gz/0.4.15?dummy=/
Collapse this list.
Port Moves
  • port deleted on 2019-03-24
    REASON: Has expired: webkit-gtk* last release in 2016 and security issues

Number of commits found: 19

Commit History - (may be incomplete: see SVNWeb link above for full details)
This is a slave port. You may also want to view the commits to the master port: net/libproxy
DateByDescription
24 Mar 2019 18:43:27
Original commit files touched by this commit Revision:496768  0.4.15
kwm search for other commits by this committer
Remove expired webkit-gtk2 and webkit-gtk3 ports.

Bump graphics/variety deprecation date, there is a patch for a update which
uses webkit2-gtk3 in ports/236180 but I had issues that I could't fix.
25 Feb 2019 16:58:49
Original commit files touched by this commit Revision:493883  0.4.15
kwm search for other commits by this committer
Mark webkit-gtk[23] ports as depricated with the same date as webkit-gtk[23].
Disable webkit-gtk[23] support if the port/plugin supports it.

Remove options for webkit-gtk[23] using ports or if they don't have a
option, mark them deprecated with the same date as webkit-gtk[23].

Haskell and geany where skipped and will be handled by the maintainers.
22 Jun 2018 19:59:41
Original commit files touched by this commit Revision:473062  0.4.15
tcberner search for other commits by this committer
Update net/libproxy to 0.4.15

* this release switched the build system to cmake
* move libproxy-gnome to libproxy-gnome2 for consistency
* add new slave libproxy-webkit3
* try to simplify the whole thing

* bump revisions in the dependencies

Reviewed by:	gnome (kwm), mat
Differential Revision:	https://reviews.freebsd.org/D15655
01 Apr 2016 14:16:20
Original commit files touched by this commit Revision:412348  0.4.12
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.

With hat:	portmgr
Sponsored by:	Absolight
19 Jan 2016 10:00:25
Original commit files touched by this commit Revision:406680  0.4.12
rakuco search for other commits by this committer
Update libproxy and its slave ports to 0.4.12.

After being dormant since 2013, libproxy development picked up some steam at
the end of last year, and the project moved from Google Code to GitHub,
where its releases are also being hosted. A summary of changes between 0.4.6
and 0.4.12 can be found here:
    https://github.com/libproxy/libproxy/blob/0.4.12/NEWS

The libproxy ports themselves have undergone several changes too:
* net/libproxy
  - Drop a lot of patches that are no longer necessary.
  - Add a few patches that I have sent upstream, and add some context to the
    0.4.6 patches that are still required.
  - Explicitly disable a few build options (.NET bindings, for example).
  - Switch to an out-of-source CMake build (also applies to the slave
(Only the first 15 lines of the commit message are shown above View all of this commit message)
17 Jan 2016 12:55:14
Original commit files touched by this commit Revision:406314  0.4.6_4
rakuco search for other commits by this committer
Add upstream patch to fix CVE-2012-4504.

Approved by:	gnome (kwm)
Security:	3b5c2362-bd07-11e5-b7ef-5453ed2e2b49
Security:	CVE-2012-4504
17 Jan 2016 10:29:27
Original commit files touched by this commit Revision:406298  0.4.6_3 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Update libproxy's website in the slave ports too.

Approved by:	gnome (kwm)
10 Sep 2014 20:50:37
Original commit files touched by this commit Revision:367888  0.4.6_3 This port version is marked as vulnerable.
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
25 Apr 2014 23:03:46
Original commit files touched by this commit Revision:352163  0.4.6_2 This port version is marked as vulnerable.
bapt search for other commits by this committer
Support stage
02 Nov 2013 04:19:08
Original commit files touched by this commit Revision:332454  0.4.6_2 This port version is marked as vulnerable.
marino search for other commits by this committer
net/libproxy-webkit: USES+= pkgconfig

Approved by:	portmgr (bapt, implicit)
20 Sep 2013 22:10:25
Original commit files touched by this commit Revision:327755  0.4.6_2 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
net)
29 Jul 2012 11:17:04
Original commit files touched by this commit   0.4.6_2 This port version is marked as vulnerable.
cs search for other commits by this committer
Fix typos in COMMENT

Approved by:	portmgr@ (implicit)
01 Jun 2012 05:26:28
Original commit files touched by this commit   0.4.6_2 This port version is marked as vulnerable.
dinoex search for other commits by this committer
- update png to 1.5.10
23 Aug 2011 18:29:54
Original commit files touched by this commit   0.4.6_1 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update to 0.4.6.
28 Mar 2010 06:47:48
Original commit files touched by this commit   0.2.3_9
dinoex search for other commits by this committer
- update to 1.4.1
Reviewed by:    exp8 run on pointyhat
Supported by:   miwi
05 Feb 2010 11:46:55
Original commit files touched by this commit   0.2.3_8
dinoex search for other commits by this committer
- update to jpeg-8
28 Nov 2009 20:06:37
Original commit files touched by this commit   0.2.3_7
marcus search for other commits by this committer
Presenting GNOME 2.28.1 for FreeBSD.  The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ .
Officially, this is mostly a polishing release in preparation for GNOME 3.0
due in about a year.

On the FreeBSD front, though, a lot went into this release.  Major thanks
goes to kwm and avl who did a lot of the porting work for this release.
In particular, kwm brought in Evolution MAPI support for better Microsoft
Exchange integration.  Avl made sure that the new gobject introspection
repository ports were nicely compartmentalized so that large dependencies
aren't brought in wholesale.

But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself)
contributed to this release.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
31 Jul 2009 13:57:52
Original commit files touched by this commit   0.2.3_1
dinoex search for other commits by this committer
- bump all port that indirectly depends on libjpeg and have not yet been bumped
or updated
Requested by:   edwin
27 Feb 2009 05:31:08
Original commit files touched by this commit   0.2.3
marcus search for other commits by this committer
Add libproxy-webkit, a plug-in which allows WebKit-based web browsers to
make use of libproxy.

Number of commits found: 19