The SuSE Proxy-Suite, a set of programs to enhance firewall security.
The first (and currently only) component being released is the FTP-Proxy.
* Securely relays FTP connections between clients and servers
* Can switch connections from active to passive and vice versa
* Utilizes port ranges for both control and data connections
* Provides extensive auditing (via syslog or rotating log files)
* Can separate user related from system triggered audit events
* Provides command restriction based on logged in user name
* Allows command argument checking with regular expressions
* Is able to retrieve configuration data from an LDAP directory
* Has been thoroughly tested against buffer overflow attacks
* Fully conforms to RFC 959 and 1123 (the basic FTP RFCs)
* Planned to support RFC 1579 ("Firewall Friendly FTP")
* Planned to support RFC 2428 (IPv6 Extensions for FTP)
* Based on GNU AutoConf, supposed to run on many UNIX systems
Ported to FreeBSD using OpenBSD port by Camiel Dobbelaar <cd@sentia.nl>,
with updates contributed by Marius Tomaschewski <mat@mt-home.net>.
Mk/**ldap.mk: Convert USE_LDAP to USES=ldap
Convert the USE_LDAP=yes to USES=ldap and adds the following features:
- Adds the argument USES=ldap:server to add openldap2{4|5|6}-server as
RUN_DEPENDS
- Adds the argument USES=ldap<version> and replaces WANT_OPENLDAP_VER
- Adds OPENLDAP versions in bsd.default-versions.mk
- Adds USE_OPENLDAP/WANT_OPENLDAP_VER in Mk/bsd.sanity.mk
- Changes consumers to use the features
Reviewed by: delphij
Approved by: portmgr
Differential Revision: https://reviews.freebsd.org/D38233
Remove WWW entries moved into port Makefiles
Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.
This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.
Approved by: portmgr (tcberner)
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.
Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.
There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above )
- Remove an old patch that adds HAVE_SYS_PARAM_H to config.h.in. It's
already there in the current version of the port.
- Replace a patch for configure.in with a post-patch command for configure
so we can remove USE_AUTOTOOLS.
- Unhide pre-install command.
net/proxy-suite: remove configure workaround
- The workaround breaks in some cases, e.g. when ipfilter is not installed
in the system
PR: 218487
Submitted by: Franco Fichtner <franco@opnsense.org>
Approved by: thomas (maintainer timeout)
net/openldap24-*:
- Convert to USES=libtool and bump dependent ports
- Avoid USE_AUTOTOOLS
- Don't use PTHREAD_LIBS
- Use MAKE_CMD
databases/glom:
- Drop :keepla
- Add INSTALL_TARGET=install-strip
databases/libgda4* databases/libgda5*:
- Convert to USES=libtool and bump dependent ports
- USES=tar:xz
- Use INSTALL_TARGET=install-strip
- Use @sample
(Only the first 15 lines of the commit message are shown above )
The vast majority of pkg-descr files had the following format when they
had both lines:
Author: ...
WWW: ....
So standardize on that, and move them to the end of the file when necessary.
Also fix some more whitespace, and remove more "signature tags" of varying
forms, like -- name, etc.
s/AUTHOR/Author/
A few other various formatting issues
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead
PR: 157936
Submitted by: myself
Exp-runs by: pav
Approved by: pav
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the
old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in
exactly the same way as USE_AUTOTOOLS itself.
Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME
team -- all GNOME 2.12.x ports use it.
Preliminary documentation can be found at:
http://people.FreeBSD.org/~ade/autotools.txt
which is in the process of being SGMLized before introduction into the
Porters Handbook.
Light blue touch-paper. Run.
There used to be a macro IPL_NAT in ipfilter that was defined to be the
same as IPNAT_NAME. This macro has been removed with the import of
ipfilter 4, so we now need to use IPNAT_NAME directly.
Fixes build on -CURRENT.
Reviewed by: roberto
Replace all known incantations of WANT_{AUTOMAKE,AUTOCONF,LIBTOOL}* with
the USE_<x> equivalents. In the current scheme of things, the WANT_
variables in this case are synonymous with the USE_ ones, and thus need
to be exterminated.
First in a series of major autotools cleanups.