notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
ghostscript9-agpl-x11 PostScript and PDF interpreter, X11 support
9.27 print on this many watch lists=4 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port 9.27Version of this port present on the latest quarterly branch.
Maintainer: doceng@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2015-08-22 17:49:01
Last Update: 2019-04-22 10:12:27
SVN Revision: 499621
License: AGPLv3
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (6 items)
  1. lib/ghostscript/9.27/X11.so
  2. /usr/local/share/licenses/ghostscript9-agpl-x11-9.27/catalog.mk
  3. /usr/local/share/licenses/ghostscript9-agpl-x11-9.27/LICENSE
  4. /usr/local/share/licenses/ghostscript9-agpl-x11-9.27/AGPLv3
  5. @postexec /usr/sbin/service ldconfig restart > /dev/null
  6. @postunexec /usr/sbin/service ldconfig restart > /dev/null
Collapse this list.
Dependency lines:
  • ghostscript9-agpl-x11>0:print/ghostscript9-agpl-x11
Conflicts:
CONFLICTS_INSTALL:
  • ghostscript[789]-[0-9]*
  • ghostscript[789]-nox11-[0-9]*
  • ghostscript9-agpl-[0-9]*
  • ghostscript9-agpl-nox11-[0-9]*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
To install the port: cd /usr/ports/print/ghostscript9-agpl-x11/ && make install clean
To add the package: pkg install ghostscript9-agpl-x11
PKGNAME: ghostscript9-agpl-x11
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ghostscript9-agpl-base>=9.27 : print/ghostscript9-agpl-base
  2. gmake : devel/gmake
  3. pkgconf>=1.3.0_1 : devel/pkgconf
  4. ice.pc : x11/libICE
  5. sm.pc : x11/libSM
  6. x11.pc : x11/libX11
  7. xext.pc : x11/libXext
  8. xt.pc : x11-toolkits/libXt
Runtime dependencies:
  1. ghostscript9-agpl-base>=9.27 : print/ghostscript9-agpl-base
  2. ice.pc : x11/libICE
  3. sm.pc : x11/libSM
  4. x11.pc : x11/libX11
  5. xext.pc : x11/libXext
  6. xt.pc : x11-toolkits/libXt
Library dependencies:
  1. libiconv.so : converters/libiconv
This port is required by:
for Build
  1. editors/texmacs
  2. graphics/ImageMagick6
  3. graphics/ImageMagick7
  4. print/flpsed
  5. print/gv

Deleted ports which required this port:

Expand this list of 2 deleted ports
  1. graphics/ImageMagick*
  2. print/ggv*
  3. Collapse this list of deleted ports.
for Run
  1. cad/xcircuit
  2. editors/ted
  3. editors/texmacs
  4. editors/texmaker
  5. graphics/ImageMagick6
  6. graphics/ImageMagick7
  7. graphics/xpeps
Expand this list (12 items / 5 hidden)
  1. misc/pspresent
  2. print/flpsed
  3. print/gv
  4. Collapse this list.

Deleted ports which required this port:

Expand this list of 2 deleted ports
  1. graphics/ImageMagick*
  2. print/ggv*
  3. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options

USES:

Master Sites:
  1. https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs927/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2015-08-22
    Affects: users of print/ghostscript*
    Author: hrs@FreeBSD.org
    Reason: 
      print/ghostscript{7,8,9,9-agpl} have been split into
      print/ghostscript{7,8,9,9-agpl}-{base,x11}.
      print/ghostscript*-nox11 ports have been removed.
    
      The -base installs Ghostscript binaries, libgs, and other data files
      and it depends on no X11 library.  The -x11 installs a small shared
      library to enable x11* devices in the installed -base package.
    
      In most cases, Ghostscript is installed as a dependency.  A port/package
      which requires Ghostscript will automatically pick up -base, and
      when x11* devices required it will pick up -x11 in addition.
    
      If one wants to install Ghostscript manually and full compatibility
      with the previous versions, just install -x11 because it installs
      -base as a dependency.  Combination of the two provides the same
      functionality as before.
    
    

Number of commits found: 12

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
22 Apr 2019 09:12:27
Original commit files touched by this commit  9.27
Revision:499621
tijl search for other commits by this committer
Make sure ghostscript9-agpl-x11 and ghostscript9-agpl-base have the same
version.
21 Apr 2019 16:41:37
Original commit files touched by this commit  9.27
Revision:499546
tijl search for other commits by this committer
Update to 9.27.

PR:		237390
Exp-run by:	antoine
Approved by:	portmgr (antoine)
MFH:		2019Q2
Security:	CVE-2019-3835, CVE-2019-3838
23 Dec 2018 19:41:20
Original commit files touched by this commit  9.26
Revision:488238 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update to 9.26.
- Make openjpeg dependency optional and off by default because it's been
  vulnerable for a long time.
- Disable IJS option because print/hpijs, the last port that used it, has
  been removed.

PR:		234013
Approved by:	doceng (bcr)
22 Sep 2018 09:53:10
Original commit files touched by this commit  9.25
Revision:480373 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update to 9.25.

This release fixes problems with argument handling, some unintended results
of the security fixes to the SAFER file access restrictions (specifically
accessing ICC profile files), and some additional security issues over the
recent 9.24 release.

PR:		231547
Exp-run by:	antoine
MFH:		2018Q3
04 Sep 2018 12:28:45
Original commit files touched by this commit  9.24
Revision:478951 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update print/ghostscript9-agpl-base and print/ghostscript9-agpl-x11 to
  9.24.
- Set USE_CSTD=gnu99 and eliminate a patch.
- Add cpe string.
- Patch configure to respect CFLAGS.

PR:		231148
Approved by:	doceng (blackend)
Security:	https://www.kb.cert.org/vuls/id/332928
26 Jun 2018 17:15:38
Original commit files touched by this commit  9.23_1
Revision:473400 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Restore patch that adds mappings for common CJK TeX fonts to cidfmap.
  Make the path in the mappings relative to LOCALBASE/share/fonts so
  print/gsfonts does not need to be installed. [1]
- Remove --enable-threadsafe from CONFIGURE_ARGS so thread-unsafe devices
  like opvp (used by Canon printer drivers) are built. [2]
- Fix detection of dlopen on FreeBSD < 11.2 (which doesn't have libdl). [2]
- Remove reference to FAPI configuration from pkg-message.  As far as I
  can tell it is only useful in combination with UFST, a commercial font
  renderer from Monotype and we don't (and can't) build with UFST support.

PR:		229211 [1], 229332 [2]
Tested by:	Osamu Matsuda <omatsuda000@gmail.com>
12 Jun 2018 09:45:14
Original commit files touched by this commit  9.23
Revision:472239 This port version is marked as vulnerable.
tijl search for other commits by this committer
Clean up print/ghostscript9-agpl-base and print/ghostscript9-agpl-x11 and
update them to version 9.23.  Share CMap data with graphics/poppler-data
and update that to 0.4.9.

Details for print/ghostscript9-agpl-base:
- Update to 9.23.
- Drop external epag device.
- Always use fontconfig to find fonts.
- Use ports openjpeg instead of bundled.
- Use bundled lcms2, because upstream forked it.
- Drop dependency on gsfonts.  Newer versions of the fonts are already
  included.
- Depend on poppler-data for CMap files.  It has the same maps except
  Identity-H, Identity-UTF16-H, and Identity-V.
- Resolve conflict with gambc by moving bin/gsc to bin/gs instead of
(Only the first 15 lines of the commit message are shown above View all of this commit message)
17 Jun 2016 23:28:05
Original commit files touched by this commit  9.16_2
Revision:417041 This port version is marked as vulnerable.
mat search for other commits by this committer
Rename all files containing a : in their filename.

While there, run make makepatch on affected ports, and rename patches
accordingly.

Sponsored by:	Absolight
19 May 2016 10:53:06
Original commit files touched by this commit  9.16_2
Revision:415500 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix trailing whitespace in pkg-descrs, categories [p-x]*

Approved by:	portmgr blanket
24 Mar 2016 15:47:50
Original commit files touched by this commit  9.16_2
Revision:411798 This port version is marked as vulnerable.
tijl search for other commits by this committer
Make print/ghostscript9-agpl-base the default Ghostscript port.  Upstream
changed the license to the AGPL 3 in version 9.07 so print/ghostscript9-base
is stuck at 9.06 which is almost 4 years old now.

Fix the logic in Uses/ghostscript.mk so "agpl" is treated as a real version
on its own instead of as a variant of other versions.

Fix print/ghostscript9-agpl-base to install eps2write.

Update math/asymptote to 2.37 to support newer Ghostscript.

PR:		208159
Exp-run by:	antoine
Approved by:	portmgr (antoine)
24 Aug 2015 06:09:14
Original commit files touched by this commit  9.16_2
Revision:395158 This port version is marked as vulnerable.
hrs search for other commits by this committer
Fix build error.
22 Aug 2015 17:48:36
Original commit files touched by this commit  9.16_2
Revision:395047 This port version is marked as vulnerable.
hrs search for other commits by this committer
- Split ghostscript into X11-independent and -dependent parts:

 * print/ghostscript{7,8,9,9-agpl}-base

   Installs Ghostscript binary, libgs, and related files.
   These ports do not depend on X11 libraries (i.e. x11* devices
   are not available).  USES=ghostscript will set dependency on
   one of them depending on GHOSTSCRIPT_DEFAULT.

   The default device is set to "display" or "bbox".

 * print/ghostscript{7,8,9,9-agpl}-x11

   Installs a shared library which provides X11 support to
   the installed Ghostscript binaries.  x11* devices will be
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 12

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
python37Oct 19
py-pillowOct 15
mod_perl2Oct 09
xpdfOct 06
xpdf3Oct 06
xpdf4Oct 06
unboundOct 03
cactiOct 02
gitlab-ceOct 02
gitlab-ceOct 02
ruby24Oct 02
ruby25Oct 02
mongodb34Sep 30
mongodb34Sep 30
mongodb36Sep 30

4 vulnerabilities affecting 12 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-10-19 10:52:46


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 37702
Broken 75
Deprecated 102
Ignore 340
Forbidden 3
Restricted 156
No CDROM 73
Vulnerable 26
Expired 15
Set to expire 73
Interactive 0
new 24 hours 3
new 48 hours6
new 7 days18
new fortnight41
new month143

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.