notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
modsecurity3-apache Intrusion detection and prevention engine / Apache Wrapper
0.0.9.b1.19_1 security on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port 0.0.9.b1.19Version of this port present on the latest quarterly branch.
Maintainer: joneum@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-05-06 18:55:36
Last Update: 2019-07-26 21:46:57
SVN Revision: 507372
Also Listed In: www
License: APACHE20
Description:
SVNWeb : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (7 items)
  1. /usr/local/share/licenses/modsecurity3-apache-0.0.9.b1.19_1/catalog.mk
  2. /usr/local/share/licenses/modsecurity3-apache-0.0.9.b1.19_1/LICENSE
  3. /usr/local/share/licenses/modsecurity3-apache-0.0.9.b1.19_1/APACHE20
  4. libexec/apache24/mod_security3.so
  5. @postexec %D/sbin/apxs -e -a -n security3 %f
  6. @preunexec %D/sbin/apxs -e -A -n security3 %f
  7. share/doc/modsecurity3-apache/README.md
Collapse this list.
Dependency lines:
  • modsecurity3-apache>0:security/modsecurity3-apache
To install the port: cd /usr/ports/security/modsecurity3-apache/ && make install clean
To add the package: pkg install modsecurity3-apache
PKGNAME: modsecurity3-apache
Flavors: there is no flavor information for this port.
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. apxs : www/apache24
  2. autoconf>=2.69 : devel/autoconf
  3. automake>=1.16.1 : devel/automake
  4. gcc9 : lang/gcc9
  5. as : devel/binutils
Runtime dependencies:
  1. apxs : www/apache24
  2. gcc9 : lang/gcc9
Library dependencies:
  1. libmodsecurity.so : security/modsecurity3
There are no ports dependent upon this port

Configuration Options

USES:

Master Sites:
  1. https://codeload.github.com/SpiderLabs/ModSecurity-apache/tar.gz/v0.0.9-beta1-19-gf76aaae?dummy=/

Number of commits found: 2

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
26 Jul 2019 20:46:57
Original commit files touched by this commit  0.0.9.b1.19_1
Revision:507372
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.

PR:		238330
06 May 2019 18:55:20
Original commit files touched by this commit  0.0.9.b1.19
Revision:500924
joneum search for other commits by this committer
New Port: security/modsecurity3-apache

The ModSecurity-apache connector is the connection point between Apache and
libmodsecurity (ModSecurity v3).
Said another way, this project provides a communication channel between Apache
and libmodsecurity.
This connector is required to use LibModSecurity with Apache.

The ModSecurity-apache connector takes the form of an Apache module.
The module simply serves as a layer of communication between Apache and
ModSecurity.

https://github.com/SpiderLabs/ModSecurity-apache

Sponsored by:	Netzkommune GmbH

Number of commits found: 2

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
libmadNov 13
chromiumNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
wordpressNov 12
nexus2-ossNov 07
php71Nov 06
php72Nov 06
php73Nov 06
php74Nov 06
fileNov 02
mariadb101-serverNov 02
mariadb102-serverNov 02

8 vulnerabilities affecting 177 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-11-14 00:15:05


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 38051
Broken 789
Deprecated 86
Ignore 1068
Forbidden 3
Restricted 156
No CDROM 72
Vulnerable 33
Expired 7
Set to expire 56
Interactive 0
new 24 hours 10
new 48 hours12
new 7 days36
new fortnight65
new month122

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.