notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
xfce4-kbdleds-plugin Xfce keyboard LEDs panel plugin
0.0.6 sysutils Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Broken BROKEN: Fails to compile with XFCE 4.16
Deprecated DEPRECATED: Unsupported upstream, cannot work with XFCE 4.16
Expired This port expired on: 2021-01-31
Ignore IGNORE: is marked as broken: Fails to compile with XFCE 4.16
Maintainer: xfce@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-02-16 10:34:29
Last Update: 2021-02-01 12:52:12
SVN Revision: 563574
Also Listed In: xfce
License: GPLv2
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (12 items)
Collapse this list.
  1. /usr/local/share/licenses/xfce4-kbdleds-plugin-0.0.6/catalog.mk
  2. /usr/local/share/licenses/xfce4-kbdleds-plugin-0.0.6/LICENSE
  3. /usr/local/share/licenses/xfce4-kbdleds-plugin-0.0.6/GPLv2
  4. lib/xfce4/panel-plugins/xfce4-kbdleds-plugin
  5. share/icons/hicolor/48x48/apps/kbdleds-plugin.png
  6. share/icons/hicolor/scalable/apps/kbdleds-plugin.svg
  7. share/locale/ru/LC_MESSAGES/xfce4-kbdleds-plugin.mo
  8. share/locale/uk/LC_MESSAGES/xfce4-kbdleds-plugin.mo
  9. share/xfce4/panel-plugins/kbdleds.desktop
  10. @owner
  11. @group
  12. @mode
Collapse this list.
Dependency lines:
  • xfce4-kbdleds-plugin>0:sysutils/xfce4-kbdleds-plugin
No installation instructions:
This port has been deleted.
PKGNAME: xfce4-kbdleds-plugin
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
xfce4-kbdleds-plugin
ABIlatestquarterly
FreeBSD:11:aarch64pkg-fallout0.0.6
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv6pkg-fallout0.0.6
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch64pkg-falloutpkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv6pkg-falloutpkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. msgfmt : devel/gettext-tools
  2. gmake>=4.3 : devel/gmake
  3. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  4. intltool-extract : textproc/intltool
  5. pkgconf>=1.3.0_1 : devel/pkgconf
  6. ice.pc : x11/libICE
  7. sm.pc : x11/libSM
  8. x11.pc : x11/libX11
Runtime dependencies:
  1. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  2. xfce4-panel : x11-wm/xfce4-panel
  3. ice.pc : x11/libICE
  4. sm.pc : x11/libSM
  5. x11.pc : x11/libX11
Library dependencies:
  1. libfontconfig.so : x11-fonts/fontconfig
  2. libfreetype.so : print/freetype2
  3. libatk-1.0.so : accessibility/atk
  4. libcairo.so : graphics/cairo
  5. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  6. libglib-2.0.so : devel/glib20
  7. libintl.so : devel/gettext-runtime
  8. libgtk-x11-2.0.so : x11-toolkits/gtk20
  9. libpango-1.0.so : x11-toolkits/pango
  10. libgarcon-gtk3-1.so : sysutils/garcon
  11. libexo-2.so : x11/libexo
  12. libxfce4ui-2.so : x11/libxfce4menu
  13. libxfce4util.so : x11/libxfce4util
  14. libxfce4panel-2.0.so : x11-wm/xfce4-panel
  15. libxfconf-0.so : x11/xfce4-conf
  16. libintl.so : devel/gettext-runtime
There are no ports dependent upon this port

Configuration Options:
Options name:
USES:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://git.xfce.org/archive/xfce4-kbdleds-plugin/snapshot/
Collapse this list.
Port Moves
  • port deleted on 2021-02-01
    REASON: Has expired: Unsupported upstream, cannot work with XFCE 4.16

Number of commits found: 7

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
0.0.6
01 Feb 2021 12:52:12
Revision:563574Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:

2021-01-31 deskutils/orage: Unsupported upstream, cannot work with XFCE 4.16
2021-01-31 sysutils/rubygem-chef-config12
2021-01-31 mail/openwebmail: Does not use modern Perl syntax and no development
activity since 2006
2021-01-31 sysutils/rubygem-ohai8
2021-01-31 deskutils/xfce4-volumed: Unsupported upstream, cannot work with XFCE
4.16
2021-01-31 sysutils/rubygem-chef12: Please use sysutils/rubygem-chef instead
2021-01-31 x11/xfce4-embed-plugin: Unsupported upstream, cannot work with XFCE
4.16
2021-01-31 net-p2p/py-transmissionrpc: Unmaintained and dead upstream, use
net-p2p/py-transmission-rpc instead
2021-01-31 science/xfce4-equake-plugin: Unsupported upstream, cannot work with
XFCE 4.16
2021-01-31 sysutils/xfce4-kbdleds-plugin: Unsupported upstream, cannot work with
XFCE 4.16
2021-01-31 textproc/py-gfm: No longer maintained by upstream, please use
textproc/py-cmarkgfm instead
0.0.6
05 Jan 2021 12:12:58
Revision:560384Original commit files touched by this commit
madpilot search for other commits by this committer
Mark broken and deprecate, This was forgotten in the XFCE 4.16 update.

Reported by:	Andrea Venturoli <ml@andreaventuroli.it>
0.0.6
26 Dec 2019 19:43:21
Revision:520947Original commit files touched by this commit
madpilot search for other commits by this committer
Make xfce4-kbdleds-plugin fetchable again by grabbing distfile from
upstream git repo directly, remove BROKEN line.

PR:		242879
Submitted by:	Zane C. Bowers-Hadley <vvelox@vvelox.net>
0.0.6
07 Nov 2019 17:17:54
Revision:516988Original commit files touched by this commit
zeising search for other commits by this committer
Add USES=xorg USES=gl, ports categories s

Add USES=xorg and USES=gl to ports in categories starting with 's'
While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
0.0.6
06 Nov 2019 16:26:35
Revision:516897Original commit files touched by this commit
antoine search for other commits by this committer
Mark a few ports BROKEN (unfetchable)
0.0.6
10 Oct 2019 20:29:19
Revision:514253Original commit files touched by this commit
pkubaj search for other commits by this committer
www/wpebackend-fdo needs C++11 compiler:
/wrkdirs/usr/ports/www/wpebackend-fdo/work/wpebackend-fdo-1.4.0/src/ipc.h:40:
error: ISO C++ forbids declaration of 'unique_ptr' with no type

sysutils/xfce4-kbdleds-plugin needs C11 compiler similarly to other xfce ports.

Approved by:	mentors (implicit approval)
0.0.6
16 Feb 2019 07:40:03
Revision:493030Original commit files touched by this commit
yuri search for other commits by this committer
New port: sysutils/xfce4-kbdleds-plugin: Xfce keyboard LEDs panel plugin

Number of commits found: 7