notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
mediawiki130 Wiki engine used by Wikipedia
1.30.1_1 www Deleted on this many watch lists=0 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 1.30.1_1Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Upstream no longer maintained
Expired This port expired on: 2019-04-14
Maintainer: wen@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-12-13 07:09:16
Last Update: 2019-04-15 17:55:05
SVN Revision: 499038
License: GPLv2
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/mediawiki130-1.30.1_1/catalog.mk
  2. /usr/local/share/licenses/mediawiki130-1.30.1_1/LICENSE
  3. /usr/local/share/licenses/mediawiki130-1.30.1_1/GPLv2
Collapse this list.
Dependency lines:
  • mediawiki130>0:www/mediawiki130
Conflicts:
CONFLICTS:
  • mediawiki127-[0-9]*
  • mediawiki131-[0-9]*
  • mediawiki132-[0-9]*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions:
This port has been deleted.
PKGNAME: mediawiki130
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
mediawiki130
ABIlatestquarterly
FreeBSD:11:aarch641.30.1-
FreeBSD:11:amd64--
FreeBSD:11:armv6--
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch641.30.1-
FreeBSD:12:amd64--
FreeBSD:12:armv61.30.1-
FreeBSD:12:armv71.30.1-
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Runtime dependencies:
  1. php.h : lang/php72
  2. ctype.so : textproc/php72-ctype
  3. dom.so : textproc/php72-dom
  4. fileinfo.so : sysutils/php72-fileinfo
  5. hash.so : security/php72-hash
  6. iconv.so : converters/php72-iconv
  7. intl.so : devel/php72-intl
  8. json.so : devel/php72-json
  9. mbstring.so : converters/php72-mbstring
  10. openssl.so : security/php72-openssl
  11. readline.so : devel/php72-readline
  12. session.so : www/php72-session
  13. xml.so : textproc/php72-xml
  14. xmlreader.so : textproc/php72-xmlreader
  15. zlib.so : archivers/php72-zlib
  16. mysqli.so : databases/php72-mysqli
  17. sockets.so : net/php72-sockets
Library dependencies:
  1. libmysqlclient.so.18 : databases/mysql56-client
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. http://releases.wikimedia.org/mediawiki/1.30/
Collapse this list.
Port Moves
  • port moved to www/mediawiki131 on 2019-04-15
    REASON: Has expired: Upstream no longer maintained
  • port moved here from www/mediawiki128 on 2018-03-14
    REASON: Has expired: Upstream no longer maintained

Number of commits found: 10

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
15 Apr 2019 17:55:05
Original commit files touched by this commit Revision:499038  1.30.1_1
rene search for other commits by this committer
Remove expired ports:
2019-04-14 www/mediawiki127: Upstream no longer maintained
2019-04-14 www/mediawiki130: Upstream no longer maintained
09 Apr 2019 14:04:50
Original commit files touched by this commit Revision:498476  1.30.1_1
sunpoet search for other commits by this committer
Update devel/readline to 8.0

- Bump PORTREVISION of dependent ports for shlib change

Changes:	https://tiswww.case.edu/php/chet/readline/CHANGES
PR:		236156
Exp-run by:	antoine
14 Jan 2019 02:44:26
Original commit files touched by this commit Revision:490224  1.30.1
wen search for other commits by this committer
- Update CONFLICTS
- Mark DEPRECATED and set EXPIRATION_DATE
30 Dec 2018 21:58:12
Original commit files touched by this commit Revision:488742  1.30.1
rene search for other commits by this committer
www/mediawiki1* : remove optional dependency on expired www/xcache
22 Sep 2018 14:20:19
Original commit files touched by this commit Revision:480387  1.30.1
wen search for other commits by this committer
- Update mediawiki to 1.27.5, 1.29.3, 1.30.1 and 1.31.1
07 Jul 2018 00:48:29
Original commit files touched by this commit Revision:474051  1.30.0_1 This port version is marked as vulnerable.
wen search for other commits by this committer
- Adjsut CONFLICTS to welcome mediawiki131
- Mark mediawiki129 DEPRECATED
24 Jun 2018 09:14:36
Original commit files touched by this commit Revision:473191  1.30.0_1 This port version is marked as vulnerable.
wen search for other commits by this committer
- Add php-openssl as depends

PR:		229189
Reported by:	markham_breitbach@ssimicro.com
08 Mar 2018 19:48:41
Original commit files touched by this commit Revision:463917  1.30.0 This port version is marked as vulnerable.
mat search for other commits by this committer
Introduce PHP flavors.

  Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now
  flavored.  They will automatically get flavors (php56, php70, php71, php72)
  depending of the versions they support (set with IGNORE_WITH_PHP).  As a
  consequence, ports using USES=pear and USES=horde are also flavored.

PR:		226242
Submitted by:	mat
Exp-run by:	antoine
Approved by:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D14208
01 Feb 2018 14:50:13
Original commit files touched by this commit Revision:460603  1.30.0 This port version is marked as vulnerable.
feld search for other commits by this committer
www/mediawiki130: Add missing PHP module dependency

When upgrading from MediaWiki 1.29:

Error: Missing one or more required components of PHP.
You are missing a required extension to PHP that MediaWiki needs.
Please install:
 * fileinfo <https://secure.php.net/fileinfo>

MFH:		2018Q1
13 Dec 2017 07:09:09
Original commit files touched by this commit Revision:456191  1.30.0 This port version is marked as vulnerable.
wen search for other commits by this committer
- Repocopy mediawiki129 --> mediawiki130 and update to 1.30.0

Number of commits found: 10