notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
py-soupsieve CSS4 selector implementation for BeautifulSoup
1.9_1 www on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port 1.9_1Version of this port present on the latest quarterly branch.
Maintainer: wen@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-04-06 08:16:07
Last Update: 2019-09-11 12:04:07
SVN Revision: 511814
Also Listed In: python
License: MIT
Description:
SVNWeb : Homepage

There is no configure plist information for this port.

Dependency lines:
  • py36-soupsieve>0:www/py-soupsieve
To install the port: cd /usr/ports/www/py-soupsieve/ && make install clean
To add the package: pkg install py36-soupsieve
PKGNAME: py36-soupsieve
Package flavors (<flavor>: <package>)
  • py36: py36-soupsieve
  • py27: py27-soupsieve
distinfo:

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py36-setuptools>0 : devel/py-setuptools@py36
  2. python3.6 : lang/python36
Runtime dependencies:
  1. py36-setuptools>0 : devel/py-setuptools@py36
  2. python3.6 : lang/python36
This port is required by:
for Run
  1. www/py-beautifulsoup

Configuration Options

USES:

Master Sites:
  1. https://files.pythonhosted.org/packages/source/s/soupsieve/
  2. https://pypi.org/packages/source/s/soupsieve/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2017-11-30
    Affects: */py*
    Author: mat@FreeBSD.org
    Reason: 
      Ports using Python via USES=python are now flavored.  All the py3-* ports
      have been removed and folded into their py-* master ports.
    
      People using Poudriere 3.2+ and binary packages do not have to do anything.
    
      For other people, to build the Python 3.6 version of, for example,
      databases/py-gdbm, you need to run:
    
        # make FLAVOR=py36 install
    
    

Number of commits found: 2

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
11 Sep 2019 11:04:07
Original commit files touched by this commit  1.9_1
Revision:511814
koobs search for other commits by this committer
www/py-soupsieve: Add missing dependency

soupsieve depends on backports.functools_lru_cache [1] on Python versions <
3, add the dependency accordingly.

While I'm here:

 - Add TEST_DEPENDS and test target to improve future QA

Note: soupsieve 'requires' [2] beautifulsoup4, but beautifulsoup4 depends
      on soupsieve via install_requires, causing a technical circular
      dependency, which is why soupsieve doesn't seem to explicitly
      install_requires on it ... anymore [3]. This seems bizzare.

[1] requirements/project.txt: backports.functools_lru_cache ; python_version <
'3'
[2] https://github.com/facelessuser/soupsieve#installation
[3]
https://github.com/facelessuser/soupsieve/commit/9a792216ea1ffce018c7968105540c08b82b96db

QA: 624 passed, 2 skipped, 6 warnings in 35.70 seconds

PR:		240490
Reported by:	jbeich
Approved by:	portmgr (blanket: missing dependencies, ports compliance)
MFH:		2019Q3 (blanket(s): run-time bugfix)
06 Apr 2019 08:15:37
Original commit files touched by this commit  1.9
Revision:498080
wen search for other commits by this committer
SoupSieve is a CSS selector library designed to be used with
BeautifulSoup4. It aims to provide selecting, matching, and
filtering using modern CSS selectors. SoupSieve currently
provides selectors from the CSS level 1 specifications up
through the latest CSS level 4 drafts (though some are not yet
implemented).

WWW: https://github.com/facelessuser/soupsieve

Number of commits found: 2

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
broSep 17
expat2Sep 16
curlSep 14
opensslSep 11
openssl111Sep 11
linux-flashplayerSep 10
onigurumaSep 07
xymon-serverSep 07
asterisk13Sep 06
asterisk15Sep 06
asterisk16Sep 06
asterisk16Sep 06
eximSep 06
wordpressSep 06
wordpressSep 06

14 vulnerabilities affecting 201 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2019-09-17 23:50:39


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 37701
Broken 408
Deprecated 537
Ignore 667
Forbidden 3
Restricted 162
No CDROM 74
Vulnerable 29
Expired 9
Set to expire 508
Interactive 0
new 24 hours 5
new 48 hours8
new 7 days24
new fortnight72
new month417

Servers and bandwidth provided by
New York Internet, iXsystems, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2019 Dan Langille. All rights reserved.