notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Port details
rubygem-jekyll2 Simple, blog aware, static site generator
2.5.3_2 www Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.5.3_2Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Use www/rubygem-jekyll instead
Expired This port expired on: 2016-12-31
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2015-10-28 17:04:24
Last Update: 2016-12-31 17:43:48
SVN Revision: 430147
Also Listed In: rubygems
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • rubygem-jekyll2>0:www/rubygem-jekyll2
No installation instructions:
This port has been deleted.
PKGNAME: rubygem-jekyll2
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
rubygem-jekyll2
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd64--
FreeBSD:11:armv62.5.3_2-
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64--
FreeBSD:12:amd64--
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby22 : lang/ruby22
  2. gem22 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-classifier-reborn>=2.0 : devel/rubygem-classifier-reborn
  2. rubygem-colorator>=0.1 : textproc/rubygem-colorator
  3. rubygem-jekyll-coffeescript>=1.0 : devel/rubygem-jekyll-coffeescript
  4. rubygem-jekyll-gist>=1.0 : textproc/rubygem-jekyll-gist
  5. rubygem-jekyll-paginate>=1.0 : textproc/rubygem-jekyll-paginate
  6. rubygem-jekyll-sass-converter>=1.0 : textproc/rubygem-jekyll-sass-converter
  7. rubygem-jekyll-watch>=1.1 : www/rubygem-jekyll-watch
  8. rubygem-kramdown>=1.3 : textproc/rubygem-kramdown
  9. rubygem-liquid2>=2.6.1 : textproc/rubygem-liquid2
  10. rubygem-mercenary>=0.3.3 : devel/rubygem-mercenary
  11. rubygem-pygments.rb>=0.6.0 : devel/rubygem-pygments.rb
  12. rubygem-redcarpet>=3.1 : textproc/rubygem-redcarpet
  13. rubygem-safe_yaml>=1.0 : devel/rubygem-safe_yaml
  14. rubygem-toml>=0.1.0 : devel/rubygem-toml
  15. ruby22 : lang/ruby22
  16. gem22 : devel/ruby-gems
Patch dependencies:
  1. ruby22 : lang/ruby22
  2. gem22 : devel/ruby-gems
Extract dependencies:
  1. ruby22 : lang/ruby22
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. textproc/rubygem-jekyll-assets1*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.global.ssl.fastly.net/gems/
Collapse this list.
Port Moves
  • port moved to www/rubygem-jekyll on 2016-12-31
    REASON: Has expired: Use www/rubygem-jekyll instead

Number of commits found: 7

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
31 Dec 2016 17:43:48
Original commit files touched by this commit Revision:430147  2.5.3_2
rene search for other commits by this committer
Remove expired ports:
2016-12-31 devel/rubygem-devise-async-rails4: Not compatible with
devel/rubygem-devise > 3
2016-12-31 devel/rubygem-devise-async: Not compatible with devel/rubygem-devise
> 3
2016-12-31 net/iet: Upstream no longer active
2016-12-31 sysutils/geomgui: Development stopped years ago.
2016-12-31 sysutils/screen-legacy: Old version released 2008-08-07 no longer
upline maintained.
2016-12-31 sysutils/ntfsprogs: Superseded by sysutils/fusefs-ntfs
2016-12-31 www/rubygem-jekyll2: Use www/rubygem-jekyll instead
2016-12-31 databases/rubygem-dm-devise: Not compatible with devel/rubygem-devise
> 3
2016-12-31 devel/rubygem-sprockets211: Use devel/rubygem-sprockets or
devel/rubygem-sprockets3 instead
2016-12-31 devel/p5-Parse-CPAN-Meta: Merged into devel/p5-CPAN-Meta 2.150008
2016-12-31 devel/jtag: development ceased 2003, superceded by devel/urjtag
05 Dec 2016 13:39:55
Original commit files touched by this commit Revision:427890  2.5.3_2
sunpoet search for other commits by this committer
- Mark DEPRECATED and set EXPIRATION_DATE to 2016-12-31
27 Apr 2016 21:57:32
Original commit files touched by this commit Revision:414136  2.5.3_2
swills search for other commits by this committer
Convert USES=gem:autoplist to USES=gem since autoplist is default
27 Apr 2016 16:36:42
Original commit files touched by this commit Revision:414118  2.5.3_2
swills search for other commits by this committer
create USES=gem and update rubygem- ports to use it

Note that for now ports still have to have USE_RUBY=yes to use USES=gem

PR:		209041
Differential Revision:	https://reviews.freebsd.org/D6070
01 Apr 2016 14:33:58
Original commit files touched by this commit Revision:412351  2.5.3_2
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.

With hat:	portmgr
Sponsored by:	Absolight
17 Jan 2016 13:23:28
Original commit files touched by this commit Revision:406456  2.5.3_2
sunpoet search for other commits by this committer
- Add PORTSCOUT

Sponsored by:	PortsCamp Taiwan
28 Oct 2015 17:04:10
Original commit files touched by this commit Revision:400402  2.5.3_2
mmoll search for other commits by this committer
www/rubygem-jekyll: update to 3.0.0

and preserve 2.5.3 as www/rubygem-jekyll2

Number of commits found: 7