notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
talloc1 Hierarchical pool based memory allocator
2.1.14 devel Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.1.14Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Old version, uses EOLed python27
Expired This port expired on: 2020-02-15
Maintainer: timur@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-06-11 21:40:22
Last Update: 2020-02-16 12:34:45
SVN Revision: 526263
License: LGPL3
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (14 items)
Collapse this list.
  1. include/talloc.h
  2. lib/libtalloc.so
  3. lib/libtalloc.so.2
  4. /usr/local/libdata/pkgconfig/talloc.pc
  5. include/pytalloc.h
  6. lib/libpytalloc-util.so
  7. lib/libpytalloc-util.so.2
  8. /usr/local/lib/python2.7/site-packages/talloc.so
  9. /usr/local/libdata/pkgconfig/pytalloc-util.pc
  10. man/man3/talloc.3.gz
  11. @ldconfig
  12. /usr/local/share/licenses/talloc1-2.1.14/catalog.mk
  13. /usr/local/share/licenses/talloc1-2.1.14/LICENSE
  14. /usr/local/share/licenses/talloc1-2.1.14/LGPL3
Collapse this list.
Dependency lines:
  • For RUN/BUILD depends:
    • talloc1>0:devel/talloc1
  • For LIB depends:
    • libpytalloc-util.so:devel/talloc1
    • libtalloc.so:devel/talloc1
Conflicts:
CONFLICTS_INSTALL:
  • talloc-*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: talloc1
Flavors: there is no flavor information for this port.
distinfo:
No package information for this port in our database

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. pkgconf>=1.3.0_1 : devel/pkgconf
  2. python2.7 : lang/python27
Runtime dependencies:
  1. python2.7 : lang/python27
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Build

Deleted ports which required this port:

Expand this list of 6 deleted ports
  1. databases/ldb*
  2. databases/ldb12*
  3. databases/ldb13*
  4. devel/tevent1*
  5. net/samba46*
  6. net/samba47*
  7. Collapse this list of deleted ports.
for Run

Deleted ports which required this port:

Expand this list of 6 deleted ports
  1. databases/ldb*
  2. databases/ldb12*
  3. databases/ldb13*
  4. devel/tevent1*
  5. net/samba46*
  6. net/samba47*
  7. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://ftp.samba.org/pub/talloc/
Collapse this list.
Port Moves
  • port moved to devel/talloc on 2020-02-16
    REASON: Has expired: Old version, uses EOLed python27

Number of commits found: 5

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
16 Feb 2020 12:34:45
Original commit files touched by this commit Revision:526263  2.1.14
rene search for other commits by this committer
Remove expired ports:

2020-02-16 archivers/rox-archive: Old, uses EOLed python27
2020-02-15 databases/ldb: Old version, uses EOLed python27
2020-02-15 databases/ldb12: Old version, uses EOLed python27
2020-02-15 databases/ldb13: Old version, uses EOLed python27
2020-02-15 databases/tdb1: Old version, uses EOLed python27
2020-02-16 deskutils/rox-memo: Old, uses EOLed python27
2020-02-16 devel/py-roxlib: Old, uses EOLed python27
2020-02-15 devel/talloc1: Old version, uses EOLed python27
2020-02-15 devel/tevent1: Old version, uses EOLed python27
2020-02-16 editors/rox-edit: Old, uses EOLed python27
2020-02-15 graphics/ocre: unfetchable, author not reachable, seems discontinued
2020-02-14 math/py-basemap: Deprecated upstream
2020-02-16 multimedia/rox-videothumbnail: Old, uses EOLed python27
2020-02-14 security/morphis: Fails to build with recent versions of python,
upstream git repository is gone
2020-02-16 x11/rox-wallpaper: Old, uses EOLed python27
2020-02-16 x11-fm/rox-mime-editor: Old, uses EOLed python27
2020-02-16 x11-fm/rox-session: Old, uses EOLed python27
14 Jan 2020 08:57:17
Original commit files touched by this commit Revision:522997  2.1.14
antoine search for other commits by this committer
Deprecate old versions of some samba libraries

With hat:	portmgr
19 Jun 2019 22:37:12
Original commit files touched by this commit Revision:504589  2.1.14
timur search for other commits by this committer
Fix conflicts and dependencies for legacy ports
13 Jun 2019 23:42:57
Original commit files touched by this commit Revision:504144  2.1.14
timur search for other commits by this committer
Adjust PKGNAMESUFFIX to reflect different versions of the repo copies.
11 Jun 2019 21:40:09
Original commit files touched by this commit Revision:503995  2.1.14
timur search for other commits by this committer
Repo-copy preparing split of the Samba supporting libs

Number of commits found: 5