notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
openoffice-4 Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
4.1.11 editors on this many watch lists=10 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 4.1.10_1Version of this port present on the latest quarterly branch.
Maintainer: office@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2013-08-26 04:19:31
Last Update: 2021-10-10 19:44:42
Commit Hash: 2c672a4
People watching this port, also watch:: firefox, chromium, libreoffice, virtualbox-ose, thunderbird
Also Listed In: java
License: APACHE20 ADOBE BSD3CLAUSE BSD4CLAUSE BSL ICU MIT MPL10 MPL11 PSFL TWAIN W3C
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (16 items)
Collapse this list.
  1. @desktop-file-utils
  2. @shared-mime-info share/mime
  3. /usr/local/share/licenses/apache-openoffice-4.1.11/catalog.mk
  4. /usr/local/share/licenses/apache-openoffice-4.1.11/LICENSE
  5. /usr/local/share/licenses/apache-openoffice-4.1.11/APACHE20
  6. /usr/local/share/licenses/apache-openoffice-4.1.11/ADOBE
  7. /usr/local/share/licenses/apache-openoffice-4.1.11/BSD3CLAUSE
  8. /usr/local/share/licenses/apache-openoffice-4.1.11/BSD4CLAUSE
  9. /usr/local/share/licenses/apache-openoffice-4.1.11/BSL
  10. /usr/local/share/licenses/apache-openoffice-4.1.11/ICU
  11. /usr/local/share/licenses/apache-openoffice-4.1.11/MIT
  12. /usr/local/share/licenses/apache-openoffice-4.1.11/MPL10
  13. /usr/local/share/licenses/apache-openoffice-4.1.11/MPL11
  14. /usr/local/share/licenses/apache-openoffice-4.1.11/PSFL
  15. /usr/local/share/licenses/apache-openoffice-4.1.11/TWAIN
  16. /usr/local/share/licenses/apache-openoffice-4.1.11/W3C
Collapse this list.
Dependency lines:
  • apache-openoffice>0:editors/openoffice-4
Conflicts:
CONFLICTS_INSTALL:
  • apache-openoffice-devel-*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
To install the port: cd /usr/ports/editors/openoffice-4/ && make install clean
To add the package, run one of these commands:
  • pkg install editors/openoffice-4
  • pkg install apache-openoffice
PKGNAME: apache-openoffice
Flavors: there is no flavor information for this port.
ONLY_FOR_ARCHS: amd64 i386 powerpc64
distinfo:
Packages (timestamps in pop-ups are UTC):
apache-openoffice
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd644.1.10_14.1.10_1
FreeBSD:11:armv6--
FreeBSD:11:i3864.1.10_14.1.10_1
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64--
FreeBSD:12:amd644.1.114.1.11
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i3864.1.114.1.11
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd644.1.114.1.11
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i3864.1.114.1.11
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd644.1.11-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i3864.1.11-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. p5-Archive-Zip>=0 : archivers/p5-Archive-Zip
  2. unzip : archivers/unzip
  3. zip : archivers/zip
  4. ant : devel/apache-ant
  5. dmake : devel/dmake
  6. epm : devel/epm
  7. gperf : devel/gperf
  8. imake : devel/imake
  9. gpatch : devel/patch
  10. sane.h : graphics/sane-backends
  11. commons-lang.jar : java/apache-commons-lang
  12. junit.jar : java/junit
  13. bsh.jar : lang/bsh
  14. bash : shells/bash
  15. lucene-core-3.6.2.jar : textproc/lucene
  16. p5-XML-Parser>=0 : textproc/p5-XML-Parser
  17. p5-libwww>=0 : www/p5-libwww
  18. p5-LWP-Protocol-https>0 : www/p5-LWP-Protocol-https
  19. gcc10>0 : lang/gcc10
  20. commons-codec.jar : java/apache-commons-codec
  21. commons-httpclient.jar : java/apache-commons-httpclient
  22. commons-logging.jar : java/apache-commons-logging
  23. java : java/openjdk8
  24. bison : devel/bison
  25. update-desktop-database : devel/desktop-file-utils
  26. gmake>=4.3 : devel/gmake
  27. pkgconf>=1.3.0_1 : devel/pkgconf
  28. update-mime-database : misc/shared-mime-info
  29. autoconf>=2.69 : devel/autoconf
  30. automake>=1.16.1 : devel/automake
  31. xorgproto>=0 : x11/xorgproto
  32. xorgproto>=0 : x11/xorgproto
  33. ice.pc : x11/libICE
  34. sm.pc : x11/libSM
  35. x11.pc : x11/libX11
  36. xau.pc : x11/libXau
  37. xaw7.pc : x11-toolkits/libXaw
  38. xcomposite.pc : x11/libXcomposite
  39. xcursor.pc : x11/libXcursor
  40. xdamage.pc : x11/libXdamage
  41. xext.pc : x11/libXext
  42. xfixes.pc : x11/libXfixes
  43. xi.pc : x11/libXi
  44. xinerama.pc : x11/libXinerama
  45. xrandr.pc : x11/libXrandr
  46. xrender.pc : x11/libXrender
  47. xt.pc : x11-toolkits/libXt
  48. perl5>=5.32.r0<5.33 : lang/perl5.32
Runtime dependencies:
  1. index.theme : misc/hicolor-icon-theme
  2. commons-lang.jar : java/apache-commons-lang
  3. bsh.jar : lang/bsh
  4. Caladea-Bold.ttf : x11-fonts/crosextrafonts-caladea-ttf
  5. Carlito-Bold.ttf : x11-fonts/crosextrafonts-carlito-ttf
  6. Arimo-Bold.ttf : x11-fonts/croscorefonts-fonts-ttf
  7. gcc10>0 : lang/gcc10
  8. commons-codec.jar : java/apache-commons-codec
  9. commons-httpclient.jar : java/apache-commons-httpclient
  10. commons-logging.jar : java/apache-commons-logging
  11. java : java/openjdk8
  12. update-desktop-database : devel/desktop-file-utils
  13. update-mime-database : misc/shared-mime-info
  14. ice.pc : x11/libICE
  15. sm.pc : x11/libSM
  16. x11.pc : x11/libX11
  17. xau.pc : x11/libXau
  18. xaw7.pc : x11-toolkits/libXaw
  19. xcomposite.pc : x11/libXcomposite
  20. xcursor.pc : x11/libXcursor
  21. xdamage.pc : x11/libXdamage
  22. xext.pc : x11/libXext
  23. xfixes.pc : x11/libXfixes
  24. xi.pc : x11/libXi
  25. xinerama.pc : x11/libXinerama
  26. xrandr.pc : x11/libXrandr
  27. xrender.pc : x11/libXrender
  28. xt.pc : x11-toolkits/libXt
Library dependencies:
  1. libapr-1.so : devel/apr1
  2. libnspr4.so : devel/nspr
  3. libcurl.so : ftp/curl
  4. libcairo.so : graphics/cairo
  5. libpng.so : graphics/png
  6. libgraphite.so : graphics/silgraphite
  7. libblas.so : math/blas
  8. libCbcSolver.so : math/cbc
  9. libCgl.so : math/cgl
  10. libcoinasl.so : math/asl
  11. libClpSolver.so : math/clp
  12. libCoinMP.so : math/coinmp
  13. libCoinUtils.so : math/coinutils
  14. libcoinmumps.so : math/ipopt
  15. libnauty.so : math/nauty
  16. libopenblas.so : math/openblas
  17. libOsi.so : math/osi
  18. libfreetype.so : print/freetype2
  19. libharfbuzz.so : print/harfbuzz
  20. libnss3.so : security/nss
  21. libexpat.so : textproc/expat2
  22. libhunspell-1.7.so : textproc/hunspell
  23. libhyphen.so : textproc/hyphen
  24. libtextcat.so : textproc/libtextcat
  25. libmythes-1.2.so : textproc/mythes
  26. librdf.so : textproc/redland
  27. libserf-1.so : www/serf
  28. libfontconfig.so : x11-fonts/fontconfig
  29. libcups.so : print/cups
  30. libdbus-1.so : devel/dbus
  31. libdbus-glib-1.so : devel/dbus-glib
  32. libintl.so : devel/gettext-runtime
  33. libGL.so : graphics/libglvnd
  34. libGLU.so : graphics/libGLU
  35. libatk-1.0.so : accessibility/atk
  36. libglib-2.0.so : devel/glib20
  37. libintl.so : devel/gettext-runtime
  38. libgtk-x11-2.0.so : x11-toolkits/gtk20
  39. libIDL-2.so : devel/libIDL
  40. libxml2.so : textproc/libxml2
  41. libxslt.so : textproc/libxslt
  42. libpango-1.0.so : x11-toolkits/pango
  43. libjpeg.so : graphics/jpeg-turbo
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

pkg-message:
If installing:
Master Sites:
Expand this list (2 items)
Collapse this list.
  1. https://archive.apache.org/dist/openoffice/4.1.11/source/
  2. https://dlcdn.apache.org/openoffice/4.1.11/source/
Collapse this list.
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2015-03-17
    Affects: users of editors/openoffice-4 and editors/openoffice-devel
    Author: truckman@FreeBSD.org
    Reason: 
      Contrary to what is stated in pkg-message, openoffice-4 and
      openoffice-devel have stored user settings in ~/.openoffice.org-devel/4
      since r325370 (2013-08-25). This update expects user settings to reside
      in the more standard ~/.openoffice.org/4.
    
      To preserve your user settings, rename or copy them from
      ~/.openoffice.org-devel/4 to ~/.openoffice.org/4. when installing this
      update to apache-openoffice-4.1.1_7 or
      apache-openoffice-devel-4.2.1652526_2,3.
    
    
Port Moves
  • port moved here from editors/openoffice-3 on 2014-02-07
    REASON: OpenOffice 3 is not supported anymore

Number of commits found: 138 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
10 Oct 2021 19:44:42
 files touched by this commit commit hash:2c672a4de941dc57142d867ba42396b1b64d2921  4.1.11
bapt search for other commits by this committer
INSTALLS_ICONS: retire the macro and rework the related dependencies

While here, make sure gtk-update-icon-cache is only on run dependency
where added as a dependency
Enforce gtk3 to depend on gtk-update-icon-cache (previously it was
inheriting the dependency)
09 Oct 2021 21:53:03
 files touched by this commit commit hash:35590404fef2c7b60e562b1d4f61f2ef2986c2a3  4.1.11
truckman search for other commits by this committer
editors/openoffice-4: Upgrade to version 4.1.11:

  - Fix CVE-2021-33035 - Buffer overflow from a crafted DBF file

Release Notes:
  https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.11+Release+Notes

The CVE-2021-40439 - Billion Laughs issue for the FreeBSD port was
fixed some time ago when the textproc/expat2 port was updated.  Unlike
other distributions, the FreeBSD port uses the system expat2 instead
of bundling an old version.

Update MASTER_SITES, the source is not mirrored on the usual Apache
mirror sites.  Prefer the Apache CDN.

Update dependencies, mostly due to math/coinmp refactoring.

Remove some bundled python shared libraries that look less than useful
and link to other dependencies.

MFH:		2021Q4
Security:	04d2cf7f-2942-11ec-b48c-1c1b0d9ea7e6
Differential Revision:	https://reviews.freebsd.org/D32400
22 Jun 2021 18:53:08
 files touched by this commit commit hash:da3162c7c9f01912ba1940e188b253f2b5c7ba77  4.1.10_1 This port version is marked as vulnerable.
kbowling search for other commits by this committer
graphics/mesa-libs: Bump reverse deps for libglvnd

Per discussion with bapt on helping pkg handle the changing of these
deps and avoiding impossible upgrade senarios.

PR:		246767
Reviewed by:	manu, bapt
Approved by:	x11
Differential Revision:	https://reviews.freebsd.org/D30824
30 Apr 2021 03:21:09
 files touched by this commit commit hash:ad5d8f0484ac6ac236825b5ce2c64bdb7eef69a4  4.1.10 This port version is marked as vulnerable.
truckman search for other commits by this committer
editors/openoffice-4: Upgrade to 4.1.10

  * Fixes CVE 2021-30245

  * Fixes https://bz.apache.org/ooo/show_bug.cgi?id=128439
06 Apr 2021 14:31:13
 files touched by this commit commit hash:135fdeebb99c3569e42d8162b265e15d29bd937d  4.1.9 This port version is marked as vulnerable.
mat search for other commits by this committer
all: Remove all other $FreeBSD keywords.
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  4.1.9 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
09 Feb 2021 07:12:47
Original commit files touched by this commit Revision:564771  4.1.9 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgraded enditors/openoffice-4 to version 4.1.9:
  * Headless mode: Crash on DOC to PDF conversion
  * Various fixes for non-FreeBSD platforms

Unbreak after gnome-vfs removal
06 Feb 2021 19:45:41
Original commit files touched by this commit Revision:564243  4.1.8_1 This port version is marked as vulnerable.
bapt search for other commits by this committer
Remove dependency on deprecated gnome2 libraries:
gnomevfs and gconf
09 Nov 2020 09:23:57
Original commit files touched by this commit Revision:554693  4.1.8 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade editors/openoffice-4 to version 4.1.8.

Fix bugs in LICENSE_FILE extraction.

Don't pass LD_FLAGS to the inner make.  It can cause problems.

Many of our local patches have been upstreamed.
08 Nov 2020 19:35:21
Original commit files touched by this commit Revision:554647  4.1.7_4 This port version is marked as vulnerable.
bapt search for other commits by this committer
Remove the MMEDIA option

openoffice depends on the expired gstreamer 0.10 for multimedia support,
gstreamer 0.10 is about to be removed from the ports tree, let's remove the
option in preparation for that
25 May 2020 18:25:19
Original commit files touched by this commit Revision:536493  4.1.7_3 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Fix build with bison 3.6.2
18 May 2020 17:30:25
Original commit files touched by this commit Revision:535758  4.1.7_3 This port version is marked as vulnerable.
truckman search for other commits by this committer
Switch from system python2 to bundled python.
09 May 2020 19:24:50
Original commit files touched by this commit Revision:534792  4.1.7_2 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update devel/gmake to 4.3.

Some changes have been made in this release that break backwards
compatibility.  Let USES=gmake force users to upgrade to this version so
port maintainers don't have to support older versions.

PR:		245725
Exp-run by:	antoine
Approved by:	portmgr (antoine)
03 Mar 2020 12:56:16
Original commit files touched by this commit Revision:527673  4.1.7_2 This port version is marked as vulnerable.
mat search for other commits by this committer
Ports MUST NOT set WITH_DEBUG.

WITH_DEBUG is a user facing variable.  When a user wants to build a port
with debugging symbols enabled, they either set WITH_DEBUG globally, or
WITH_DEBUG_PORTS+=category/port.

Approved by:	bapt
With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D23940
30 Dec 2019 09:15:29
Original commit files touched by this commit Revision:521475  4.1.7_2 This port version is marked as vulnerable.
ale search for other commits by this committer
Rename my jakarta- ports to apache-
11 Dec 2019 17:53:49
Original commit files touched by this commit Revision:519824  4.1.7_2 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.72.0

Changes:	http://www.boost.org/users/history/version_1_72_0.html
PR:		241449
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D22136
08 Dec 2019 22:49:11
Original commit files touched by this commit Revision:519580  4.1.7_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Attempt to fix gcc builds on powerpc, that were broken by a boost upgrade.

Clang builds using -std=gnu++98 can use the STL headers in
/usr/include/c++/v1, but recent versions of the gcc headers forbid this.
As a fallback, OpenOffice tries to use the TR1 headers supplied by boost,
but recent versions of boost no longer have those headers.  In theory
the gcc TR1 headers should work, but I was not able to make those work.
Solve this problem by doing gcc builds using the "bundled" version of
boost which is much older rather that boost from ports.

Patch the "bundled" boost to fix the compiler feature detection logic
to get rid of a bunch of compiler warnings.

The headers in the ports version of vigra has some C++11 stuff that
gcc also complains about, so use the "bundled" version of vigra for
(Only the first 15 lines of the commit message are shown above View all of this commit message)
26 Nov 2019 21:46:13
Original commit files touched by this commit Revision:518482  4.1.7_1 This port version is marked as vulnerable.
jkim search for other commits by this committer
Clean up after java/openjdk6 and java/openjdk6-jre removal

java/openjdk6 support was removed from Mk/bsd.java.mk (r512662) and
java/openjdk6 and java/openjdk6-jre were removed from the ports tree
(r512663).  Now this patch completely removes remaining stuff from the
ports tree.

PR:			241953 (exp-run)
Reviewed by:		glewis
Approved by:		portmgr (antoine)
Differential Revision:	https://reviews.freebsd.org/D22342
07 Oct 2019 11:09:49
Original commit files touched by this commit Revision:513938  4.1.7_1 This port version is marked as vulnerable.
pfg search for other commits by this committer
editors/openoffice-4: bump revision.

This port was frogotten from r513899.

Reported by:	truckman
Approved by:	thierry (mentor)(implicit)
06 Oct 2019 21:33:41
Original commit files touched by this commit Revision:513909  4.1.7 This port version is marked as vulnerable.
antoine search for other commits by this committer
Fix dependencies
20 Sep 2019 16:56:36
Original commit files touched by this commit Revision:512422  4.1.7 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade editors/openoffice-4 to 4.1.7.

The build wants to include the git hash value in the build artifact
for display on the Help -> About popup, but it can't determine that
when building from a source tarball, as opposed to a git checkout.
Patch around that until upstream implements a way to include this
info into the tarball and pick it up from there.

Add xorg to USES for correctness.

patch-i127929 has been committed upstream.
19 Aug 2019 15:35:28
Original commit files touched by this commit Revision:509290  4.1.6_7 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.71.0

Changes:	http://www.boost.org/users/history/version_1_71_0.html
PR:		238827
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D20774
13 Aug 2019 16:03:12
Original commit files touched by this commit Revision:508837  4.1.6_6 This port version is marked as vulnerable.
mat search for other commits by this committer
Convert to UCL & cleanup pkg-message (categories e-g)
26 Jul 2019 20:46:57
Original commit files touched by this commit Revision:507372  4.1.6_6 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.

PR:		238330
12 Apr 2019 06:36:31
Original commit files touched by this commit Revision:498698  4.1.6_5 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.70.0

Changes:	http://www.boost.org/users/history/version_1_70_0.html
PR:		235956
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D19303
18 Jan 2019 21:14:42
Original commit files touched by this commit Revision:490671  4.1.6_4 This port version is marked as vulnerable.
jbeich search for other commits by this committer
textproc/hunspell: update to 1.7.0

- Drop const optimization as v2 API moved to nuspell

Changes:	https://github.com/hunspell/hunspell/releases/tag/v1.7.0
12 Dec 2018 01:35:36
Original commit files touched by this commit Revision:487272  4.1.6_3 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.

PR:		231590
12 Dec 2018 00:15:50
Original commit files touched by this commit Revision:487266  4.1.6_2 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.69.0

Changes:	http://www.boost.org/users/history/version_1_69_0.html
PR:		232525
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D17645
11 Dec 2018 10:10:02
Original commit files touched by this commit Revision:487230  4.1.6_1 This port version is marked as vulnerable.
antoine search for other commits by this committer
Spell CHOSEN_COMPILER_TYPE correctly

PR:		199098
With hat:	portmgr
23 Nov 2018 19:26:38
Original commit files touched by this commit Revision:485699  4.1.6_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix for crash in Freetype code.  Check the return value of the
FT_Get_Glyph() function.  See
https://bz.apache.org/ooo/show_bug.cgi?id=127929 [1]

Ensure that unowinreg.dll is included in DISTFILES when running the
makesum and distclean targets.

PR:		233404 [1]
Obtained from:	upstream [1]
MFH:		2018Q4
21 Nov 2018 07:10:11
Original commit files touched by this commit Revision:485501  4.1.6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Get unoregwin.dll back into distinfo.  It seems that something has changed
in the ports framework such that "make makesum" drops optional distfiles
from distinfo if the option to use that distfile is not enabled.

Reported by:	brian mckeon <brianjwb AT gmail.com>
MFH:		2018Q4
18 Nov 2018 22:08:20
Original commit files touched by this commit Revision:485282  4.1.6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade editors/openoffice-4 to version 4.1.6:

  * Fixed bugs which caused improper handling (crashes) when using
    Microsoft Drawing Binary File format

  * Fix a loop that visits all objects on a page so that all objects get
    visited

  * Updated logos

Release notes: https://s.apache.org/AOO-416releasenotes

Pet portlint (add missing USES= entries).

MFH:		2018Q4
15 Oct 2018 17:27:42
Original commit files touched by this commit Revision:482164  4.1.5_10 This port version is marked as vulnerable.
truckman search for other commits by this committer
editors/openoffice-4, editors/openoffice-devel:

	Fix build with OpenSSL 1.1.x

	Pet portlint (USES block location)

PR:		232265
Reported by:	pkg-fallout
11 Sep 2018 18:34:28
Original commit files touched by this commit Revision:479538  4.1.5_9 This port version is marked as vulnerable.
zeising search for other commits by this committer
Change x11/xorgproto to become a build dep

Change x11/xorgproto to become a build time dependency when added to
USE_XORG.  Change the dependency to be on the port, rather than a file the
port installs.
Fix fallout.
Bump portrevision on depending ports.

PR:		230909
Reviewed by:	eadler
Approved by:	portmgr (antoine)
Obtained
from:	https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/xorgproto
exp-run:	antoine
Differential Revision:	https://reviews.freebsd.org/D16906
17 Aug 2018 21:44:28
Original commit files touched by this commit Revision:477451  4.1.5_8 This port version is marked as vulnerable.
truckman search for other commits by this committer
Explicitly depend on python2 since the OpenOffice pyuno module fails
to build with python3.  No PORTREVISION bump since this does not change
the package.

PR:		229408
Submitted by:	Curtis Villamizar <curtis@ipv6.occnc.com>
09 Aug 2018 06:58:31
Original commit files touched by this commit Revision:476723  4.1.5_8 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.68.0

- Switch to C++14 for libboost_system to support C++14 consumers

Changes:	http://www.boost.org/users/history/version_1_68_0.html
PR:		229569
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D16165
29 Jul 2018 22:18:46
Original commit files touched by this commit Revision:475857  4.1.5_7 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which
has now moved from GCC 6 to GCC 7 by default.

This includes ports
 - featuring USE_GCC=yes or USE_GCC=any,
 - featuring USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and those
 - with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
   c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.

PR:		222542
12 Jun 2018 03:55:02
Original commit files touched by this commit Revision:472229  4.1.5_6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Instead of symlinking the directory containing the OpenOffice .desktop
files under $PREFIX/share/applications, symlink the individual .desktop
files.  This is what upstream does on Linux and what LibreOffice does
as well.  The Plasma 5 desktop ignores symlinks to directories when it
is scanning for .desktop files.

PR:		228030
Reported by:	kan@FreeBSD.org
18 Apr 2018 21:06:00
Original commit files touched by this commit Revision:467736  4.1.5_5 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix editors/openoffice-4 build with boost 1.67 by checking the boost
version and including <boost/next_prior.hpp> instead of
<boost/utility.hpp> when the new version of boost is detected.

PR:		227553
Reported by:	jbeich
18 Apr 2018 13:57:43
Original commit files touched by this commit Revision:467711  4.1.5_5 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.67.0

Changes:	http://www.boost.org/users/history/version_1_67_0.html
PR:		227427
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D15030
21 Mar 2018 21:24:44
Original commit files touched by this commit Revision:465240  4.1.5_4 This port version is marked as vulnerable.
brnrd search for other commits by this committer
devel/apr1: Bump portrevision

 - Repair my rookie mistake of earlier today
 - Bump revision of dependent ports (again)

Reported by:	antoine
21 Mar 2018 19:50:35
Original commit files touched by this commit Revision:465232  4.1.5_3 This port version is marked as vulnerable.
brnrd search for other commits by this committer
devel/apr1: Fix runtime issues of dependent port

 - iconv is in base in all supported FreeBSD versions
 - Fix build with MariaDB 10.2 [2]
 - Bump portrevision in dependencies

PR:		226705 [1], 226026 [2]
With hat:	apache
Approved by:	joneum (apache)
28 Jan 2018 04:16:24
Original commit files touched by this commit Revision:460159  4.1.5_2 This port version is marked as vulnerable.
truckman search for other commits by this committer
Set WITH_DEBUG if the CRASHDUMP option is set rather than bailing
out if CRASHDUMP is selected and WITH_DEBUG is not set.

Suggested by:	jbeich
26 Jan 2018 18:33:09
Original commit files touched by this commit Revision:460047  4.1.5_2 This port version is marked as vulnerable.
truckman search for other commits by this committer
Don't enable crashdumps by default.  This build knob causes the build
to be done with debug symbols, which greatly increase the size of the
build, but this is all in vain because the executables and libraries
are subsequently stripped.

Build with debug symbols if WITH_DEBUG is set.

Build with -fstack-protector.

Only fetch unowinreg.dll when building the SDK.

Add three new options:

  CRASHDUMP - Enable crashdumps, requires WITH_DEBUG

  DBGUTIL   - Enable assertions, object counting, and other
              non-production runtime debugging.

  DEBUG     - Compile with -O0 for better debugability.  The ports
              framework also sets WITH_DEBUG.

Fold a couple long lines in the Makefile.
24 Jan 2018 09:41:04
Original commit files touched by this commit Revision:459824  4.1.5_1 This port version is marked as vulnerable.
ak search for other commits by this committer
- Update name of autoreconf WRKSRC variable in comment
- Fix a few ports with invalid USES autoreconf arguments
- Add check for invalid USES autoreconf arguments

Differential Revision:	https://reviews.freebsd.org/D14004
Approved by:	tijl (autotools maintainer), portmgr (mat)
19 Jan 2018 19:40:47
Original commit files touched by this commit Revision:459465  4.1.5_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Remove the CCACHE option and other ccache code from the Makefile
and use the ccache code in the ports framework handle all of the
details.

Don't prepend ${WRKSRC}/solenv/bin to PATH in CONFIGURE_ENV since
it is no longer needed and blocks the framework from adding
CCACHE_WRAPPER_PATH to PATH in CONFIGURE_ENV and MAKE_ENV.

Sanitize MAKE_ENV and export its to the build, similar to what is
done by the default do-build target.  This passes CCACHE_DIR and
HOME (set to WRKDIR) to the build, so the $HOME override in r459316
is no longer needed.  We need to remove the CPPFLAGS setting from
MAKE_ENV before exporting to the build because it breaks the build
of the bundled icu module.  CFLAGS and CXXFLAGS are also removed
because they would interfere with the carefully constructed compiler
flags set by the port.  The include paths are already handled by
the port, and the port also modifies the optmization flags for some
files to work around compiler bugs.

While here, remove files/ooo.sh files/generate.pl since they have
been obsolete for a long while.

No PORTREVISION bump since the package should be unchanged.

PR:		224276
18 Jan 2018 09:43:39
Original commit files touched by this commit Revision:459318  4.1.5_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Remove some leftovers from an earlier version of the $HOME fix.
18 Jan 2018 07:31:31
Original commit files touched by this commit Revision:459316  4.1.5_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix editors/openoffice-4 build with clang 6.0.0 by compiling with
-std=gnu++98 since that was the default for the compilers historically
used for the build.  It turns out that -std=c++98 does not work
because the vigra headers depend on LLONG_MAX and friends, which
are not defined without the GNU extensions.

Compensate for a recent poudriere change by overriding $HOME and
setting it to /tmp if $HOME is not writeable.  Some of the test
code run during the build wants to use mkstemp() to create temporary
directories under $HOME, which does not work for the "nobody" user
which points $HOME at /nonexistent.

No PORTREVISION bump since this is a build fix and there is no
change to the package.

PR:		225129
Reported by:	jbeich
18 Jan 2018 04:11:03
Original commit files touched by this commit Revision:459315  4.1.5_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.66.0

Changes:	http://www.boost.org/users/history/version_1_66_0.html
PR:		223922
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D13279
31 Dec 2017 00:00:06
Original commit files touched by this commit Revision:457654  4.1.5 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to Apache OpenOffice 4.1.5.

The following bugs are fixed:
    BZ 127568 Diagrams become corrupt (not retrievable) when Calc document
	      is saved

    BZ 127580 Fix for Issue 127568 created a new bug in Base

    BZ 127581 Writer crashes after copying all content
27 Nov 2017 07:28:35
Original commit files touched by this commit Revision:454935  4.1.4_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix the table wizard in openoffice-base on FreeBSD 10 amd64.  One of the
source files triggers a bug in the clang 3.4 code optimizer.

MFH:	2017Q4
20 Oct 2017 16:02:13
Original commit files touched by this commit Revision:452538  4.1.4 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to Apache OpenOffice 4.1.4:

    * Several updates for language dictionaries

    * Some translation fixes in the UI

    * Bug fixes

    * Security improvements

    * Updated graphics/logos (new Apache feather)

    * Enhancements to the build tools (for developers)

Clarify LICENSE entries, change MPL to MPL10 and MPL11 since code with
(Only the first 15 lines of the commit message are shown above View all of this commit message)
25 Sep 2017 00:08:17
Original commit files touched by this commit Revision:450560  4.1.3_13 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.65.1

Changes:	http://www.boost.org/users/history/version_1_65_1.html
PR:		218835
Approved by:	maintainer timeout (1.65.1: 2 weeks; 1.65.0: 1 month)
Tested by:	jhibbits (on powerpc64, earlier version)
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D11582
25 Sep 2017 00:05:06
Original commit files touched by this commit Revision:450557  4.1.3_12 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: enable C++11 features

PR:		218835
Obtained from:	https://github.com/DragonFlyBSD/DeltaPorts/pull/690
Approved by:	maintainer timeout (2 months)
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D11582
10 Sep 2017 20:55:39
Original commit files touched by this commit Revision:449591  4.1.3_11 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
   c++14-lang, c++0x, c11, or gcc-c++11-lib.

PR:		219275
22 Jul 2017 03:50:13
Original commit files touched by this commit Revision:446366  4.1.3_10 This port version is marked as vulnerable.
truckman search for other commits by this committer
Include <complex> instead of the obsolete <boost/tr1/complex.hpp>.  The
upcoming boost 1.65 upgrade removes support for tr1.

Sort ONLY_FOR_ARCHS to pacify portlint.

No PORTREVISION bump since the code does not appear to change.

PR:		220723
14 Jul 2017 17:20:34
Original commit files touched by this commit Revision:445794  4.1.3_10 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Update WWW

Approved by:	portmgr blanket
23 May 2017 05:03:16
Original commit files touched by this commit Revision:441503  4.1.3_10 This port version is marked as vulnerable.
rezny search for other commits by this committer
Revision bump of all ports with USE_GL after consolidation of mesa-libs

Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D10845
02 May 2017 06:48:11
Original commit files touched by this commit Revision:439934  4.1.3_9 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.64.0

Changes:	http://www.boost.org/users/history/version_1_64_0.html
PR:		218835
Approved by:	office (bapt)
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D10472
01 Apr 2017 15:23:32
Original commit files touched by this commit Revision:437439  4.1.3_8 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using using Mk/bsd.octave.mk which in turn has USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
   c++11-lang, c++0x, c11, or gcc-c++11-lib.

PR:		216707
31 Jan 2017 03:42:07
Original commit files touched by this commit Revision:432898  4.1.3_7 This port version is marked as vulnerable.
truckman search for other commits by this committer
On amd64, clang++ 4.0 uses the MOVAPS SSE instruction to initialize
sufficiently large objects returned by the "new" operator.  This
requires that the object have 16-byte alignment.  The FreeBSD
malloc() implementation does the correct thing here, but OpenOffice
has a couple of internal memory allocator implementations that only
align to 8-byte boundaries at most.  In addition OpenOffice overrides
the new operator to interpose a couple of layers of wrappers.  If
the --enable-debug option is passed to configure, the wrapper adds
8 to the size passed to the allocator and adds an 8 byte offset to
the pointer returned by the allocator to make room for a signature
that it adds to the beginning of the memory block (the signature
is validated and the inverse transformation is done when the memory
is freed).  This breaks the proper alignment done by the mamory
allocator.  Fix these problems by adding an EXTRA_PATCH that teaches
the internal OpenOffice memory allocators to do 16-byte alignment
(Only the first 15 lines of the commit message are shown above View all of this commit message)
24 Jan 2017 06:30:15
Original commit files touched by this commit Revision:432313  4.1.3_6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Clean up the logic for setting FREEBSD_ENV_SET.

Make a guess at the proper value of PACKAGE_MIDDLE for powerpc64 (needed
for solver and language packs).

A fixup for language packs on powerpc64 that was missed in the previous
commit.
24 Jan 2017 02:09:10
Original commit files touched by this commit Revision:432309  4.1.3_6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Add PowerPC64 support.  [1]

Add a section to pkg-message mentioning that spell check dictionaries
for the desired languages should be installed.  [2]

PR:		215130, 212103
Submitted by:	Curtis Hamilton <hamiltcl@verizon.net> [1]
Submitted by:	Arrigo Marchiori <ardovm AT yahoo.it> [2]
22 Jan 2017 08:35:12
Original commit files touched by this commit Revision:432098  4.1.3_5 This port version is marked as vulnerable.
jbeich search for other commits by this committer
editors/openoffice-devel: unbreak with clang 4.0

main/desktop/source/app/officeipcthread.cxx:228:14: error: ordered comparison
between pointer and zero ('rtlDigest' (aka 'void *') and 'int')
        if ( handle > 0 )
             ~~~~~~ ^ ~
main/desktop/source/deployment/misc/dp_misc.cxx:106:16: error: ordered
comparison between pointer and zero ('rtlDigest' (aka 'void *') and 'int')
    if (digest <= 0) {
        ~~~~~~ ^  ~
main/sd/source/ui/view/viewshe3.cxx:229:48: error: ordered comparison between
pointer and zero ('SdPage *' and 'int')
        if (pDocument->GetSdPage(0, ePageKind) > 0)
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~

PR:		216206
Submitted by:	pfg
Obtained from:	upstream
18 Jan 2017 13:20:32
Original commit files touched by this commit Revision:431796  4.1.3_5  Sanity Test Failure This port version is marked as vulnerable.
tijl search for other commits by this committer
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user.  Add LANG=C and LC_ALL=C at the beginning of
bsd.port.mk and export them so all commands are executed with the C locale.
LC_ALL=C overrides all other LC_* variables.  LANG is used by setlocale(3)
as default value for LC_* variables, so normally it isn't used when LC_ALL
is set, but there's code out there that looks at LANG directly so it's safer
to set it as well.  The only commands not captured by this are !=
assignments before any inclusion of bsd.port.*mk.

Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to
CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a
different locale (e.g. USE_LOCALE=en_US.UTF-8).

PR:		215882
Exp-run by:	antoine
Approved by:	portmgr (antoine)
07 Jan 2017 14:43:11
Original commit files touched by this commit Revision:430796  4.1.3_5 This port version is marked as vulnerable.
jbeich search for other commits by this committer
textproc/hunspell: update to 1.6.0

- Restore DIST_SUBDIR from r305651
- Adjust license for "or later" clause
- Restore GPLv2+/LGPL21+ license files removed upstream as
  GPLv3+/LGPL3+ only affects Hunspell 2.0 (not currently built)
- Unbreak |make makepatch|

Changes:	https://github.com/hunspell/hunspell/releases/tag/v1.6.0
PR:		215714
Submitted by:	sunpoet (based on)
Exp-run by:	antoine
MFH:		2017Q1
Differential Revision:	https://reviews.freebsd.org/D8887
07 Jan 2017 10:42:51
Original commit files touched by this commit Revision:430778  4.1.3_4 This port version is marked as vulnerable.
olivierd search for other commits by this committer
Chase update of graphics/poppler (and slaves ports) in revision r430777
06 Jan 2017 08:45:04
Original commit files touched by this commit Revision:430692  4.1.3_3 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.63.0

Changes:	http://www.boost.org/users/history/version_1_63_0.html
PR:		215598
Exp-run by:	antoine
Approved by:	office (bapt)
MFH:		2017Q1
03 Dec 2016 22:24:36
Original commit files touched by this commit Revision:427743  4.1.3_2 This port version is marked as vulnerable.
jbeich search for other commits by this committer
textproc/hunspell: update to 1.5.4

Changes:	https://github.com/hunspell/hunspell/blob/v1.5.4/ChangeLog
PR:		214837
Exp-run by:	antoine (for 1.5.3)
Approved by:	office (bapt)
26 Nov 2016 16:54:30
Original commit files touched by this commit Revision:427174  4.1.3_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
editors/openoffice*: unbreak consumers with hunspell 1.5

main/lingucomponent/source/spellcheck/spell/sspellimp.cxx:39:10: fatal error:
'dictmgr.hxx' file not found
 #include <dictmgr.hxx>
          ^

PR:		214844
Obtained from:	upstream
Approved by:	portmgr blanket
23 Nov 2016 12:45:47
Original commit files touched by this commit Revision:426908  4.1.3_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/boost-*: update to 1.62.0

- Enable `long double` C99 math usage
- Switch 9.x back to building with GCC

Changes:	http://www.boost.org/users/history/
PR:		199601
Submitted by:	Chen Xu, bapt, amdmi3, truckman (based on)
Reviewed by:	rakuco (kde) (earlier version)
Exp-run by:	antoine (3 tries), truckman (consumers only, earlier versions)
Approved by:	bapt (office)
21 Oct 2016 12:51:41
Original commit files touched by this commit Revision:424411  4.1.3  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
${RM} already has -f.

PR:		213570
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
12 Oct 2016 21:19:55
Original commit files touched by this commit Revision:423894  4.1.3 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade ApacheOpenOffice to version 4.1.3.

This version contains the fix for CVE-2016-1513 that was fixed locally
in 4.1.2_8 with a patch from upstream.

Configure now requires p5-LWP-Protocol-https, though we don't actually
use it we don't use bootstrap to download anything.
09 Oct 2016 12:10:02
Original commit files touched by this commit Revision:423591  4.1.2_10 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/nspr, security/nss: drop version from SONAME

No other downstream appends synthetic library version, and doing so
causes underlinking due to fragile build system (see below). Not to
mention being unable to swap out bundled libs from upstream builds.

  $ cc -lplds4 -L/usr/local/lib
  /usr/lib/crt1.o: In function `_start1':
  crt1_c.c:(.text+0xa6): undefined reference to `main'
  /usr/local/lib/libplds4.so: undefined reference to `pthread_set_name_np'
  /usr/local/lib/libplds4.so: undefined reference to `pthread_create'
  /usr/local/lib/libplds4.so: undefined reference to `pthread_condattr_init'
  /usr/local/lib/libplds4.so: undefined reference to `pthread_setschedparam'
  /usr/local/lib/libplds4.so: undefined reference to `pthread_getschedparam'

PR:		213144
Exp-run by:	antoine
05 Sep 2016 20:02:03
Original commit files touched by this commit Revision:421390  4.1.2_9 This port version is marked as vulnerable.
olivierd search for other commits by this committer
Chase update of Poppler after revision r421386
21 Jul 2016 18:09:59
Original commit files touched by this commit Revision:418885  4.1.2_8 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix CVE-2016-1513 - Memory Corruption Vulnerability (Impress Presentations).

Regenerate distinfo to add TIMESTAMP.

Obtained from:	<https://bz.apache.org/ooo/show_bug.cgi?id=127045>
MFH:		2016Q3
Security:	72f71e26-4f69-11e6-ac37-ac9e174be3af
12 Jul 2016 03:24:20
Original commit files touched by this commit Revision:418412  4.1.2_7 This port version is marked as vulnerable.
truckman search for other commits by this committer
Add missing dependencies reported by stage-qa:
        USE_XORG+=      sm xinerama

        devel/dbus (when GNOME option is enabled)

        multimedia/gstreamer (when MMEDIA option is enabled)

        graphics/poppler (-devel only, when PDFIMPORT option is enabled)

Add USES=ssl since this OpenOffice does use OpenSSL.  The base and ports
versions of OpenSSL are both known to work.  It is unknown if LibreSSL
works because the dependency ftp/curl does not currently build with
LibreSSL.

Replace one remaining path to a .jar file with ${JAVALIBDIR} in
CONFIGURE_ARGS.

Replace an absolute symlink with a relative one.

Re-align \ line continuation characters in *_DEPENDS after removal of
${PORTSDIR} from dependencies, and make a few other whitespace cleanups.

MFH:		2016Q3
26 May 2016 06:01:49
Original commit files touched by this commit Revision:415875  4.1.2_6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix build of openoffice-4 and openoffice-devel with libc++ 3.8.0.

Openffice defines its own overloaded variant of round(), which is
only different in return type from the 'real' round() from <math.h>,
so it is ambiguous (in the C++ lookup sense).  Fix this by renaming
the custom round() to round_(), and using a define to minimize
needed changes in the code.

PR:		209588
Submitted by:	dim
01 May 2016 05:26:21
Original commit files touched by this commit Revision:414385  4.1.2_6 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update TARGET_ORDER_OVERRIDE to for the changes to Uses/gnome.mk
in r413768.

Don't bother trying to create ${STAGEDIR}${DESKTOPDIR} since it
is already handled by mtree.
01 Apr 2016 14:00:57
Original commit files touched by this commit Revision:412346  4.1.2_5 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
20 Mar 2016 21:42:08
Original commit files touched by this commit Revision:411522  4.1.2_5 This port version is marked as vulnerable.
truckman search for other commits by this committer
Delay running gnome-post-install until the plist has been generated by
post-install so that the icons are detected and gtk-update-icon-cache
gets run when the package is installed. [1]

Import upstream trunk commit r1728872 to add the
CLOSESOCKET_DOESNT_WAKE_UP_ACCEPT up accept fix to the pipe code. [2]

PR:		208026 [1]
PR:		207301 [2]
11 Mar 2016 11:53:42
Original commit files touched by this commit Revision:410825  4.1.2_4 This port version is marked as vulnerable.
tijl search for other commits by this committer
Combine print/cups-base, print/cups-client and print/cups-image into
print/cups and update it to 2.1.3.  Also remove print/cups-pstoraster,
improve print/cups-filters, print/foomatic-* and update print/hplip to
3.16.2.

Long description:

First some background.  When you hand a file to cups it sets up a chain of
filter programs that converts the file to something a printer understands.
Each filter has a cost associated with it and cups tries to find the
cheapest chain.  Costs used to be configured in such a way that files were
first converted to PostScript.  This could then be manipulated further (e.g.
putting multiple pages on one sheet) before finally being sent to a
PostScript printer or another filter like pstoraster which produces a raster
format understood by non-PostScript printer drivers.  Nowadays most filters
(Only the first 15 lines of the commit message are shown above View all of this commit message)
29 Jan 2016 00:44:00
Original commit files touched by this commit Revision:407439  4.1.2_3 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix nss-related problems with password-protected documents.

Apply patches from upstream commits r1724971 and r1726068 to fix
upstream bug <https://bz.apache.org/ooo/show_bug.cgi?id=125431>,
"The Password is incorrect. The file cannot be opened."

PR:		206234
Submitted by:	Arrigo Marchiori <ardovm AT yahoo.it>
MFH:		2106Q1
21 Jan 2016 19:40:10
Original commit files touched by this commit Revision:406872  4.1.2_2 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.40.0. [1]

Add patches to py-poppler [2] and rubygem-poppler [3] to fix the build
of these ports with poppler 0.39+.

PR:		206293 [1]
Submitted by:	olivierd@ [1]
Obtained from:	ubuntu [2], rubygem-poppler upstream [3]
02 Jan 2016 20:58:43
Original commit files touched by this commit Revision:405096  4.1.2_1 This port version is marked as vulnerable.
truckman search for other commits by this committer
Correct the Icon entry in the .desktop files so that the icons are
visible in the menu.

PR:		205758
13 Nov 2015 04:13:58
Original commit files touched by this commit Revision:401476  4.1.2 This port version is marked as vulnerable.
truckman search for other commits by this committer
Now that we are no longer avoiding certain versions of clang, convert to
USES=compiler:c++11-lib instead of trying to emulate it.
29 Oct 2015 16:29:50
Original commit files touched by this commit Revision:400472  4.1.2 This port version is marked as vulnerable.
truckman search for other commits by this committer
Upgrade to Apache OpenOffice 4.1.2

  * Release Notes:
   <https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.2+Release+Notes
>

  * Bug Fixes: <http://s.apache.org/9uI>

  * Improvements / Enhancements

    o Several distinct enhancements were applied to the WebDAV
      management and file locking: OpenOffice is now able to properly
      interact with Microsoft Sharepoint, enabling a more productive
      usage in corporate-level environments. These enhancements were
      funded, and contributed upstream, by the Emilia-Romagna regional
(Only the first 15 lines of the commit message are shown above View all of this commit message)
23 Oct 2015 23:22:24
Original commit files touched by this commit Revision:400064  4.1.1_18 This port version is marked as vulnerable.
truckman search for other commits by this committer
Explicity set $JAVA_HOME in startup wrapper to the OpenJDK version used
for the build to avoid any potential issues with relying on javavmwrapper
parsing bsd.java.mk to determine this at runtime.

Fix an botch in the FreeBSD-specific $LD_LIBRARY_PATH code in the
startup wrapper.

Java is needed at runtime, so flag it as a runtime dependency.
18 Oct 2015 08:18:26
Original commit files touched by this commit Revision:399605  4.1.1_17 This port version is marked as vulnerable.
truckman search for other commits by this committer
Patch the source with r1697228, r1697237, r1697247, r1697306, and
r1697312 from upstream trunk (with a few tweaks to compensate for
some other upstream changes not included here) to unbreak the build
with OpenJDK8.

Revert r399536 to unmark broken.

PR:		199591 (openjdk8 by default exp-run)
17 Oct 2015 13:19:25
Original commit files touched by this commit Revision:399536  4.1.1_16 This port version is marked as vulnerable.
swills search for other commits by this committer
editors/openoffice-4: mark broken with OpenJDK8
09 Oct 2015 22:17:28
Original commit files touched by this commit Revision:398966  4.1.1_16 This port version is marked as vulnerable.
truckman search for other commits by this committer
Removing --enable-symbols=small from CONFIGURE_ARGS allows us to avoid
the need to use ${STRIP_CMD}.

Fix an intermittent build failure by adding a missing dependency to the
port's build framework.  This change has been committed to the upstream
trunk.
26 Sep 2015 07:40:48
Original commit files touched by this commit Revision:397932  4.1.1_16 This port version is marked as vulnerable.
truckman search for other commits by this committer
Add Caladea and Carlito fonts.  They are metrically equivalent to some
Microsoft fonts and the proper definitions within OpenOffice have been
added so that they are recognized as such. [1]

The Linux ports handle the mapping from the printeradmin command to the
spadmin executable in the shell wrapper.  Do the same in the FreeBSD
port rather than munging the printeradmin.desktop file.  Retain the
spadmin link to the wrapper for backwards compatability.

The setofficelang command went away a long time ago.  Remove it from
the shell wrapper and remove the link.

Exec the OpenOffice executables from the wrapper so that the shell for
the wrapper doesn't hang around as an extra process until OpenOffice
terminates.

Nuke an extraneous shell continuation in the Makefile.

Suggested by:	pfg [1]
24 Sep 2015 21:07:19
Original commit files touched by this commit Revision:397761  4.1.1_15 This port version is marked as vulnerable.
truckman search for other commits by this committer
Fix a regression in directory permissions and add a missing directory used
for shared extensions.  This combination of issues could cause incomplete
cleanup on pkg removal if OpenOffice had been run by a user in the wheel
group.

Add a note about the location of the Wiki Publisher extension to
pkg-message.
16 Sep 2015 03:03:46
Original commit files touched by this commit Revision:397038  4.1.1_14 This port version is marked as vulnerable.
truckman search for other commits by this committer
Update the comment about the clang 3.6 and clang 3.7 code generation
bug with the upstream bug ID.

More do-install target optimization:

  * Use the tar -s option to modify the path names when unpacking
    the install archive into the staging directory rather than
    unpacking, repacking, and unpacking again

  * Pass --with-unix-wrapper to configure and patch a makefile
    to get the desired Exec and Icon entries in the .desktop
    files instead of patching them after they have been staged.
    The Icon entries do not need to specify the .png suffix.

  * Streamline the usage of ${STRIP_CMD}
(Only the first 15 lines of the commit message are shown above View all of this commit message)
10 Sep 2015 00:33:08
Original commit files touched by this commit Revision:396545  4.1.1_13 This port version is marked as vulnerable.
truckman search for other commits by this committer
Unbreak wrapper script so that if a particular application is
specified but without specifying a document, that application is
started instead of presenting the user with the generic startup
window and requiring him to pick the document type (running
openoffice-*-scalc should open to a new spreadsheet, etc.)

Building with clang 3.7 is reported to have the same failure mode
as clang 3.6, so use the same optimization tweak as a workaround.

Various cleanups to do-install:

  * The paths ${PREFIX}/${INSTALLATION_BASEDIR} and
    ${PREFIX}/${INSTALLATION_BASEDIR}/${AOODIR}, and
    ${PREFIX}/${INSTALLATION_BASEDIR}/${AOODIR}/share/xdg are
    frequently used, so create a few variables to hold those paths
(Only the first 15 lines of the commit message are shown above View all of this commit message)
07 Sep 2015 15:19:19
Original commit files touched by this commit Revision:396278  4.1.1_12 This port version is marked as vulnerable.
truckman search for other commits by this committer
Import various improvements from openoffice-devel r393676, r395652, and
r396247:

 * Consolidate patch-freebsd.mk, patch-set_soenv.in, patch-unxfbsd.mk,
   and other changes that were committed to the upstream trunk
   into patch-build-framework:

   o Changes to aid building with gcc from ports on FreeBSD

   o Changes to detect when building with clang and to decode the
     compiler version

 * Remove the REINPLACE_CMD patches from post-patch and $FBSD_LDFLAGS
   from do-build that are no longer needed for building with gcc in
   the general case because of the previous patch
(Only the first 15 lines of the commit message are shown above View all of this commit message)
17 Aug 2015 14:20:41
Original commit files touched by this commit Revision:394508  4.1.1_11 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove UNIQUENAME and LATEST_LINK.

UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now,
we won't have conflicts there.

Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer
is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel
has the correct PKGNAME anyway.

Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called
OPTIONS_FILE now.)

Reviewed by:	antoine, bapt
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3336
04 Aug 2015 22:13:34
Original commit files touched by this commit Revision:393558  4.1.1_11 This port version is marked as vulnerable.
truckman search for other commits by this committer
Various build updates from openoffice-devel (primarily r382334 and
r391960):

  * patch-i118574 no longer seems necessary for a clean build

  * Regnerate patch-i114430 with make makepatch

  * Build using boost from ports instead of the bundled boost

  * Build using silgraphite from ports instead of the bundled version

  * Add missing LIB_DEPENDS that are brought in by other dependencies,
    but are directly linked as requested by pkgconfig/*.pc

  * Build using sane and xrender headers from ports instead of bundled
(Only the first 15 lines of the commit message are shown above View all of this commit message)
02 Aug 2015 16:06:17
Original commit files touched by this commit Revision:393431  4.1.1_10 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update poppler to 0.34.0. [1]

Chase all users of shlib version change of libpoppler.so.

PR:		201477 [1]
Submitted by:	olivierd@ [1]
28 Jun 2015 15:20:05
Original commit files touched by this commit Revision:390787  4.1.1_9 This port version is marked as vulnerable.
antoine search for other commits by this committer
MAKE_JOBS_SAFE=yes is a nop since july 2013

Number of commits found: 138 (showing only 100 on this page)

1 | 2  »