notbugIf you buy from Amazon USA, please support us by using this link.
Port details
vlc Qt based multimedia player and streaming server
2.2.8_13,4 multimedia on this many watch lists=72 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Deprecated DEPRECATED: vlc 2.x and vlc-qt4 is EOL upstream
Expiration Date EXPIRATION DATE: 2018-12-31
Maintainer: multimedia@FreeBSD.org search for ports maintained by this maintainer
Port Added: 04 Apr 2003 01:39:14
Also Listed In: audio ipv6 net www
License: GPLv2
VLC media player is a highly portable multimedia player for various
audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, and
more) as well as DVD's, VCD's, and various streaming protocols. It
can also be used as a server to stream in unicast or multicast in
IPv4 or IPv6 on a high-bandwidth network. VLC also has the ability
to transcode media on-the-fly for streaming or saving to disk.

WWW: https://www.videolan.org
SVNWeb : Homepage : PortsMon
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (222 items)
  1. @desktop-file-utils
  2. /usr/local/share/licenses/vlc-2.2.8_13,4/catalog.mk
  3. /usr/local/share/licenses/vlc-2.2.8_13,4/LICENSE
  4. /usr/local/share/licenses/vlc-2.2.8_13,4/GPLv2
  5. bin/cvlc
  6. @comment bin/nvlc
  7. bin/qvlc
  8. @comment bin/qvlc
  9. bin/rvlc
  10. @comment bin/svlc
  11. bin/vlc
  12. bin/vlc-wrapper
  13. include/vlc/deprecated.h
  14. include/vlc/libvlc.h
  15. include/vlc/libvlc_events.h
  16. include/vlc/libvlc_media.h
  17. include/vlc/libvlc_media_discoverer.h
  18. include/vlc/libvlc_media_library.h
  19. include/vlc/libvlc_media_list.h
  20. include/vlc/libvlc_media_list_player.h
  21. include/vlc/libvlc_media_player.h
  22. include/vlc/libvlc_structures.h
  23. include/vlc/libvlc_version.h
  24. include/vlc/libvlc_vlm.h
  25. include/vlc/plugins/vlc_about.h
  26. include/vlc/plugins/vlc_access.h
  27. include/vlc/plugins/vlc_addons.h
  28. include/vlc/plugins/vlc_aout.h
  29. include/vlc/plugins/vlc_aout_volume.h
  30. include/vlc/plugins/vlc_arrays.h
  31. include/vlc/plugins/vlc_atomic.h
  32. include/vlc/plugins/vlc_avcodec.h
  33. include/vlc/plugins/vlc_bits.h
  34. include/vlc/plugins/vlc_block.h
  35. include/vlc/plugins/vlc_block_helper.h
  36. include/vlc/plugins/vlc_charset.h
  37. include/vlc/plugins/vlc_codec.h
  38. include/vlc/plugins/vlc_common.h
  39. include/vlc/plugins/vlc_config.h
  40. include/vlc/plugins/vlc_config_cat.h
  41. include/vlc/plugins/vlc_configuration.h
  42. include/vlc/plugins/vlc_cpu.h
  43. include/vlc/plugins/vlc_demux.h
  44. include/vlc/plugins/vlc_dialog.h
  45. include/vlc/plugins/vlc_epg.h
  46. include/vlc/plugins/vlc_es.h
  47. include/vlc/plugins/vlc_es_out.h
  48. include/vlc/plugins/vlc_events.h
  49. include/vlc/plugins/vlc_filter.h
  50. include/vlc/plugins/vlc_fingerprinter.h
  51. include/vlc/plugins/vlc_fourcc.h
  52. include/vlc/plugins/vlc_fs.h
  53. include/vlc/plugins/vlc_gcrypt.h
  54. include/vlc/plugins/vlc_http.h
  55. include/vlc/plugins/vlc_httpd.h
  56. include/vlc/plugins/vlc_image.h
  57. include/vlc/plugins/vlc_inhibit.h
  58. include/vlc/plugins/vlc_input.h
  59. include/vlc/plugins/vlc_input_item.h
  60. include/vlc/plugins/vlc_keys.h
  61. include/vlc/plugins/vlc_main.h
  62. include/vlc/plugins/vlc_md5.h
  63. include/vlc/plugins/vlc_meta_fetcher.h
  64. include/vlc/plugins/vlc_media_library.h
  65. include/vlc/plugins/vlc_messages.h
  66. include/vlc/plugins/vlc_meta.h
  67. include/vlc/plugins/vlc_mime.h
  68. include/vlc/plugins/vlc_modules.h
  69. include/vlc/plugins/vlc_mouse.h
  70. include/vlc/plugins/vlc_mtime.h
  71. include/vlc/plugins/vlc_network.h
  72. include/vlc/plugins/vlc_objects.h
  73. include/vlc/plugins/vlc_opengl.h
  74. include/vlc/plugins/vlc_picture.h
  75. include/vlc/plugins/vlc_picture_fifo.h
  76. include/vlc/plugins/vlc_picture_pool.h
  77. include/vlc/plugins/vlc_playlist.h
  78. include/vlc/plugins/vlc_plugin.h
  79. include/vlc/plugins/vlc_probe.h
  80. include/vlc/plugins/vlc_rand.h
  81. include/vlc/plugins/vlc_services_discovery.h
  82. include/vlc/plugins/vlc_sout.h
  83. include/vlc/plugins/vlc_spu.h
  84. include/vlc/plugins/vlc_stream.h
  85. include/vlc/plugins/vlc_strings.h
  86. include/vlc/plugins/vlc_subpicture.h
  87. include/vlc/plugins/vlc_text_style.h
  88. include/vlc/plugins/vlc_threads.h
  89. include/vlc/plugins/vlc_tls.h
  90. include/vlc/plugins/vlc_url.h
  91. include/vlc/plugins/vlc_variables.h
  92. include/vlc/plugins/vlc_video_splitter.h
  93. include/vlc/plugins/vlc_vlm.h
  94. include/vlc/plugins/vlc_vout.h
  95. include/vlc/plugins/vlc_vout_display.h
  96. include/vlc/plugins/vlc_vout_osd.h
  97. include/vlc/plugins/vlc_vout_window.h
  98. include/vlc/plugins/vlc_xlib.h
  99. include/vlc/plugins/vlc_xml.h
  100. include/vlc/vlc.h
  101. lib/libvlc.so
  102. lib/libvlc.so.5
  103. lib/libvlc.so.5.5.1
  104. lib/libvlccore.so
  105. lib/libvlccore.so.8
  106. lib/libvlccore.so.8.0.1
  107. libdata/pkgconfig/libvlc.pc
  108. libdata/pkgconfig/vlc-plugin.pc
  109. man/man1/vlc-wrapper.1.gz
  110. man/man1/vlc.1.gz
  111. share/applications/vlc.desktop
  112. share/icons/hicolor/128x128/apps/vlc-xmas.png
  113. share/icons/hicolor/128x128/apps/vlc.png
  114. share/icons/hicolor/16x16/apps/vlc.png
  115. share/icons/hicolor/16x16/apps/vlc.xpm
  116. share/icons/hicolor/256x256/apps/vlc.png
  117. share/icons/hicolor/32x32/apps/vlc-xmas.xpm
  118. share/icons/hicolor/32x32/apps/vlc.png
  119. share/icons/hicolor/32x32/apps/vlc.xpm
  120. share/icons/hicolor/48x48/apps/vlc-xmas.png
  121. share/icons/hicolor/48x48/apps/vlc.png
  122. share/apps/solid/actions/vlc-openbd.desktop
  123. share/apps/solid/actions/vlc-opencda.desktop
  124. share/apps/solid/actions/vlc-opendvd.desktop
  125. share/apps/solid/actions/vlc-openvcd.desktop
  126. share/locale/ach/LC_MESSAGES/vlc.mo
  127. share/locale/af/LC_MESSAGES/vlc.mo
  128. share/locale/am/LC_MESSAGES/vlc.mo
  129. share/locale/an/LC_MESSAGES/vlc.mo
  130. share/locale/ar/LC_MESSAGES/vlc.mo
  131. share/locale/ast/LC_MESSAGES/vlc.mo
  132. share/locale/az/LC_MESSAGES/vlc.mo
  133. share/locale/be/LC_MESSAGES/vlc.mo
  134. share/locale/bg/LC_MESSAGES/vlc.mo
  135. share/locale/bn/LC_MESSAGES/vlc.mo
  136. share/locale/bn_IN/LC_MESSAGES/vlc.mo
  137. share/locale/br/LC_MESSAGES/vlc.mo
  138. share/locale/bs/LC_MESSAGES/vlc.mo
  139. share/locale/ca/LC_MESSAGES/vlc.mo
  140. share/locale/cgg/LC_MESSAGES/vlc.mo
  141. share/locale/ckb/LC_MESSAGES/vlc.mo
  142. share/locale/co/LC_MESSAGES/vlc.mo
  143. share/locale/cs/LC_MESSAGES/vlc.mo
  144. share/locale/cy/LC_MESSAGES/vlc.mo
  145. share/locale/da/LC_MESSAGES/vlc.mo
  146. share/locale/de/LC_MESSAGES/vlc.mo
  147. share/locale/el/LC_MESSAGES/vlc.mo
  148. share/locale/en_GB/LC_MESSAGES/vlc.mo
  149. share/locale/es/LC_MESSAGES/vlc.mo
  150. share/locale/es_MX/LC_MESSAGES/vlc.mo
  151. share/locale/et/LC_MESSAGES/vlc.mo
  152. share/locale/eu/LC_MESSAGES/vlc.mo
  153. share/locale/fa/LC_MESSAGES/vlc.mo
  154. share/locale/ff/LC_MESSAGES/vlc.mo
  155. share/locale/fi/LC_MESSAGES/vlc.mo
  156. share/locale/fr/LC_MESSAGES/vlc.mo
  157. share/locale/fur/LC_MESSAGES/vlc.mo
  158. share/locale/ga/LC_MESSAGES/vlc.mo
  159. share/locale/gd/LC_MESSAGES/vlc.mo
  160. share/locale/gl/LC_MESSAGES/vlc.mo
  161. share/locale/gu/LC_MESSAGES/vlc.mo
  162. share/locale/he/LC_MESSAGES/vlc.mo
  163. share/locale/hi/LC_MESSAGES/vlc.mo
  164. share/locale/hr/LC_MESSAGES/vlc.mo
  165. share/locale/hu/LC_MESSAGES/vlc.mo
  166. share/locale/hy/LC_MESSAGES/vlc.mo
  167. share/locale/ia/LC_MESSAGES/vlc.mo
  168. share/locale/id/LC_MESSAGES/vlc.mo
  169. share/locale/is/LC_MESSAGES/vlc.mo
  170. share/locale/it/LC_MESSAGES/vlc.mo
  171. share/locale/ja/LC_MESSAGES/vlc.mo
  172. share/locale/ka/LC_MESSAGES/vlc.mo
  173. share/locale/kk/LC_MESSAGES/vlc.mo
  174. share/locale/km/LC_MESSAGES/vlc.mo
  175. share/locale/kn/LC_MESSAGES/vlc.mo
  176. share/locale/ko/LC_MESSAGES/vlc.mo
  177. share/locale/ks_IN/LC_MESSAGES/vlc.mo
  178. share/locale/ky/LC_MESSAGES/vlc.mo
  179. share/locale/lg/LC_MESSAGES/vlc.mo
  180. share/locale/lt/LC_MESSAGES/vlc.mo
  181. share/locale/lv/LC_MESSAGES/vlc.mo
  182. share/locale/mai/LC_MESSAGES/vlc.mo
  183. share/locale/mk/LC_MESSAGES/vlc.mo
  184. share/locale/ml/LC_MESSAGES/vlc.mo
  185. share/locale/mn/LC_MESSAGES/vlc.mo
  186. share/locale/mr/LC_MESSAGES/vlc.mo
  187. share/locale/ms/LC_MESSAGES/vlc.mo
  188. share/locale/my/LC_MESSAGES/vlc.mo
  189. share/locale/nb/LC_MESSAGES/vlc.mo
  190. share/locale/ne/LC_MESSAGES/vlc.mo
  191. share/locale/nl/LC_MESSAGES/vlc.mo
  192. share/locale/nn/LC_MESSAGES/vlc.mo
  193. share/locale/oc/LC_MESSAGES/vlc.mo
  194. share/locale/or/LC_MESSAGES/vlc.mo
  195. share/locale/pa/LC_MESSAGES/vlc.mo
  196. share/locale/pl/LC_MESSAGES/vlc.mo
  197. share/locale/ps/LC_MESSAGES/vlc.mo
  198. share/locale/pt_BR/LC_MESSAGES/vlc.mo
  199. share/locale/pt_PT/LC_MESSAGES/vlc.mo
  200. share/locale/ro/LC_MESSAGES/vlc.mo
  201. share/locale/ru/LC_MESSAGES/vlc.mo
  202. share/locale/si/LC_MESSAGES/vlc.mo
  203. share/locale/sk/LC_MESSAGES/vlc.mo
  204. share/locale/sl/LC_MESSAGES/vlc.mo
  205. share/locale/sq/LC_MESSAGES/vlc.mo
  206. share/locale/sr/LC_MESSAGES/vlc.mo
  207. share/locale/sv/LC_MESSAGES/vlc.mo
  208. share/locale/ta/LC_MESSAGES/vlc.mo
  209. share/locale/te/LC_MESSAGES/vlc.mo
  210. share/locale/tet/LC_MESSAGES/vlc.mo
  211. share/locale/th/LC_MESSAGES/vlc.mo
  212. share/locale/tl/LC_MESSAGES/vlc.mo
  213. share/locale/tr/LC_MESSAGES/vlc.mo
  214. share/locale/uk/LC_MESSAGES/vlc.mo
  215. share/locale/uz/LC_MESSAGES/vlc.mo
  216. share/locale/vi/LC_MESSAGES/vlc.mo
  217. share/locale/wa/LC_MESSAGES/vlc.mo
  218. share/locale/zh_CN/LC_MESSAGES/vlc.mo
  219. share/locale/zh_TW/LC_MESSAGES/vlc.mo
  220. share/locale/zu/LC_MESSAGES/vlc.mo
  221. @postexec /usr/sbin/service ldconfig restart > /dev/null
  222. @postunexec /usr/sbin/service ldconfig restart > /dev/null
  223. Collapse this list.

To install the port: cd /usr/ports/multimedia/vlc/ && make install clean
To add the package: pkg install vlc

PKGNAME: vlc

distinfo:

TIMESTAMP = 1514481430
SHA256 (vlc-2.2.8.tar.xz) = 9bf046848fb56d93518881b39099b8288ee005d5ba0ddf705b6f6643b8d562ec
SIZE (vlc-2.2.8.tar.xz) = 22137276


Slave ports
  1. multimedia/vlc-qt4

NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. ffmpeg>=3.4.1,1 : multimedia/ffmpeg
  2. yasm : devel/yasm
  3. v4l_compat>=0 : multimedia/v4l_compat
  4. update-desktop-database : devel/desktop-file-utils
  5. gmake : devel/gmake
  6. pkgconf>=1.3.0_1 : devel/pkgconf
  7. msgfmt : devel/gettext-tools
  8. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  9. xorgproto>=0 : x11/xorgproto
  10. xorgproto>=0 : x11/xorgproto
  11. xcb.pc : x11/libxcb
  12. moc : devel/qt5-buildtools
Runtime dependencies:
  1. ffmpeg>=3.4.1,1 : multimedia/ffmpeg
  2. update-desktop-database : devel/desktop-file-utils
  3. gtk-update-icon-cache : graphics/gtk-update-icon-cache
  4. xcb.pc : x11/libxcb
Library dependencies:
  1. libgcrypt.so : security/libgcrypt
  2. libdvbpsi.so : multimedia/libdvbpsi
  3. libfontconfig.so : x11-fonts/fontconfig
  4. libfreetype.so : print/freetype2
  5. libidn.so : dns/libidn
  6. liba52.so : audio/liba52
  7. libavahi-common.so : net/avahi-app
  8. libdbus-1.so : devel/dbus
  9. libdca.so : multimedia/libdca
  10. libdvdnav.so : multimedia/libdvdnav
  11. libdvdread.so : multimedia/libdvdread
  12. libfaad.so : audio/faad
  13. libFLAC.so : audio/flac
  14. libgnutls.so : security/gnutls
  15. libliveMedia.so : net/liveMedia
  16. libmad.so : audio/libmad
  17. libmatroska.so : multimedia/libmatroska
  18. libmpeg2.so : multimedia/libmpeg2
  19. libogg.so : audio/libogg
  20. libopus.so : audio/opus
  21. libpng.so : graphics/png
  22. libsamplerate.so : audio/libsamplerate
  23. libspeex.so : audio/speex
  24. libtag.so : audio/taglib
  25. libtheora.so : multimedia/libtheora
  26. libtwolame.so : audio/twolame
  27. libv4l2.so : multimedia/libv4l
  28. libva.so : multimedia/libva
  29. libcddb.so : audio/libcddb
  30. libvdpau.so : multimedia/libvdpau
  31. libvorbis.so : audio/libvorbis
  32. libxcb-keysyms.so : x11/xcb-util-keysyms
  33. libiconv.so : converters/libiconv
  34. liblua-5.2.so : lang/lua52
  35. libintl.so : devel/gettext-runtime
  36. libatk-1.0.so : accessibility/atk
  37. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  38. libglib-2.0.so : devel/glib20
  39. libintl.so : devel/gettext-runtime
  40. libxml2.so : textproc/libxml2
  41. libpango-1.0.so : x11-toolkits/pango
  42. libGL.so : graphics/mesa-libs
  43. libQt5Core.so : devel/qt5-core
  44. libQt5Gui.so : x11-toolkits/qt5-gui
  45. libQt5Widgets.so : x11-toolkits/qt5-widgets
  46. libQt5X11Extras.so : x11/qt5-x11extras

This port is required by:

for Libraries for Run * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
===> The following configuration options are available for vlc-2.2.8_13,4:
     A52=on: AC-3 support via liba52
     AALIB=off: AAlib graphics library support
     ASS=off: ASS/SSA subtitle rendering
     AVAHI=on: Zeroconf support via Avahi
     CACA=off: libcaca graphics library support
     DBUS=on: D-Bus IPC system support
     DCA=on: DTS support via libdca
     DOCS=on: Build and/or install documentation
     DVDNAV=on: DVD menu navigation
     DVDREAD=on: DVD Playback support
     FAAD=on: FAAD AAC decoder support
     FLAC=on: FLAC lossless audio codec support
     FLUID=off: Fluidsynth MIDI support
     FREERDP=off: RDP support
     FRIBIDI=off: Bidirectional text support via GNU FriBidi
     GME=off: Game Music Emu (libgme) support
     GNOMEVFS2=off: GnomeVFS2 (virtual file system) support
     GNUTLS=on: SSL/TLS support via GnuTLS
     GOOM=off: Goom visualisation plugin
     HTTPD=on: httpd output streaming support
     JACK=off: JACK audio server support
     KATE=off: Kate codec support
     LIBBLURAY=off: Blu-ray discs support via libbluray
     LIBRSVG2=off: SVG vector graphics support via librsvg2
     LIBSSH2=off: SCP/SFTP support via libssh2
     LIRC=off: Infrared remote control support
     LIVEMEDIA=on: Multimedia streaming support via liveMedia
     LUA=on: Lua scripting language support
     MAD=on: MAD MP3 audio decoder support
     MATROSKA=on: Matroska container format support
     MODPLUG=off: ModPlug decoder support
     MPEG2=on: MPEG-2 video support via libmpeg2
     MTP=off: Media Transfer Protocol support
     MUSEPACK=off: MPC audio format support
     NCURSES=off: Console (text) interface support
     NLS=on: Native Language Support
     NOTIFY=off: Desktop notification support
     OGG=on: Ogg media format support
     OPTIMIZED_CFLAGS=on: Use extra compiler optimizations
     OPUS=on: Opus audio codec support
     PNG=on: PNG image format support
     PULSEAUDIO=off: PulseAudio sound server support
     QT4=off: Qt 4 toolkit support
     QT5=on: Qt 5 toolkit support
     REALRTSP=off: Real RTSP access module
     RUNROOT=off: Enable running as root
     SAMPLERATE=on: Sample rate conversion support
     SCHROEDINGER=off: Dirac video codec support via libschroedinger
     SDL=off: Simple Direct Media Layer support
     SHOUTCAST=off: SHOUTcast and Ogg Icecast support
     SIDPLAY=off: C64 sid demux support
     SKINS=off: Skins interface module
     SMB=off: SMB network protocol support
     SNDIO=off: Sndio audio support
     SPEEX=on: Speex audio format support
     STREAM=on: stream output
     TAGLIB=on: ID3 tag and Ogg comment support
     THEORA=on: Ogg Theora video codec support
     TWOLAME=on: TwoLAME MP2 audio encoder support
     UPNP=off: UPnP protocol support
     V4L=on: Video 4 Linux support
     VAAPI=on: VAAPI (GPU video acceleration) support
     VCD=on: Audio/Video CD support
     VDPAU=on: VDPAU (GPU video acceleration) support
     VORBIS=on: Ogg Vorbis audio codec support
     X11=on: X11 (graphics) support
     X264=off: H.264 video codec support via x264
     X265=off: H.265 video codec support via x265
     ZVBI=off: VBI decoding support
===> Use 'make config' to modify these settings

USES:
compiler:c++11-lib desktop-file-utils gmake iconv libtool pathfix  pkgconfig tar:xz lua gettext qt:5 gnome gl

Conflicts:
  • CONFLICTS:
    • vlc-qt4-*
    • vlc3-*
Master Sites:
  1. ftp://ftp.crans.org/pub/videolan/vlc/2.2.8/
  2. http://download.videolan.org/pub/videolan/vlc/2.2.8/
  3. http://ftp.snt.utwente.nl/pub/software/videolan/vlc/2.2.8/

Number of commits found: 487 (showing only 100 on this page)

1 | 2 | 3 | 4 | 5  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
29 Sep 2018 08:04:27
Original commit files touched by this commit  2.2.8_13,4
Revision:480899
riggs search for other commits by this committer
Bump PORTREVISION to chase update of multimedia/v4l_compat and libv4l
29 Sep 2018 07:26:03
Original commit files touched by this commit  2.2.8_12,4
Revision:480896
riggs search for other commits by this committer
Register depreciation (2018-12-31)

Details:
- No more upstream support for 2.x and qt4
- Register CONFLICTS with vlc3
- Bump PORTREVISION
11 Sep 2018 18:34:28
Original commit files touched by this commit  2.2.8_11,4
Revision:479538
zeising search for other commits by this committer
Change x11/xorgproto to become a build dep

Change x11/xorgproto to become a build time dependency when added to
USE_XORG.  Change the dependency to be on the port, rather than a file the
port installs.
Fix fallout.
Bump portrevision on depending ports.

PR:		230909
Reviewed by:	eadler
Approved by:	portmgr (antoine)
Obtained
from:	https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/xorgproto
exp-run:	antoine
Differential Revision:	https://reviews.freebsd.org/D16906
03 Sep 2018 10:12:59
Original commit files touched by this commit  2.2.8_10,4
Revision:478852
jhale search for other commits by this committer
Fix build with Qt 5.11

PR:		230884
01 Sep 2018 17:05:48
Original commit files touched by this commit  2.2.8_10,4
Revision:478711
antoine search for other commits by this committer
Switch default version of samba to 4.7
Samba 4.6 will be discontinued in a few weeks

Reviewed by:	mat
Differential Revision:	https://reviews.freebsd.org/D16904
10 Aug 2018 00:55:12
Original commit files touched by this commit  2.2.8_9,4
Revision:476802
jbeich search for other commits by this committer
multimedia/x264: update to 0.155.2917

- HI10P is always built after
https://git.videolan.org/?p=x264.git;a=commitdiff;h=71ed44c73124

Changes:	https://git.videolan.org/?p=x264.git;a=shortlog;h=0a84d986e7020f8344f00752e3600b9769cc1e85
ABI:		https://abi-laboratory.pro/tracker/timeline/x264/
31 Jul 2018 18:41:30
Original commit files touched by this commit  2.2.8_8,4
Revision:476013
zeising search for other commits by this committer
Switch to xorgproto instead of individual packages

Upstream used to distribute protocol headers as separate packages, but has
decided to merge those to a common package, named xorgproto.  This update
tracks that change.

* Add a new port, x11/xorgproto, with are protocol headers for xorg.
* Hook the new protocol port to the build and to infrastructure in
  bsd.xorg.mk.
* Update all ports with a dependency on any of the old *proto packages to
  instead depend on xorgproto.  Bump portrevision.
* Delete the old *proto packages, update MOVED.

PR:		230023
Submitted by:	zeising
Approved by:	portmgr (antoine)
exp-run by:	antoine
29 Jul 2018 22:18:46
Original commit files touched by this commit  2.2.8_7,4
Revision:475857
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which
has now moved from GCC 6 to GCC 7 by default.

This includes ports
 - featuring USE_GCC=yes or USE_GCC=any,
 - featuring USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and those
 - with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
   c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.

PR:		222542
28 Jun 2018 17:39:55
Original commit files touched by this commit  2.2.8_6,4
Revision:473503 This port version is marked as vulnerable.
tcberner search for other commits by this committer
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk

From now on, ports that depend on Qt4 will have to set
	USES=		qt:4
	USE_QT=		foo bar
ports depending on Qt5 will use
	USES=		qt:5
	USE_QT=		foo bar

PR:		229225
Exp-run by:	antoine
Reviewed by:	mat
Approved by:	portmgr (antoine)
Differential Revision:	-https://reviews.freebsd.org/D15540
01 Jun 2018 22:16:12
Original commit files touched by this commit  2.2.8_6,4
Revision:471300 This port version is marked as vulnerable.
riggs search for other commits by this committer
Bump PORTREVISIONS to chase update to audio/fluidsynth 1.1.11

PR:		228265
09 May 2018 20:27:52
Original commit files touched by this commit  2.2.8_5,4
Revision:469466 This port version is marked as vulnerable.
swills search for other commits by this committer
Bump PORTREVISION on more opencv consumers due to opencv update
02 May 2018 15:07:27
Original commit files touched by this commit  2.2.8_4,4
Revision:468844 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/ffmpeg: update to 4.0

- FFSERVER support was removed upstream
- libressl now uses libtls backend instead of patching openssl one
- Clang i386 no longer uses 16-byte aligned stack

Changes:	https://git.ffmpeg.org/gitweb/ffmpeg.git/blob/n4.0:/Changelog
ABI:		https://abi-laboratory.pro/tracker/timeline/ffmpeg/
PR:		227726
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D15175
27 Apr 2018 12:53:23
Original commit files touched by this commit  2.2.8_3,4
Revision:468425 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/vlc: unbreak with ffmpeg 4.0

codec/avcodec/audio.c:99:37: error: use of undeclared identifier
'FF_INPUT_BUFFER_PADDING_SIZE'
                av_malloc( i_size + FF_INPUT_BUFFER_PADDING_SIZE );
                                    ^
codec/avcodec/subtitle.c:147:50: error: use of undeclared identifier
'FF_INPUT_BUFFER_PADDING_SIZE'
                               block->i_buffer + FF_INPUT_BUFFER_PADDING_SIZE);
                                                 ^
codec/avcodec/video.c:254:36: error: use of undeclared identifier
'CODEC_FLAG_GRAY'
        p_sys->p_context->flags |= CODEC_FLAG_GRAY;
                                   ^
codec/avcodec/encoder.c:525:20: error: no member named 'border_masking' in
'struct AVCodecContext'
        p_context->border_masking = p_sys->f_border_masking;
        ~~~~~~~~~  ^
(Only the first 15 lines of the commit message are shown above View all of this commit message)
22 Apr 2018 18:14:25
Original commit files touched by this commit  2.2.8_3,4
Revision:468044 This port version is marked as vulnerable.
riggs search for other commits by this committer
Bump PORTREVISION for ports depending on libmatroska

MFH:		2018Q2
17 Feb 2018 21:45:30
Original commit files touched by this commit  2.2.8_2,4
Revision:462195 This port version is marked as vulnerable.
yuri search for other commits by this committer
multimedia/libbluray: Update to 1.0.2

Additional port changes:
* Changed to DISTVERSION
* Removed USES=autoreconf (not needed)
* Added post-extract creating symlink linux->freebsd

Bumped 6 depending ports.

Reported by:	portscout
Approved by:	tcberner (mentor)
Differential Revision:	https://reviews.freebsd.org/D14406
11 Feb 2018 20:19:12
Original commit files touched by this commit  2.2.8_1,4
Revision:461527 This port version is marked as vulnerable.
madpilot search for other commits by this committer
- Update multimedia/x265 to 2.6
- Use the distfile provided by the VideoLAN project
- Add options for HI10P and HI12P (available only for amd64)
- Add DEBUG option
- Add OPTIMIZED_CFLAGS option
- Force using clang 5.0 on 10.4. Base provided clang fails during
  compilation
- Chase shlib bump in dependent ports

PR:		225431
Submitted by:	daniel.engberg.lists@pyret.net
Approved by:	Maintainer timeout
01 Jan 2018 10:28:51
Original commit files touched by this commit  2.2.8,4
Revision:457763 This port version is marked as vulnerable.
riggs search for other commits by this committer
Update to upstream version 2.2.8

Additional details:
- Update FFmpeg version required to 3.4.1,1
- Clean some unrecognized options
- Fix build with net/freerdp and audio/libsidplay2
- Drop DIRAC option because the module was removed upstream
  (dirac codec is still supported via schroedinger)

PR:		224660
Submitted by:	cpm
29 Dec 2017 02:55:42
Original commit files touched by this commit  2.2.6_5,4
Revision:457488 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/{lib,}x264: update to 0.152.2854

Changes:	https://git.videolan.org/?p=x264.git;a=shortlog;h=e9a5903edf8ca59ef20e6f4894c196f135af735e
23 Dec 2017 07:03:21
Original commit files touched by this commit  2.2.6_4,4
Revision:457024 This port version is marked as vulnerable.
antoine search for other commits by this committer
Change default version of samba from 4.4 to 4.6

Reviewed by:	mat
With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D13529
12 Dec 2017 21:29:57
Original commit files touched by this commit  2.2.6_3,4
Revision:456184 This port version is marked as vulnerable.
madpilot search for other commits by this committer
- Update libva to 2.0.0
- Update libva-intel-driver to 2.0.0
- Update libva-utils to 2.0.0
- Bump dependent ports due to shlib bump
- Import upstream patch to fix multimedia/mpv [1]
- Import upstream patch to fix multimedia/gstreamer1-vaapi [2]

Approved by:	cpm [1], multimedia (timeout) [2]
Obtained
from:	https://github.com/mpv-player/mpv/commit/2ecf240b1cd20875991a5b18efafbe799864ff7f
[1]
		https://cgit.freedesktop.org/gstreamer/gstreamer-vaapi/commit/gst-libs/gst/vaapi/gstvaapiutils.c?id=777bba473e3ed1c7b8b7f7f0322892851c70dfd9
[2]
Differential Revision:	https://reviews.freebsd.org/D12761
21 Oct 2017 06:50:50
Original commit files touched by this commit  2.2.6_2,4
Revision:452570 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/ffmpeg: update to 3.4

Notable changes:
- i386/amd64 now depend on NASM per
https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/4f9297ac3b39
- NETCDF is now MYSOFA but the dependency doesn't exist in ports yet
- SCHROEDINGER is gone per
https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/220b24c7c9
- DRM, LIBRSVG2, LIBXML2 are new options
- ABI isn't completely compatible: some structs have changed

Minor cleanup:
- Don't pass --disable-{in,out}dev when it's already blocked by disabled
dependency
- Drop redundant "Enable" from option descriptions
- Switch CDIO_DESC to use Mk/bsd.options.desc.mk

Changes:	https://git.ffmpeg.org/gitweb/ffmpeg.git/blob/n3.4:/Changelog
ABI:		https://abi-laboratory.pro/tracker/timeline/ffmpeg/
PR:		223057
Exp-run by:	antoine
15 Oct 2017 14:05:04
Original commit files touched by this commit  2.2.6_1,4
Revision:452147 This port version is marked as vulnerable.
madpilot search for other commits by this committer
Retire WITHOUT_DEBUG flag.

The flag has partial support across the tree, and the same effect
can be obtained by using ".undef WITH_DEBUG".

Reviewed by:		mat, rene
Approved by:		portmgr (rene)
Differential Revision:	https://reviews.freebsd.org/D12548
10 Sep 2017 20:55:39
Original commit files touched by this commit  2.2.6_1,4
Revision:449591 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
   c++14-lang, c++0x, c11, or gcc-c++11-lib.

PR:		219275
26 May 2017 07:23:20
Original commit files touched by this commit  2.2.6,4
Revision:441756 This port version is marked as vulnerable.
riggs search for other commits by this committer
Update to upstream version 2.2.6

Details:
This is a bugfix release for the recently discovered
subtitle remote vulnerability, see
http://blog.checkpoint.com/2017/05/23/hacked-in-translation/
In addition to the statements in this blog post, the VLC devs
added bounds checks and string termination in multiple places
in the subtitle demuxer. It is hence possible that, contrary
to the blog post, this issue was not fixed completely in
version 2.2.5.1

MFH:		2017Q2
23 May 2017 05:03:16
Original commit files touched by this commit  2.2.5.1_1,4
Revision:441503 This port version is marked as vulnerable.
rezny search for other commits by this committer
Revision bump of all ports with USE_GL after consolidation of mesa-libs

Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D10845
13 May 2017 12:24:25
Original commit files touched by this commit  2.2.5.1,4
Revision:440832 This port version is marked as vulnerable.
riggs search for other commits by this committer
Update to upstream version 2.2.5.1

MFH:		2017Q2
25 Apr 2017 08:20:31
Original commit files touched by this commit  2.2.4_14,4
Revision:439367 This port version is marked as vulnerable.
riggs search for other commits by this committer
Chase ffmpeg 3.3 update (ABI changes)

PR:		218658
Submitted by:	riggs
23 Apr 2017 10:23:13
Original commit files touched by this commit  2.2.4_13,4
Revision:439215 This port version is marked as vulnerable.
ehaupt search for other commits by this committer
Chase multimedia/libmatroska update.
01 Apr 2017 15:23:32
Original commit files touched by this commit  2.2.4_12,4
Revision:437439 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using using Mk/bsd.octave.mk which in turn has USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
   c++11-lang, c++0x, c11, or gcc-c++11-lib.

PR:		216707
25 Mar 2017 23:37:05
Original commit files touched by this commit  2.2.4_11,4
Revision:436925 This port version is marked as vulnerable.
antoine search for other commits by this committer
Switch default version of samba from 4.3 to 4.4

With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D10131
21 Mar 2017 21:59:31
Original commit files touched by this commit  2.2.4_10,4
Revision:436659 This port version is marked as vulnerable.
antoine search for other commits by this committer
- Add USES=samba to handle dependency on samba
  Valid ARGS:  build, env, lib, run (default: build,run)
- Add SAMBA_DEFAULT to bsd.default-versions.mk (default: 4.3)
- Remove obsolete samba36 ports
- Modify samba4x ports to install libsmbclient
- Convert the ports tree to USES=samba

Reviewed by:	mat
Differential Revision:	https://reviews.freebsd.org/D8919
20 Feb 2017 18:00:05
Original commit files touched by this commit  2.2.4_9,4
Revision:434479 This port version is marked as vulnerable.
riggs search for other commits by this committer
Chase libass runtime fix r434477; bump PORTREVISION on consumers

PR:		216837
Reported by:	cpm
MFH:		2017Q1
18 Feb 2017 15:11:37
Original commit files touched by this commit  2.2.4_8,4
Revision:434358 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Add upstream patch to fix the build with the SKINS option after r434332.

PR:		217051
18 Feb 2017 08:20:45
Original commit files touched by this commit  2.2.4_8,4
Revision:434332 This port version is marked as vulnerable.
riggs search for other commits by this committer
Use c++11 by default, in preparation for Qt 5.7.1 update

PR:		217051
Submitted by:	rakuco
05 Feb 2017 08:17:43
Original commit files touched by this commit  2.2.4_7,4
Revision:433383 This port version is marked as vulnerable.
riggs search for other commits by this committer
Update libass to upstream version 0.13.6; bump PORTREVISION on consumers

Reported by:	robert.burmeister@utoledo.edu (via email)
30 Dec 2016 08:08:20
Original commit files touched by this commit  2.2.4_6,4
Revision:429961 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/libass: belatedly bump PORTREVISION after r429876

ASS_Style grew in size by |int Justify| member. Old consumers may
not initialize it leading to crashes.

Reported by:	Kevin Oberman
11 Dec 2016 15:22:47
Original commit files touched by this commit  2.2.4_5,4
Revision:428352 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/ffmpeg: update to 3.2.2

Changes:	https://git.ffmpeg.org/gitweb/ffmpeg.git/blob/n3.2.2:/Changelog
PR:		207547
Submitted by:	riggs, ebirth@b0ss.net (libressl fix)
Exp-run by:	antoine (3 tries)
04 Dec 2016 13:18:03
Original commit files touched by this commit  2.2.4_4,4
Revision:427782 This port version is marked as vulnerable.
riggs search for other commits by this committer
Add non-default OPTION for SNDIO

PR:		212024
Submitted by:	t@tobik.me
20 Nov 2016 09:38:09
Original commit files touched by this commit  2.2.4_4,4
Revision:426566 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISIONS for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.8.5 to GCC 4.9.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

In particular that is ports with USE_GCC=yes, USE_GCC=any, or one of
gcc-c++11-lib, openmp, nestedfct, c++11-lib as well as c++14-lang,
c++11-lang, c++0x, c11 requested via USES=compiler.
13 Nov 2016 14:43:42
Original commit files touched by this commit  2.2.4_3,4
Revision:426055 This port version is marked as vulnerable.
riggs search for other commits by this committer
Fix build with ffmpeg 3.x

PR:		214234
Submitted by:	jbeich
05 Nov 2016 20:10:46
Original commit files touched by this commit  2.2.4_2,4
Revision:425445 This port version is marked as vulnerable.
bapt search for other commits by this committer
Update to libdvbpsi 1.3.0
21 Oct 2016 12:51:41
Original commit files touched by this commit  2.2.4_1,4
Revision:424411  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
${RM} already has -f.

PR:		213570
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
23 Sep 2016 13:14:29
Original commit files touched by this commit  2.2.4_1,4
Revision:422672 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/x264: update to 0.148.2708

Changes:	https://git.videolan.org/?p=x264.git;a=shortlog;h=86b71982e131eaa70125f8d0e725fcade9c4c677
Differential Revision:	https://reviews.freebsd.org/D7958
Approved by:	koobs (maintainer)
09 Sep 2016 19:42:46
Original commit files touched by this commit  2.2.4,4
Revision:421635 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like
"CC foo.c"). CMake and ninja enable this by default, some autotools
using ports do as well. This is unacceptable because we need complete
build logs at any time, so we now switch to verbose build logs
unconditionally. Note that this change deliberately affects ALL
builds and not only package builds on cluster, because we need to
be sure that user experiencing failure can always provide informative
build log regardless of settings and without rerunning the build.

Change summary:

- Always do verbose builds for cmake, ninja and GNU configure (the
  latter includes check if --disable-silent-rules is actually supported
  by the configure script; there are isolated cases when it's not true)
(Only the first 15 lines of the commit message are shown above View all of this commit message)
11 Jun 2016 09:36:43
Original commit files touched by this commit  2.2.4,4
Revision:416711 This port version is marked as vulnerable.
riggs search for other commits by this committer
Update to upstream release 2.2.4, fix remote attack CVE-2016-5108

Detailed changelog (BSD relevant excerpts):

Decoder:
* Fix crash in G.711 wav files
* Fix mp3 crash in libmad
* Fix out-of-bound write in adpcm QT IMA codec (CVE-2016-5108)

Qt:
* Fix resizing issues

Translations:
* Update of Bulgarian, Catalan, German, French, Italian, Marathi, Norwegian
  Bokmal, Norwegian Nynorsk, Portuguese, Slovak, Spanish (Mexico), Swedish,
  Simplified Chinese, and Traditional Chinese translations

MFH:		2016Q2
Security:	CVE-2016-5108
01 Jun 2016 06:17:51
Original commit files touched by this commit  2.2.3,4
Revision:416225 This port version is marked as vulnerable.
riggs search for other commits by this committer
Fix build with libc++ 3.8.0

VLC brings its own header for atomic operations which defines a whole
bunch of atomic macros, conflicting with the ones in the C++ standard
<atomic> header. This changeset works around those.

PR:		209722
Submitted by:	dim
27 May 2016 16:09:10
Original commit files touched by this commit  2.2.3,4
Revision:415944 This port version is marked as vulnerable.
riggs search for other commits by this committer
Update to upstream version 2.2.3

Differential Revision:	https://reviews.freebsd.org/D6373
19 May 2016 10:44:12
Original commit files touched by this commit  2.2.1_9,4
Revision:415499 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix trailing whitespace in pkg-descrs, categories [g-n]*

Approved by:	portmgr blanket
03 May 2016 01:02:26
Original commit files touched by this commit  2.2.1_9,4
Revision:414501 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/ffmpeg: enable VAAPI and VDPAU by default

Build VAAPI and VDPAU backends, so ports using system ffmpeg can take
advantage of GPU-assisted decoding. Also, propagate defaults to consumers.

Approved by:	cpm, multimedia (riggs), maintainer timeout (3 weeks)
Differential Revision:	https://reviews.freebsd.org/D5898
01 Apr 2016 14:16:20
Original commit files touched by this commit  2.2.1_8,4
Revision:412348 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.

With hat:	portmgr
Sponsored by:	Absolight
27 Mar 2016 14:58:00
Original commit files touched by this commit  2.2.1_8,4
Revision:411990 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol
  supported by libgnutls-dane and gnutls-cli.  Also clarify the option
  description.
- Add an IDN option.
- libgnutls-openssl has been removed in 3.4.  Some ports used this library
  in their LIB_DEPENDS but no port actually required it.
- Some old API functions have been removed.  Ports that used these have been
  updated or patched to use the new API.
- Add a patch to print/cups to prevent overlinking of libgnutls.so.
- Bump PORTREVISION on dependent ports.

net-im/jabber: This port used the old API to give users fine grained
control over which crypto algorithms were used via a configuration file.
It's not immediately obvious how to port this to the new API so the port
always uses the defaults now.

www/hydra: Mark BROKEN.  This uses more removed calls than the other ports,
is said to be alpha quality and not fully functional and has been abandoned
10 years ago.

PR:		207768
Exp-run by:	antoine
Approved by:	portmgr (antoine)
22 Feb 2016 12:32:47
Original commit files touched by this commit  2.2.1_7,4
Revision:409337 This port version is marked as vulnerable.
kwm search for other commits by this committer
Add a build depend on v4l_compat when the V4L option is enabled (which is
by default). So dvb support is enabled and build. This allows vlc to
understand dvb:// uri's again.

PR:		207397
Submitted by:	Tobias Kortkamp <t@tobik.me>
05 Dec 2015 09:15:41
Original commit files touched by this commit  2.2.1_6,4
Revision:403038 This port version is marked as vulnerable.
jbeich search for other commits by this committer
multimedia/x265: update to 1.8

ABI isn't compatible, so bump PORTREVISION in consumers.

PR:		204990
Submitted by:	Anton Sayetsky <vsasjason@gmail.com>
15 Oct 2015 14:55:14
Original commit files touched by this commit  2.2.1_5,4
Revision:399346  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
Drop 8 support.

With hat:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3694
18 Aug 2015 17:41:32
Original commit files touched by this commit  2.2.1_5,4
Revision:394625 This port version is marked as vulnerable.
delphij search for other commits by this committer
Apply vendor changeset ce91452:

demux: mp4: correctly match release function

Obtained from:	VLC
MFH:		2015Q3
02 Aug 2015 15:03:20
Original commit files touched by this commit  2.2.1_4,4
Revision:393429 This port version is marked as vulnerable.
tijl search for other commits by this committer
By default libtool replaces -export-symbols <file> with -retain-symbols-file
<file> on ELF systems, but this doesn't really do what -export-symbols is
meant to do.  On GNU ELF systems it converts <file> to a simple version
script first and then uses -version-script instead of -retain-symbols-file.
Let USES=libtool patch libtool scripts to do this on all systems with GNU
ld(1).

Bump PORTREVISION on all ports where the build log contains -export-symbols.

audio/calf: This port builds a module that now exports only one function,
but it also builds a number of executables that link to this module and
expect to see other functions.  Because it's already a bit dodgy to link to
a module (libtool warns about this) let the module continue to export only
one function and instead build an ordinary library from the same source that
the executables can link to.  Fix a number of other issues in the same
(Only the first 15 lines of the commit message are shown above View all of this commit message)
11 Jul 2015 11:22:47
Original commit files touched by this commit  2.2.1_3,4
Revision:391732 This port version is marked as vulnerable.
nox search for other commits by this committer
- Update to compile with Lua 5.3 support.
- Bump PORTREVISION.

PR:		201470
Submitted by:	milios@ccsys.com
03 Jul 2015 07:02:44
Original commit files touched by this commit  2.2.1_2,4
Revision:391217 This port version is marked as vulnerable.
koobs search for other commits by this committer
multimedia/{lib}x264: Update to 0.144.2533 and major refactor

- Update to 0.144.2533 (from upstream stable branch) [1]
- Switch x264 and libx264 ports to master/slave ports respectively
- Bump PORTREVISION for dependent ports as the shared library version
  has changed.

multimedia/x264:

- Clean up and update "updating instructions" in Makefile header
- Tweak COMMENT
- Only LIB_DEPENDS on libx264 and add PLIST_FILES if this isn't the
  libx264 port.
- Allow COMMENT, USES, OPTIONS_*, CONFIGURE_ARGS to be overriden in
  libx264 port.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
29 Jun 2015 00:28:58
Original commit files touched by this commit  2.2.1_1,4
Revision:390874 This port version is marked as vulnerable.
adamw search for other commits by this committer
Update multimedia/x265 to 1.7, and bump PORTREVISION on its consumers.
02 May 2015 14:24:13
Original commit files touched by this commit  2.2.1,4
Revision:385179 This port version is marked as vulnerable.
nox search for other commits by this committer
Update to 2.2.1 - changelog is here:

	https://www.videolan.org/developers/vlc-branch/NEWS
19 Apr 2015 19:50:48
Original commit files touched by this commit  2.2.0_4,4
Revision:384322 This port version is marked as vulnerable.
adamw search for other commits by this committer
Update x265 to 1.6, and bump PORTREVISION on its consumers for shlib
version change.
28 Mar 2015 21:39:50
Original commit files touched by this commit  2.2.0_3,4
Revision:382558 This port version is marked as vulnerable.
nox search for other commits by this committer
- Add Qt 4 knob and slave port to multimedia/vlc with appropriate CONFLICTS.
- Remove SIDPLAY knob from vlc as it's now broken:

	/usr/bin/ld:
/usr/local/lib/sidplay/builders/libresid-builder.a(resid-builder.o): relocation
R_X86_64_32S against `_ZTV12ReSIDBuilder' can not be used when making a shared
object; recompile with -fPIC

- Unbreak phonon-vlc by switching it to using vlc-qt4 slave port. [1]
- Bump PORTREVISIONs.

Reported by:	makc [1]
15 Mar 2015 14:15:45
Original commit files touched by this commit  2.2.0_2,4
Revision:381333 This port version is marked as vulnerable.
nox search for other commits by this committer
- Switch qt5 buildtools dep to be a build dep only.
- Bump PORTREVISION.

Submitted by:	makc (via private email)
14 Mar 2015 20:21:55
Original commit files touched by this commit  2.2.0_1,4
Revision:381293 This port version is marked as vulnerable.
nox search for other commits by this committer
- Add missing dependencies on yasm and minizip.
- Bump PORTREVISION.
14 Mar 2015 19:39:50
Original commit files touched by this commit  2.2.0,4
Revision:381292 This port version is marked as vulnerable.
nox search for other commits by this committer
Update to 2.2.0 - changelog is here:

	https://www.videolan.org/developers/vlc-branch/NEWS
03 Feb 2015 07:48:24
Original commit files touched by this commit  2.1.5_18,4
Revision:378342 This port version is marked as vulnerable.
martymac search for other commits by this committer
Update multimedia/libdvdread and multimedia/libdvdnav

- Update multimedia/libdvdread to version 5.0.1
- Update multimedia/libdvdnav to version 5.0.2
- Bump revisions of ports that depend on multimedia/libdvdnav
  (library version is going backwards from 4.2.1 to 4.1.2)
- Ports depending on multimedia/libdvdread do not need to be bumped
  (the library keeps being numbered 4.1.2 and is binary compatible with the
  previous version)
02 Jan 2015 18:46:34
Original commit files touched by this commit  2.1.5_17,4
Revision:376062 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.6.1 -> 1.6.2, bump depends

Changes:
- src/sexp.c (do_vsexp_sscan): Return error for invalid args.
- cipher/md.c (_gcry_md_info): Fix a segv in case of calling
  with wrong parameters.
- cipher/primegen.c (_gcry_generate_elg_prime): Change to return an
  error code, possible NULL deref in call to prime generator.
- cipher/dsa.c (generate): Take care of new return code.
- cipher/elgamal.c (generate): Change to return an error code.  Take
	care of _gcry_generate_elg_prime return code.
- ecc: Support the non-standard 0x40 compression flag for EdDSA.
- mpi: Extend the internal mpi_get_buffer.
- mpi: Fix regression for powerpc-apple-darwin detection.
- Fix bug inhibiting the use of the sentinel attribute in src/gcrypt.h.in
(Only the first 15 lines of the commit message are shown above View all of this commit message)
31 Dec 2014 12:58:26
Original commit files touched by this commit  2.1.5_16,4
Revision:375881 This port version is marked as vulnerable.
nox search for other commits by this committer
- Add LIVEMEDIA to OPTIONS_DEFAULT.
- Bump PORTREVISION.

PR:		196073
Submitted by:	thierry
25 Dec 2014 20:54:43
Original commit files touched by this commit  2.1.5_15,4
Revision:375598 This port version is marked as vulnerable.
bapt search for other commits by this committer
Bump portrevision after png update
25 Dec 2014 19:04:27
Original commit files touched by this commit  2.1.5_14,4
Revision:375594 This port version is marked as vulnerable.
antoine search for other commits by this committer
Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgrade
19 Dec 2014 18:49:30
Original commit files touched by this commit  2.1.5_14,4
Revision:374965 This port version is marked as vulnerable.
riggs search for other commits by this committer
Avoid pulling in x11 depencencies if not necessary
- Use INSTALL_ICONS only when X11 OPTION is enabled
- Bump PORTREVISION

Reported-by:	olgeni
13 Dec 2014 18:49:26
Original commit files touched by this commit  2.1.5_13,4
Revision:374673 This port version is marked as vulnerable.
riggs search for other commits by this committer
- Fix buffering in OSS backend
- Fix QT4 GUI layout issue

While one it:
- Use INSTALLS_ICONS

PR:		193807
Submitted by:	hselasky@FreeBSD.org
08 Dec 2014 16:48:41
Original commit files touched by this commit  2.1.5_12,4
Revision:374303 This port version is marked as vulnerable.
tijl search for other commits by this committer
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it.  Bump PORTREVISION on their dependent
ports except the ones that depend on these:

audio/libogg
audio/libvorbis
devel/pcre
ftp/curl
graphics/jpeg
graphics/libart_lgpl
graphics/tiff
textproc/expat2
textproc/libxslt

In these cases the same trick as in the recent gettext update is used.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
02 Dec 2014 03:23:14
Original commit files touched by this commit  2.1.5_11,4
Revision:373737 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Drop .la files from multimedia/dirac and multimedia/schroedinger
- Bump dependent ports as .so versions have changed
- While here, remove @dirrm* from plists and add missing empty directory to
plist of multimedia/lives

Approved by:	portmgr blanket
22 Nov 2014 16:23:34
Original commit files touched by this commit  2.1.5_10,4
Revision:373073 This port version is marked as vulnerable.
xmj search for other commits by this committer
multimedia/x264: General overhaul

- Split x264 into two ports: the CLI application (x264), and the library
  (libx264). This will allow x264 to use lavf and friends from ffmpeg for
  decoding and demuxing while preventing a circular dependency between the
  two: x264 can depend on ffmpeg, but ffmpeg will depend on libx264 rather
  than x264.
- Add the LAVF option to the CLI port, making the dependency on ffmpeg
  optional.
- Update to 0.142.2455.
- Amend fixes to local patches so that they can apply to the new upstream
  files.
- Provide the git revision and other version information to the build
  environment, allowing the CLI binary to display this information (like the
  Windows builds).
- Remove unsupported build options (X11_OUTPUT).
- Ensure that the library and CLI ports each have the appropriate options.
- Add notes for future contributors who wish to update the ports.
- Bump PORTREVISION for all dependent ports.

PR:           187805
Differential Revision:	https://reviews.freebsd.org/D1159
Submitted by: Andrew Berg <aberg010@my.hennepintech.edu>
Approved by:  koobs (maintainer, mentor)
11 Sep 2014 10:45:59
Original commit files touched by this commit  2.1.5_9,4
Revision:367917 This port version is marked as vulnerable.
riggs search for other commits by this committer
- Mark IGNORE when trying to use pulseaudio with vlc on
  pre-9.x systems due to an rtld issue during build

PR:		186629
Submitted by:	bobf@mrp3.com
10 Sep 2014 20:50:37
Original commit files touched by this commit  2.1.5_9,4
Revision:367888 This port version is marked as vulnerable.
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
10 Sep 2014 14:40:18
Original commit files touched by this commit  2.1.5_8,4
Revision:367855 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Drop .la files for multimedia/libkate, no dependees require them
- Add LICENSE_FILE
- Bump dependent ports as .so version has changed

Approved by:	portmgr blanket
31 Aug 2014 11:54:17
Original commit files touched by this commit  2.1.5_7,4
Revision:366746 This port version is marked as vulnerable.
tijl search for other commits by this committer
converters/fribidi:
- Add USES=libtool and bump dependent ports
- Add INSTALL_TARGET=install-strip
30 Aug 2014 18:18:14
Original commit files touched by this commit  2.1.5_6,4
Revision:366659 This port version is marked as vulnerable.
tijl search for other commits by this committer
dns/libidn:
- Add USES=libtool and bump dependent ports
- Add INSTALL_TARGET=install-strip
- Always install libidn-components.png because it is used by libidn.info
- Add -lintl to Libs.private instead of Libs in libidn.pc
11 Aug 2014 13:59:47
Original commit files touched by this commit  2.1.5_5,4
Revision:364613 This port version is marked as vulnerable.
tijl search for other commits by this committer
comms/lirc:
- Fix missing -lusb [1]
- Convert to USES=libtool and bump dependent ports
- Add INSTALL_TARGET=install-strip
- Use @sample

Reported by:	sbruno [1]
04 Aug 2014 15:46:12
Original commit files touched by this commit  2.1.5_4,4
Revision:364024 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Switch audio/musepack to USES=libtool, drop .la files
- Bump dependent ports as .so version has changed
- Fix audio/abcde by requiring python
- Fix audio/moc plist with MUSEPACK enabled

Approved by:	portmgr blanket
01 Aug 2014 12:54:46
Original commit files touched by this commit  2.1.5_3,4
Revision:363706 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Switch devel/libzvbi to USES=libtool, drop .la files
- Bump dependent ports as .so version has changed

Approved by:	portmgr blanket
30 Jul 2014 03:57:24
Original commit files touched by this commit  2.1.5_2,4
Revision:363436 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.5.3_3 -> 1.6.1

- Update to 1.6.1
- Remove some unneeded patches
- Fix pkg-plist
- report configure bug upstream
  https://bugs.g10code.com/gnupg/issue1668
- report API breakage downstream and find that MacPorts had the same issue
  https://rt.cpan.org/Ticket/Display.html?id=97201
- bump PORTREVISION for dependent ports (approx. 100 ports)
- Thanks to exp-run by antoine@ to find ports that break
- patch ports that would otherwise break
  security/shishi with PR 192164 is already committed
  [1] devel/ccrtp
  [2] editors/abiword
  [3] security/p5-Crypt-GCrypt

PR:		191256, 192162 [1], 192163 [2], 192166 [3]
Submitted by:	Carlos Jacobo Puga Medina <cjpugmed@gmail.com>
Approved by:	maintainer timeout, antoine (exp-run), portmgr (implicit)
23 Jul 2014 09:54:02
Original commit files touched by this commit  2.1.5_1,4
Revision:362645 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and
  adjust all ports that depend on security/gnutls3
- Update mail/anubis to version 4.2 which supports gnutls 3.x
- Update mail/libvmime to a development snapshot (recommended by upstream
  developers)

PR:		191274
Exp-run by:	antoine
Approved by:	portmgr (antoine)
22 Jul 2014 21:31:12
Original commit files touched by this commit  2.1.5,4
Revision:362585 This port version is marked as vulnerable.
nox search for other commits by this committer
Fix build with GME knob.

PR:		192044
21 Jul 2014 20:19:50
Original commit files touched by this commit  2.1.5,4
Revision:362477 This port version is marked as vulnerable.
nox search for other commits by this committer
Update to 2.1.5 - changelog is here:

	https://www.videolan.org/developers/vlc-branch/NEWS
20 Jul 2014 17:34:08
Original commit files touched by this commit  2.1.4_10,4
Revision:362339 This port version is marked as vulnerable.
nox search for other commits by this committer
- Fix LIRC knob so that liblirc_client is actually found again.
- Bump PORTREVISION.
18 Jul 2014 11:02:59
Original commit files touched by this commit  2.1.4_9,4
Revision:362200 This port version is marked as vulnerable.
tijl search for other commits by this committer
audio/rhythmbox: drop :keepla
multimedia/banshee: add USES=libtool and INSTALL_TARGET=install-strip
multimedia/libmtp: add USES=libtool and INSTALL_TARGET=install-strip
multimedia/libaacs:
- USES=libtool pathfix
- Add INSTALL_TARGET=install-strip
- Avoid USE_AUTOTOOLS
- Remove plist target, superseded by makeplist
multimedia/libbluray:
- USES=libtool pathfix
- Add INSTALL_TARGET=install-strip
- Avoid USE_AUTOTOOLS
- Remove plist target, superseded by makeplist
- Use OPTIONS_SUB
- Replace patch with post-patch command

Bump dependent ports
12 Jul 2014 18:03:24
Original commit files touched by this commit  2.1.4_8,4
Revision:361631 This port version is marked as vulnerable.
nox search for other commits by this committer
- Fix build with MUSEPACK knob.
- Replace another occurence of /usr/local with LOCALBASE.

PR:		191836
Submitted by:	mikhail.rokhin@gmail.com
11 Jul 2014 14:12:31
Original commit files touched by this commit  2.1.4_8,4
Revision:361536 This port version is marked as vulnerable.
tijl search for other commits by this committer
Add a global OPUS_DESC
11 Jul 2014 10:26:02
Original commit files touched by this commit  2.1.4_8,4
Revision:361520 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Add USES=libtool to devel/upnp and bump dependent ports
- Add USES=pathfix and INSTALL_TARGET=install-strip
- Add a patch to fix definitions of ITHREAD_MUTEX_*

Approved by:	portmgr (implicit, bump unstaged port)
10 Jun 2014 12:38:10
Original commit files touched by this commit  2.1.4_7,4
Revision:357305 This port version is marked as vulnerable.
tijl search for other commits by this committer
Fix compilation on i386 when OPTIMIZED_CFLAGS option is off.

PR:		190614
09 Jun 2014 14:50:22
Original commit files touched by this commit  2.1.4_7,4
Revision:357163 This port version is marked as vulnerable.
bapt search for other commits by this committer
Update libdvbpsi to 1.2.0
Strip binaries
USES=libtool
Use options helpers
Chase library change
03 Jun 2014 09:20:33
Original commit files touched by this commit  2.1.4_6,4
Revision:356312 This port version is marked as vulnerable.
tijl search for other commits by this committer
Fix pkg-plist when NLS option is off.

Reported by:	Thomas Mueller <tmueller@sysgo.com>
02 Jun 2014 20:42:44
Original commit files touched by this commit  2.1.4_6,4
Revision:356249 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Remove libproxy dependency.  I cannot find any references to it.
- Add libidn dependency.  It is always picked up when detected by
  configure.
- Add libxml2 dependency (USE_GNOME=libxml2).  It's actually an optional
  dependency but it is used by several other plugins.
- Replace OSVERSION+clang tests with USES=compiler:c11.
- Replace post-patch command with USES=pathfix.
- Add some more --enable-* flags to CONFIGURE_ARGS to make sure configure
  doesn't silently ignore problems with dependencies.
- Add some more --disable-* flags to CONFIGURE_ARGS to make sure
  configure doesn't auto-enable them.
- Specify the correct location of KDE Solid files in CONFIGURE_ARGS.
  ("Play with VLC" option when you insert a CD/DVD.)
- Add ac_cv_search_pthread_rwlock_init=-pthread to CONFIGURE_ARGS to
  override the test for libpthread.  It detects pthread_rwlock_init in
(Only the first 15 lines of the commit message are shown above View all of this commit message)
29 May 2014 19:58:14
Original commit files touched by this commit  2.1.4_5,4
Revision:355741 This port version is marked as vulnerable.
kwm search for other commits by this committer
Commit correct patch.

Noticed by:	nwhitehorn@
29 May 2014 19:44:48
Original commit files touched by this commit  2.1.4_5,4
Revision:355735 This port version is marked as vulnerable.
kwm search for other commits by this committer
Fix compile on ppc.

PR:		ports/188278
Submitted by:	nwhitehorn@
26 May 2014 22:24:13
Original commit files touched by this commit  2.1.4_5,4
Revision:355463 This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert vlc to USES=libtool
Because vlc uses a dynamic plist that dynamic plist should be created after the
removal of the .la files hence move this target into add-plist-data (this is a
dirty workaround) and one more reason why dynamic plist are evil
libvlc.so.X number has changed (hidden by dynamic plist, told you this is evil)
bump all consumers of libvlc.so
26 May 2014 22:02:46
Original commit files touched by this commit  2.1.4_4,4
Revision:355458 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix build with new lua

Submitted by:	dankm (via irc)

Number of commits found: 487 (showing only 100 on this page)

1 | 2 | 3 | 4 | 5  »  

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
mariadb100-serverOct 20
mariadb101-serverOct 20
mariadb102-serverOct 20
mariadb103-serverOct 20
mariadb55-serverOct 20
mysql55-serverOct 20
mysql56-serverOct 20
mysql57-serverOct 20
mysql80-serverOct 20
percona55-serverOct 20
percona56-serverOct 20
percona57-serverOct 20
ruby23Oct 20
ruby24Oct 20
libsshOct 17

8 vulnerabilities affecting 97 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2018-10-20 16:03:41


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 35717
Broken 62
Deprecated 522
Ignore 348
Forbidden 3
Restricted 162
No CDROM 74
Vulnerable 44
Expired 4
Set to expire 495
Interactive 0
new 24 hours 7
new 48 hours15
new 7 days52
new fortnight146
new month233

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2018 Dan Langille. All rights reserved.