FreshPorts -- The Place For Ports If you buy from Amazon USA, please support us by using this link.
Follow us
Blog
Twitter

We also have a status page: https://freshports.wordpress.com/

Port details
node4 V8 JavaScript for client and server (4.x LTS)
4.8.6_1 www on this many watch lists=1 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port
Maintainer: bhughes@FreeBSD.org search for ports maintained by this maintainer
Port Added: 15 Dec 2015 04:40:30
License: MIT
node - evented I/O for V8 javascript

WWW: http://nodejs.org/
SVNWeb : Homepage : PortsMon
    Pseudo-pkg-plist information, but much better, from make generate-plist
    Expand this list (121 items)
  1. /usr/local/share/licenses/node4-4.8.6_1/catalog.mk
  2. /usr/local/share/licenses/node4-4.8.6_1/LICENSE
  3. /usr/local/share/licenses/node4-4.8.6_1/MIT
  4. bin/node
  5. include/node/ares.h
  6. include/node/ares_version.h
  7. include/node/common.gypi
  8. include/node/config.gypi
  9. include/node/libplatform/libplatform.h
  10. include/node/nameser.h
  11. include/node/node.h
  12. include/node/node_buffer.h
  13. include/node/node_object_wrap.h
  14. include/node/node_version.h
  15. @comment include/node/openssl/aes.h
  16. @comment include/node/openssl/archs/BSD-x86/opensslconf.h
  17. @comment include/node/openssl/archs/BSD-x86_64/opensslconf.h
  18. @comment include/node/openssl/archs/VC-WIN32/opensslconf.h
  19. @comment include/node/openssl/archs/VC-WIN64A/opensslconf.h
  20. @comment include/node/openssl/archs/aix-gcc/opensslconf.h
  21. @comment include/node/openssl/archs/aix64-gcc/opensslconf.h
  22. @comment include/node/openssl/archs/darwin-i386-cc/opensslconf.h
  23. @comment include/node/openssl/archs/darwin64-x86_64-cc/opensslconf.h
  24. @comment include/node/openssl/archs/linux-aarch64/opensslconf.h
  25. @comment include/node/openssl/archs/linux-armv4/opensslconf.h
  26. @comment include/node/openssl/archs/linux-elf/opensslconf.h
  27. @comment include/node/openssl/archs/linux-ppc/opensslconf.h
  28. @comment include/node/openssl/archs/linux-ppc64/opensslconf.h
  29. @comment include/node/openssl/archs/linux-x32/opensslconf.h
  30. @comment include/node/openssl/archs/linux-x86_64/opensslconf.h
  31. @comment include/node/openssl/archs/linux32-s390x/opensslconf.h
  32. @comment include/node/openssl/archs/linux64-s390x/opensslconf.h
  33. @comment include/node/openssl/archs/solaris-x86-gcc/opensslconf.h
  34. @comment include/node/openssl/archs/solaris64-x86_64-gcc/opensslconf.h
  35. @comment include/node/openssl/asn1.h
  36. @comment include/node/openssl/asn1_mac.h
  37. @comment include/node/openssl/asn1t.h
  38. @comment include/node/openssl/bio.h
  39. @comment include/node/openssl/blowfish.h
  40. @comment include/node/openssl/bn.h
  41. @comment include/node/openssl/buffer.h
  42. @comment include/node/openssl/camellia.h
  43. @comment include/node/openssl/cast.h
  44. @comment include/node/openssl/cmac.h
  45. @comment include/node/openssl/cms.h
  46. @comment include/node/openssl/comp.h
  47. @comment include/node/openssl/conf.h
  48. @comment include/node/openssl/conf_api.h
  49. @comment include/node/openssl/crypto.h
  50. @comment include/node/openssl/des.h
  51. @comment include/node/openssl/des_old.h
  52. @comment include/node/openssl/dh.h
  53. @comment include/node/openssl/dsa.h
  54. @comment include/node/openssl/dso.h
  55. @comment include/node/openssl/dtls1.h
  56. @comment include/node/openssl/e_os2.h
  57. @comment include/node/openssl/ebcdic.h
  58. @comment include/node/openssl/ec.h
  59. @comment include/node/openssl/ecdh.h
  60. @comment include/node/openssl/ecdsa.h
  61. @comment include/node/openssl/engine.h
  62. @comment include/node/openssl/err.h
  63. @comment include/node/openssl/evp.h
  64. @comment include/node/openssl/hmac.h
  65. @comment include/node/openssl/idea.h
  66. @comment include/node/openssl/krb5_asn.h
  67. @comment include/node/openssl/kssl.h
  68. @comment include/node/openssl/lhash.h
  69. @comment include/node/openssl/md4.h
  70. @comment include/node/openssl/md5.h
  71. @comment include/node/openssl/mdc2.h
  72. @comment include/node/openssl/modes.h
  73. @comment include/node/openssl/obj_mac.h
  74. @comment include/node/openssl/objects.h
  75. @comment include/node/openssl/ocsp.h
  76. @comment include/node/openssl/opensslconf.h
  77. @comment include/node/openssl/opensslv.h
  78. @comment include/node/openssl/ossl_typ.h
  79. @comment include/node/openssl/pem.h
  80. @comment include/node/openssl/pem2.h
  81. @comment include/node/openssl/pkcs12.h
  82. @comment include/node/openssl/pkcs7.h
  83. @comment include/node/openssl/pqueue.h
  84. @comment include/node/openssl/rand.h
  85. @comment include/node/openssl/rc2.h
  86. @comment include/node/openssl/rc4.h
  87. @comment include/node/openssl/ripemd.h
  88. @comment include/node/openssl/rsa.h
  89. @comment include/node/openssl/safestack.h
  90. @comment include/node/openssl/seed.h
  91. @comment include/node/openssl/sha.h
  92. @comment include/node/openssl/srp.h
  93. @comment include/node/openssl/srtp.h
  94. @comment include/node/openssl/ssl.h
  95. @comment include/node/openssl/ssl2.h
  96. @comment include/node/openssl/ssl23.h
  97. @comment include/node/openssl/ssl3.h
  98. @comment include/node/openssl/stack.h
  99. @comment include/node/openssl/symhacks.h
  100. @comment include/node/openssl/tls1.h
  101. @comment include/node/openssl/ts.h
  102. @comment include/node/openssl/txt_db.h
  103. @comment include/node/openssl/ui.h
  104. @comment include/node/openssl/ui_compat.h
  105. @comment include/node/openssl/whrlpool.h
  106. @comment include/node/openssl/x509.h
  107. @comment include/node/openssl/x509_vfy.h
  108. @comment include/node/openssl/x509v3.h
  109. include/node/v8-debug.h
  110. include/node/v8-platform.h
  111. include/node/v8-profiler.h
  112. include/node/v8-testing.h
  113. include/node/v8-util.h
  114. include/node/v8-version.h
  115. include/node/v8.h
  116. include/node/v8config.h
  117. @(,,444) man/man1/node.1.gz
  118. share/doc/node/gdbinit
  119. share/systemtap/tapset/node.stp
  120. @postexec /sbin/ldconfig -m /usr/local/lib
  121. @postunexec /sbin/ldconfig -R
  122. Collapse this list.

To install the port: cd /usr/ports/www/node4/ && make install clean
To add the package: pkg install node4

PKGNAME: node4

ONLY_FOR_ARCHS: amd64 i386

distinfo:

TIMESTAMP = 1510090419
SHA256 (node-v4.8.6.tar.gz) = f37a92ca7254ecac80f905a5ba5c5ccf8d886c7dab80d84cf6e28af24b1ff680
SIZE (node-v4.8.6.tar.gz) = 22853697


NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.

Build dependencies:
  1. gmake : devel/gmake
  2. python2.7 : lang/python27
  3. python2 : lang/python2
  4. pkgconf>=1.3.0_1 : devel/pkgconf
Runtime dependencies:
  1. python2.7 : lang/python27
  2. python2 : lang/python2
Library dependencies:
  1. libuv.so : devel/libuv
  2. libicui18n.so : devel/icu

This port is required by:

for Run * - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...
Configuration Options
===> The following configuration options are available for node4-4.8.6_1:
     BUNDLED_SSL=off: Use node.js's bundled OpenSSL implementation
     DOCS=on: Build and/or install documentation
     NLS=on: Native Language Support
===> Use 'make config' to modify these settings

USES:
compiler:c++11-lib gmake python:2 pkgconfig localbase ssl

pkg-message:
Note: If you need npm (Node Package Manager), please install the npm2
package, or build any of the www/npm* ports with the NODE4 option enabled.

Master Sites:
  1. http://nodejs.org/dist/v4.8.6/
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2017-02-13
    Affects: users of www/node*
    Author: bradleythughes@fastmail.fm
    Reason: 
      The BUNDLED_SSL option is now enabled by default on FreeBSD 10, since
      Node.js requires OpenSSL 1.0.2, and FreeBSD 10 is shipped with 1.0.1.
    
    
  • 2016-06-14
    Affects: users of www/node, www/node5, and www/node4
    Author: adamw@FreeBSD.org
    Reason: 
      node now prefers a few libraries from ports to the versions bundled
      with node. However, node cannot use the libssl from LibreSSL. If you
      are using LibreSSL as your SSL provider, you must enable the
      "BUNDLED_SSL" option when building node.
    
    

Number of commits found: 54

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
09 Nov 2017 02:31:48
Original commit files touched by this commit  4.8.6_1
Revision:453790
jbeich search for other commits by this committer
devel/icu: update to 60.1

Changes:	http://site.icu-project.org/download/60
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		223373
Exp-run by:	antoine
08 Nov 2017 13:40:54
Original commit files touched by this commit  4.8.6
Revision:453735
bhughes search for other commits by this committer
www/node4: Update 4.8.5 -> 4.8.6

Remove files/patch-deps_v8_src_runtime_runtime-i18n.cc, which has been
landed (independently) upstream.

Approved by:	robak (mentor)
Differential Revision:	https://reviews.freebsd.org/D13002
06 Nov 2017 14:17:57
Original commit files touched by this commit  4.8.5
Revision:453618
bhughes search for other commits by this committer
www/node8: copy from www/node, update 8.8.1 -> 8.9.0 (LTS)

Create a new port for the latest Node.js 8.9.0 LTS release. Update
CONFLICTS for the existing Node.js ports to include the new node8 port
and remove non-existent ports.

https://nodejs.org/en/blog/release/v8.9.0/

Approved by:	robak (mentor)
Differential Revision:	https://reviews.freebsd.org/D12930
02 Nov 2017 21:41:47
Original commit files touched by this commit  4.8.5
Revision:453381
olgeni search for other commits by this committer
Fix whitespace issues (mixed tab/spaces, alignment) in a few ports.

This round is @FreeBSD.org residents except teams.
25 Oct 2017 18:37:51
Original commit files touched by this commit  4.8.5
Revision:452889
bhughes search for other commits by this committer
www/node4: Update 4.8.4_2 -> 4.8.5

Update to the latest upstream v4.x release to address a remote DoS
vulnerability.

https://nodejs.org/en/blog/vulnerability/oct-2017-dos/
https://nodejs.org/en/blog/release/v4.8.5/

Approved by:	robak (mentor)
MFH:		2017Q4
Security:	CVE-2017-14919
Differential Revision:	https://reviews.freebsd.org/D12783
25 Sep 2017 00:02:36
Original commit files touched by this commit  4.8.4_2
Revision:450556  Sanity Test Failure This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 59.1

- Temporarily keep C++98 working in consumers for Clang's default -std=

Changes:	http://site.icu-project.org/download/59
PR:		218788
Submitted by:	takefu@airport.fm, dcarmich@dcarmichael.net (early version)
Exp-run by:	antoine
22 Sep 2017 10:48:29
Original commit files touched by this commit  4.8.4_1
Revision:450351 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove USES=execinfo.

PR:		220271
Submitted by:	mat (review), Yasuhiro KIMURA (PR)
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D11488
14 Sep 2017 18:45:06
Original commit files touched by this commit  4.8.4_1
Revision:449849 This port version is marked as vulnerable.
jbeich search for other commits by this committer
www/node4: unbreak with ICU >= 59

../deps/v8/src/runtime/runtime-i18n.cc:587:3: error: no member named
'Normalizer' in namespace 'icu'; did you mean 'UNormalizer2'?
  icu::Normalizer::normalize(u_value, normalizationForms[form_id], 0, result,
  ^~~~~~~~~~~~~~~
  UNormalizer2
/usr/local/include/unicode/unorm2.h:119:29: note: 'UNormalizer2' declared here
typedef struct UNormalizer2 UNormalizer2;  /**< C typedef for struct
UNormalizer2. @stable ICU 4.4 */
                            ^
../deps/v8/src/runtime/runtime-i18n.cc:587:8: error: incomplete type
'UNormalizer2' named in nested name specifier
  icu::Normalizer::normalize(u_value, normalizationForms[form_id], 0, result,
  ~~~~~^~~~~~~~~~~~
/usr/local/include/unicode/unorm2.h:118:8: note: forward declaration of
'UNormalizer2'
struct UNormalizer2;
       ^

PR:		222224
10 Sep 2017 20:55:39
Original commit files touched by this commit  4.8.4_1
Revision:449591 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
(via Mk/bsd.default-versions.mk and lang/gcc) which has moved from
GCC 5.4 to GCC 6.4 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++11-lang,
   c++14-lang, c++0x, c11, or gcc-c++11-lib.

PR:		219275
13 Jul 2017 15:20:05
Original commit files touched by this commit  4.8.4
Revision:445654 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node4: Update 4.8.3 -> 4.8.4

- sort ONLY_FOR_ARCHS

Approved by:	mat (co-mentor)
MFH:		2017Q3
Security:	3eff66c5-66c9-11e7-aa1d-3d2e663cef42
Differential Revision:	https://reviews.freebsd.org/D11578
02 Jun 2017 19:15:40
Original commit files touched by this commit  4.8.3
Revision:442454 This port version is marked as vulnerable.
bhughes search for other commits by this committer
multiple ports: Update MAINTANER

Change bradleythughes@fastmail.fm -> bhughes@FreeBSD.org after
receiving my ports commit bit on all ports I maintain: devel/awscli,
devel/py-botocore, net/py-s3transfer, net/turnserver, www/node4,
www/node6, and www/node.

Approved by:	robak (mentor)
Differential Review:	https://reviews.freebsd.org/D11015
10 May 2017 17:52:11
Original commit files touched by this commit  4.8.3
Revision:440578 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update to 4.8.3

Changes:	https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V4.md
PR:		219191
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
06 Apr 2017 14:20:05
Original commit files touched by this commit  4.8.2
Revision:437869 This port version is marked as vulnerable.
robak search for other commits by this committer
www/node4: update 4.8.1 -> 4.8.2

PR:		218428
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
01 Apr 2017 15:23:32
Original commit files touched by this commit  4.8.1_1
Revision:437439 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISIONs for ports depending on the canonical version of GCC and
lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some
circumstances such as versions of FreeBSD or platforms).

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using using Mk/bsd.octave.mk which in turn has USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang,
   c++11-lang, c++0x, c11, or gcc-c++11-lib.

PR:		216707
23 Mar 2017 23:25:28
Original commit files touched by this commit  4.8.1
Revision:436797 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update to 4.8.1

Changes:	https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V4.md
PR:		218045
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
02 Mar 2017 15:40:20
Original commit files touched by this commit  4.8.0
Revision:435240 This port version is marked as vulnerable.
krion search for other commits by this committer
Update www/node4 to 4.8.0

PR:		217329
Submitted by:	maintainer
Approved by:	mat (mentor)
Differential Revision:	https://reviews.freebsd.org/D9793
14 Feb 2017 16:15:02
Original commit files touched by this commit  4.7.3_2
Revision:434123 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Enable BUNDLED_SSL by default only on FreeBSD 10

- Add UPDATING entry
- Bump PORTREVISION for dependency change

PR:		217095
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
05 Feb 2017 21:20:24
Original commit files touched by this commit  4.7.3_1
Revision:433456 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile so
  bsd.default-versions.mk can rely on ARCH being defined.
- In bsd.port.mk move inclusion of bsd.default-versions.mk from the
  pre-makefile section to the options section so the variables can be used
  earlier.  Also put the bit of code sitting between the options section and
  the pre-makefile section into the options section.
- Remove last few cases where ports set WITH_OPENSSL_PORT.  This variable is
  handled in bsd.default-versions.mk and some ports were setting it after
  including bsd.port.options.mk.  After FreeBSD 9 EoL all but a few ports,
  and then only when setting non-default options, work without setting that
  variable.

PR:		215996
Exp-run by:	antoine
Approved by:	portmgr (antoine)
05 Feb 2017 05:32:15
Original commit files touched by this commit  4.7.3
Revision:433370 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update to 4.7.3

Changes:	https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V4.md
PR:		216793
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
06 Jan 2017 20:02:55
Original commit files touched by this commit  4.7.2
Revision:430745 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update to 4.7.2

- Update pkg-message

Changes:	https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V4.md
		https://nodejs.org/en/blog/release/v4.7.2/
PR:		215777
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
09 Dec 2016 12:57:44
Original commit files touched by this commit  4.7.0
Revision:428200 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 4.7.0

Changes:	https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V4.md
		https://nodejs.org/en/blog/release/v4.7.0/
PR:		215168
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
07 Dec 2016 23:54:57
Original commit files touched by this commit  4.6.2_1
Revision:428089 This port version is marked as vulnerable.
adamw search for other commits by this committer
Remove www/node in preparation for moving node7 into its place.
Update the CONFLICTS lines for the node ports at the same time.

PR:		213948
Approved by:	maintainer (Bradley T. Hughes)
19 Nov 2016 22:03:39
Original commit files touched by this commit  4.6.2_1
Revision:426540 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node7: Add Node.js 7.1.0, copied from www/node

PR:		213945
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
19 Nov 2016 18:21:20
Original commit files touched by this commit  4.6.2_1
Revision:426525 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 58.1

Changes:	http://site.icu-project.org/download/58
PR:		214384
Exp-run by:	antoine
Approved by:	office (bapt)
19 Nov 2016 12:21:22
Original commit files touched by this commit  4.6.2
Revision:426362 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node: Copy to www/node6 as LTS version

PR:		213693
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
18 Nov 2016 19:33:38
Original commit files touched by this commit  4.6.2
Revision:426335 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node4: update 4.6.1 -> 4.6.2

PR:		214386
Changes:	https://nodejs.org/en/blog/release/v4.6.2/
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
28 Oct 2016 13:42:28
Original commit files touched by this commit  4.6.1
Revision:424840 This port version is marked as vulnerable.
feld search for other commits by this committer
www/node4: Update to 4.6.1

PR:		213603
Security:	CVE-2016-5180
30 Sep 2016 13:43:18
Original commit files touched by this commit  4.6.0
Revision:422985 This port version is marked as vulnerable.
vanilla search for other commits by this committer
Update to 4.6.0.

PR:		213071
Submitted by:	maintainer
24 Sep 2016 11:06:57
Original commit files touched by this commit  4.5.0_1
Revision:422711 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update devel/icu to 57.1.
- Clean up the Makefile.
- Follow some upstream recommendations (--with-data-packaging=archive,
  --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE).
- Patch makefiles to install static libraries with INSTALL_DATA so they
  aren't stripped.
- Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc.
- Fix endianness detection in ICU.  The code wanted to use BYTE_ORDER
  defined in machine/endian.h, but this isn't visible because ICU is
  compiled with _XOPEN_SOURCE.  Patch the code to use _BYTE_ORDER instead.
- Compile ICU with C++11 compiler to enable move constructors.
- Patch ICU to fix a problem with atomics in the case of a C++11 compiler
  without C++11 header <atomic> (like Clang on FreeBSD 9).
- Bump all ports that depend on it due to library version change.
- Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU
  pkgconfig files.
- Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs
  a C++11 runtime library now.  Add this to all ports that depend on it
  so their executables load the right libstdc++.so on FreeBSD 9.

PR:		205120
Exp-run by:	antoine
Approved by:	portmgr (antoine)
20 Aug 2016 22:03:15
Original commit files touched by this commit  4.5.0
Revision:420532 This port version is marked as vulnerable.
pawel search for other commits by this committer
Update to version 4.5.0

Changelog:
https://nodejs.org/en/blog/release/v4.5.0/

PR:		211983
Submitted by:	Bradley T. Hughes (maintainer)
22 Jul 2016 08:07:05
Original commit files touched by this commit  4.4.7_4
Revision:418912 This port version is marked as vulnerable.
mat search for other commits by this committer
Stop people putting arguments to USES=ssl.

Sponsored by:	Absolight
09 Jul 2016 13:42:54
Original commit files touched by this commit  4.4.7_4
Revision:418280 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node[4]: Fix OpenSSL dependencies after USES=ssl changes

PR:		210891
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
09 Jul 2016 13:06:53
Original commit files touched by this commit  4.4.7_3
Revision:418276 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node[4]: Use NLS option to enable system-icu

PR:		210786
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
06 Jul 2016 22:10:14
Original commit files touched by this commit  4.4.7_2
Revision:418153 This port version is marked as vulnerable.
mat search for other commits by this committer
Bump PORTREVISION for the icu revert.

This time not bumping lang/php70, but devel/php70-intl which is the one
really depending on icu.

PR:		205120
With hat:	portmgr
Sponsored by:	Absolight
06 Jul 2016 11:19:56
Original commit files touched by this commit  4.4.7_1
Revision:418128 This port version is marked as vulnerable.
gahr search for other commits by this committer
devel/icu: bump PORTREVISION on missing dependent ports

Reported by:	rakuco
30 Jun 2016 06:26:31
Original commit files touched by this commit  4.4.7
Revision:417811 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node4: 4.4.6 -> 4.4.7

- debugger:
  o All properties of an array (aside from length) can now be printed
    in the repl (cjihrig) #6448
- npm:
  o Upgrade npm to 2.15.8 (Rebecca Turner) #7412
- stream:
  o Fix for a bug that became more prevalent with the stream changes
    that landed in v4.4.5. (Anna Henningsen) #7160
- V8:
  o Fix for a bug in crankshaft that was causing crashes on arm64
    (Myles Borins) #7442
  o Add missing classes to postmortem info such as JSMap and JSSet
    (evan.lucas) #3792

PR:		210520
Changes:	https://nodejs.org/en/blog/release/v4.4.7/
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
30 Jun 2016 05:42:38
Original commit files touched by this commit  4.4.6
Revision:417807 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node4: 4.4.5 -> 4.4.6

This is an important security release. Please consult
https://nodejs.org/en/blog/vulnerability/june-2016-security-releases/
for the details.

This release is specifically related to a Buffer overflow vulnerability
discovered in v8, more details can be found in the CVE 2016-1669.

PR:		210520
Changes:	https://nodejs.org/en/blog/release/v4.4.6/
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
29 Jun 2016 20:00:47
Original commit files touched by this commit  4.4.5_2
Revision:417791 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node[45]: work around build breakages due to include path ordering

Add a post-configure step to strip out all occurrences of
-I${LOCALBASE}/include. Rely instead on USES+=localbase to tell the
compiler where to find includes from external dependencies.

After r416894, node.js builds will use external dependencies instead of
bundled ones. Fallout from this changes includes several build
breakages. All come from the fact that the node-gyp build process adds
-I${LOCALBASE}/include to CFLAGS before all others, including its own
bundled dependencies. This causes the build to incorrectly pick up
include files from any packages in ${LOCALBASE}, rather than the bundled
libraries as intended.

PR:		210618
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
29 Jun 2016 14:22:47
Original commit files touched by this commit  4.4.5_2
Revision:417767 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove all usage of OPENSSL_PORT from ports, this is deprecated, and
always was a user defined variable.

Sponsored by:	Absolight
18 Jun 2016 12:28:31
Original commit files touched by this commit  4.4.5_2
Revision:417063 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node, www/node[45]: Depend on devel/icu instead of the bundled icu-small

PR:		210333
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
Reviewed by:	w.schwarzenfeld@utanet.at
14 Jun 2016 15:53:53
Original commit files touched by this commit  4.4.5_1
Revision:416894 This port version is marked as vulnerable.
adamw search for other commits by this committer
Prefer external libraries to the ones bundled with node.

Do not statically link bundled libraries into node.js. It requires
openssl 1.0.2, so pull that in from ports when the base version is not
new enough. While all versions use c-ares, only www/node has a configure
knob to enable building against an unbundled version. All other
dependencies are specified in www/node/common.mk and used by all 3
ports.

node cannot build against LibreSSL, so if it's the chosen SSL provider,
the BUNDLED_SSL option must be enabled.

The www/node010 and www/node012 ports have not been done since both are
deprecated and have very old bundled dependencies that are not available
in ports.

PR:		209793
Submitted by:	Bradley T. Hughes (maintainer)
27 May 2016 11:12:16
Original commit files touched by this commit  4.4.5
Revision:415933 This port version is marked as vulnerable.
robak search for other commits by this committer
www/node4: update 4.4.4 -> 4.4.5

- Bugfix release

PR:		209781
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
MFH:		2016Q2
06 May 2016 21:29:18
Original commit files touched by this commit  4.4.4
Revision:414729 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node4: 4.4.3 -> 4.4.4

Update to the latest upstream v4.x LTS release after the recent openssl
CVEs.

Release announcement with changelog is here:
  https://nodejs.org/en/blog/release/v4.4.4/
  https://nodejs.org/en/blog/vulnerability/openssl-may-2016/

PR:		209340
MFH:		2016Q2
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
05 May 2016 19:49:38
Original commit files touched by this commit  4.4.3
Revision:414659 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node010, node012, node4: fix CONFLICTS

- Forgot this in the last commit

PR:		209215
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
15 Apr 2016 23:11:29
Original commit files touched by this commit  4.4.3
Revision:413403 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 4.4.3

Changes:	https://github.com/nodejs/node/blob/v4.x/CHANGELOG.md
PR:		208809
Submitted by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
14 Apr 2016 11:08:53
Original commit files touched by this commit  4.4.2
Revision:413257 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node012 www/node4: Fix build with libc++ 3.8.0

PR:		208467
Submitted by:	dim
Approved by:	Bradley T. Hughes <bradleythughes@fastmail.fm> (maintainer)
12 Apr 2016 17:41:04
Original commit files touched by this commit  4.4.2
Revision:413149 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node012, www/node4: really change maintainer

PR:		208587
Submitted by:	lwhsu
11 Apr 2016 10:00:34
Original commit files touched by this commit  4.4.2
Revision:413008 This port version is marked as vulnerable.
pi search for other commits by this committer
www/node4: 4.4.1 -> 4.4.2

- lots of small fixes
- submitter becomes maintainer

PR:             208588
Submitted by:   Bradley T. Hughes <bradleythughes@fastmail.fm>
Approved by:    Daniel Lin <linpct@gmail.com> (maintainer)
29 Mar 2016 19:58:58
Original commit files touched by this commit  4.4.1
Revision:412132 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Update to 4.4.1

PR:		208379
Submitted by:	bradleythughes@fastmail.fm
Approved by:	linpct@gmail.com (maintainer)
29 Feb 2016 15:18:52
Original commit files touched by this commit  4.3.1
Revision:409813 This port version is marked as vulnerable.
vanilla search for other commits by this committer
Update to 4.3.1.

PR:		207476
Submitted by:	maintainer
16 Feb 2016 06:02:24
Original commit files touched by this commit  4.3.0
Revision:408977 This port version is marked as vulnerable.
vanilla search for other commits by this committer
Update to 4.3.0.

PR:		207205
Submitted by:	maintainer
26 Jan 2016 15:13:08
Original commit files touched by this commit  4.2.6
Revision:407275 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Update to 4.2.6.

PR:		206642
Submitted by:	linpct@gmail.com (maintainer)
17 Jan 2016 13:13:01
Original commit files touched by this commit  4.2.4
Revision:406370 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 4.2.4

Changes:	https://github.com/nodejs/node/blob/v4.x/CHANGELOG.md
PR:		206223
Submitted by:	Daniel Lin <linpct@gmail.com> (maintainer)
Sponsored by:	PortsCamp Taiwan
15 Dec 2015 04:40:21
Original commit files touched by this commit  4.2.3
Revision:403756 This port version is marked as vulnerable.
koobs search for other commits by this committer
www/node: Update to 5.2.0, Create www/node4, Update to 4.2.3

www/node:

 * Update PORTVERSION and distinfo checksum (5.2.0) [1]
 * Add CONFLICTS to www/node4

www/node4:

 * Create www/node4 port for LTS users
 * Update www/node4 to 4.2.3 [2]
 * Add CONFLICTS to www/node

* Add UPDATING entry for users wishing to remain on LTS (4.x)

Based on:

PR:		204653 [1][2]
Submitted by:	Randy Westlund <rwestlun gmail com> [1][2]
Approved by:	maintainer <linpct gmail com>

Number of commits found: 54

Login
User Login
Create account

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD

This site
What is FreshPorts?
About the authors
Issues
FAQ
How big is it?
The latest upgrade!
Privacy
Forums
Blog
Contact

Search
Enter Keywords:
 
more...

Latest Vulnerabilities
curl*Dec 11
linux-c7-curl*Dec 11
wiresharkDec 10
procmail*Dec 08
opensslDec 07
firefoxDec 05
firefox-esrDec 05
linux-firefoxDec 05
linux-seamonkeyDec 05
seamonkeyDec 05
waterfoxDec 05
mybbDec 02
varnish4Dec 02
varnish5Dec 02
asterisk13Dec 01

14 vulnerabilities affecting 78 ports have been reported in the past 14 days

* - modified, not new

All vulnerabilities

Last updated:
2017-12-11 14:55:48


Ports
Home
Categories
Deleted ports
Sanity Test Failures
Newsfeeds

Statistics
Graphs
NEW Graphs (Javascript)
Traffic

Calculated hourly:
Port count 32114
Broken 121
Deprecated 41
Ignore 356
Forbidden 0
Restricted 173
No CDROM 77
Vulnerable 44
Expired 11
Set to expire 33
Interactive 0
new 24 hours 4
new 48 hours6
new 7 days81
new fortnight18987
new month48535

Servers and bandwidth provided by
New York Internet, SuperNews, and RootBSD
Valid HTML, CSS, and RSS.
Copyright © 2000-2017 Dan Langille. All rights reserved.