notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)

/commits.php is going away

I'm proposing to take /commits.php away - it mainly duplicates the home page. Details in this GitHub issue.
Port details
node8 V8 JavaScript for client and server (8.x LTS)
8.17.0 www Deleted on this many watch lists=1 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 8.17.0Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Node.js 8.x has reached end-of-life, see https://github.com/nodejs/Release
Expired This port expired on: 2019-12-31
Maintainer: bhughes@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-11-06 14:18:04
Last Update: 2020-03-10 21:55:06
SVN Revision: 528198
People watching this port, also watch:: zsh, git, node, sudo, npm
License: MIT
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (127 items)
Collapse this list.
  1. /usr/local/share/licenses/node8-8.17.0/catalog.mk
  2. /usr/local/share/licenses/node8-8.17.0/LICENSE
  3. /usr/local/share/licenses/node8-8.17.0/MIT
  4. bin/node
  5. include/node/common.gypi
  6. include/node/config.gypi
  7. include/node/libplatform/libplatform.h
  8. include/node/libplatform/libplatform-export.h
  9. include/node/libplatform/v8-tracing.h
  10. include/node/node.h
  11. include/node/node_api.h
  12. include/node/node_api_types.h
  13. include/node/node_buffer.h
  14. include/node/node_object_wrap.h
  15. include/node/node_version.h
  16. @comment include/node/openssl/aes.h
  17. @comment include/node/openssl/archs/BSD-x86/opensslconf.h
  18. @comment include/node/openssl/archs/BSD-x86_64/opensslconf.h
  19. @comment include/node/openssl/archs/VC-WIN32/opensslconf.h
  20. @comment include/node/openssl/archs/VC-WIN64A/opensslconf.h
  21. @comment include/node/openssl/archs/aix-gcc/opensslconf.h
  22. @comment include/node/openssl/archs/aix64-gcc/opensslconf.h
  23. @comment include/node/openssl/archs/darwin-i386-cc/opensslconf.h
  24. @comment include/node/openssl/archs/darwin64-x86_64-cc/opensslconf.h
  25. @comment include/node/openssl/archs/linux-aarch64/opensslconf.h
  26. @comment include/node/openssl/archs/linux-armv4/opensslconf.h
  27. @comment include/node/openssl/archs/linux-elf/opensslconf.h
  28. @comment include/node/openssl/archs/linux-ppc/opensslconf.h
  29. @comment include/node/openssl/archs/linux-ppc64/opensslconf.h
  30. @comment include/node/openssl/archs/linux-x32/opensslconf.h
  31. @comment include/node/openssl/archs/linux-x86_64/opensslconf.h
  32. @comment include/node/openssl/archs/linux32-s390x/opensslconf.h
  33. @comment include/node/openssl/archs/linux64-s390x/opensslconf.h
  34. @comment include/node/openssl/archs/solaris-x86-gcc/opensslconf.h
  35. @comment include/node/openssl/archs/solaris64-x86_64-gcc/opensslconf.h
  36. @comment include/node/openssl/asn1.h
  37. @comment include/node/openssl/asn1_mac.h
  38. @comment include/node/openssl/asn1t.h
  39. @comment include/node/openssl/bio.h
  40. @comment include/node/openssl/blowfish.h
  41. @comment include/node/openssl/bn.h
  42. @comment include/node/openssl/buffer.h
  43. @comment include/node/openssl/camellia.h
  44. @comment include/node/openssl/cast.h
  45. @comment include/node/openssl/cmac.h
  46. @comment include/node/openssl/cms.h
  47. @comment include/node/openssl/comp.h
  48. @comment include/node/openssl/conf.h
  49. @comment include/node/openssl/conf_api.h
  50. @comment include/node/openssl/crypto.h
  51. @comment include/node/openssl/des.h
  52. @comment include/node/openssl/des_old.h
  53. @comment include/node/openssl/dh.h
  54. @comment include/node/openssl/dsa.h
  55. @comment include/node/openssl/dso.h
  56. @comment include/node/openssl/dtls1.h
  57. @comment include/node/openssl/e_os2.h
  58. @comment include/node/openssl/ebcdic.h
  59. @comment include/node/openssl/ec.h
  60. @comment include/node/openssl/ecdh.h
  61. @comment include/node/openssl/ecdsa.h
  62. @comment include/node/openssl/engine.h
  63. @comment include/node/openssl/err.h
  64. @comment include/node/openssl/evp.h
  65. @comment include/node/openssl/hmac.h
  66. @comment include/node/openssl/idea.h
  67. @comment include/node/openssl/krb5_asn.h
  68. @comment include/node/openssl/kssl.h
  69. @comment include/node/openssl/lhash.h
  70. @comment include/node/openssl/md4.h
  71. @comment include/node/openssl/md5.h
  72. @comment include/node/openssl/mdc2.h
  73. @comment include/node/openssl/modes.h
  74. @comment include/node/openssl/obj_mac.h
  75. @comment include/node/openssl/objects.h
  76. @comment include/node/openssl/ocsp.h
  77. @comment include/node/openssl/opensslconf.h
  78. @comment include/node/openssl/opensslv.h
  79. @comment include/node/openssl/ossl_typ.h
  80. @comment include/node/openssl/pem.h
  81. @comment include/node/openssl/pem2.h
  82. @comment include/node/openssl/pkcs12.h
  83. @comment include/node/openssl/pkcs7.h
  84. @comment include/node/openssl/pqueue.h
  85. @comment include/node/openssl/rand.h
  86. @comment include/node/openssl/rc2.h
  87. @comment include/node/openssl/rc4.h
  88. @comment include/node/openssl/ripemd.h
  89. @comment include/node/openssl/rsa.h
  90. @comment include/node/openssl/safestack.h
  91. @comment include/node/openssl/seed.h
  92. @comment include/node/openssl/sha.h
  93. @comment include/node/openssl/srp.h
  94. @comment include/node/openssl/srtp.h
  95. @comment include/node/openssl/ssl.h
  96. @comment include/node/openssl/ssl2.h
  97. @comment include/node/openssl/ssl23.h
  98. @comment include/node/openssl/ssl3.h
  99. @comment include/node/openssl/stack.h
  100. @comment include/node/openssl/symhacks.h
  101. @comment include/node/openssl/tls1.h
  102. @comment include/node/openssl/ts.h
  103. @comment include/node/openssl/txt_db.h
  104. @comment include/node/openssl/ui.h
  105. @comment include/node/openssl/ui_compat.h
  106. @comment include/node/openssl/whrlpool.h
  107. @comment include/node/openssl/x509.h
  108. @comment include/node/openssl/x509_vfy.h
  109. @comment include/node/openssl/x509v3.h
  110. include/node/v8-debug.h
  111. include/node/v8-inspector-protocol.h
  112. include/node/v8-inspector.h
  113. include/node/v8-platform.h
  114. include/node/v8-profiler.h
  115. include/node/v8-testing.h
  116. include/node/v8-util.h
  117. include/node/v8-value-serializer-version.h
  118. include/node/v8-version.h
  119. include/node/v8-version-string.h
  120. include/node/v8.h
  121. include/node/v8config.h
  122. lib/dtrace/node.d
  123. @(,,444) man/man1/node.1.gz
  124. share/doc/node/gdbinit
  125. share/doc/node/lldb_commands.py
  126. share/doc/node/lldbinit
  127. share/systemtap/tapset/node.stp
Collapse this list.
Dependency lines:
  • node8>0:www/node8
Conflicts:
CONFLICTS_INSTALL:
  • node6-[0-9]*
  • node10-[0-9]*
  • node12-[0-9]*
  • node-[0-9]*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions: this port has been deleted.
The package name of this deleted port was:
PKGNAME: node8
Flavors: there is no flavor information for this port.
ONLY_FOR_ARCHS: aarch64 amd64 armv6 armv7 i386 powerpc64
distinfo:
Packages (timestamps in pop-ups are UTC):
node8
ABIlatestquarterly
FreeBSD:11:aarch648.12.0-
FreeBSD:11:amd64--
FreeBSD:11:armv6--
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch648.12.0-
FreeBSD:12:amd64--
FreeBSD:12:armv68.12.0-
FreeBSD:12:armv7--
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. c-ares>=1.10.0 : dns/c-ares
  2. libuv>1.23.2 : devel/libuv
  3. libnghttp2>=1.39.2 : www/libnghttp2
  4. icu>=60.1 : devel/icu
  5. gmake : devel/gmake
  6. python2.7 : lang/python27
  7. pkgconf>=1.3.0_1 : devel/pkgconf
Runtime dependencies:
  1. ca_root_nss>=0 : security/ca_root_nss
Library dependencies:
  1. libcares.so : dns/c-ares
  2. libuv.so : devel/libuv
  3. libnghttp2.so : www/libnghttp2
  4. libicui18n.so : devel/icu
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

pkg-message:
If installing:
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. http://nodejs.org/dist/v8.17.0/
Collapse this list.
Port Moves
  • port moved to www/node10 on 2020-03-10
    REASON: Has expired: Node.js 8.x has reached end-of-life, see https://github.com/nodejs/Release
  • port moved here from www/node6 on 2019-11-02
    REASON: Has expired: Node.js 6.x LTS reaches end-of-life on 2019-04-30, see https://github.com/nodejs/Release

Number of commits found: 49

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
10 Mar 2020 21:55:06
Original commit files touched by this commit Revision:528198  8.17.0
rene search for other commits by this committer
Remove expired ports:

2019-12-31 www/node8: Node.js 8.x has reached end-of-life, see
https://github.com/nodejs/Release
www/npm-node8, slave of www/node8
www/yarn-node8, slave of www/node8
10 Mar 2020 05:35:11
Original commit files touched by this commit Revision:528143  8.17.0
bhughes search for other commits by this committer
www/node8: add deprecation notice and expiration date

Node.js 8.x reached end-of-life on 2019-12-31.

Sponsored by:	Miles AS
31 Jan 2020 11:13:47
Original commit files touched by this commit Revision:524691  8.17.0
bhughes search for other commits by this committer
www/node8: Update to 8.17.0

https://nodejs.org/en/blog/release/v8.17.0/

Sponsored by:	Miles AS
03 Nov 2019 22:32:03
Original commit files touched by this commit Revision:516610  8.16.2
bhughes search for other commits by this committer
www/node12: copy from www/node

Create a new port for the latest Node.js 12.13.0 LTS release. Update
CONFLICTS for the existing Node.js ports to include the new node12 port.

https://nodejs.org/en/blog/release/v12.13.0/

Sponsored by:	Miles AS
22 Oct 2019 20:50:19
Original commit files touched by this commit Revision:515214  8.16.2
bhughes search for other commits by this committer
www/node8: Update 8.16.1_1 -> 8.16.2

https://nodejs.org/en/blog/release/v8.16.2/

Sponsored by:	Miles AS
03 Oct 2019 20:35:30
Original commit files touched by this commit Revision:513733  8.16.1_1
jbeich search for other commits by this committer
devel/icu: update to 65.1

Changes:	http://site.icu-project.org/download/65
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
14 Sep 2019 22:01:13
Original commit files touched by this commit Revision:512079  8.16.1
jbeich search for other commits by this committer
Drop C++11 workaround for GCC < 6 after r449590

lang/gcc5 will expire in ~1 month. If someone still uses lang/gcc48
they should backport C++11 fix instead. QA on GCC architecuters is
currently limited to powerpc64 which uses GCC_DEFAULT.

PR:		193528
20 Aug 2019 22:27:14
Original commit files touched by this commit Revision:509479  8.16.1
bhughes search for other commits by this committer
www/node8: Update 8.16.0 -> 8.16.1

This is a security release. All Node.js users should consult the security
release summary at
https://nodejs.org/en/blog/vulnerability/aug-2019-security-releases/
for details on patched vulnerabilities.

MFH:		2019Q3
Security:	c97a940b-c392-11e9-bb38-000d3ab229d6
Sponsored by:	Miles AS
14 Aug 2019 12:25:09
Original commit files touched by this commit Revision:508913  8.16.0_1 This port version is marked as vulnerable.
mat search for other commits by this committer
Convert to UCL & cleanup pkg-message (categories w)
26 Jul 2019 20:46:57
Original commit files touched by this commit Revision:507372  8.16.0_1 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
as defined in Mk/bsd.default-versions.mk which has moved from GCC 8.3
to GCC 9.1 under most circumstances now after revision 507371.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, everything INDEX-11 shows with a dependency on lang/gcc9 now.

PR:		238330
24 May 2019 05:42:46
Original commit files touched by this commit Revision:502419  8.16.0 This port version is marked as vulnerable.
antoine search for other commits by this committer
Revert r502354 and unbreak INDEX
23 May 2019 20:28:28
Original commit files touched by this commit Revision:502354  8.16.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
Remove www/node6

This port reached end-of-life upstream on 2019-04-30. Remove node6-*
from CONFLICTS for the remaining www/node* ports.

Sponsored by:	Miles AS
08 May 2019 19:09:47
Original commit files touched by this commit Revision:501038  8.16.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: add registers used by powerpc64 to sampler

Add missing registers for powerpc64.

PR:		237617
Submitted by:	pkubaj
Sponsored by:	Miles AS
21 Apr 2019 18:04:52
Original commit files touched by this commit Revision:499549  8.16.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.15.1_1 -> 8.16.0

https://nodejs.org/en/blog/release/v8.16.0/

Sponsored by:	Miles AS
29 Mar 2019 04:57:05
Original commit files touched by this commit Revision:497067  8.15.1_1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node*: specify minimum versions of dependencies in BUILD_DEPENDS

Add BUILD_DEPENDS for all LIB_DEPENDS, specifying the minimum version as
the version bundled with a particlar version of Node.js. This should help
people building from ports with out-of-date dependencies with a helpful
message instead of build failures.

Reported by:	freebsd-ports@
Sponsored by:	Miles AS
27 Mar 2019 21:11:09
Original commit files touched by this commit Revision:496981  8.15.1_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 64.1

Changes:	http://site.icu-project.org/download/64
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		236325
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D19479
12 Mar 2019 21:08:19
Original commit files touched by this commit Revision:495527  8.15.1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8:set environment variables for host build

The Node.js build system supports cross-compilation via node-gyp, which
picks up CC, CXX, LINK, C*FLAGS, and LDFLAGS from the environment for the
target build, but not for the host. We need to set the environment variables
for the "host" build.

Sponsored by:	Miles AS
Differential Revision:	https://reviews.freebsd.org/D19250
03 Mar 2019 09:16:07
Original commit files touched by this commit Revision:494486  8.15.1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.15.0 -> 8.15.1

This is a security release. All Node.js users should consult the security
release summary at
https://nodejs.org/en/blog/vulnerability/february-2019-security-releases/
for details on patched vulnerabilities.

MFH:		2019Q1
Security:	b71d7193-3c54-11e9-a3f9-00155d006b02
Sponsored by:	Miles AS
11 Feb 2019 18:24:42
Original commit files touched by this commit Revision:492706  8.15.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node*: fix build on non-amd64/-i386 when BUNDLED_SSL is unset

The --openssl-no-asm configure option should only be set
when BUNDLED_SSL is enabled.

PR:		235311
Reported by:	jbeich
Sponsored by:	Miles AS
23 Jan 2019 21:14:27
Original commit files touched by this commit Revision:491058  8.15.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: convert port to use BROKEN_SSL

Sponsored by:	Miles AS
28 Dec 2018 20:45:36
Original commit files touched by this commit Revision:488624  8.15.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.14.0_1 -> 8.15.0

The 8.14.0 security release introduced some unexpected breakages on the
8.x release line. This is a special release to fix a regression in the
HTTP binary upgrade response body and add a missing CLI flag to adjust
the max header size of the http parser.

https://nodejs.org/en/blog/release/v8.15.0/

Sponsored by:	Miles AS
21 Dec 2018 12:50:29
Original commit files touched by this commit Revision:487991  8.14.0_1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: fix build on powerpc64

PR:		233689
Submitted by:	Piotr Kubaj <pkubaj@anongoth.pl>
Sponsored by:	Miles AS
12 Dec 2018 01:35:36
Original commit files touched by this commit Revision:487272  8.14.0_1 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
defined via Mk/bsd.default-versions.mk which has moved from GCC 7.4 t
GCC 8.2 under most circumstances.

This includes ports
 - with USE_GCC=yes or USE_GCC=any,
 - with USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and
 - with USES=compiler specifying openmp, nestedfct, c11, c++0x, c++11-lang,
   c++11-lib, c++14-lang, c++17-lang, or gcc-c++11-lib
plus, as a double check, everything INDEX-11 showed depending on lang/gcc7.

PR:		231590
11 Dec 2018 10:10:02
Original commit files touched by this commit Revision:487230  8.14.0 This port version is marked as vulnerable.
antoine search for other commits by this committer
Spell CHOSEN_COMPILER_TYPE correctly

PR:		199098
With hat:	portmgr
10 Dec 2018 11:35:37
Original commit files touched by this commit Revision:487155  8.14.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.13.0 -> 8.14.0

This is a security release addressing multiple vulnerabilities. Users
are recommended to upgrade as soon as possible.

https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
https://nodejs.org/en/blog/release/v8.14.0/

MFH:		2018Q4
Security:	2a86f45a-fc3c-11e8-a414-00155d006b02
Sponsored by:	Miles AS
21 Nov 2018 04:43:13
Original commit files touched by this commit Revision:485495  8.13.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.12.0_1 -> 8.13.0

https://nodejs.org/en/blog/release/v8.13.0/

Sponsored by:	Miles AS
02 Nov 2018 13:32:35
Original commit files touched by this commit Revision:483807  8.12.0_1 This port version is marked as vulnerable.
rene search for other commits by this committer
Remove compatibility code for FreeBSD < 11.2 from all ports.

Simplify some ports where DragonFlyBSD no longer needs to be special-cased.
Submitted by:	rene
Reviewed by:	bapt, jbeich
Differential Revision:	https://reviews.freebsd.org/D17724
31 Oct 2018 21:03:49
Original commit files touched by this commit Revision:483618  8.12.0_1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node10: copy from www/node, update 10.12.0_1 -> 10.13.0 (LTS)

Create a new port for the latest Node.js 10.13.0 LTS release. Update
CONFLICTS for the existing Node.js ports to include the new node10 port
and remove non-existent ports.

https://nodejs.org/en/blog/release/v10.13.0/

Sponsored by:	Miles AS
23 Oct 2018 11:35:04
Original commit files touched by this commit Revision:482830  8.12.0_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 63.1

Changes:	http://site.icu-project.org/download/63
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		232300
Exp-run by:	antoine
14 Sep 2018 03:49:54
Original commit files touched by this commit Revision:479758  8.12.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.11.4_1 -> 8.12.0

- drop b8f47b27571f.patch, which has been applied upstream
- refresh patches with `make makepatch`

https://nodejs.org/en/blog/release/v8.12.0/

Sponsored by:	Miles AS
06 Sep 2018 19:40:23
Original commit files touched by this commit Revision:479151  8.11.4_1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: add dependency on www/libnghttp2

... instead of using the bundled version. Bump PORTREVISION due to the
new dependency.

Sponsored by:	Miles AS
27 Aug 2018 11:28:24
Original commit files touched by this commit Revision:478193  8.11.4 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.11.3_2 -> 8.11.4

This is a security release addressing multiple vulnerabilities. Users
are recommended to upgrade as soon as possible.

https://nodejs.org/en/blog/vulnerability/august-2018-security-releases/
https://nodejs.org/en/blog/release/v8.11.4/

MFH:		2018Q3
Security:	0904e81f-a89d-11e8-afbb-bc5ff4f77b71
Sponsored by:	Miles AS
26 Aug 2018 18:42:28
Original commit files touched by this commit Revision:478155  8.11.3_2 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
Update WWW

Approved by:	portmgr (blanket)
29 Jul 2018 22:18:46
Original commit files touched by this commit Revision:475857  8.11.3_2 This port version is marked as vulnerable.
gerald search for other commits by this committer
Bump PORTREVISION for ports depending on the canonical version of GCC
in the ports tree (via Mk/bsd.default-versions.mk and lang/gcc) which
has now moved from GCC 6 to GCC 7 by default.

This includes ports
 - featuring USE_GCC=yes or USE_GCC=any,
 - featuring USES=fortran,
 - using Mk/bsd.octave.mk which in turn features USES=fortran, and those
 - with USES=compiler specifying one of openmp, nestedfct, c11, c++0x,
   c++11-lib, c++11-lang, c++14-lang, c++17-lang, or gcc-c++11-lib.

PR:		222542
29 Jun 2018 14:22:11
Original commit files touched by this commit Revision:473551  8.11.3_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 62.1

Changes:	http://site.icu-project.org/download/62
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		229359
Exp-run by:	antoine (only 10.4)
15 Jun 2018 14:11:07
Original commit files touched by this commit Revision:472452  8.11.3 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.11.2 -> 8.11.3

Update to the latest security release, fixing CVE-2018-7161,
CVE-2018-7167, and CVE-2018-1000168.

https://nodejs.org/en/blog/release/v8.11.3/
https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/

PR:		229038
Submitted by:	Pascal Christen <pascal.christen@hostpoint.ch>
MFH:		2018Q2
Security:	45b8e2eb-7056-11e8-8fab-63ca6e0e13a2
Sponsored by:	Miles AS
21 May 2018 21:13:06
Original commit files touched by this commit Revision:470576  8.11.2 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.11.1_1 -> 8.11.2

https://nodejs.org/en/blog/release/v8.11.2/
06 Apr 2018 15:53:17
Original commit files touched by this commit Revision:466648  8.11.1_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 61.1

Changes:	http://site.icu-project.org/download/61
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		227042
Exp-run by:	antoine
MFH:		2018Q2 (required by Firefox 61)
04 Apr 2018 08:03:48
Original commit files touched by this commit Revision:466396  8.11.1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
www/node8: unbreak with ICU 61

../src/node_i18n.cc:526:12: error: use of undeclared identifier 'TimeZone'; did
you mean 'icu::TimeZone'?
    return TimeZone::getTZDataVersion(*status);
           ^~~~~~~~
           icu::TimeZone
/usr/local/include/unicode/timezone.h:131:18: note: 'icu::TimeZone' declared
here
class U_I18N_API TimeZone : public UObject {
                 ^

https://ssl.icu-project.org/trac/changeset/40705

PR:		227042
Reported by:	antoine (via exp-run)
Obtained from:	upstream
01 Apr 2018 09:19:54
Original commit files touched by this commit Revision:466133  8.11.1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.11.0 -> 8.11.1

No changes from the previous verison. This release ensures that the
hosted binaries from the Node.js project adhere to the platform support
contract, which does not apply to the FreeBSD port and packages.

MFH:		2018Q2
29 Mar 2018 19:55:52
Original commit files touched by this commit Revision:465915  8.11.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.10.0 -> 8.11.0

This is a security release addressing multiple vulnerabilities. Users
are recommended to upgrade as soon as possible.

https://nodejs.org/en/blog/vulnerability/march-2018-security-releases/
https://nodejs.org/en/blog/release/v8.11.0/

MFH:		2018Q1
Security:	5a9bbb6e-32d3-11e8-a769-6daaba161086
07 Mar 2018 15:16:15
Original commit files touched by this commit Revision:463799  8.10.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.9.4 -> 8.10.0

This release comes with a lot of big changes. There are updates to V8,
libuv, and ICU, a bugfix in npm, and support for building with OpenSSL
1.1.0.

https://nodejs.org/en/blog/release/v8.10.0/
19 Feb 2018 11:10:43
Original commit files touched by this commit Revision:462307  8.9.4 This port version is marked as vulnerable.
antoine search for other commits by this committer
Reduce dependency on the python2 metaport

PR:		225752
Submitted by:	Yasuhiro KIMURA
08 Feb 2018 14:29:36
Original commit files touched by this commit Revision:461241  8.9.4 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node,www/node8,www/node6: disable dtrace usdt on armv[67]

Disable the DTRACE option by default on armv[67] since Node.js fails to
build on armv[67] with the following error:

dt_modtext:/usr/src/cddl/contrib/opensolaris/lib/libdtrace/common/dt_link.c(820):
arm not implemented

PR:		224271
Submitted by:	mikael.urankar@gmail.com
03 Feb 2018 22:30:24
Original commit files touched by this commit Revision:460855  8.9.4 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.9.3 -> 8.9.4

https://nodejs.org/en/blog/release/v8.9.4/

While here, pet portlint:
- move ONLY_FOR_ARCHS
- remove USES_LDCONFIG (node.js doesn't install a .so)

Differential Revision:	https://reviews.freebsd.org/D13775
14 Dec 2017 19:46:23
Original commit files touched by this commit Revision:456345  8.9.3 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.9.1_1 -> 8.9.3

Approved by:	mat (co-mentor)
Security:	bea84a7a-e0c9-11e7-b4f3-11baa0c2df21
Differential Revision:	https://reviews.freebsd.org/D13442
09 Nov 2017 02:31:48
Original commit files touched by this commit Revision:453790  8.9.1_1 This port version is marked as vulnerable.
jbeich search for other commits by this committer
devel/icu: update to 60.1

Changes:	http://site.icu-project.org/download/60
ABI:		https://abi-laboratory.pro/tracker/timeline/icu4c/
PR:		223373
Exp-run by:	antoine
08 Nov 2017 13:41:42
Original commit files touched by this commit Revision:453737  8.9.1 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: Update 8.9.0 -> 8.9.1

Approved by:	robak (mentor)
Differential Revision:	https://reviews.freebsd.org/D13004
06 Nov 2017 14:17:57
Original commit files touched by this commit Revision:453618  8.9.0 This port version is marked as vulnerable.
bhughes search for other commits by this committer
www/node8: copy from www/node, update 8.8.1 -> 8.9.0 (LTS)

Create a new port for the latest Node.js 8.9.0 LTS release. Update
CONFLICTS for the existing Node.js ports to include the new node8 port
and remove non-existent ports.

https://nodejs.org/en/blog/release/v8.9.0/

Approved by:	robak (mentor)
Differential Revision:	https://reviews.freebsd.org/D12930

Number of commits found: 49