notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Port details
dexed IDE for the D programming language
3.7.4 editors Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 3.7.4Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Depends on expiring devel/dfmt
Expired This port expired on: 2019-09-04
Maintainer: acm@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2018-11-20 03:05:31
Last Update: 2019-09-05 11:40:24
SVN Revision: 511180
License: BSL
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • dexed-gtk2>0:editors/dexed
Conflicts:
CONFLICTS_INSTALL:
  • dexed-qt5
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions:
This port has been deleted.
PKGNAME: dexed-gtk2
Package flavors (<flavor>: <package>)
  • gtk2: dexed-gtk2
  • qt5: dexed-qt5
ONLY_FOR_ARCHS: i386 amd64
distinfo:
No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ldmd2 : lang/ldc
  2. libiz.a : devel/iz
  3. libmir-core.a : devel/mir-core
  4. libdparse.a : devel/libdparse
  5. libstdx-allocator.a : devel/stdx-allocator
  6. ppcx64 : lang/fpc
  7. chm.fpm : misc/fpc-chm
  8. fcl-base.fpm : devel/fpc-fcl-base
  9. fcl-db.fpm : devel/fpc-fcl-db
  10. fcl-image.fpm : devel/fpc-fcl-image
  11. fcl-json.fpm : devel/fpc-fcl-json
  12. fcl-net.fpm : devel/fpc-fcl-net
  13. fcl-registry.fpm : devel/fpc-fcl-registry
  14. fcl-stl.fpm : devel/fpc-fcl-stl
  15. fcl-web.fpm : devel/fpc-fcl-web
  16. fcl-xml.fpm : devel/fpc-fcl-xml
  17. numlib.fpm : math/fpc-numlib
  18. opengl.fpm : graphics/fpc-opengl
  19. openssl.fpm : security/fpc-openssl
  20. pasjpeg.fpm : graphics/fpc-pasjpeg
  21. rtl-objpas.fpm : lang/fpc-rtl-objpas
  22. regexpr.fpm : devel/fpc-regexpr
  23. rtl-extra.fpm : lang/fpc-rtl-extra
  24. x11.fpm : x11/fpc-x11
  25. cairo.fpm : graphics/fpc-cairo
  26. fpcres : lang/fpc-utils
  27. gtk2.fpm : x11-toolkits/fpc-gtk2
  28. interfaces.ppu : editors/lazarus
  29. x11.pc : x11/libX11
Runtime dependencies:
  1. ldmd2 : lang/ldc
  2. dscanner : devel/d-scanner
  3. dcd-client : devel/dcd-client
  4. dcd-server : devel/dcd-server
  5. dfmt : devel/dfmt
  6. ddemangle : lang/dlang-tools
  7. x11.pc : x11/libX11
Library dependencies:
  1. libglib-2.0.so : devel/glib20
  2. libgtk-x11-2.0.so : x11-toolkits/gtk20
  3. libatk-1.0.so : accessibility/atk
  4. libpango-1.0.so : x11-toolkits/pango
  5. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  6. libcairo.so : graphics/cairo
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://codeload.github.com/BBasile/dexed/tar.gz/v3.7.4?dummy=/
Collapse this list.
Port Moves
  • port deleted on 2019-09-05
    REASON: Has expired: Depends on expiring devel/dfmt
  • port moved here from editors/coedit on 2018-11-19
    REASON: Project was renamed

Number of commits found: 7

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
05 Sep 2019 11:40:24
Original commit files touched by this commit Revision:511180  3.7.4
rene search for other commits by this committer
Remove expired ports:
2019-09-04 devel/ace+tao-doc: Broken for more than 6 months
2019-09-04 devel/dfmt: Broken for more than 6 months
2019-09-04 devel/ignition-transport: Broken for more than 6 months
2019-09-04 devel/spin: Broken for more than 6 months
2019-09-04 editors/dexed: Depends on expiring devel/dfmt
2019-09-04 editors/p5-Padre: Depends on expiring x11-toolkits/p5-Wx
2019-09-04 emulators/qemu2: Latest 3.X branch is in ports tree
2019-09-04 games/asc: Broken for more than 6 months
2019-09-04 games/slade: Broken for more than 6 months
2019-09-04 graphics/gimp-wavelet-decompose-plugin: Broken for more than 6 months
2019-09-04 graphics/py-pyembree: Depends on expiring graphics/embree
2019-09-04 irc/irssi-otr: Broken for more than 6 months
2019-09-04 mail/p5-Mail-ClamAV: Broken for more than 6 months
2019-09-04 mail/qmail-ldap: Broken for more than 6 months
(Only the first 15 lines of the commit message are shown above View all of this commit message)
04 Aug 2019 09:07:48
Original commit files touched by this commit Revision:508082  3.7.4
antoine search for other commits by this committer
Deprecate ports broken for more than 6 months
26 Jun 2019 11:52:23
Original commit files touched by this commit Revision:505150  3.7.4
rene search for other commits by this committer
Clean up final leftovers from Qt4.

Submitted by:	rene
Reviewed by:	mat, tcberner
Differential Revision:	https://reviews.freebsd.org/D20725
07 Mar 2019 06:29:54
Original commit files touched by this commit Revision:494911  3.7.4
acm search for other commits by this committer
- Update to 3.7.4
16 Jan 2019 11:13:45
Original commit files touched by this commit Revision:490472  3.6.21_1
tijl search for other commits by this committer
Fix Qt5 symbol version scripts to put the catch-all clause first.  When
a symbol matches multiple clauses the last one takes precedence.  If the
catch-all is last it captures everything.  In the case of Qt5 libraries
this caused all symbols to have a Qt_5 label while some should have
Qt_5_PRIVATE_API.  This only affects lld because GNU ld always gives the
catch-all lowest priority.

Older versions of Qt5Webengine exported some memory allocation symbols from
the bundled Chromium.  Version 5.9 stopped exporting these [1] but the
symbols were kept as weak wrappers for the standard allocation functions to
maintain binary compatibility. [2][3]  The problem is that the call to the
standard function in these weak wrappers is only resolved to the standard
function if there's a call to this standard function in other parts of
Qt5Webengine, because only then is there a non-weak symbol that takes
precedence over the weak one.  If there's no such non-weak symbol the call
(Only the first 15 lines of the commit message are shown above View all of this commit message)
05 Dec 2018 16:46:07
Original commit files touched by this commit Revision:486685  3.6.21
acm search for other commits by this committer
- Fix build

Reported by:	pkg-fallout
20 Nov 2018 03:05:14
Original commit files touched by this commit Revision:485407  3.6.21
acm search for other commits by this committer
- Rename editors/coedit to editors/dexed. Project was renamed

Number of commits found: 7