Quantum GIS (QGIS) is a user friendly Open Source Geographic Information
System. QGIS supports vector, raster, and database formats.
QGIS is licensed under the GNU GPL.
Some of the major features include:
- Support for spatially enabled PostGIS tables
- Support for shapefiles, ArcInfo coverages, Mapinfo and other formats
- Raster support for a large number of formats
- Identify features
- Display attribute tables
- Select features
- GRASS Digitizing
- Feature labeling
===> The following configuration options are available for qgis-4.2.3_2:
SERVER=on: Enable QGIS server
GRASS=on: Add GRASS GIS to processing tools
===> Use 'make config' to modify these settings
graphics/qgis: Update to 4.2.1
Major release update from QGIS 3.x to 4.x, which brings many changes
and new features.
Users who previously used 3.x can transfer their configuration to
separate configuration directories in 4.x. This happens automatically
upon the first launch, unless the user declines it. The configuration
for 3.x versions is therefore preserved.
Since many, but not yet all, of the plugins familiar from 3.x work in
the 4.x versions, you can continue working with QGIS 3.x for now. To do
so, replace the existing installation from graphics/qgis with the one
from graphics/qgis-ltr, where 3.x versions will continue to be
maintained until further notice.
- 4.x versions are real Qt6 ones
- Use PDF4QT for better rendering in PDF
When building in an unclean environment, the port should now be
unaffected by whether the ports `archivers/lazperf` and/or
`devel/spatialindex` are installed system-wide. The internal versions
will be used in any case.
Changelog: https://qgis.org/project/visual-changelogs/visualchangelog42/
graphics/qgis: Update to 3.44.9
3.44.9 is also the new LTR version and was actually intended to replace
3.40.15 (graphics/qgis-ltr) as the LTR version starting with 3.44.8.
Since the 4.0.x versions are “early adopters” and, for example, still
have major issues with most plugins, 3.44.x will continue to be used
for graphics/qgis for a transitional period, and graphics/qgis-ltr will
remain at 3.40.15.
Changelog: https://github.com/qgis/QGIS/compare/final-3_44_7%5E...final-3_44_8https://github.com/qgis/QGIS/compare/final-3_45_8%5E...final-3_44_9
MFH: 2026Q2
graphics/qgis: Update to 3.44.0
- unbreak "sip-build: class 'QgsTopologicalMesh::Changes' has not been defined"
Changelog: https://changelog.qgis.org/en/version/3.44/
Reported by: portscout, Repology
graphics/qgis: Use gettid patch from qgis project
A few hours after the commit of v3.42.0 of the QGIS port, a suitable
patch [1] was published in the main branch of the QGIS project, which
represents a more general solution for the replacement of the
linux-centric gettid().
[1] https://github.com/qgis/QGIS/commit/00c4fa69116bda5a40af1dfc2ed194f9aec08d52
graphics/qgis: Disable usage of ccache
If ccache is used, the build breaks with
ccache: error: unknown configuration option "compiler_type"
PR: 284996
Reported by: Martin Birgmeier <d8zNeCFG@aon.at>
*/*: Remove qtbuilder and sip from RUN_DEPENDS
devel/py-qtbuilder and devel/py-sip should only be used as a
BUILD_DEPENDS. (e.g. USE_PYQT=qtbuilder:build sip:build)
Usually, these are only used to build the PyQt framework, but a few
other ports need them to build. Ports that have them as a BUILD_DEPENDS
unnecessarily haven't been audited yet.
Sip used to be needed for run, but this hasn't been the case for quite
some time. Runtime is provided by the devel/py-qt[56]-sip ports.
(USE_PYQT=pysip). The main PyQt ports provide this automatically, so
it isn't necessary to add it to individual consumers.
While here:
www/onionshare: Remove PyQt stuff completely. It uses PySide.
With hat: kde@
*/*: Add ${PY_SETUPTOOLS} to BUILD_DEPENDS
Fix build when setuptools is removed from RUN_DEPENDS in
Mk/Uses/python.mk.
PR: 270510
Approved by: portmgr (blanket)
devel/py-python-dateutil: Move devel/py-dateutil to devel/py-python-dateutil
- Convert to USE_PYTHON=pep517
- Bump PORTREVISION of dependent ports for dependency change
- While I'm here, update audio/py-pyradio to use PYTHON_PKGNAMEPREFIX instead of
PKGNAMEPREFIX for *_DEPENDS
graphics/qgis: Update to 3.36.0
Among the exciting new features added to this release is a new
"Movie Mode" for the temporal controller that facilitates the production
of animated maps. This release also brings new functionalities for map
tips (on Desktop and Server) and improvements to the growing collection
of 3D functionality, giving users the power to take advantage of advanced
data types, such as Meshes, Point Clouds, and 3D Tiles
Changelog: https://changelog.qgis.org/en/qgis/version/3.36
Reported by: portscout, Repology
graphics/qgis: Avoid CMake warning MAKE_GRASS
CMake Warning:
Ignoring extra path from command line:
"/usr/ports/graphics/qgis/work/.build/WITH_GRASS8"
This happens, because of unneeded CMAKE_OFF=WITH_GRASSx.
Not functional change, not bump of PORTREVISION necessary.
PR: 274793
Reported by: Martin Birgmeier <d8zNeCFG@aon.at>
MFH: 2024Q1
*/*: Sunset 12.4-RELEASE/12-STABLE from ports tree
- Remove all references to defunct ARCH arm
- Remove all references to defunct ARCH sparc64
- Remove x11-drivers/xf86-video-sunffb which requires defunct sparc64
ARCH
- Remove sysutils/afbinit requires defunct sparc64 ARCH
- Remove all references to bktr driver
- Remove all references to defunct FreeBSD_12
- Remove all references to OSVERSION/OSREL corresponding to 12
- Remove conditionals in Mk/Uses/cabal.mk
- Remove sparc reference from Mk/Uses/qt-dist.mk
- Remove BROKEN_sparc64/NOT_FOR_ARCH=sparc64
- Remove BROKEN_FreeBSD_12* from:
- Remove OpenSSL patches from:
- Remove conditional flags for OSVERSION >= 1300000 to fixed flags.
Also move conditional flags for non sparc64/arm ARCH to fixed flags.
Reviewed by: brooks, jbeich, rene, salvadore
Differential Revision: https://reviews.freebsd.org/D42068
graphics/qgis: Readd patch to fix flex version
For FreeBSD versions < 1300501 the existing version of FLEX in base is
unsufficient. Readd old patch to install the ports version of FLEX.
CMake Error at
/usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230
(message): Could NOT find FLEX: Found unsuitable version "2.5.37",
but required is at least "2.6" (found /usr/bin/flex)
Call Stack (most recent call first):
/usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:598
(_FPHSA_FAILURE_MESSAGE)
/usr/local/share/cmake/Modules/FindFLEX.cmake:269
(FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:339 (find_package)
Thanks to Martin Birgmeier <d8zNeCFG@aon.at> for reporting.
PR: 274793